aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/Makefile1
-rw-r--r--www/py-WebTest/Makefile20
-rw-r--r--www/py-WebTest/distinfo3
-rw-r--r--www/py-WebTest/pkg-descr7
-rw-r--r--www/py-WebTest/pkg-plist1
5 files changed, 32 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index c60c5b52d53d..267d802eadd6 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1222,6 +1222,7 @@
SUBDIR += py-HTMLgen
SUBDIR += py-Lightbox
SUBDIR += py-WebError
+ SUBDIR += py-WebTest
SUBDIR += py-albatross
SUBDIR += py-amf
SUBDIR += py-apachelog
diff --git a/www/py-WebTest/Makefile b/www/py-WebTest/Makefile
new file mode 100644
index 000000000000..4a88c4dd4c53
--- /dev/null
+++ b/www/py-WebTest/Makefile
@@ -0,0 +1,20 @@
+# New ports collection makefile for: py-WebTest
+# Date created: 24 Feb, 2009
+# Whom: Wen Heping <wenheping@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= WebTest
+PORTVERSION= 1.1
+CATEGORIES= www python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= Helper to test WSGI applications
+
+USE_PYTHON= 2.5
+USE_PYDISTUTILS= easy_install
+
+.include <bsd.port.mk>
diff --git a/www/py-WebTest/distinfo b/www/py-WebTest/distinfo
new file mode 100644
index 000000000000..a1996254fe22
--- /dev/null
+++ b/www/py-WebTest/distinfo
@@ -0,0 +1,3 @@
+MD5 (WebTest-1.1.tar.gz) = f2adfd0f6d766bb2214fb1a1f3db03cc
+SHA256 (WebTest-1.1.tar.gz) = 78030defded997c48def56d268136eb91ccce41dbd9d767b08308bf6381cfefd
+SIZE (WebTest-1.1.tar.gz) = 31705
diff --git a/www/py-WebTest/pkg-descr b/www/py-WebTest/pkg-descr
new file mode 100644
index 000000000000..a52e46e74bbf
--- /dev/null
+++ b/www/py-WebTest/pkg-descr
@@ -0,0 +1,7 @@
+py-WebTest is a helper to test WSGI applications, it wraps
+any WSGI application and makes it easy to send test requests
+to that application, without starting up an HTTP server.
+It provides convenient full-stack testing of applications
+written with any WSGI-compatible framework.
+
+WWW: http://pythonpaste.org/webtest/
diff --git a/www/py-WebTest/pkg-plist b/www/py-WebTest/pkg-plist
new file mode 100644
index 000000000000..ddf68a1c022f
--- /dev/null
+++ b/www/py-WebTest/pkg-plist
@@ -0,0 +1 @@
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%