aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--databases/Makefile1
-rw-r--r--databases/sqlite-ext-pcre/Makefile39
-rw-r--r--databases/sqlite-ext-pcre/distinfo2
-rw-r--r--databases/sqlite-ext-pcre/pkg-descr4
-rw-r--r--databases/sqlite-ext-pcre/pkg-message11
5 files changed, 57 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 868ed350a3e5..d683f67d230c 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -890,6 +890,7 @@
SUBDIR += sqldeveloper
SUBDIR += sqlite-ext-miscfuncs
SUBDIR += sqlite-ext-mobigroup
+ SUBDIR += sqlite-ext-pcre
SUBDIR += sqlite2
SUBDIR += sqlite3
SUBDIR += sqliteman
diff --git a/databases/sqlite-ext-pcre/Makefile b/databases/sqlite-ext-pcre/Makefile
new file mode 100644
index 000000000000..0c33bbab61b6
--- /dev/null
+++ b/databases/sqlite-ext-pcre/Makefile
@@ -0,0 +1,39 @@
+# $FreeBSD$
+
+PORTNAME= sqlite-ext-pcre
+PORTVERSION= 20100208
+CATEGORIES= databases
+
+MAINTAINER= vivek@khera.org
+COMMENT= Regexp function for SQLite based on PCRE library
+
+LIB_DEPENDS+= libpcre.so:${PORTSDIR}/devel/pcre
+
+USE_SQLITE= yes
+DIST_SUBDIR= sqlite-ext
+
+LIBFILE= pcre.so
+INST_DIR= ${PREFIX}/libexec/${DIST_SUBDIR}
+USE_LDCONFIG= ${INST_DIR}
+
+SUB_LIST+= LIBFILE=${LIBFILE}
+
+PLIST_DIRS= libexec/${DIST_SUBDIR}
+PLIST_FILES= ${PLIST_DIRS}/${LIBFILE}
+
+USES= gmake pkgconfig
+
+USE_GITHUB= yes
+GH_ACCOUNT= ralight
+GH_PROJECT= sqlite3-pcre
+GH_COMMIT= c98da41
+GH_TAGNAME= ${GH_COMMIT}
+
+do-build:
+ @cd ${WRKSRC} && ${GMAKE}
+
+do-install:
+ @${MKDIR} ${STAGEDIR}${PREFIX}/libexec/${DIST_SUBDIR}
+ @${INSTALL_PROGRAM} ${WRKSRC}/${LIBFILE} ${STAGEDIR}${PREFIX}/libexec/${DIST_SUBDIR}
+
+.include <bsd.port.mk>
diff --git a/databases/sqlite-ext-pcre/distinfo b/databases/sqlite-ext-pcre/distinfo
new file mode 100644
index 000000000000..985ca7224b12
--- /dev/null
+++ b/databases/sqlite-ext-pcre/distinfo
@@ -0,0 +1,2 @@
+SHA256 (sqlite-ext/sqlite-ext-pcre-20100208.tar.gz) = 16faf92d820b29791347332537e7e7dfef59fcd884081cb54482242533982183
+SIZE (sqlite-ext/sqlite-ext-pcre-20100208.tar.gz) = 2423
diff --git a/databases/sqlite-ext-pcre/pkg-descr b/databases/sqlite-ext-pcre/pkg-descr
new file mode 100644
index 000000000000..dd12616cbda7
--- /dev/null
+++ b/databases/sqlite-ext-pcre/pkg-descr
@@ -0,0 +1,4 @@
+This is sqlite3-pcre, an extension for sqlite3 that uses libpcre to provide
+a regexp() function to use with the REGEXP operator.
+
+WWW: https://github.com/ralight/sqlite3-pcre
diff --git a/databases/sqlite-ext-pcre/pkg-message b/databases/sqlite-ext-pcre/pkg-message
new file mode 100644
index 000000000000..70906d9f80bf
--- /dev/null
+++ b/databases/sqlite-ext-pcre/pkg-message
@@ -0,0 +1,11 @@
+*********************************************************************
+Loading extensions is by default prohibited as a security measure;
+see "Security Considerations" in
+http://www.sqlite.org/cvstrac/wiki?p=LoadableExtensions.
+
+If the sqlite3 program and library are built this way, you cannot
+use these functions from the program, you must write your own program
+using the sqlite3 API, and call sqlite3_enable_load_extension as
+described above, or else rebuild the sqlite3 program to allow
+loadable extensions.
+*********************************************************************