aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/rubygem-fog-json/Makefile20
-rw-r--r--devel/rubygem-fog-json/distinfo2
-rw-r--r--devel/rubygem-fog-json/pkg-descr5
4 files changed, 28 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index e206f7566cc0..3728852da152 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4214,6 +4214,7 @@
SUBDIR += rubygem-fog
SUBDIR += rubygem-fog-brightbox
SUBDIR += rubygem-fog-core
+ SUBDIR += rubygem-fog-json
SUBDIR += rubygem-font-awesome-rails
SUBDIR += rubygem-foreman
SUBDIR += rubygem-foreman_api
diff --git a/devel/rubygem-fog-json/Makefile b/devel/rubygem-fog-json/Makefile
new file mode 100644
index 000000000000..99ab6eef29d0
--- /dev/null
+++ b/devel/rubygem-fog-json/Makefile
@@ -0,0 +1,20 @@
+# Created by: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= fog-json
+PORTVERSION= 1.0.0
+CATEGORIES= devel rubygems
+MASTER_SITES= RG
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Extraction of the JSON parsing tools between providers
+
+LICENSE= MIT
+
+RUN_DEPENDS= rubygem-multi_json>=1:${PORTSDIR}/devel/rubygem-multi_json
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/devel/rubygem-fog-json/distinfo b/devel/rubygem-fog-json/distinfo
new file mode 100644
index 000000000000..eaa21df69226
--- /dev/null
+++ b/devel/rubygem-fog-json/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/fog-json-1.0.0.gem) = dcd321b42f551a9ed3a2a5d43bdfe703b7588dcac5a9e504577501ba50d52794
+SIZE (rubygem/fog-json-1.0.0.gem) = 7680
diff --git a/devel/rubygem-fog-json/pkg-descr b/devel/rubygem-fog-json/pkg-descr
new file mode 100644
index 000000000000..425212ed7c9f
--- /dev/null
+++ b/devel/rubygem-fog-json/pkg-descr
@@ -0,0 +1,5 @@
+rubygem-fog-json (Fog::Json) provides extraction of the JSON parsing tools
+shared between a number of providers in the 'fog' gem.
+
+WWW: https://github.com/fog/fog-json
+RG: https://rubygems.org/gems/fog-json