aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--textproc/p5-CSS-Simple/Makefile9
-rw-r--r--textproc/p5-HTML-CTPP2/Makefile9
-rw-r--r--textproc/p5-HTML-Entities-ImodePictogram/Makefile9
-rw-r--r--textproc/p5-Makefile-DOM/Makefile9
-rw-r--r--textproc/p5-PDF-Table/Makefile3
-rw-r--r--textproc/p5-Parse-CSV/Makefile9
-rw-r--r--textproc/p5-Sort-Naturally/Makefile9
-rw-r--r--textproc/p5-Spreadsheet-XLSX/Makefile9
-rw-r--r--textproc/p5-TeX-Hyphen/Makefile8
-rw-r--r--textproc/p5-Text-Delimited/Makefile9
-rw-r--r--textproc/p5-Text-Match-FastAlternatives/Makefile9
-rw-r--r--textproc/p5-Text-Striphigh/Makefile9
-rw-r--r--textproc/p5-Text-Textile/Makefile10
-rw-r--r--textproc/p5-XML-Atom-Ext-OpenSearch/Makefile9
-rw-r--r--textproc/p5-XML-AutoWriter/Makefile8
-rw-r--r--textproc/p5-XML-Clean/Makefile9
-rw-r--r--textproc/p5-XML-Compile-Dumper/Makefile9
-rw-r--r--textproc/p5-XML-Descent/Makefile9
-rw-r--r--textproc/xqilla/Makefile8
19 files changed, 53 insertions, 110 deletions
diff --git a/textproc/p5-CSS-Simple/Makefile b/textproc/p5-CSS-Simple/Makefile
index 1b28bbb8f4dc..8fce3daf67d7 100644
--- a/textproc/p5-CSS-Simple/Makefile
+++ b/textproc/p5-CSS-Simple/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-CSS-Simple
-# Date created: Thu Oct 28 09:56:23 EDT 2010
-# Whom: Vivek Khera <vivek@khera.org>
-#
+# Created by: Vivek Khera <vivek@khera.org>
# $FreeBSD$
-#
PORTNAME= CSS-Simple
PORTVERSION= 3211
@@ -17,7 +13,8 @@ COMMENT= Interface through which to read/write/manipulate CSS files
BUILD_DEPENDS= p5-Tie-IxHash>=0:${PORTSDIR}/devel/p5-Tie-IxHash
RUN_DEPENDS= p5-Tie-IxHash>=0:${PORTSDIR}/devel/p5-Tie-IxHash
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= CSS::Simple.3
PLIST_FILES= %%SITE_PERL%%/CSS/Simple.pm \
diff --git a/textproc/p5-HTML-CTPP2/Makefile b/textproc/p5-HTML-CTPP2/Makefile
index 55973abcfe14..bc8582c9239e 100644
--- a/textproc/p5-HTML-CTPP2/Makefile
+++ b/textproc/p5-HTML-CTPP2/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-HTML-CTPP2
-# Date Created: 20 Mar, 2008
-# Whom: Andrei V. Shetuhin <reki@reki.ru>
-#
+# Created by: Andrei V. Shetuhin <reki@reki.ru>
# $FreeBSD$
-#
PORTNAME= HTML-CTPP2
PORTVERSION= 2.6.7
@@ -18,7 +14,8 @@ COMMENT= Perl interface module to CTPP2 library
BUILD_DEPENDS= ctpp2>=2.5.1:${PORTSDIR}/textproc/ctpp2
LIB_DEPENDS= ctpp2:${PORTSDIR}/textproc/ctpp2
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= HTML::CTPP2.3
diff --git a/textproc/p5-HTML-Entities-ImodePictogram/Makefile b/textproc/p5-HTML-Entities-ImodePictogram/Makefile
index 64f1d826096f..012b86981d37 100644
--- a/textproc/p5-HTML-Entities-ImodePictogram/Makefile
+++ b/textproc/p5-HTML-Entities-ImodePictogram/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: textproc/p5-HTML-Entities-ImodePictogram
-# Date created: 17 Aug 2007
-# Whom: Shinsuke Matsui <smatsui@karashi.org>
-#
+# Created by: Shinsuke Matsui <smatsui@karashi.org>
# $FreeBSD$
-#
PORTNAME= HTML-Entities-ImodePictogram
PORTVERSION= 0.06
@@ -14,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= smatsui@karashi.org
COMMENT= HTML::Entities::ImodePictogram - encode / decode i-mode pictogram
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= HTML::Entities::ImodePictogram.3 \
HTML::Entities::ImodePictogram.ja.3
diff --git a/textproc/p5-Makefile-DOM/Makefile b/textproc/p5-Makefile-DOM/Makefile
index 15bec145aea4..366e616fb3ac 100644
--- a/textproc/p5-Makefile-DOM/Makefile
+++ b/textproc/p5-Makefile-DOM/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Makefile-DOM
-# Date created: 2008-04-17
-# Whom: Gea-Suan Lin <gslin@gslin.org>
-#
+# Created by: Gea-Suan Lin <gslin@gslin.org>
# $FreeBSD$
-#
PORTNAME= Makefile-DOM
PORTVERSION= 0.006
@@ -19,7 +15,8 @@ RUN_DEPENDS= p5-Clone>=0.18:${PORTSDIR}/devel/p5-Clone \
p5-List-MoreUtils>=0.21:${PORTSDIR}/lang/p5-List-MoreUtils \
p5-Params-Util>=0.22:${PORTSDIR}/devel/p5-Params-Util
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= MDOM::Dumper.3 \
MDOM::Element.3 \
diff --git a/textproc/p5-PDF-Table/Makefile b/textproc/p5-PDF-Table/Makefile
index bde1ceaa5ab1..d5a81a3e4c96 100644
--- a/textproc/p5-PDF-Table/Makefile
+++ b/textproc/p5-PDF-Table/Makefile
@@ -13,7 +13,8 @@ COMMENT= A utility class for building table layouts in a PDF::API2 object
BUILD_DEPENDS= p5-PDF-API2>=0:${PORTSDIR}/textproc/p5-PDF-API2
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:C/\.h3//}
diff --git a/textproc/p5-Parse-CSV/Makefile b/textproc/p5-Parse-CSV/Makefile
index abbd937b63a8..9f66778bc906 100644
--- a/textproc/p5-Parse-CSV/Makefile
+++ b/textproc/p5-Parse-CSV/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Parse-CSV
-# Date created: 2006-10-19
-# Whom: Jin-Shan Tseng <tjs@cdpa.nsysu.edu.tw>
-#
+# Created by: Jin-Shan Tseng <tjs@cdpa.nsysu.edu.tw>
# $FreeBSD$
-#
PORTNAME= Parse-CSV
PORTVERSION= 2.00
@@ -19,7 +15,8 @@ BUILD_DEPENDS= p5-Params-Util>=0.22:${PORTSDIR}/devel/p5-Params-Util \
RUN_DEPENDS= p5-Params-Util>=0.22:${PORTSDIR}/devel/p5-Params-Util \
p5-Text-CSV_XS>=0.42:${PORTSDIR}/textproc/p5-Text-CSV_XS
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Parse::CSV.3
diff --git a/textproc/p5-Sort-Naturally/Makefile b/textproc/p5-Sort-Naturally/Makefile
index 8eba98928d86..ab455e73a1fa 100644
--- a/textproc/p5-Sort-Naturally/Makefile
+++ b/textproc/p5-Sort-Naturally/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Sort-Naturally
-# Date created: 30 December 2004
-# Whom: Aaron Dalton <aaron@daltons.ca>
-#
+# Created by: Aaron Dalton <aaron@daltons.ca>
# $FreeBSD$
-#
PORTNAME= Sort-Naturally
PORTVERSION= 1.03
@@ -17,7 +13,8 @@ COMMENT= Sort lexically, but sort numeral parts numerically
LICENSE= ART10 GPLv1
LICENSE_COMB= dual
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Sort::Naturally.3
diff --git a/textproc/p5-Spreadsheet-XLSX/Makefile b/textproc/p5-Spreadsheet-XLSX/Makefile
index 7444e6ca2246..34ec0f576c98 100644
--- a/textproc/p5-Spreadsheet-XLSX/Makefile
+++ b/textproc/p5-Spreadsheet-XLSX/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Spreadsheet-XLSX
-# Date created: 2011-08-12
-# Whom: Steve Wills <swills@FreeBSD.org>
-#
+# Created by: Steve Wills <swills@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Spreadsheet-XLSX
PORTVERSION= 0.13
@@ -22,7 +18,8 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Spreadsheet::XLSX.3 Spreadsheet::XLSX::Fmt2007.3 Spreadsheet::XLSX::Utility2007.3
diff --git a/textproc/p5-TeX-Hyphen/Makefile b/textproc/p5-TeX-Hyphen/Makefile
index 692b2ad2411f..27f9023d3cd7 100644
--- a/textproc/p5-TeX-Hyphen/Makefile
+++ b/textproc/p5-TeX-Hyphen/Makefile
@@ -1,9 +1,4 @@
-# New ports collection makefile for: p5-TeX-Hyphen
-# Date created: Oct 22, 2002
-# Whom: kuriyama@FreeBSD.org
-#
# $FreeBSD$
-#
PORTNAME= TeX-Hyphen
PORTVERSION= 1.01
@@ -14,7 +9,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= kuriyama@FreeBSD.org
COMMENT= Hyphenate words using TeX's patterns
-PERL_CONFIGURE= YES
+USES= perl5
+USE_PERL5= configure
MAN3= TeX::Hyphen.3 TeX::Hyphen::czech.3 TeX::Hyphen::german.3
diff --git a/textproc/p5-Text-Delimited/Makefile b/textproc/p5-Text-Delimited/Makefile
index 1edfcf294249..eff965bba314 100644
--- a/textproc/p5-Text-Delimited/Makefile
+++ b/textproc/p5-Text-Delimited/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Text-Delimited
-# Date created: 2006-08-01
-# Whom: Gea-Suan Lin <gslin@gslin.org>
-#
+# Created by: Gea-Suan Lin <gslin@gslin.org>
# $FreeBSD$
-#
PORTNAME= Text-Delimited
PORTVERSION= 2.00
@@ -14,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= gslin@gslin.org
COMMENT= Module for parsing delimited text files
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Text::Delimited.3
diff --git a/textproc/p5-Text-Match-FastAlternatives/Makefile b/textproc/p5-Text-Match-FastAlternatives/Makefile
index e9700019db07..4da54afb88d6 100644
--- a/textproc/p5-Text-Match-FastAlternatives/Makefile
+++ b/textproc/p5-Text-Match-FastAlternatives/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Text-Match-FastAlternatives
-# Date created: 30 April 2010
-# Whom: Kevin Lo <kevlo@FreeBSD.org>
-#
+# Created by: Kevin Lo <kevlo@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Text-Match-FastAlternatives
PORTVERSION= 1.04
@@ -14,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= kevlo@FreeBSD.org
COMMENT= Efficient search for many strings
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Text::Match::FastAlternatives.3
diff --git a/textproc/p5-Text-Striphigh/Makefile b/textproc/p5-Text-Striphigh/Makefile
index 95e1d0cffd64..94fd0400559e 100644
--- a/textproc/p5-Text-Striphigh/Makefile
+++ b/textproc/p5-Text-Striphigh/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Text-Striphigh
-# Date created: Mon Nov 10 2003
-# Whom: kai
-#
+# Created by: kai
# $FreeBSD$
-#
PORTNAME= Text-Striphigh
PORTVERSION= 0.02
@@ -14,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= kai@xs4all.nl
COMMENT= Perl extension to strip the high bit off of ISO-8859-1 text
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
WRKSRC= ${WRKDIR}/Striphigh-${PORTVERSION}
MAN3= Text::Striphigh.3
diff --git a/textproc/p5-Text-Textile/Makefile b/textproc/p5-Text-Textile/Makefile
index f46c125c34ae..e2993f5c1882 100644
--- a/textproc/p5-Text-Textile/Makefile
+++ b/textproc/p5-Text-Textile/Makefile
@@ -1,10 +1,5 @@
-# ex:ts=8
-# Ports collection makefile for: p5-Text-Textile
-# Date created: May 4, 2005
-# Whom: Travis Campbell <hcoyote@ghostar.org>
-#
+# Created by: Travis Campbell <hcoyote@ghostar.org>
# $FreeBSD$
-#
PORTNAME= Text-Textile
PORTVERSION= 2.12
@@ -15,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= hcoyote@ghostar.org
COMMENT= A perl-based implementation of the Textile syntax by Dean Allen
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Text::Textile.3
diff --git a/textproc/p5-XML-Atom-Ext-OpenSearch/Makefile b/textproc/p5-XML-Atom-Ext-OpenSearch/Makefile
index e602219a1aa1..dd4c4c622ac2 100644
--- a/textproc/p5-XML-Atom-Ext-OpenSearch/Makefile
+++ b/textproc/p5-XML-Atom-Ext-OpenSearch/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-XML-Atom-Ext-OpenSearch
-# Date created: 27 Oct 2008
-# Whom: Denis Pokataev <catone@cpan.org>
-#
+# Created by: Denis Pokataev <catone@cpan.org>
# $FreeBSD$
-#
PORTNAME= XML-Atom-Ext-OpenSearch
PORTVERSION= 0.03
@@ -17,7 +13,8 @@ COMMENT= XML::Atom extension for OpenSearch data
BUILD_DEPENDS= p5-XML-Atom>=0:${PORTSDIR}/textproc/p5-XML-Atom
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= XML::Atom::Ext::OpenSearch.3 \
XML::Atom::Ext::OpenSearch::Query.3
diff --git a/textproc/p5-XML-AutoWriter/Makefile b/textproc/p5-XML-AutoWriter/Makefile
index e0658717f90b..914f8a87a0f7 100644
--- a/textproc/p5-XML-AutoWriter/Makefile
+++ b/textproc/p5-XML-AutoWriter/Makefile
@@ -1,9 +1,4 @@
-# New ports collection makefile for: XML::AutoWriter
-# Date created: 9 Jan 2004
-# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
-#
# $FreeBSD$
-#
PORTNAME= XML-AutoWriter
PORTVERSION= 0.40
@@ -17,7 +12,8 @@ COMMENT= Perl module for DOCTYPE based XML output
TEST_DEPENDS= p5-XML-Parser>=0:${PORTSDIR}/textproc/p5-XML-Parser
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= XML::AutoWriter.3 \
XML::Doctype::AttDef.3 \
diff --git a/textproc/p5-XML-Clean/Makefile b/textproc/p5-XML-Clean/Makefile
index c37652d2fff6..68229e1a7a7f 100644
--- a/textproc/p5-XML-Clean/Makefile
+++ b/textproc/p5-XML-Clean/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: textproc/p5-XML-Clean
-# Date created: Sep 17 2004
-# Whom: Rong-En Fan <rafan@infor.org>
-#
+# Created by: Rong-En Fan <rafan@infor.org>
# $FreeBSD$
-#
PORTNAME= XML-Clean
PORTVERSION= 1.06
@@ -14,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= rafan@FreeBSD.org
COMMENT= Ensure, that *(HTML)* text pass throught an XML parser
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= XML::Clean.3
diff --git a/textproc/p5-XML-Compile-Dumper/Makefile b/textproc/p5-XML-Compile-Dumper/Makefile
index 375f2de6d951..5e43193ee0ec 100644
--- a/textproc/p5-XML-Compile-Dumper/Makefile
+++ b/textproc/p5-XML-Compile-Dumper/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-XML-Compile-Dumper
-# Date created: 2010-11-23
-# Whom: Patrick Powell <papowell@astart.com>
-#
+# Created by: Patrick Powell <papowell@astart.com>
# $FreeBSD$
-#
PORTNAME= XML-Compile-Dumper
PORTVERSION= 0.13
@@ -23,7 +19,8 @@ BUILD_DEPENDS= p5-Data-Dump-Streamer>=2.08:${PORTSDIR}/devel/p5-Data-Dump-Stream
p5-XML-LibXML-Simple>=0.13:${PORTSDIR}/textproc/p5-XML-LibXML-Simple
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= XML::Compile::Dumper.3
diff --git a/textproc/p5-XML-Descent/Makefile b/textproc/p5-XML-Descent/Makefile
index 58fb4263bd76..ea467127c8c4 100644
--- a/textproc/p5-XML-Descent/Makefile
+++ b/textproc/p5-XML-Descent/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: XML-TokeParser
-# Date created: 10 April 2010
-# Whom: Mike Bristow <mike@urgle.com>
-#
+# Created by: Mike Bristow <mike@urgle.com>
# $FreeBSD$
-#
PORTNAME= XML-Descent
PORTVERSION= 1.04
@@ -18,7 +14,8 @@ BUILD_DEPENDS= p5-XML-TokeParser>=0:${PORTSDIR}/textproc/p5-XML-TokeParser \
p5-Test-Differences>=0:${PORTSDIR}/devel/p5-Test-Differences
RUN_DEPENDS= p5-XML-TokeParser>=0:${PORTSDIR}/textproc/p5-XML-TokeParser
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= XML::Descent.3
diff --git a/textproc/xqilla/Makefile b/textproc/xqilla/Makefile
index 3b185794714a..3251470cbe1c 100644
--- a/textproc/xqilla/Makefile
+++ b/textproc/xqilla/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: xqilla
-# Date created: Sep 22 2007
-# Whom: vanilla@
-#
+# Created by: vanilla@
# $FreeBSD$
-#
PORTNAME= xqilla
PORTVERSION= 2.3.0
@@ -18,7 +14,7 @@ COMMENT= An XQuery and XPath2 library
LIB_DEPENDS= xerces-c.3:${PORTSDIR}/textproc/xerces-c3
USE_GMAKE= yes
-USE_PERL5= yes
+USES= perl5
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include