aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-im/jitsi/Makefile2
-rw-r--r--net-im/mercury/Makefile2
-rw-r--r--net-im/openfire/Makefile3
-rw-r--r--net-im/pwytter/Makefile3
-rw-r--r--net-im/py-skype4py/Makefile2
-rw-r--r--net-mgmt/lanmap/Makefile2
-rw-r--r--net-mgmt/nagiosagent/Makefile3
-rw-r--r--net-mgmt/phpweathermap/Makefile2
-rw-r--r--net-mgmt/unifi2/Makefile2
-rw-r--r--net-mgmt/unifi3/Makefile2
-rw-r--r--net-mgmt/zenpack-macreport/Makefile2
-rw-r--r--net-p2p/azureus2/Makefile4
-rw-r--r--net-p2p/bittyrant/Makefile3
-rw-r--r--net-p2p/frost/Makefile2
-rw-r--r--net-p2p/phex/Makefile2
-rw-r--r--net-p2p/retroshare/Makefile3
-rw-r--r--net-p2p/solidcoin/Makefile3
-rw-r--r--net-p2p/transmission-remote-gui/Makefile3
-rw-r--r--net-p2p/vuze/Makefile2
-rw-r--r--net/binkd/Makefile2
-rw-r--r--net/hawknl-devel/Makefile4
-rw-r--r--net/hupnp/Makefile3
-rw-r--r--net/jsch/Makefile2
-rw-r--r--net/libtcp4u/Makefile2
-rw-r--r--net/nusoap/Makefile2
-rw-r--r--net/openmq/Makefile2
-rw-r--r--net/p5-Net-Ping-External/Makefile3
-rw-r--r--net/p5-S3/Makefile3
-rw-r--r--net/py-pysphere/Makefile3
-rw-r--r--net/py-xmlrpclib/Makefile2
-rw-r--r--net/py-zope.proxy/Makefile2
-rw-r--r--net/repeater/Makefile2
-rw-r--r--net/rsmb/Makefile2
-rw-r--r--net/sip_scenario/Makefile3
-rw-r--r--net/tn5250j/Makefile2
-rw-r--r--net/wizd/Makefile4
-rw-r--r--news/crashmail/Makefile3
37 files changed, 39 insertions, 54 deletions
diff --git a/net-im/jitsi/Makefile b/net-im/jitsi/Makefile
index e816937c4bce..13cbd88fe525 100644
--- a/net-im/jitsi/Makefile
+++ b/net-im/jitsi/Makefile
@@ -13,7 +13,7 @@ COMMENT= Open source IM and VoIP application
MAN1= jitsi.1
-USE_ZIP= yes
+USES= zip
USE_JAVA= yes
USE_ANT= yes
MAKE_ARGS= rebuild
diff --git a/net-im/mercury/Makefile b/net-im/mercury/Makefile
index c349f9192dbf..ee00e4370c25 100644
--- a/net-im/mercury/Makefile
+++ b/net-im/mercury/Makefile
@@ -21,7 +21,7 @@ RUN_DEPENDS= java:${PORTSDIR}/java/javavmwrapper \
RCVER= rc8a
-USE_ZIP= yes
+USES= zip
USE_JAVA= yes
JAVA_VERSION= 1.6+
NO_BUILD= yes
diff --git a/net-im/openfire/Makefile b/net-im/openfire/Makefile
index 73e6339a8a12..92af45eda6db 100644
--- a/net-im/openfire/Makefile
+++ b/net-im/openfire/Makefile
@@ -20,9 +20,8 @@ OPTIONS_DEFINE= DOCS PLUGINS
OPTIONS_DEFAULT=PLUGINS
PLUGINS_DESC= Install bundled plugins
-USES= dos2unix
+USES= dos2unix zip
DOS2UNIX_FILES= src/java/org/jivesoftware/openfire/server/ServerDialback.java
-USE_ZIP= yes
USE_LDCONFIG= yes
USE_ANT= yes
USE_JAVA= yes
diff --git a/net-im/pwytter/Makefile b/net-im/pwytter/Makefile
index 5bc1360be96e..73f264984076 100644
--- a/net-im/pwytter/Makefile
+++ b/net-im/pwytter/Makefile
@@ -19,8 +19,7 @@ BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tkinter>0:${PORTSDIR}/x11-toolkits/py-tkin
RUN_DEPENDS:= ${BUILD_DEPENDS}
-USE_ZIP= yes
-USES= gettext
+USES= gettext zip
USE_PYTHON= 2
USE_PYDISTUTILS= easy_install
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
diff --git a/net-im/py-skype4py/Makefile b/net-im/py-skype4py/Makefile
index cc2cf62bb531..f76967f954d7 100644
--- a/net-im/py-skype4py/Makefile
+++ b/net-im/py-skype4py/Makefile
@@ -17,6 +17,6 @@ PYDISTUTILS_AUTOPLIST= yes
USE_PYDISTUTILS= easy_install
USE_PYTHON= 2
-USE_ZIP= yes
+USES= zip
.include <bsd.port.mk>
diff --git a/net-mgmt/lanmap/Makefile b/net-mgmt/lanmap/Makefile
index d9ff5a68f036..6aaff1ca058e 100644
--- a/net-mgmt/lanmap/Makefile
+++ b/net-mgmt/lanmap/Makefile
@@ -13,7 +13,7 @@ RUN_DEPENDS= twopi:${PORTSDIR}/graphics/graphviz
WRKSRC= ${WRKDIR}/${PORTNAME}
GNU_CONFIGURE= yes
-USE_ZIP= yes
+USES= zip
NO_STAGE= yes
.include <bsd.port.pre.mk>
diff --git a/net-mgmt/nagiosagent/Makefile b/net-mgmt/nagiosagent/Makefile
index 69befc27e31a..07edd309940c 100644
--- a/net-mgmt/nagiosagent/Makefile
+++ b/net-mgmt/nagiosagent/Makefile
@@ -15,8 +15,7 @@ COMMENT= Qt-based frontend to Nagios
PLIST_FILES= bin/NagiosAgent \
share/pixmaps/NagiosAgent.png
-USES= qmake
-USE_ZIP= yes
+USES= qmake zip
USE_QT4= gui network corelib uic_build rcc_build moc_build
DESKTOP_ENTRIES= "NagiosAgent" "GUI client for Nagios" \
diff --git a/net-mgmt/phpweathermap/Makefile b/net-mgmt/phpweathermap/Makefile
index 122864f8c977..45a88e259e61 100644
--- a/net-mgmt/phpweathermap/Makefile
+++ b/net-mgmt/phpweathermap/Makefile
@@ -15,7 +15,7 @@ RUN_DEPENDS= ${LOCALBASE}/share/pear/Console/Getopt.php:${PORTSDIR}/devel/pear \
rrdtool:${PORTSDIR}/databases/rrdtool
NO_BUILD= yes
-USE_ZIP= yes
+USES= zip
USE_PHP= gd
LICENSE= GPLv2
diff --git a/net-mgmt/unifi2/Makefile b/net-mgmt/unifi2/Makefile
index 18b51b6cc04e..082a7c6998e5 100644
--- a/net-mgmt/unifi2/Makefile
+++ b/net-mgmt/unifi2/Makefile
@@ -16,7 +16,7 @@ RUN_DEPENDS= mongodb>0:${PORTSDIR}/databases/mongodb
SUB_LIST+= USERS=${USERS} GROUPS=${GROUPS} JAVASHAREDIR=${JAVASHAREDIR}
-USE_ZIP= yes
+USES= zip
USE_JAVA= yes
JAVA_VERSION= 1.6+
JAVA_OS= native
diff --git a/net-mgmt/unifi3/Makefile b/net-mgmt/unifi3/Makefile
index 4714f87edd65..8f8fd7ae953a 100644
--- a/net-mgmt/unifi3/Makefile
+++ b/net-mgmt/unifi3/Makefile
@@ -16,7 +16,7 @@ RUN_DEPENDS= mongodb>0:${PORTSDIR}/databases/mongodb
SUB_LIST+= USERS=${USERS} GROUPS=${GROUPS} JAVASHAREDIR=${JAVASHAREDIR}
-USE_ZIP= yes
+USES= zip
USE_JAVA= yes
JAVA_VERSION= 1.6+
JAVA_OS= native
diff --git a/net-mgmt/zenpack-macreport/Makefile b/net-mgmt/zenpack-macreport/Makefile
index 6f8e848a226b..ebcf38ffd1cb 100644
--- a/net-mgmt/zenpack-macreport/Makefile
+++ b/net-mgmt/zenpack-macreport/Makefile
@@ -14,7 +14,7 @@ PLIST_FILES= zenoss/ZenPack/${ZPACK}
PLIST_DIRS= zenoss/ZenPack
USES= zenoss
-USE_ZIP= yes
+USES= zip
ZPACKGROUP= community
WRKSRC= ${WRKDIR}/zenoss-${ZPACKPREFIX}${PORTNAME}-${TAG}
TAG= b345f53
diff --git a/net-p2p/azureus2/Makefile b/net-p2p/azureus2/Makefile
index 4522bd5e5fae..55ac46db0380 100644
--- a/net-p2p/azureus2/Makefile
+++ b/net-p2p/azureus2/Makefile
@@ -24,8 +24,8 @@ JAVA_VERSION= 1.6+
JAVA_OS= native
USE_ANT= yes
-USE_ZIP= yes
-USE_DOS2UNIX= org/gudy/azureus2/ui/swt/test/PrintTransferTypes.java \
+USES= dos2unix zip
+DOS2UNIX_FILES= org/gudy/azureus2/ui/swt/test/PrintTransferTypes.java \
org/gudy/azureus2/platform/macosx/access/jnilib/OSXAccess.java
NO_WRKSUBDIR= yes
diff --git a/net-p2p/bittyrant/Makefile b/net-p2p/bittyrant/Makefile
index b3d0f29b5f95..38e2ea0bd79e 100644
--- a/net-p2p/bittyrant/Makefile
+++ b/net-p2p/bittyrant/Makefile
@@ -17,8 +17,7 @@ BUILD_DEPENDS= ${JAVALIBDIR}/log4j.jar:${PORTSDIR}/devel/log4j \
${JAVALIBDIR}/${SWT}.jar:${PORTSDIR}/x11-toolkits/${SWT}
RUN_DEPENDS= ${JAVALIBDIR}/${SWT}.jar:${PORTSDIR}/x11-toolkits/${SWT}
-USES= dos2unix
-USE_ZIP= yes
+USES= dos2unix zip
DOS2UNIX_FILES= build.xml \
org/gudy/azureus2/ui/swt/test/PrintTransferTypes.java \
org/gudy/azureus2/platform/macosx/access/jnilib/OSXAccess.java
diff --git a/net-p2p/frost/Makefile b/net-p2p/frost/Makefile
index b108088d2ac5..ba9dd916bce7 100644
--- a/net-p2p/frost/Makefile
+++ b/net-p2p/frost/Makefile
@@ -12,10 +12,10 @@ DISTNAME= ${PORTNAME}-14-Mar-2009
MAINTAINER= peter.thoenen@yahoo.com
COMMENT= Freenet client that provides messenger and file services
+USES= zip
USE_JAVA= yes
JAVA_VERSION= 1.6+
JAVA_RUN= yes
-USE_ZIP= yes
NO_BUILD= yes
NO_WRKSUBDIR= yes
PLIST_SUB= JAR_DIR=${JAR_DIR}
diff --git a/net-p2p/phex/Makefile b/net-p2p/phex/Makefile
index edc0b7a468ba..6dda833975a9 100644
--- a/net-p2p/phex/Makefile
+++ b/net-p2p/phex/Makefile
@@ -10,9 +10,9 @@ DISTNAME= ${PORTNAME}_${PORTVERSION}
MAINTAINER= jhale@FreeBSD.org
COMMENT= A Java multi platform and spyware free gnutella client
+USES= zip
USE_JAVA= yes
JAVA_VERSION= 1.6+
-USE_ZIP= yes
NO_BUILD= yes
SUB_FILES= ${PORTNAME}.sh
diff --git a/net-p2p/retroshare/Makefile b/net-p2p/retroshare/Makefile
index 9c502a60b1ad..0705d6d2817b 100644
--- a/net-p2p/retroshare/Makefile
+++ b/net-p2p/retroshare/Makefile
@@ -30,8 +30,7 @@ LIB_DEPENDS= libdbus-1.so:${PORTSDIR}/devel/dbus \
libxslt.so:${PORTSDIR}/textproc/libxslt
RUN_DEPENDS= pinentry-qt4:${PORTSDIR}/security/pinentry-qt4
-USES= qmake
-USE_ZIP= yes
+USES= qmake zip
USE_GNOME= glib20
USE_XORG= ice sm x11 xau xcb xdmcp xext xrender
USE_QT4= corelib gui network xml script designer_build uic_build \
diff --git a/net-p2p/solidcoin/Makefile b/net-p2p/solidcoin/Makefile
index 05480f4f076e..363bba0fde73 100644
--- a/net-p2p/solidcoin/Makefile
+++ b/net-p2p/solidcoin/Makefile
@@ -22,8 +22,7 @@ OPTIONS_DEFAULT= WXGTK
WRKSRC= ${WRKDIR}/src
-USES= gmake dos2unix
-USE_ZIP= yes
+USES= gmake dos2unix zip
USE_GNOME= glib20
USE_OPENSSL= yes
USE_BDB= yes
diff --git a/net-p2p/transmission-remote-gui/Makefile b/net-p2p/transmission-remote-gui/Makefile
index 740807472fcb..277db64d2759 100644
--- a/net-p2p/transmission-remote-gui/Makefile
+++ b/net-p2p/transmission-remote-gui/Makefile
@@ -17,9 +17,8 @@ RUN_DEPENDS= transmission-daemon:${PORTSDIR}/net-p2p/transmission-daemon
PROJECTHOST= transmisson-remote-gui
-USE_ZIP= yes
USE_FPC= fcl-net
-USES= iconv
+USES= iconv zip
USE_GNOME= #
WRKSRC= ${WRKDIR}/TransGUI
diff --git a/net-p2p/vuze/Makefile b/net-p2p/vuze/Makefile
index f802211b4c6c..2e1b6681f7b0 100644
--- a/net-p2p/vuze/Makefile
+++ b/net-p2p/vuze/Makefile
@@ -16,11 +16,11 @@ BUILD_DEPENDS= ${JAVALIBDIR}/log4j.jar:${PORTSDIR}/devel/log4j \
${JAVALIBDIR}/swt-devel.jar:${PORTSDIR}/x11-toolkits/swt-devel
RUN_DEPENDS= ${JAVALIBDIR}/swt-devel.jar:${PORTSDIR}/x11-toolkits/swt-devel
+USES= zip
USE_JAVA= yes
JAVA_VERSION= 1.6+
JAVA_OS= native
USE_ANT= yes
-USE_ZIP= yes
NO_WRKSUBDIR= yes
INSTALLS_ICONS= yes
diff --git a/net/binkd/Makefile b/net/binkd/Makefile
index 3caacb7342f2..d66137a4f1c5 100644
--- a/net/binkd/Makefile
+++ b/net/binkd/Makefile
@@ -12,7 +12,7 @@ MAINTAINER= fjoe@FreeBSD.org
COMMENT= Fidonet TCP/IP mailer
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-USE_ZIP= yes
+USES= zip
USE_RC_SUBR= binkd
GNU_CONFIGURE= yes
diff --git a/net/hawknl-devel/Makefile b/net/hawknl-devel/Makefile
index fea6b5c3ec42..fa0b2231a0a2 100644
--- a/net/hawknl-devel/Makefile
+++ b/net/hawknl-devel/Makefile
@@ -14,9 +14,7 @@ COMMENT= Portable networking library (devel)
CONFLICTS= hawknl-[0-9]*
-USE_ZIP= yes
-USE_DOS2UNIX= yes
-USE_GMAKE= yes
+USES= dos2unix gmake zip
MAKEFILE= makefile.linux
USE_LDCONFIG= yes
diff --git a/net/hupnp/Makefile b/net/hupnp/Makefile
index 6919675c65b2..5111c21003b9 100644
--- a/net/hupnp/Makefile
+++ b/net/hupnp/Makefile
@@ -11,8 +11,7 @@ DISTNAME= herqq-${PORTVERSION}
MAINTAINER= fluffy@FreeBSD.org
COMMENT= Library for building UPnP devices and control points
-USES= gmake qmake
-USE_ZIP= yes
+USES= gmake qmake zip
USE_QT4= corelib network xml dbus gui \
moc_build rcc_build uic_build
diff --git a/net/jsch/Makefile b/net/jsch/Makefile
index 11bba2c86719..b0bbbd4f13df 100644
--- a/net/jsch/Makefile
+++ b/net/jsch/Makefile
@@ -9,7 +9,7 @@ MASTER_SITES= SF
MAINTAINER= miwi@FreeBSD.org
COMMENT= A pure Java implementation of SSH2
-USE_ZIP= yes
+USES= zip
USE_JAVA= yes
JAVA_VERSION= 1.6+
USE_ANT= yes
diff --git a/net/libtcp4u/Makefile b/net/libtcp4u/Makefile
index 018fba96fcd4..6b0ada382896 100644
--- a/net/libtcp4u/Makefile
+++ b/net/libtcp4u/Makefile
@@ -16,7 +16,7 @@ LICENSE= GPLv2
WRKSRC= ${WRKDIR}/tcp4u.331/src
PATCH_WRKSRC= ${WRKDIR}/tcp4u.331
-USE_ZIP= yes
+USES= zip
PLIST_FILES= include/udp4u.h include/tcp4u.h \
include/smtp4u.h include/http4u.h \
diff --git a/net/nusoap/Makefile b/net/nusoap/Makefile
index f117a3e938a3..55126edde728 100644
--- a/net/nusoap/Makefile
+++ b/net/nusoap/Makefile
@@ -9,10 +9,10 @@ MASTER_SITES= SF
MAINTAINER= clsung@FreeBSD.org
COMMENT= SOAP Toolkit for PHP
+USES= zip
NO_BUILD= yes
NO_WRKSUBDIR= yes
USE_PHP= curl zlib xml
-USE_ZIP= yes
NO_STAGE= yes
.include <bsd.port.pre.mk>
diff --git a/net/openmq/Makefile b/net/openmq/Makefile
index f668b9d55bf2..a1b82ecf1b51 100644
--- a/net/openmq/Makefile
+++ b/net/openmq/Makefile
@@ -23,7 +23,7 @@ BOOTJARS= javaee-api-6.0.jar:2 \
grizzly-nio-framework-1.9.18a.jar:3 \
jhall-2.0.jar:4
-USE_ZIP= yes
+USES= zip
USE_JAVA= yes
JAVA_VERSION= 1.6
JAVA_VENDOR= openjdk
diff --git a/net/p5-Net-Ping-External/Makefile b/net/p5-Net-Ping-External/Makefile
index 33b5218dd55f..0ba6967e9cb9 100644
--- a/net/p5-Net-Ping-External/Makefile
+++ b/net/p5-Net-Ping-External/Makefile
@@ -13,8 +13,7 @@ COMMENT= Perl cross-platform interface to ICMP "ping" utilities
LICENSE= ART10 GPLv1
LICENSE_COMB= dual
-USE_ZIP= yes
-USES= perl5
+USES= perl5 zip
USE_PERL5= configure
.include <bsd.port.mk>
diff --git a/net/p5-S3/Makefile b/net/p5-S3/Makefile
index a0e205a15903..7da5b5fa4985 100644
--- a/net/p5-S3/Makefile
+++ b/net/p5-S3/Makefile
@@ -17,9 +17,8 @@ RUN_DEPENDS= p5-Digest-HMAC>=0:${PORTSDIR}/security/p5-Digest-HMAC \
p5-libwww>=0:${PORTSDIR}/www/p5-libwww
NO_BUILD= yes
-USES= perl5
+USES= perl5 zip
USE_PERL5= run
-USE_ZIP= yes
WRKSRC= ${WRKDIR}/s3-example-libraries/perl
do-install:
diff --git a/net/py-pysphere/Makefile b/net/py-pysphere/Makefile
index a41ec978bf21..5dca8bad3263 100644
--- a/net/py-pysphere/Makefile
+++ b/net/py-pysphere/Makefile
@@ -13,8 +13,7 @@ COMMENT= Python API for interaction with the vSphere Web Services SDK
LICENSE= BSD
-USE_ZIP= yes
-USE_DOS2UNIX= yes
+USES= dos2unix zip
USE_PYTHON= 2
USE_PYDISTUTILS= yes
PYDISTUTILS_AUTOPLIST= yes
diff --git a/net/py-xmlrpclib/Makefile b/net/py-xmlrpclib/Makefile
index ed7d65012701..28431b1ba231 100644
--- a/net/py-xmlrpclib/Makefile
+++ b/net/py-xmlrpclib/Makefile
@@ -11,7 +11,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Python implementation of the XML-RPC protocol
USE_PYTHON= yes
-USE_ZIP= yes
+USES= zip
DOCSDIR= ${PREFIX}/share/doc/py-xmlrpclib
EXAMPLESDIR= ${PREFIX}/share/examples/py-xmlrpclib
diff --git a/net/py-zope.proxy/Makefile b/net/py-zope.proxy/Makefile
index 5c695cf15297..f19aa0852502 100644
--- a/net/py-zope.proxy/Makefile
+++ b/net/py-zope.proxy/Makefile
@@ -16,9 +16,9 @@ LICENSE= ZPL21
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}zope.interface>=3.3.0:${PORTSDIR}/devel/py-zope.interface
+USES= zip
USE_PYTHON= yes
USE_PYDISTUTILS= yes
PYDISTUTILS_AUTOPLIST= yes
-USE_ZIP= yes
.include <bsd.port.mk>
diff --git a/net/repeater/Makefile b/net/repeater/Makefile
index c6d1edcca587..5cd635f92962 100644
--- a/net/repeater/Makefile
+++ b/net/repeater/Makefile
@@ -10,7 +10,7 @@ DISTNAME= repeater${PORTVERSION:C/\.//}
MAINTAINER= rick@sloservers.com
COMMENT= UltraVNC repeater
-USE_ZIP= yes
+USES= zip
USE_RC_SUBR= repeater
WRKSRC= ${WRKDIR}/Ver${PORTVERSION:C/\.//}
ALL_TARGET= repeater
diff --git a/net/rsmb/Makefile b/net/rsmb/Makefile
index 6dc2520da427..00b19607c77c 100644
--- a/net/rsmb/Makefile
+++ b/net/rsmb/Makefile
@@ -12,7 +12,7 @@ COMMENT= Really Small Message Broker, an MQTT supporting server
NO_BUILD= yes
NO_WRKSUBDIR= yes
-USE_ZIP= yes
+USES= zip
USE_LINUX= yes
LINUX_OSRELEASE=2.6.16
IA32_BINARY_PORT= yes
diff --git a/net/sip_scenario/Makefile b/net/sip_scenario/Makefile
index 4442f3323aa6..b960c143711e 100644
--- a/net/sip_scenario/Makefile
+++ b/net/sip_scenario/Makefile
@@ -12,8 +12,7 @@ COMMENT= SIP call flow creator (HTML format)
LICENSE= APACHE20
-USE_ZIP= yes
-USES= perl5
+USES= perl5 zip
USE_PERL5= run
WRKSRC= ${WRKDIR}
diff --git a/net/tn5250j/Makefile b/net/tn5250j/Makefile
index 358bdef85291..5487748ec08a 100644
--- a/net/tn5250j/Makefile
+++ b/net/tn5250j/Makefile
@@ -22,7 +22,7 @@ RUN_DEPENDS= ${JAVAJARDIR}/mail.jar:${PORTSDIR}/java/javamail \
${JAVAJARDIR}/itext.jar:${PORTSDIR}/devel/itext \
${JAVAJARDIR}/log4j.jar:${PORTSDIR}/devel/log4j
-USE_ZIP= yes
+USES= zip
USE_ANT= yes
USE_JAVA= 1.3+
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
diff --git a/net/wizd/Makefile b/net/wizd/Makefile
index b4ec5a786dfc..9b7398b6ab0b 100644
--- a/net/wizd/Makefile
+++ b/net/wizd/Makefile
@@ -15,10 +15,10 @@ LIB_DEPENDS= libdvdread.so:${PORTSDIR}/multimedia/libdvdread \
libjpeg.so:${PORTSDIR}/graphics/jpeg
RUN_DEPENDS= nkf:${PORTSDIR}/japanese/nkf
-USE_DOS2UNIX= Makefile nkfwrap/Makefile nkfwrap/nkfwrap_test.c \
+DOS2UNIX_FILES= Makefile nkfwrap/Makefile nkfwrap/nkfwrap_test.c \
wizd_http.c wizd_menu.c
USE_RC_SUBR= wizd
-USE_ZIP= yes
+USES= dos2unix zip:infozip
EXTRACT_AFTER_ARGS= -d ${WRKSRC}
post-patch:
diff --git a/news/crashmail/Makefile b/news/crashmail/Makefile
index 66d2e3a10460..63cb176681d9 100644
--- a/news/crashmail/Makefile
+++ b/news/crashmail/Makefile
@@ -15,8 +15,7 @@ BUILD_WRKSRC= ${WRKSRC}/src
INSTALL_WRKSRC= ${WRKSRC}/src
ALL_TARGET= linux
-USE_ZIP= yes
-USE_GMAKE= yes
+USES= gmake zip
NO_STAGE= yes
post-patch: