aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--editors/led/Makefile1
-rw-r--r--editors/led/files/patch-src::file.c12
2 files changed, 13 insertions, 0 deletions
diff --git a/editors/led/Makefile b/editors/led/Makefile
index e4a29d221434..8bdc898234e9 100644
--- a/editors/led/Makefile
+++ b/editors/led/Makefile
@@ -7,6 +7,7 @@
PORTNAME= led
PORTVERSION= 0.9.2
+PORTREVISION= 1
CATEGORIES= editors
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}-editor
diff --git a/editors/led/files/patch-src::file.c b/editors/led/files/patch-src::file.c
new file mode 100644
index 000000000000..e0df894f46ba
--- /dev/null
+++ b/editors/led/files/patch-src::file.c
@@ -0,0 +1,12 @@
+
+$FreeBSD$
+
+--- src/file.c.orig Sun Jun 10 06:44:19 2001
++++ src/file.c Tue Apr 30 02:15:40 2002
+@@ -148,4 +148,6 @@
+
+ curr = curr->next;
+ }
++ fflush(fp);
++ fsync(fileno(fp));
+ }