aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--mail/Makefile1
-rw-r--r--mail/py-mailnag/Makefile48
-rw-r--r--mail/py-mailnag/distinfo3
-rw-r--r--mail/py-mailnag/files/patch-mailnag19
-rw-r--r--mail/py-mailnag/files/patch-mailnag-config19
-rw-r--r--mail/py-mailnag/pkg-descr7
6 files changed, 97 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index 5f6e58eb61e6..4cba1ea49131 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -497,6 +497,7 @@
SUBDIR += py-fuglu
SUBDIR += py-mail-parser
SUBDIR += py-mailmanclient
+ SUBDIR += py-mailnag
SUBDIR += py-managesieve3
SUBDIR += py-milter
SUBDIR += py-notmuch
diff --git a/mail/py-mailnag/Makefile b/mail/py-mailnag/Makefile
new file mode 100644
index 000000000000..17456cef3d1b
--- /dev/null
+++ b/mail/py-mailnag/Makefile
@@ -0,0 +1,48 @@
+# $FreeBSD$
+
+PORTNAME= mailnag
+DISTVERSIONPREFIX= v
+DISTVERSION= 2.1.0
+CATEGORIES= mail python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= tagattie@FreeBSD.org
+COMMENT= Extensible mail notification daemon
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libnotify.so:devel/libnotify \
+ libsecret-1.so:security/libsecret
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dbus>0:devel/py-dbus@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}setproctitle>0:devel/py-setproctitle@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}xdg>0:devel/py-xdg@${PY_FLAVOR}
+
+USES= desktop-file-utils gettext-tools gnome python:3.5+ shebangfix
+
+USE_GITHUB= yes
+GH_ACCOUNT= pulb
+
+USE_GNOME= gdkpixbuf2 glib20 gtk30 pygobject3
+USE_GSTREAMER1= yes
+USE_PYTHON= autoplist distutils
+
+SHEBANG_FILES= mailnag mailnag-config
+SHEBANG_GLOB= *.py
+
+NO_ARCH= yes
+
+PORTDOCS= AUTHORS NEWS README.md
+
+OPTIONS_DEFINE= DOCS
+
+post-patch:
+ ${REINPLACE_CMD} -e 's|/usr/bin|${PREFIX}/bin|' \
+ ${WRKSRC}/data/mailnag-config.desktop \
+ ${WRKSRC}/data/mailnag.desktop
+
+post-install-DOCS-on:
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_MAN} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/mail/py-mailnag/distinfo b/mail/py-mailnag/distinfo
new file mode 100644
index 000000000000..520f05351ac3
--- /dev/null
+++ b/mail/py-mailnag/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1611988656
+SHA256 (pulb-mailnag-v2.1.0_GH0.tar.gz) = ceba2fa7486b3d63915fcf20a29351fcf88ed6678ebe9fbe3be964921de2ecfd
+SIZE (pulb-mailnag-v2.1.0_GH0.tar.gz) = 178552
diff --git a/mail/py-mailnag/files/patch-mailnag b/mail/py-mailnag/files/patch-mailnag
new file mode 100644
index 000000000000..b91c6e9db9b8
--- /dev/null
+++ b/mail/py-mailnag/files/patch-mailnag
@@ -0,0 +1,19 @@
+--- mailnag.orig 2021-01-30 10:40:37 UTC
++++ mailnag
+@@ -30,6 +30,7 @@ import argparse
+ import logging
+ import os
+ import signal
++from setproctitle import setproctitle
+
+ from Mailnag.common.utils import fix_cwd
+
+@@ -86,7 +87,7 @@ def main():
+ mainloop = GLib.MainLoop()
+ daemon = None
+
+- set_procname(PROGNAME)
++ setproctitle(PROGNAME)
+
+ DBusGMainLoop(set_as_default = True)
+ GLib.unix_signal_add(GLib.PRIORITY_HIGH, signal.SIGTERM,
diff --git a/mail/py-mailnag/files/patch-mailnag-config b/mail/py-mailnag/files/patch-mailnag-config
new file mode 100644
index 000000000000..34c7b54aebc0
--- /dev/null
+++ b/mail/py-mailnag/files/patch-mailnag-config
@@ -0,0 +1,19 @@
+--- mailnag-config.orig 2020-12-30 17:29:49 UTC
++++ mailnag-config
+@@ -25,6 +25,7 @@ import os
+ import subprocess
+ import logging
+ from gi.repository import Gtk
++from setproctitle import setproctitle
+
+ from Mailnag.common.utils import fix_cwd, init_logging
+
+@@ -80,7 +81,7 @@ class App(Gtk.Application):
+
+
+ def main():
+- set_procname("mailnag-config")
++ setproctitle("mailnag-config")
+ init_logging(enable_stdout = True, enable_syslog = False, log_level = LOG_LEVEL)
+ app = App()
+ app.run(None)
diff --git a/mail/py-mailnag/pkg-descr b/mail/py-mailnag/pkg-descr
new file mode 100644
index 000000000000..aa390c2532e9
--- /dev/null
+++ b/mail/py-mailnag/pkg-descr
@@ -0,0 +1,7 @@
+Mailnag is a daemon program that checks POP3 and IMAP servers for new
+mail. On mail arrival it performs various actions provided by
+plugins. Mailnag comes with a set of desktop-independent default
+plugins for visual/sound notifications, script execution etc. and can
+be extended with additional plugins easily.
+
+WWW: https://github.com/pulb/mailnag