aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Mk/Uses/imake.mk8
-rw-r--r--Mk/bsd.port.mk14
-rw-r--r--Mk/bsd.sanity.mk4
-rw-r--r--audio/sonata/Makefile2
-rw-r--r--cad/qelectrotech/Makefile1
-rw-r--r--deskutils/cairo-dock/Makefile2
-rw-r--r--graphics/hugin-devel/Makefile32
-rw-r--r--irc/py-supybot/Makefile1
-rw-r--r--math/proofgeneral/Makefile1
-rw-r--r--net-im/prosody/Makefile1
-rw-r--r--net/htpdate/Makefile1
-rw-r--r--net/mosquitto/Makefile2
-rw-r--r--net/mpd5/Makefile1
-rw-r--r--ports-mgmt/dialog4ports/Makefile1
-rw-r--r--print/rprint/Makefile1
-rw-r--r--sysutils/bacula-server/Makefile1
-rw-r--r--sysutils/bacula5-server/Makefile1
-rw-r--r--sysutils/pfstat/Makefile1
-rw-r--r--sysutils/puppet27/Makefile2
-rw-r--r--textproc/hs-pandoc/Makefile1
-rw-r--r--x11-toolkits/tk85/Makefile1
-rw-r--r--x11-wm/afterstep/Makefile1
22 files changed, 4 insertions, 76 deletions
diff --git a/Mk/Uses/imake.mk b/Mk/Uses/imake.mk
index f584be51a238..f6340c841f8b 100644
--- a/Mk/Uses/imake.mk
+++ b/Mk/Uses/imake.mk
@@ -23,14 +23,6 @@ IGNORE= USES=imake:${imake_ARGS:S/ /,/g} is not a valid argument
imake_ARGS=
.endif
-.if defined(NO_INSTALL_MANPAGES)
-imake_ARGS+= noman
-.endif
-
-.if ! ${imake_ARGS:Mnoman}
-MANCOMPRESSED?= yes
-.endif
-
BUILD_DEPENDS+= imake:${PORTSDIR}/devel/imake
.if defined(USE_GCC)
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index beaa8957cb21..24816171d557 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -574,8 +574,7 @@ FreeBSD_MAINTAINER= portmgr@FreeBSD.org
# INSTALL_SCRIPT
# - A command to install executable scripts.
# INSTALL_DATA - A command to install sharable data.
-# INSTALL_MAN - A command to install manpages. May or not compress,
-# depending on the value of MANCOMPRESSED (see below).
+# INSTALL_MAN - A command to install manpages.
# COPYTREE_BIN
# COPYTREE_SHARE
# - Similiar to INSTALL_PROGRAM and INSTALL_DATA commands but
@@ -1616,17 +1615,6 @@ MAKE_SHELL?= ${SH}
CONFIGURE_ENV+= SHELL=${CONFIGURE_SHELL} CONFIG_SHELL=${CONFIGURE_SHELL}
MAKE_ENV+= SHELL=${MAKE_SHELL} NO_LINT=YES
-.if defined(MANCOMPRESSED)
-.if ${MANCOMPRESSED} != yes && ${MANCOMPRESSED} != no && \
- ${MANCOMPRESSED} != maybe
-check-makevars::
- @${ECHO_MSG} "${PKGNAME}: Makefile error: value of MANCOMPRESSED (is \"${MANCOMPRESSED}\") can only be \"yes\", \"no\" or \"maybe\"".
- @${FALSE}
-.endif
-.endif
-
-MANCOMPRESSED?= no
-
.if defined(PATCHFILES)
.if ${PATCHFILES:M*.zip}x != x
PATCH_DEPENDS+= ${LOCALBASE}/bin/unzip:${PORTSDIR}/archivers/unzip
diff --git a/Mk/bsd.sanity.mk b/Mk/bsd.sanity.mk
index d980bab6d279..bc63966fd8d0 100644
--- a/Mk/bsd.sanity.mk
+++ b/Mk/bsd.sanity.mk
@@ -140,10 +140,10 @@ DEV_WARNING+= "INSTALLS_EGGINFO is deprecated, please add the entry directly to
SANITY_UNSUPPORTED= USE_OPENAL USE_FAM USE_MAKESELF USE_ZIP USE_LHA USE_CMAKE \
USE_READLINE USE_ICONV PERL_CONFIGURE PERL_MODBUILD \
USE_PERL5_BUILD USE_PERL5_RUN USE_DISPLAY USE_FUSE \
- USE_GETTEXT USE_GMAKE USE_SCONS USE_DRUPAL
+ USE_GETTEXT USE_GMAKE USE_SCONS USE_DRUPAL NO_INSTALL_MANPAGES
SANITY_DEPRECATED= USE_XZ USE_BZIP2 USE_PYDISTUTILS PYTHON_CONCURRENT_INSTALL \
PYDISTUTILS_AUTOPLIST PYTHON_PY3K_PLIST_HACK PYDISTUTILS_NOEGGINFO \
- USE_PYTHON_PREFIX PYTHON_PKGNAMESUFFIX NO_INSTALL_MANPAGES
+ USE_PYTHON_PREFIX PYTHON_PKGNAMESUFFIX
USE_OPENAL_ALT= USES=openal
USE_FAM_ALT= USES=fam
diff --git a/audio/sonata/Makefile b/audio/sonata/Makefile
index 507772133507..43f910ba51a5 100644
--- a/audio/sonata/Makefile
+++ b/audio/sonata/Makefile
@@ -29,7 +29,7 @@ TAGLIB_DESC= Install support for editing metadata
ZSI_DESC= Install support for automatic lyrics fetching
OPTIONS_SUB= yes
-MANPAGES_MAKE_ENV_OFF= NO_INSTALL_MANPAGES=${NO_INSTALL_MANPAGES}
+MANPAGES_MAKE_ENV_OFF= NO_INSTALL_MANPAGES=yes
DOCS_MAKE_ENV= NOPORTDOCS=${NOPORTDOCS}
MPD_RUN_DEPENDS+= musicpd:${PORTSDIR}/audio/musicpd
MMKEYS_RUN_DEPENDS=${PYTHON_PKGNAMEPREFIX}dbus>=0.82.4:${PORTSDIR}/devel/py-dbus
diff --git a/cad/qelectrotech/Makefile b/cad/qelectrotech/Makefile
index 7500efd8e95f..cc46a2b9f6e1 100644
--- a/cad/qelectrotech/Makefile
+++ b/cad/qelectrotech/Makefile
@@ -26,7 +26,6 @@ QMAKE_ARGS+= QMAKE_RPATHDIR="${_GCC_RUNTIME}"
MAN1= qelectrotech.1
MANLANG= "" cs el es fr.ISO8859-1 fr.UTF-8 fr it pl pt_PT
-MANCOMPRESSED= yes
pre-configure:
${MV} ${WRKSRC}/man/files/pt ${WRKSRC}/man/files/pt_PT
diff --git a/deskutils/cairo-dock/Makefile b/deskutils/cairo-dock/Makefile
index 1ef157800770..bcf31f0a239f 100644
--- a/deskutils/cairo-dock/Makefile
+++ b/deskutils/cairo-dock/Makefile
@@ -28,8 +28,6 @@ LDFLAGS+= -L${LOCALBASE}/lib
CMAKE_ARGS+= -Dinstall-pc-path:STRING="${LOCALBASE}/libdata/pkgconfig"
CMAKE_ARGS+= -DROOT_PREFIX:PATH=${STAGEDIR}
-MANCOMPRESSED= yes
-
post-patch:
@${FIND} ${WRKSRC} -type f -name "*" | ${XARGS} ${REINPLACE_CMD} -e \
's|/usr/share/pixmaps/|${LOCALBASE}/share/pixmaps/|g; \
diff --git a/graphics/hugin-devel/Makefile b/graphics/hugin-devel/Makefile
index d26a715e09a1..8133d8f484c8 100644
--- a/graphics/hugin-devel/Makefile
+++ b/graphics/hugin-devel/Makefile
@@ -49,38 +49,6 @@ WX_UNICODE= yes
USE_GL= glew glut
-MANCOMPRESSED= yes
-
-MAN1= align_image_stack.1 \
- autooptimiser.1 \
- autopano-noop.sh.1 \
- calibrate_lens_gui.1 \
- celeste_standalone.1 \
- checkpto.1 \
- cpclean.1 \
- cpfind.1 \
- deghosting_mask.1 \
- fulla.1 \
- hugin.1 \
- hugin_hdrmerge.1 \
- hugin_stitch_project.1 \
- icpfind.1 \
- nona.1 \
- linefind.1 \
- matchpoint.1 \
- nona_gui.1 \
- pano_modify.1 \
- pano_trafo.1 \
- pto2mk.1 \
- pto_gen.1 \
- pto_lensstack.1 \
- pto_merge.1 \
- pto_var.1 \
- tca_correct.1 \
- PTBatcher.1 \
- PTBatcherGUI.1 \
- vig_optimize.1
-
post-configure:
${REINPLACE_CMD} \
's/-pthread;-D_THREAD_SAFE/-pthread -D_THREAD_SAFE/g' \
diff --git a/irc/py-supybot/Makefile b/irc/py-supybot/Makefile
index 02bd9746dae7..35ddb167aecf 100644
--- a/irc/py-supybot/Makefile
+++ b/irc/py-supybot/Makefile
@@ -19,7 +19,6 @@ PYDISTUTILS_EGGINFO= supybot-${PORTVERSION}-py${PYTHON_VER}.egg-info
DOCS= ACKS ChangeLog INSTALL LICENSE README RELNOTES
-MANCOMPRESSED= no
MAN1= supybot.1 supybot-adduser.1 supybot-wizard.1 supybot-botchk.1 \
supybot-plugin-create.1 supybot-plugin-doc.1
diff --git a/math/proofgeneral/Makefile b/math/proofgeneral/Makefile
index 618f354206e6..7042f9dbf3bb 100644
--- a/math/proofgeneral/Makefile
+++ b/math/proofgeneral/Makefile
@@ -43,7 +43,6 @@ MAKE_ARGS+= PREFIX="${LOCALBASE}" DEST_PREFIX="${STAGEDIR}${PREFIX}" \
SUB_FILES= pkg-message
SUB_LIST= EMACS_SITE_LISPDIR=${EMACS_SITE_LISPDIR}
-MANCOMPRESSED= no
INFO= PG-adapting ProofGeneral
.if ${PORT_OPTIONS:MDOCS}
diff --git a/net-im/prosody/Makefile b/net-im/prosody/Makefile
index c3dd6530c07c..6a0659302e4f 100644
--- a/net-im/prosody/Makefile
+++ b/net-im/prosody/Makefile
@@ -24,7 +24,6 @@ USERS= prosody
GROUPS= ${USERS}
USE_RC_SUBR= prosody
-MANCOMPRESSED= no
OPTIONS_DEFINE= LUAJIT
LUAJIT_DESC= Run prosody using luajit
diff --git a/net/htpdate/Makefile b/net/htpdate/Makefile
index c33e8c9aeb36..9f220b2bd38d 100644
--- a/net/htpdate/Makefile
+++ b/net/htpdate/Makefile
@@ -15,7 +15,6 @@ LICENSE= GPLv2 # (or later)
USES= tar:bzip2
MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS}"
-MANCOMPRESSED= yes
PLIST_FILES= bin/${PORTNAME} man/man8/${PORTNAME}.8.gz
PORTDOCS= Changelog README
USE_RC_SUBR= ${PORTNAME}
diff --git a/net/mosquitto/Makefile b/net/mosquitto/Makefile
index 9f022717d696..01b2e6c96123 100644
--- a/net/mosquitto/Makefile
+++ b/net/mosquitto/Makefile
@@ -24,8 +24,6 @@ USES= cmake
USE_PYTHON= 2
NOCONFIGURE= yes
USE_RC_SUBR= mosquitto
-MANCOMPRESSED= no
-NO_MANCOMPRESS= yes
USE_LDCONFIG= yes
USERS= nobody
diff --git a/net/mpd5/Makefile b/net/mpd5/Makefile
index 92ef7a33bbc8..035768c5213e 100644
--- a/net/mpd5/Makefile
+++ b/net/mpd5/Makefile
@@ -31,7 +31,6 @@ RUN_DEPENDS+= /boot/modules/ng_ipacct.ko:${PORTSDIR}/net-mgmt/ng_ipacct
.endif
.endif
-MANCOMPRESSED= maybe
USE_RC_SUBR= mpd5
HTMLNUM!= jot 70 1
CONFSUF= conf secret script
diff --git a/ports-mgmt/dialog4ports/Makefile b/ports-mgmt/dialog4ports/Makefile
index e3f5bc81c8d8..57273cf748ba 100644
--- a/ports-mgmt/dialog4ports/Makefile
+++ b/ports-mgmt/dialog4ports/Makefile
@@ -23,7 +23,6 @@ USES= uidfix
# CCACHE has options, so may need d4p, make d4p not ccache friendly
# to avoid circular dependency
NO_CCACHE= yes
-MANCOMPRESSED= yes
MAKE_ENV+= __MAKE_CONF=/dev/null SRCCONF=/dev/null
.if !defined(D4P_SLAVE)
diff --git a/print/rprint/Makefile b/print/rprint/Makefile
index 60d489edd3ab..958a5c9261f0 100644
--- a/print/rprint/Makefile
+++ b/print/rprint/Makefile
@@ -12,7 +12,6 @@ COMMENT= Remote printing utility using a raw bidirectional tcp connection
LICENSE= BSD4CLAUSE
-MANCOMPRESSED= yes
PLIST_FILES= bin/rprint man/man1/rprint.1.gz
post-patch:
diff --git a/sysutils/bacula-server/Makefile b/sysutils/bacula-server/Makefile
index dcf4f22ed0bd..3f2bd099d621 100644
--- a/sysutils/bacula-server/Makefile
+++ b/sysutils/bacula-server/Makefile
@@ -48,7 +48,6 @@ SUB_FILES+= pkg-install.client pkg-deinstall.client pkg-message.client
SUB_FILES+= pkg-message.server
.endif
-MANCOMPRESSED= yes
CONFIGURE_ARGS+=--with-tcp-wrappers=/usr/lib \
--enable-smartalloc \
--sysconfdir=${ETCDIR} \
diff --git a/sysutils/bacula5-server/Makefile b/sysutils/bacula5-server/Makefile
index ba82a0e8d4e3..4dca125bdb9a 100644
--- a/sysutils/bacula5-server/Makefile
+++ b/sysutils/bacula5-server/Makefile
@@ -53,7 +53,6 @@ SUB_FILES+= pkg-install.client pkg-deinstall.client pkg-message.client
SUB_FILES+= pkg-message.server
.endif
-MANCOMPRESSED= yes
CONFIGURE_ARGS+=--with-tcp-wrappers=/usr/lib \
--enable-smartalloc \
--sysconfdir=${ETCDIR} \
diff --git a/sysutils/pfstat/Makefile b/sysutils/pfstat/Makefile
index 58616098fa94..99577988eb60 100644
--- a/sysutils/pfstat/Makefile
+++ b/sysutils/pfstat/Makefile
@@ -20,7 +20,6 @@ USE_RC_SUBR= pfstatd
MAN8= pfstat.8 \
pfstatd.8
-MANCOMPRESSED= no
PLIST_FILES= bin/pfstat \
bin/pfstatd
diff --git a/sysutils/puppet27/Makefile b/sysutils/puppet27/Makefile
index e4d67112e0bc..ab35b867b263 100644
--- a/sysutils/puppet27/Makefile
+++ b/sysutils/puppet27/Makefile
@@ -30,8 +30,6 @@ SUB_FILES+= pkg-message
PORTSCOUT= limit:^2\.7\.
-MANCOMPRESSED= yes
-
OPTIONS_DEFAULT= PACKAGE_ORIGIN
OPTIONS_SINGLE= PATCHES
OPTIONS_SINGLE_PATCHES= PACKAGE_ORIGIN PACKAGE_ROOT
diff --git a/textproc/hs-pandoc/Makefile b/textproc/hs-pandoc/Makefile
index 4902b44cac96..bc4ea3dd1565 100644
--- a/textproc/hs-pandoc/Makefile
+++ b/textproc/hs-pandoc/Makefile
@@ -33,7 +33,6 @@ MAN1SRC= man/man1
MAN5SRC= man/man5
MAN1PAGES= pandoc.1
MAN5PAGES= pandoc_markdown.5
-MANCOMPRESSED= no
FLAGS_DEFINE= EMBED_DATA_FILES HTTPS TRYPANDOC
FLAGS_DEFAULT= HTTPS
diff --git a/x11-toolkits/tk85/Makefile b/x11-toolkits/tk85/Makefile
index dc18dc6c792a..75efce41320b 100644
--- a/x11-toolkits/tk85/Makefile
+++ b/x11-toolkits/tk85/Makefile
@@ -41,7 +41,6 @@ INSTALL_TARGET= install
MAKE_ENV= SHORT_TK_VER=${SHORT_TK_VER}
PLIST_SUB= TK_VER=${TK_VER} SHORT_TK_VER=${SHORT_TK_VER}
NOPRECIOUSMAKEVARS= yes # Otherwise 'make readmes' is broken
-MANCOMPRESSED= no
DATADIR= ${PREFIX}/share/${PORTNAME}${TK_VER}
SUB_FILES= pkgIndex.tcl
diff --git a/x11-wm/afterstep/Makefile b/x11-wm/afterstep/Makefile
index f463fe4a0f36..522d29508325 100644
--- a/x11-wm/afterstep/Makefile
+++ b/x11-wm/afterstep/Makefile
@@ -23,7 +23,6 @@ USES= imake
USE_XORG= xpm xext x11
USE_CSTD= gnu89
INSTALL_TARGET= install install.man
-MANCOMPRESSED= yes
CFLAGS+= -Wno-return-type
SRCDIRS= afterstep \