aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--UPDATING15
-rw-r--r--dns/ldns/Makefile47
-rw-r--r--dns/ldns/pkg-plist6
-rw-r--r--dns/py-ldns/Makefile4
-rw-r--r--dns/py-ldns/pkg-plist6
5 files changed, 51 insertions, 27 deletions
diff --git a/UPDATING b/UPDATING
index 2365e1952d0f..8f995ad59301 100644
--- a/UPDATING
+++ b/UPDATING
@@ -5,6 +5,21 @@ they are unavoidable.
You should get into the habit of checking this file for changes each time
you update your ports collection, before attempting any port upgrades.
+20130711:
+ AFFECTS: users of dns/py-ldns
+ AUTHOR: mat@FreeBSD.org
+
+ The dns/py-ldns port now only installs the Python bits, and depends on
+ dns/ldns. Because of that, you can't just do a regular upgrade, it'd install
+ dns/ldns overwritting existing files and removing them when removing the old
+ version of dns/py-ldns.
+
+ # pkg_delete -f py-ldns-\*
+ # cd /usr/ports/dns/py-ldns && make clean && make install clean
+ or
+ # pkg delete -fg py-ldns-\*
+ # pkg install -f dns/py-ldns
+
20130707:
AFFECTS: users of www/ajaxplorer
AUTHOR: madpilot@FreeBSD.org
diff --git a/dns/ldns/Makefile b/dns/ldns/Makefile
index 49711978b215..3d6a587ee101 100644
--- a/dns/ldns/Makefile
+++ b/dns/ldns/Makefile
@@ -3,6 +3,7 @@
PORTNAME= ldns
PORTVERSION= 1.6.16
+PORTREVISION= 1
CATEGORIES= dns
MASTER_SITES= http://www.nlnetlabs.nl/downloads/ldns/ \
CRITICAL
@@ -17,23 +18,32 @@ USE_GMAKE= yes
USE_OPENSSL= yes
USE_LDCONFIG= yes
-OPTIONS_DEFINE= DOXYGEN EXAMPLES DRILL GOST PYLDNS
+.if !defined(BUILD_PYLDNS)
+OPTIONS_DEFINE= DOXYGEN EXAMPLES DRILL
OPTIONS_DEFAULT= EXAMPLES DRILL
DRILL_DESC= With drill program
+.endif
+
+OPTIONS_DEFINE+= GOST
+
GOST_DESC= GOST signatures enabled, requires openssl >= 1.0.0
-PYLDNS_DESC= ${PYTHON_DESC}
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MPYLDNS}
+.if defined(BUILD_PYLDNS)
USE_PYTHON= yes
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-CONFLICTS= ldns-[0-9]*
-.else
-CONFLICTS= py*-ldns-[0-9]*
-.endif
+ALL_TARGET= pyldns
+INSTALL_TARGET= install-pyldns
+CONFIGURE_ARGS+=--with-pyldns
+LIB_DEPENDS+= ldns:${PORTSDIR}/dns/ldns
+BUILD_DEPENDS+= ${LOCALBASE}/bin/swig:${PORTSDIR}/devel/swig13
+
+post-patch:
+ @${SED} -i '' -e 's=-I./include/ldns=-I${LOCALBASE}/include/ldns=' ${WRKSRC}/Makefile.in
+.else
ALL_TARGET= all
INSTALL_TARGET= install-lib install-h install-config
@@ -233,13 +243,6 @@ MAN3= ldns_bget_token.3 ldns_bgetc.3 ldns_bskipcs.3 ldns_buffer.3 \
MAN1+= ldns-config.1
.endif
-.if ${PORT_OPTIONS:MGOST}
-BUILD_DEPENDS+= openssl>=1.0:${PORTSDIR}/security/openssl
-.else
-NO_GOST= --disable-gost
-CONFIGURE_ARGS+=${NO_GOST}
-.endif
-
.if ${PORT_OPTIONS:MDRILL}
PLIST_SUB+= DRILLPROG=""
MAN1+= drill.1
@@ -262,15 +265,17 @@ MAN1+= ldns-chaos.1 ldns-compare-zones.1 ldns-dpa.1 \
PLIST_SUB+= EXAMPLES="@comment "
.endif
-.if ${PORT_OPTIONS:MPYLDNS}
-CONFIGURE_ARGS+=--with-pyldns
-BUILD_DEPENDS+= ${LOCALBASE}/bin/swig:${PORTSDIR}/devel/swig13
-INSTALL_TARGET+=install-pyldns
-PLIST_SUB+= PYLDNS=""
+.endif # BUILD_PYLDNS
+
+.if ${PORT_OPTIONS:MGOST}
+BUILD_DEPENDS+= openssl>=1.0:${PORTSDIR}/security/openssl
.else
-PLIST_SUB+= PYLDNS="@comment "
+NO_GOST= --disable-gost
+CONFIGURE_ARGS+=${NO_GOST}
.endif
+.if !defined(BUILD_PYLDNS)
+
post-configure:
.if ${PORT_OPTIONS:MEXAMPLES}
@(cd ${WRKSRC}/examples; ./configure --prefix=${PREFIX} \
@@ -299,4 +304,6 @@ post-install:
@(cd ${WRKSRC}/drill; ${GMAKE} install)
.endif
+.endif # BUILD_PYLDNS
+
.include <bsd.port.mk>
diff --git a/dns/ldns/pkg-plist b/dns/ldns/pkg-plist
index 583dd17c3a49..c85955a9f567 100644
--- a/dns/ldns/pkg-plist
+++ b/dns/ldns/pkg-plist
@@ -60,10 +60,4 @@ lib/libldns.a
lib/libldns.la
lib/libldns.so
lib/libldns.so.1
-%%PYLDNS%%%%PYTHON_SITELIBDIR%%/_ldns.so.1
-%%PYLDNS%%%%PYTHON_SITELIBDIR%%/ldns.py
-%%PYLDNS%%%%PYTHON_SITELIBDIR%%/_ldns.so
-%%PYLDNS%%%%PYTHON_SITELIBDIR%%/_ldns.la
-%%PYLDNS%%%%PYTHON_SITELIBDIR%%/_ldns.a
-%%PYLDNS%%@dirrm %%PYTHON_SITELIBDIR%%/ldns
@dirrm include/ldns
diff --git a/dns/py-ldns/Makefile b/dns/py-ldns/Makefile
index 4bb19cbdd89e..bf98311a7a2c 100644
--- a/dns/py-ldns/Makefile
+++ b/dns/py-ldns/Makefile
@@ -3,6 +3,8 @@
MASTERDIR= ${.CURDIR}/../../dns/ldns
-OPTIONS_SET= PYLDNS
+BUILD_PYLDNS=yes
+
+PLIST= ${.CURDIR}/pkg-plist
.include "${MASTERDIR}/Makefile"
diff --git a/dns/py-ldns/pkg-plist b/dns/py-ldns/pkg-plist
new file mode 100644
index 000000000000..c1313ba89239
--- /dev/null
+++ b/dns/py-ldns/pkg-plist
@@ -0,0 +1,6 @@
+%%PYTHON_SITELIBDIR%%/_ldns.so.1
+%%PYTHON_SITELIBDIR%%/ldns.py
+%%PYTHON_SITELIBDIR%%/_ldns.so
+%%PYTHON_SITELIBDIR%%/_ldns.la
+%%PYTHON_SITELIBDIR%%/_ldns.a
+@dirrm %%PYTHON_SITELIBDIR%%/ldns