aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/sigslot/Makefile28
-rw-r--r--devel/sigslot/distinfo1
-rw-r--r--devel/sigslot/pkg-comment1
-rw-r--r--devel/sigslot/pkg-descr3
-rw-r--r--devel/sigslot/pkg-plist1
6 files changed, 35 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index bd5427577111..fb6efd4a3815 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -705,6 +705,7 @@
SUBDIR += shmap
SUBDIR += showgrammar
SUBDIR += shtool
+ SUBDIR += sigslot
SUBDIR += silc-toolkit
SUBDIR += sip
SUBDIR += soup
diff --git a/devel/sigslot/Makefile b/devel/sigslot/Makefile
new file mode 100644
index 000000000000..4e250692d632
--- /dev/null
+++ b/devel/sigslot/Makefile
@@ -0,0 +1,28 @@
+# ex:ts=8
+# Ports collection makefile for: sigslot
+# Date created: Jul 30, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= sigslot
+PORTVERSION= 1.0.0
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME}-${PORTVERSION:S/./-/g}
+
+MAINTAINER= ports@FreeBSD.org
+
+NO_BUILD= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+post-patch:
+ @(cd ${WRKSRC} ; ${MV} -f sigslot.h sigslot.h.orig ; \
+ ${CAT} sigslot.h.orig | /usr/bin/col -b > sigslot.h)
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/sigslot.h ${PREFIX}/include
+
+.include <bsd.port.mk>
diff --git a/devel/sigslot/distinfo b/devel/sigslot/distinfo
new file mode 100644
index 000000000000..616bd36a2262
--- /dev/null
+++ b/devel/sigslot/distinfo
@@ -0,0 +1 @@
+MD5 (sigslot-1-0-0.tar.gz) = ab03dc4b188ba47cd836df88775dadfd
diff --git a/devel/sigslot/pkg-comment b/devel/sigslot/pkg-comment
new file mode 100644
index 000000000000..ec9aa41ab5f5
--- /dev/null
+++ b/devel/sigslot/pkg-comment
@@ -0,0 +1 @@
+C++ Signal/Slot Library
diff --git a/devel/sigslot/pkg-descr b/devel/sigslot/pkg-descr
new file mode 100644
index 000000000000..a3738019f482
--- /dev/null
+++ b/devel/sigslot/pkg-descr
@@ -0,0 +1,3 @@
+sigslot - C++ Signal/Slot Library
+
+WWW: http://sigslot.sourceforge.net/
diff --git a/devel/sigslot/pkg-plist b/devel/sigslot/pkg-plist
new file mode 100644
index 000000000000..68d78827e570
--- /dev/null
+++ b/devel/sigslot/pkg-plist
@@ -0,0 +1 @@
+include/sigslot.h