aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--MOVED1
-rw-r--r--UPDATING22
-rw-r--r--devel/viewvc/Makefile8
-rw-r--r--www/mod_python3/distinfo2
-rw-r--r--www/mod_python33/Makefile (renamed from www/mod_python3/Makefile)8
-rw-r--r--www/mod_python33/distinfo2
-rw-r--r--www/mod_python33/files/patch-Makefile.in (renamed from www/mod_python3/files/patch-Makefile.in)0
-rw-r--r--www/mod_python33/files/patch-configure (renamed from www/mod_python3/files/patch-configure)0
-rw-r--r--www/mod_python33/files/patch-src__connobject.c (renamed from www/mod_python3/files/patch-src__connobject.c)0
-rw-r--r--www/mod_python33/pkg-descr (renamed from www/mod_python3/pkg-descr)0
-rw-r--r--www/mod_python33/pkg-message (renamed from www/mod_python3/pkg-message)0
-rw-r--r--www/mod_python33/pkg-plist (renamed from www/mod_python3/pkg-plist)0
12 files changed, 32 insertions, 11 deletions
diff --git a/MOVED b/MOVED
index 0d08db1ce3b4..a466fe39fe2d 100644
--- a/MOVED
+++ b/MOVED
@@ -5997,3 +5997,4 @@ math/umatrix||2014-04-13|Has expired: Unmaintained since 2001
lang/f77||2014-04-13|Has expired: Unmaintained since 2001
security/labrea||2014-04-14|Has expired: Unmaintained since 2003
lang/dmd|lang/dmd1|2014-04-14|Upline no longer supports dmd 1.X, it is now the secondary dmd port.
+www/mod_python3|www/mod_python33|2014-04-15|Port moved to reflect PKGNAMESUFFIX
diff --git a/UPDATING b/UPDATING
index 09c0e60b4f73..7624c148bea5 100644
--- a/UPDATING
+++ b/UPDATING
@@ -5,6 +5,24 @@ they are unavoidable.
You should get into the habit of checking this file for changes each time
you update your ports collection, before attempting any port upgrades.
+20140415:
+ AFFECTS: Users of mod_python3
+ AUTHOR: ohauer@FreeBSD.org
+
+ www/mod_python3 was renamed to www/mod_python33, additional www/mod_python35
+ with support for apache24 was added to the portstree.
+
+ To reflect the new port location use:
+
+ pkgng users:
+ # pkg set -o www/mod_python3:www/mod_python33
+
+ portmaster users:
+ # portmaster -o www/mod_python33 www/mod_python3
+
+ portupgrade users:
+ # portugrade -o www/mod_python33 www/mod_python3
+
20140414:
AFFECTS: Users of dmd 1.X and dmd 2.x.
AUTHOR: cy@FreeBSD.org
@@ -83,8 +101,8 @@ you update your ports collection, before attempting any port upgrades.
AFFECTS: users of textproc/elasticsearch
AUTHOR: tj@FreeBSD.org
- Elasticsearch has been updated to version 1.1.0. If you are updating
- from a version prior to 1.0.0 you will need to do a full cluster
+ Elasticsearch has been updated to version 1.1.0. If you are updating
+ from a version prior to 1.0.0 you will need to do a full cluster
shutdown for this update as it can not be performed in a rolling
fashion.
diff --git a/devel/viewvc/Makefile b/devel/viewvc/Makefile
index b8d1bef41a56..80a6405fb78c 100644
--- a/devel/viewvc/Makefile
+++ b/devel/viewvc/Makefile
@@ -18,18 +18,20 @@ OPTIONS_DEFAULT= WEBSRV APACHE SVN
OPTIONS_SINGLE= WEBSRV APMOD
OPTIONS_SINGLE_WEBSRV= APACHE LIGHTTPD
-OPTIONS_SINGLE_APMOD= MODPYTHON3 MODWSGI3
+OPTIONS_SINGLE_APMOD= MODPYTHON33 MODPYTHON35 MODWSGI3
WEBSRV_DESC= Enable web server support
APMOD_DESC= depend on optional Apache module
MODWSGI3_DESC= Enable mod_wsgi3 support
-MODPYTHON3_DESC= Enable mod_python3 support
+MODPYTHON33_DESC= Enable mod_python33 support
+MODPYTHON35_DESC= Enable mod_python35 support
MYSQL_DESC= Bonsai-like repository query facilities
APACHE_USE= APACHE_RUN=22+
LIGHTTPD_RUN_DEPENDS= lighttpd:${PORTSDIR}/www/lighttpd
-MODPYTHON3_RUN_DEPENDS= ${APACHE_PKGNAMEPREFIX}mod_python>=3.3:${PORTSDIR}/www/mod_python3
+MODPYTHON33_RUN_DEPENDS=${APACHE_PKGNAMEPREFIX}mod_python33>=3.3:${PORTSDIR}/www/mod_python33
+MODPYTHON35_RUN_DEPENDS=${APACHE_PKGNAMEPREFIX}mod_python35>=3.5:${PORTSDIR}/www/mod_python35
MODWSGI3_RUN_DEPENDS= ${APACHE_PKGNAMEPREFIX}mod_wsgi3>=3.3:${PORTSDIR}/www/mod_wsgi3
SVN_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}subversion>=0:${PORTSDIR}/devel/py-subversion
MYSQL_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}MySQLdb>=0:${PORTSDIR}/databases/py-MySQLdb
diff --git a/www/mod_python3/distinfo b/www/mod_python3/distinfo
deleted file mode 100644
index f19a5d6e0112..000000000000
--- a/www/mod_python3/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (mod_python-3.3.1.tgz) = ad2331fd5fcfd720ef9e3482973fc2d06eff36ba0c44693cfa42056a62175a6b
-SIZE (mod_python-3.3.1.tgz) = 447954
diff --git a/www/mod_python3/Makefile b/www/mod_python33/Makefile
index fb4e0cb912fe..e5c7101a35b3 100644
--- a/www/mod_python3/Makefile
+++ b/www/mod_python33/Makefile
@@ -3,12 +3,13 @@
PORTNAME= mod_python
PORTVERSION= 3.3.1
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= www python
MASTER_SITES= ${MASTER_SITE_APACHE_HTTPD}
MASTER_SITE_SUBDIR= modpython
PKGNAMEPREFIX= ${APACHE_PKGNAMEPREFIX}
-EXTRACT_SUFX= .tgz
+PKGNAMESUFFIX= 33
+DIST_SUBDIR= apache2
MAINTAINER= apache@FreeBSD.org
COMMENT= Apache module that embeds the Python interpreter within the server
@@ -17,10 +18,9 @@ LICENSE= APACHE20
USE_APACHE= 22
USE_PYTHON= yes
+USES= tar:tgz
INSTALLS_EGGINFO= yes
-LATEST_LINK= mod_python3
-
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --with-apxs="${APXS}" \
--with-python="${PYTHON_CMD}" \
diff --git a/www/mod_python33/distinfo b/www/mod_python33/distinfo
new file mode 100644
index 000000000000..e1380d3a0e86
--- /dev/null
+++ b/www/mod_python33/distinfo
@@ -0,0 +1,2 @@
+SHA256 (apache2/mod_python-3.3.1.tgz) = ad2331fd5fcfd720ef9e3482973fc2d06eff36ba0c44693cfa42056a62175a6b
+SIZE (apache2/mod_python-3.3.1.tgz) = 447954
diff --git a/www/mod_python3/files/patch-Makefile.in b/www/mod_python33/files/patch-Makefile.in
index bde1f5bc7fff..bde1f5bc7fff 100644
--- a/www/mod_python3/files/patch-Makefile.in
+++ b/www/mod_python33/files/patch-Makefile.in
diff --git a/www/mod_python3/files/patch-configure b/www/mod_python33/files/patch-configure
index e979f312021d..e979f312021d 100644
--- a/www/mod_python3/files/patch-configure
+++ b/www/mod_python33/files/patch-configure
diff --git a/www/mod_python3/files/patch-src__connobject.c b/www/mod_python33/files/patch-src__connobject.c
index aa665ffebd74..aa665ffebd74 100644
--- a/www/mod_python3/files/patch-src__connobject.c
+++ b/www/mod_python33/files/patch-src__connobject.c
diff --git a/www/mod_python3/pkg-descr b/www/mod_python33/pkg-descr
index 6e3e10329de3..6e3e10329de3 100644
--- a/www/mod_python3/pkg-descr
+++ b/www/mod_python33/pkg-descr
diff --git a/www/mod_python3/pkg-message b/www/mod_python33/pkg-message
index 612fd5e7f501..612fd5e7f501 100644
--- a/www/mod_python3/pkg-message
+++ b/www/mod_python33/pkg-message
diff --git a/www/mod_python3/pkg-plist b/www/mod_python33/pkg-plist
index 329677302b98..329677302b98 100644
--- a/www/mod_python3/pkg-plist
+++ b/www/mod_python33/pkg-plist