aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--audio/mp3blaster/Makefile2
-rw-r--r--audio/rhythmbox/Makefile2
-rw-r--r--audio/rosegarden/Makefile1
-rw-r--r--comms/lirc/Makefile27
-rw-r--r--comms/lirc/pkg-plist8
-rw-r--r--comms/py-lirc/Makefile2
-rw-r--r--emulators/visualboyadvance-m/Makefile1
-rw-r--r--graphics/geeqie/Makefile2
-rw-r--r--multimedia/audacious-plugins/Makefile2
-rw-r--r--multimedia/gxine/Makefile1
-rw-r--r--multimedia/mplayer/Makefile2
-rw-r--r--multimedia/mplayer2/Makefile2
-rw-r--r--multimedia/mpv/Makefile2
-rw-r--r--multimedia/mythtv/Makefile2
-rw-r--r--multimedia/totem/Makefile2
-rw-r--r--multimedia/vlc/Makefile2
-rw-r--r--multimedia/xine/Makefile2
17 files changed, 32 insertions, 30 deletions
diff --git a/audio/mp3blaster/Makefile b/audio/mp3blaster/Makefile
index 92a8648c51f4..7466fb743a03 100644
--- a/audio/mp3blaster/Makefile
+++ b/audio/mp3blaster/Makefile
@@ -3,7 +3,7 @@
PORTNAME= mp3blaster
PORTVERSION= 3.2.5
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= audio
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
diff --git a/audio/rhythmbox/Makefile b/audio/rhythmbox/Makefile
index 47159e53f1c8..3afa5af5d835 100644
--- a/audio/rhythmbox/Makefile
+++ b/audio/rhythmbox/Makefile
@@ -4,7 +4,7 @@
PORTNAME= rhythmbox
PORTVERSION= 0.12.8
-PORTREVISION= 15
+PORTREVISION= 16
CATEGORIES= audio gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
diff --git a/audio/rosegarden/Makefile b/audio/rosegarden/Makefile
index 616d50c1f468..fe65a21df566 100644
--- a/audio/rosegarden/Makefile
+++ b/audio/rosegarden/Makefile
@@ -3,6 +3,7 @@
PORTNAME= rosegarden
PORTVERSION= 14.02
+PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION}/
diff --git a/comms/lirc/Makefile b/comms/lirc/Makefile
index 7cc6381240d1..6e5d9b4d535c 100644
--- a/comms/lirc/Makefile
+++ b/comms/lirc/Makefile
@@ -3,7 +3,7 @@
PORTNAME= lirc
PORTVERSION= 0.9.0
-PORTREVISION= 5
+PORTREVISION= 6
PORTEPOCH= 1
CATEGORIES= comms
MASTER_SITES= SF/${PORTNAME}/LIRC/${PORTVERSION}
@@ -14,19 +14,19 @@ COMMENT= Linux Infrared Remote Control
BUILD_DEPENDS= v4l_compat>=1.0.20110603:${PORTSDIR}/multimedia/v4l_compat
-USE_AUTOTOOLS= libtool automake autoheader aclocal autoconf
-USES= gmake tar:bzip2
-ACLOCAL_ARGS= -I "${ACLOCAL_DIR}" -I ${LOCALBASE}/share/aclocal
+INSTALL_TARGET= install-strip
+USES= gmake libtool tar:bzip2
+USE_AUTOTOOLS= libtoolize automake autoheader aclocal autoconf
+AUTOMAKE_ARGS= -a -c -f
USE_XORG= sm x11
USE_PYTHON= yes
USE_CSTD= gnu89
-GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-CONFIGURE_ARGS= --enable-sandboxed --with-devdir=/var/run/lirc \
- --sysconfdir=${PREFIX}/etc
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ARGS= --enable-sandboxed --with-devdir=/var/run/lirc \
+ --sysconfdir=${PREFIX}/etc
+CPPFLAGS+= -I${LOCALBASE}/include
+LIBS+= -L${LOCALBASE}/lib
OPTIONS_DEFINE= MINIMAL DEBUG UARTLIRC DOCS EXAMPLES
@@ -63,10 +63,11 @@ CONFIGURE_ARGS+= --enable-debug
RUN_DEPENDS+= uartlirc>=0.3:${PORTSDIR}/comms/uartlirc
.endif
-# XXX: work around an issue with automake-1.13 erroring out on a
-# non-existent m4 directory before libtoolize creates it
-pre-configure::
- @${MKDIR} ${WRKSRC}/m4
+post-patch:
+ @${REINPLACE_CMD} \
+ -e 's/`$${LIBUSB_CONFIG} --libs`/-lusb/' \
+ -e 's/`$${LIBUSB_CONFIG} --cflags`//' \
+ ${WRKSRC}/configure.ac
post-install:
.if ${PORT_OPTIONS:MDOCS}
diff --git a/comms/lirc/pkg-plist b/comms/lirc/pkg-plist
index ae72a95243b0..ca8293461299 100644
--- a/comms/lirc/pkg-plist
+++ b/comms/lirc/pkg-plist
@@ -12,9 +12,9 @@ bin/pronto2lirc
bin/xmode2
include/lirc/lirc_client.h
lib/liblirc_client.a
-lib/liblirc_client.la
lib/liblirc_client.so
-lib/liblirc_client.so.2
+lib/liblirc_client.so.0
+lib/liblirc_client.so.0.2.1
man/man1/ircat.1.gz
man/man1/irexec.1.gz
man/man1/irpty.1.gz
@@ -31,8 +31,6 @@ man/man8/lircmd.8.gz
sbin/lircd
sbin/lircmd
@dirrm include/lirc
-@unexec if cmp -s %D/etc/lircd.conf.sample %D/etc/lircd.conf; then rm -f %D/etc/lircd.conf; fi
-etc/lircd.conf.sample
-@exec if [ ! -f %D/etc/lircd.conf ] ; then cp -p %D/%F %B/lircd.conf; fi
+@sample etc/lircd.conf.sample
@exec mkdir -p /var/run/lirc
@unexec rmdir /var/run/lirc 2> /dev/null || true
diff --git a/comms/py-lirc/Makefile b/comms/py-lirc/Makefile
index 47cb3a81201f..265942d2985e 100644
--- a/comms/py-lirc/Makefile
+++ b/comms/py-lirc/Makefile
@@ -3,7 +3,7 @@
PORTNAME= lirc
PORTVERSION= 0.0.5
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= comms python
MASTER_SITES= SF/py${PORTNAME}/py${PORTNAME}/${PORTVERSION}
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
diff --git a/emulators/visualboyadvance-m/Makefile b/emulators/visualboyadvance-m/Makefile
index 24c2d3df280e..3a4e5675ea21 100644
--- a/emulators/visualboyadvance-m/Makefile
+++ b/emulators/visualboyadvance-m/Makefile
@@ -3,6 +3,7 @@
PORTNAME= visualboyadvance-m
PORTVERSION= 1.8.0r${SVN_REV}
+PORTREVISION= 1
CATEGORIES= emulators
MASTER_SITES= https://cooltrainer.org/freebsd-ports/visualboyadvance-m/
diff --git a/graphics/geeqie/Makefile b/graphics/geeqie/Makefile
index 84b36250fc2b..3e641c11270f 100644
--- a/graphics/geeqie/Makefile
+++ b/graphics/geeqie/Makefile
@@ -3,7 +3,7 @@
PORTNAME= geeqie
PORTVERSION= 1.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
diff --git a/multimedia/audacious-plugins/Makefile b/multimedia/audacious-plugins/Makefile
index 02f3c418a575..866d2799299c 100644
--- a/multimedia/audacious-plugins/Makefile
+++ b/multimedia/audacious-plugins/Makefile
@@ -3,7 +3,7 @@
PORTNAME= audacious-plugins
PORTVERSION= 3.5
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= multimedia audio
MASTER_SITES= http://distfiles.audacious-media-player.org/
diff --git a/multimedia/gxine/Makefile b/multimedia/gxine/Makefile
index 70d11e3b29fc..9906cd8a65f6 100644
--- a/multimedia/gxine/Makefile
+++ b/multimedia/gxine/Makefile
@@ -3,6 +3,7 @@
PORTNAME= gxine
PORTVERSION= 0.5.908
+PORTREVISION= 1
CATEGORIES= multimedia
MASTER_SITES= SF/xine/${PORTNAME}/${PORTVERSION}
diff --git a/multimedia/mplayer/Makefile b/multimedia/mplayer/Makefile
index 6a55731732fb..f5f6928408da 100644
--- a/multimedia/mplayer/Makefile
+++ b/multimedia/mplayer/Makefile
@@ -3,7 +3,7 @@
PORTNAME= mplayer
PORTVERSION= ${MPLAYER_PORT_VERSION}
-PORTREVISION= 5
+PORTREVISION= 6
COMMENT= High performance media player supporting many formats
diff --git a/multimedia/mplayer2/Makefile b/multimedia/mplayer2/Makefile
index 8b6e8de23e38..e69180c478ce 100644
--- a/multimedia/mplayer2/Makefile
+++ b/multimedia/mplayer2/Makefile
@@ -2,7 +2,7 @@
PORTNAME= mplayer2
PORTVERSION= ${MPLAYER2_PORT_VERSION}
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= multimedia audio
MASTER_SITES= LOCAL/gblach/
diff --git a/multimedia/mpv/Makefile b/multimedia/mpv/Makefile
index 99492c8ba9b7..d0c8a89c139e 100644
--- a/multimedia/mpv/Makefile
+++ b/multimedia/mpv/Makefile
@@ -3,7 +3,7 @@
PORTNAME= mpv
PORTVERSION= 0.4.2
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= multimedia audio
MASTER_SITES= GH:0 GHC:0 http://ftp.waf.io/pub/release/:1 \
diff --git a/multimedia/mythtv/Makefile b/multimedia/mythtv/Makefile
index af693489a8e3..ecb5fba38b6d 100644
--- a/multimedia/mythtv/Makefile
+++ b/multimedia/mythtv/Makefile
@@ -3,7 +3,7 @@
PORTNAME= mythtv
PORTVERSION= 0.27.0.20140121
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= multimedia
MASTER_SITES= http://people.freebsd.org/~decke/distfiles/
diff --git a/multimedia/totem/Makefile b/multimedia/totem/Makefile
index 4d8b34173098..8a02354e5049 100644
--- a/multimedia/totem/Makefile
+++ b/multimedia/totem/Makefile
@@ -4,7 +4,7 @@
PORTNAME= totem
PORTVERSION= 2.32.0
-PORTREVISION?= 5
+PORTREVISION?= 6
CATEGORIES= multimedia gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
diff --git a/multimedia/vlc/Makefile b/multimedia/vlc/Makefile
index 7a9c3156ca6b..6a2843a137da 100644
--- a/multimedia/vlc/Makefile
+++ b/multimedia/vlc/Makefile
@@ -3,7 +3,7 @@
PORTNAME= vlc
DISTVERSION= 2.1.5
-PORTREVISION= 4
+PORTREVISION= 5
PORTEPOCH= 4
CATEGORIES= multimedia audio ipv6 net www
MASTER_SITES= http://download.videolan.org/pub/videolan/${PORTNAME}/${DISTVERSION:S/a$//}/ \
diff --git a/multimedia/xine/Makefile b/multimedia/xine/Makefile
index accc2dab1917..0dfe08d792e3 100644
--- a/multimedia/xine/Makefile
+++ b/multimedia/xine/Makefile
@@ -2,7 +2,7 @@
PORTNAME= xine
PORTVERSION= 0.99.8
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= multimedia
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-ui/${PORTVERSION}
DISTNAME= ${PORTNAME}-ui-${PORTVERSION}