aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--biology/Makefile1
-rw-r--r--biology/readseq/Makefile26
-rw-r--r--biology/readseq/distinfo3
-rwxr-xr-xbiology/readseq/files/readseq.in3
-rw-r--r--biology/readseq/pkg-descr5
5 files changed, 38 insertions, 0 deletions
diff --git a/biology/Makefile b/biology/Makefile
index adb71952bb1e..956405f7e693 100644
--- a/biology/Makefile
+++ b/biology/Makefile
@@ -148,6 +148,7 @@
SUBDIR += python-nexus
SUBDIR += rainbow
SUBDIR += rampler
+ SUBDIR += readseq
SUBDIR += recombine
SUBDIR += ruby-bio
SUBDIR += rubygem-bio
diff --git a/biology/readseq/Makefile b/biology/readseq/Makefile
new file mode 100644
index 000000000000..5956dbea4551
--- /dev/null
+++ b/biology/readseq/Makefile
@@ -0,0 +1,26 @@
+# $FreeBSD$
+
+PORTNAME= readseq
+DISTVERSION= 2.1.19
+CATEGORIES= biology java
+# The site used by bioconda for 2.1.30 is down as of 2021-04-13
+# MASTER_SITES= http://iubio.bio.indiana.edu/soft/molbio/readseq/java/
+MASTER_SITES= https://sourceforge.net/projects/readseq/files/latest/
+DISTNAME= ${PORTNAME}
+EXTRACT_SUFX= .jar
+
+MAINTAINER= jwb@FreeBSD.org
+COMMENT= Read and reformat biosequences, Java command-line version
+
+LICENSE= PD
+
+USE_JAVA= yes
+NO_BUILD= yes
+SUB_FILES= readseq
+PLIST_FILES= bin/readseq share/java/classes/readseq.jar
+
+do-install:
+ ${INSTALL_DATA} ${DISTDIR}/${DISTFILES} ${STAGEDIR}${JAVAJARDIR}
+ ${INSTALL_SCRIPT} ${WRKDIR}/readseq ${STAGEDIR}${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/biology/readseq/distinfo b/biology/readseq/distinfo
new file mode 100644
index 000000000000..a4a40484d345
--- /dev/null
+++ b/biology/readseq/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1618350447
+SHA256 (readseq.jar) = 966e7d4e1c4c6add588b3ead281c993c6a0c35b991a1ded53f81230a54ac6778
+SIZE (readseq.jar) = 767702
diff --git a/biology/readseq/files/readseq.in b/biology/readseq/files/readseq.in
new file mode 100755
index 000000000000..41d8d2466c57
--- /dev/null
+++ b/biology/readseq/files/readseq.in
@@ -0,0 +1,3 @@
+#!/bin/sh -e
+
+java -jar %%JAVAJARDIR%%/readseq.jar "$@"
diff --git a/biology/readseq/pkg-descr b/biology/readseq/pkg-descr
new file mode 100644
index 000000000000..f07d55783e38
--- /dev/null
+++ b/biology/readseq/pkg-descr
@@ -0,0 +1,5 @@
+Sequence reading library developed by the Ribosomal Database Project. It can
+handle genbank, embl, fasta, fastq, sff and sto files, can read from files or
+streams, and can handle indexing files.
+
+WWW: https://sourceforge.net/projects/readseq