aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--GIDs1
-rw-r--r--UIDs1
-rw-r--r--security/stunnel/Makefile1
-rw-r--r--security/stunnel/pkg-install4
4 files changed, 5 insertions, 2 deletions
diff --git a/GIDs b/GIDs
index 29471aaaa171..2296942b8f4d 100644
--- a/GIDs
+++ b/GIDs
@@ -91,6 +91,7 @@ prelude:*:281:
_sphinx:*:312:
dkfilter:*:325:
wildfire:*:340:
+stunnel:*:341:
ldap:*:389:
tiarra:*:398:
drweb:*:426:
diff --git a/UIDs b/UIDs
index 86026092ecd3..c24d9b47b031 100644
--- a/UIDs
+++ b/UIDs
@@ -101,6 +101,7 @@ prelude:*:281:281:Prelude user:/nonexistent:/sbin/nologin
_sphinx:*:312:312::0:0:Sphinxsearch Owner:/nonexistent:/sbin/nologin
dkfilter:*:325:325:DK Filter Owner:/nonexistent:/sbin/nologin
wildfire:*:340:340::0:0:Wildfire Daemon:/nonexistent:/sbin/nologin
+stunnel:*:341:341::0:0:Stunnel Daemon:/nonexistent:/sbin/nologin
ldap:*:389:389:OpenLDAP Server:/nonexistent:/sbin/nologin
tiarra:*:398:398:Tiarra IRC Proxy:/nonexistent:/usr/sbin/nologin
drweb:*:426:426:Dr.Web Mail Scanner:/nonexistent:/sbin/nologin
diff --git a/security/stunnel/Makefile b/security/stunnel/Makefile
index f3b053e90b08..c4ddbda14fa6 100644
--- a/security/stunnel/Makefile
+++ b/security/stunnel/Makefile
@@ -7,6 +7,7 @@
PORTNAME= stunnel
PORTVERSION= 4.20
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= http://www.stunnel.org/download/stunnel/src/ \
ftp://stunnel.mirt.net/stunnel/ \
diff --git a/security/stunnel/pkg-install b/security/stunnel/pkg-install
index 2753471a8467..1fd776379bbf 100644
--- a/security/stunnel/pkg-install
+++ b/security/stunnel/pkg-install
@@ -16,7 +16,7 @@ POST-INSTALL)
if pw group show "${GROUP}" 2>/dev/null; then
echo "You already have a group \"${GROUP}\", so I will use it."
else
- if pw groupadd ${GROUP} ; then
+ if pw groupadd -g 341 -n ${GROUP} ; then
echo "Added group \"${GROUP}\"."
else
echo "Adding group \"${GROUP}\" failed..."
@@ -27,7 +27,7 @@ POST-INSTALL)
if pw user show "${USER}" 2>/dev/null; then
echo "You already have a user \"${USER}\", so I will use it."
else
- if pw useradd ${USER} -g ${GROUP} -h - \
+ if pw useradd -u 341 -n ${USER} -g ${GROUP} -h - \
-d /nonexistent -c "stunnel Daemon" -s /sbin/nologin
then
echo "Added user \"${USER}\"."