aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--databases/galera/Makefile3
-rw-r--r--deskutils/growl-for-linux/Makefile2
-rw-r--r--games/openclonk/Makefile2
-rw-r--r--graphics/gcolor3/Makefile2
-rw-r--r--lang/swi-pl/Makefile4
-rw-r--r--math/blis/Makefile2
-rw-r--r--math/qalculate/Makefile2
-rw-r--r--multimedia/pwcbsd/Makefile2
-rw-r--r--net-im/corebird/Makefile2
-rw-r--r--security/wolfssl/Makefile4
-rw-r--r--sysutils/fsearch/Makefile2
-rw-r--r--textproc/highlight/Makefile2
-rw-r--r--textproc/ibus-qt/Makefile2
-rw-r--r--textproc/libstaroffice/Makefile2
-rw-r--r--textproc/rubygem-cld3/Makefile2
-rw-r--r--textproc/uncrustify/Makefile4
-rw-r--r--www/netsurf/Makefile2
-rw-r--r--www/rubygem-jquery-rails-rails50/Makefile2
-rw-r--r--x11/sakura/Makefile4
19 files changed, 45 insertions, 2 deletions
diff --git a/databases/galera/Makefile b/databases/galera/Makefile
index c6192b6f9450..a911728ec05e 100644
--- a/databases/galera/Makefile
+++ b/databases/galera/Makefile
@@ -15,7 +15,8 @@ BUILD_DEPENDS= checkmk:devel/check \
${LOCALBASE}/include/boost/shared_ptr.hpp:devel/boost-libs
LIB_DEPENDS= libboost_date_time.so:devel/boost-libs
-NOT_FOR_ARCHS= i386
+BROKEN_powerpc64= fails to compile: gu_atomic.h: This GCC version does not support 8-byte atomics on this platform. Use GCC >= 4.7.x
+NOT_FOR_ARCHS= i386
# On i386 older versions of clang produce:
# cannot compile this atomic library call yet ... __atomic_add_fetch
# whereas newer ones generate a call to __atomic_add_fetch which ends up with
diff --git a/deskutils/growl-for-linux/Makefile b/deskutils/growl-for-linux/Makefile
index 943b10b51d31..6aa587a0ce83 100644
--- a/deskutils/growl-for-linux/Makefile
+++ b/deskutils/growl-for-linux/Makefile
@@ -15,6 +15,8 @@ BUILD_DEPENDS= desktop-file-install:devel/desktop-file-utils
LIB_DEPENDS= libcurl.so:ftp/curl \
libdbus-glib-1.so:devel/dbus-glib
+BROKEN_powerpc64= fails to compile: balloon.c:160: error: nested functions are disabled, use -fnested-functions to re-enable
+
CONFIGURE_ARGS= OPENSSL_CFLAGS="-I${OPENSSLINC}" OPENSSL_LIBS="-L${OPENSSLLIB} -lcrypto"
GH_ACCOUNT= mattn
diff --git a/games/openclonk/Makefile b/games/openclonk/Makefile
index 1dcb22d16430..f10f60b8e662 100644
--- a/games/openclonk/Makefile
+++ b/games/openclonk/Makefile
@@ -21,6 +21,8 @@ LIB_DEPENDS= libboost_thread.so:devel/boost-libs \
libpng.so:graphics/png \
libvorbis.so:audio/libvorbis
+BROKEN_powerpc64= fails to compile: C4Texture.cpp:260:13: error: 'stoul' is not a member of 'std'
+
USES= compiler:c++14-lang cmake desktop-file-utils jpeg pkgconfig tar:bzip2
USE_GL= glew
USE_GNOME= gtk30
diff --git a/graphics/gcolor3/Makefile b/graphics/gcolor3/Makefile
index 298c19454f0d..d91ae08d12b4 100644
--- a/graphics/gcolor3/Makefile
+++ b/graphics/gcolor3/Makefile
@@ -11,6 +11,8 @@ COMMENT= Simple color chooser
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/LICENSE
+BROKEN_powerpc64= fails to compile: main.c: In function '_print_version_and_exit': will never be executed
+
USES= autoreconf gmake gettext libtool pkgconfig
USE_GNOME= cairo gdkpixbuf2 gtk30 intltool
GNU_CONFIGURE= yes
diff --git a/lang/swi-pl/Makefile b/lang/swi-pl/Makefile
index 9a9a6bd950e8..3c4d5008939c 100644
--- a/lang/swi-pl/Makefile
+++ b/lang/swi-pl/Makefile
@@ -17,6 +17,10 @@ LIB_DEPENDS= libgmp.so:math/gmp \
libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2
+BROKEN_mips= fails to link: libswipl.so: undefined reference to '__sync_sub_and_fetch_4'
+BROKEN_mips64= fails to link: libswipl.so: undefined reference to '__sync_sub_and_fetch_4'
+BROKEN_powerpc64= fails to compile: pce_principal.pl:155: Shared object "pl2xpce" not found, required by "swipl"
+
SWIPLDIR= ${PORTNAME:C/-//}-${PORTVERSION}
NOPRECIOUSMAKEVARS= yes
diff --git a/math/blis/Makefile b/math/blis/Makefile
index 62f28029fc58..9c459c6c9aa0 100644
--- a/math/blis/Makefile
+++ b/math/blis/Makefile
@@ -14,6 +14,8 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= bash:shells/bash
+BROKEN_powerpc64= fails to configure: common.mk:118: Unable to determine compiler vendor
+
OPTIONS_DEFINE= PARA CBLAS
PARA_DESC= use pthread parallelization
CBLAS_DESC= build the CBLAS compatibility layer
diff --git a/math/qalculate/Makefile b/math/qalculate/Makefile
index 58f7cd948ee0..024d39cd1823 100644
--- a/math/qalculate/Makefile
+++ b/math/qalculate/Makefile
@@ -18,6 +18,8 @@ LIB_DEPENDS= libcln.so:math/cln \
RUN_DEPENDS= gnuplot:math/gnuplot \
wget:ftp/wget
+BROKEN_powerpc64= fails to compile: main.cc: undefined reference to Calculator::temporaryCategory[abi:cxx11]()
+
USES= autoreconf compiler:c++11-lang gettext gmake \
libtool:build localbase pkgconfig
USE_GNOME= cairo gdkpixbuf2 gtk30 intltool libxml2
diff --git a/multimedia/pwcbsd/Makefile b/multimedia/pwcbsd/Makefile
index c42da32be992..e1ac9d573419 100644
--- a/multimedia/pwcbsd/Makefile
+++ b/multimedia/pwcbsd/Makefile
@@ -14,6 +14,8 @@ COMMENT= The Linux pwc webcam driver ported to FreeBSD
LICENSE= GPLv2
+BROKEN_powerpc64= fails to compile: pcpu.h:187: error: size of array '__assert_0' is negative
+
CONFLICTS= pwcview-[0-9]*
SSP_UNSAFE= kernel module does not support ssp
diff --git a/net-im/corebird/Makefile b/net-im/corebird/Makefile
index 30d3a7b6cfdf..c899eb36accb 100644
--- a/net-im/corebird/Makefile
+++ b/net-im/corebird/Makefile
@@ -19,6 +19,8 @@ LIB_DEPENDS= libsoup-2.4.so:devel/libsoup \
librest-0.7.so:devel/librest \
libgspell-1.so:textproc/gspell
+BROKEN_powerpc64= fails to compile: CbMedia.h:61: redefinition of typedef 'CbMedia'
+
USE_GITHUB= yes
GH_ACCOUNT= baedert
diff --git a/security/wolfssl/Makefile b/security/wolfssl/Makefile
index 6f8fff98645c..9b88ef593e36 100644
--- a/security/wolfssl/Makefile
+++ b/security/wolfssl/Makefile
@@ -12,6 +12,10 @@ LICENSE= GPLv2
BUILD_DEPENDS= bash:shells/bash
+BROKEN_mips= fails to package: pkg-static: Unable to access file libwolfssl.so.3: No such file or directory
+BROKEN_mips64= fails to package: pkg-static: Unable to access file libwolfssl.so.3: No such file or directory
+BROKEN_powerpc64= fails to package: pkg-static: Unable to access file libwolfssl.so.3: No such file or directory
+
USES= libtool zip
GNU_CONFIGURE= yes
CONFIGURE_SHELL=bash
diff --git a/sysutils/fsearch/Makefile b/sysutils/fsearch/Makefile
index cac14f078517..94d4bcc046f3 100644
--- a/sysutils/fsearch/Makefile
+++ b/sysutils/fsearch/Makefile
@@ -14,6 +14,8 @@ LICENSE_FILE= ${WRKSRC}/License
BUILD_DEPENDS= ${LOCALBASE}/share/aclocal/ax_check_compile_flag.m4:devel/autoconf-archive
LIB_DEPENDS= libpcre.so:devel/pcre
+BROKEN_powerpc64= fails to configure: checking whether C compiler accepts -std=c11... no
+
USE_GITHUB= yes
GH_ACCOUNT= cboxdoerfer
diff --git a/textproc/highlight/Makefile b/textproc/highlight/Makefile
index fba1a55d71c6..d7dee2656a62 100644
--- a/textproc/highlight/Makefile
+++ b/textproc/highlight/Makefile
@@ -15,6 +15,8 @@ LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= boost-libs>0:devel/boost-libs
+BROKEN_powerpc64= fails to compile: rtfgenerator.cpp:279:37: 'to_string' was not declared in this scope
+
USES= compiler:c++11-lib gmake lua:52 pkgconfig tar:bzip2
USE_CXXSTD= c++11
MAKEFILE= makefile
diff --git a/textproc/ibus-qt/Makefile b/textproc/ibus-qt/Makefile
index f5695f7d8992..0a67c2e6991e 100644
--- a/textproc/ibus-qt/Makefile
+++ b/textproc/ibus-qt/Makefile
@@ -19,6 +19,8 @@ RUN_DEPENDS= ibus>=1.3.7:textproc/ibus
LIB_DEPENDS= libdbus-1.so:devel/dbus \
libicuuc.so:devel/icu
+BROKEN_powerpc64= fails to link: libicui18n.so: undefined reference to '__cxa_throw_bad_array_new_length@CXXABI_1.3.8'
+
GH_ACCOUNT= ibus
USE_QT4= gui dbus moc_build qmake_build moc_build uic_build rcc_build
diff --git a/textproc/libstaroffice/Makefile b/textproc/libstaroffice/Makefile
index b5a415196470..a2c4f6474549 100644
--- a/textproc/libstaroffice/Makefile
+++ b/textproc/libstaroffice/Makefile
@@ -15,6 +15,8 @@ LICENSE_COMB= dual
BUILD_DEPENDS= ${LOCALBASE}/include/boost/shared_ptr.hpp:devel/boost-libs
LIB_DEPENDS= librevenge-0.0.so:textproc/librevenge
+BROKEN_powerpc64= fails to configure: Could not find Boost implementation of shared_ptr
+
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
USE_LDCONFIG= yes
diff --git a/textproc/rubygem-cld3/Makefile b/textproc/rubygem-cld3/Makefile
index 8be666412636..985a07ca5d7f 100644
--- a/textproc/rubygem-cld3/Makefile
+++ b/textproc/rubygem-cld3/Makefile
@@ -15,6 +15,8 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= devel/protobuf>0:devel/protobuf \
rubygem-ffi>0:devel/rubygem-ffi
+BROKEN_powerpc64= fails to install: Error installing cld3-3.1.2.gem: Failed to build gem native extension
+
USE_RUBY= yes
USES= gem pkgconfig
diff --git a/textproc/uncrustify/Makefile b/textproc/uncrustify/Makefile
index 32cb36e566d4..983f8784df54 100644
--- a/textproc/uncrustify/Makefile
+++ b/textproc/uncrustify/Makefile
@@ -12,6 +12,10 @@ COMMENT= Highly configurable source code beautifier
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
+BROKEN_mips= fails to compile: cc1plus: error: unrecognized command line option "-std=gnu++0x"
+BROKEN_mips64= fails to compile: cc1plus: error: unrecognized command line option "-std=gnu++0x"
+BROKEN_powerpc64= fails to compile: cc1plus: error: unrecognized command line option "-std=gnu++0x"
+
NO_WRKSUBDIR= yes
USES= cmake:outsource
CMAKE_ARGS= -DCURRENT_VERSION="${PORTVERSION}"
diff --git a/www/netsurf/Makefile b/www/netsurf/Makefile
index 9df5ae91f1da..580ebcb656ac 100644
--- a/www/netsurf/Makefile
+++ b/www/netsurf/Makefile
@@ -33,6 +33,8 @@ LIB_DEPENDS= libcurl.so:ftp/curl \
RUN_DEPENDS= duk:lang/duktape \
${LOCALBASE}/share/certs/ca-root-nss.crt:security/ca_root_nss
+BROKEN_powerpc64= fails to compile: dukky.h:40: expected declaration specifiers or '...' before 'dom_string'
+
ALL_TARGET= #empty
LDFLAGS+= -L${OPENSSLLIB} -lssl -lcrypto ${ICONV_LIB}
CFLAGS+= -I${OPENSSLINC}
diff --git a/www/rubygem-jquery-rails-rails50/Makefile b/www/rubygem-jquery-rails-rails50/Makefile
index 1cd612f9e676..09d46b96b89f 100644
--- a/www/rubygem-jquery-rails-rails50/Makefile
+++ b/www/rubygem-jquery-rails-rails50/Makefile
@@ -17,6 +17,8 @@ RUN_DEPENDS= rubygem-rails-dom-testing-rails50>=1.0:textproc/rubygem-rails-dom-t
rubygem-railties50>=4.2.0:www/rubygem-railties50 \
rubygem-thor>=0.14:devel/rubygem-thor
+BROKEN_powerpc64= fails to install: pkg-static: rubygem-rails-dom-testing-2.0.3 conflicts with rubygem-rails-dom-testing-rails50-2.0.3 (installs files into the same place)
+
NO_ARCH= yes
USE_RUBY= yes
USES= gem
diff --git a/x11/sakura/Makefile b/x11/sakura/Makefile
index ba7d0a2e0358..58c0305cd3a4 100644
--- a/x11/sakura/Makefile
+++ b/x11/sakura/Makefile
@@ -9,9 +9,11 @@ MASTER_SITES= http://launchpadlibrarian.net/301803318/
MAINTAINER= danilo@FreeBSD.org
COMMENT= Terminal emulator based on GTK and VTE
+LICENSE= GPLv2
+
LIB_DEPENDS= libgnutls.so:security/gnutls
-LICENSE= GPLv2
+BROKEN_powerpc64= fails to build: sakura.c:1348: 'for' loop initial declaration used outside C99 mode
OPTIONS_DEFINE= DOCS