aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--graphics/gfont/Makefile1
-rw-r--r--graphics/gfont/files/patch-shtool11
-rw-r--r--lang/STk/Makefile1
-rw-r--r--lang/STk/files/patch-Tcl-configure11
4 files changed, 24 insertions, 0 deletions
diff --git a/graphics/gfont/Makefile b/graphics/gfont/Makefile
index cc8f1d69c4a2..b9598820bc2a 100644
--- a/graphics/gfont/Makefile
+++ b/graphics/gfont/Makefile
@@ -20,6 +20,7 @@ RUN_DEPENDS= gsftopk:${PORTSDIR}/print/teTeX
USE_GHOSTSCRIPT_BUILD= yes
USE_PERL5= yes
GNU_CONFIGURE= yes
+MAKE_JOBS_UNSAFE=yes
MAN1= gfont.1
diff --git a/graphics/gfont/files/patch-shtool b/graphics/gfont/files/patch-shtool
new file mode 100644
index 000000000000..c9e4faeb559d
--- /dev/null
+++ b/graphics/gfont/files/patch-shtool
@@ -0,0 +1,11 @@
+--- shtool.orig 2009-11-04 18:51:24.000000000 +0300
++++ shtool 2009-11-04 18:51:29.000000000 +0300
+@@ -228,7 +228,7 @@
+ ;;
+ -[a-zA-Z0-9])
+ opt_OPT=`awk 'BEGIN { printf("%s", substr(OPT, 2)); }' \
+- "OPT=$1" </dev/null"`
++ "OPT=$1" </dev/null`
+ opt_ARG=''
+ ;;
+ *)
diff --git a/lang/STk/Makefile b/lang/STk/Makefile
index 88a647bd8cc7..9cdea88fda97 100644
--- a/lang/STk/Makefile
+++ b/lang/STk/Makefile
@@ -19,6 +19,7 @@ COMMENT= A scheme interpreter with full access to the Tk graphical package
USE_XORG= x11 ice sm xt
GNU_CONFIGURE= yes
CFLAGS= -I${LOCALBASE}/include
+MAKE_JOBS_UNSAFE=yes
PLIST_SUB= STK_VERSION=${PORTVERSION} STK_ARCH=${STK_ARCH}
diff --git a/lang/STk/files/patch-Tcl-configure b/lang/STk/files/patch-Tcl-configure
new file mode 100644
index 000000000000..2d103e45d575
--- /dev/null
+++ b/lang/STk/files/patch-Tcl-configure
@@ -0,0 +1,11 @@
+--- Tcl/configure.orig 1998-01-03 15:46:25.000000000 +0300
++++ Tcl/configure 2009-11-04 05:58:13.000000000 +0300
+@@ -3219,7 +3219,7 @@
+ # results, and the version is kept in special file).
+
+ if test -r /etc/.relid -a "X`uname -n`" = "X`uname -s`" ; then
+- system=MP-RAS-`awk '{print $3}' /etc/.relid'`
++ system=MP-RAS-`awk '{print $3}' /etc/.relid`
+ fi
+ if test "`uname -s`" = "AIX" ; then
+ system=AIX-`uname -v`.`uname -r`