aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--databases/elixir-geo/Makefile1
-rw-r--r--databases/elixir-geo/files/patch-mix.exs10
-rw-r--r--databases/elixir-mongo/Makefile1
-rw-r--r--databases/elixir-mongo/files/patch-mix.exs12
-rw-r--r--devel/elixir-bson/Makefile1
-rw-r--r--devel/elixir-bson/files/patch-mix.exs10
-rw-r--r--devel/elixir-lager_logger/Makefile1
-rw-r--r--devel/elixir-lager_logger/files/patch-mix.exs20
-rw-r--r--textproc/elixir-funnel/Makefile1
-rw-r--r--textproc/elixir-funnel/files/patch-mix.exs5
-rw-r--r--textproc/elixir-sweet_xml/Makefile1
-rw-r--r--textproc/elixir-sweet_xml/files/patch-mix.exs18
-rw-r--r--www/elixir-joken/Makefile1
-rw-r--r--www/elixir-joken/files/patch-mix.exs10
-rw-r--r--www/elixir-webassembly/Makefile1
-rw-r--r--www/elixir-webassembly/files/patch-mix.exs21
16 files changed, 77 insertions, 37 deletions
diff --git a/databases/elixir-geo/Makefile b/databases/elixir-geo/Makefile
index 8daceb53888c..552244a9a15c 100644
--- a/databases/elixir-geo/Makefile
+++ b/databases/elixir-geo/Makefile
@@ -3,6 +3,7 @@
PORTNAME= geo
PORTVERSION= 0.16.1
DISTVERSIONPREFIX= v
+PORTREVISION= 1
CATEGORIES= databases
PKGNAMEPREFIX= elixir-
diff --git a/databases/elixir-geo/files/patch-mix.exs b/databases/elixir-geo/files/patch-mix.exs
new file mode 100644
index 000000000000..9cda313a9341
--- /dev/null
+++ b/databases/elixir-geo/files/patch-mix.exs
@@ -0,0 +1,10 @@
+--- mix.exs.orig 2015-09-26 08:11:34 UTC
++++ mix.exs
+@@ -4,7 +4,6 @@ defmodule Geo.Mixfile do
+ def project do
+ [ app: :geo,
+ version: "0.16.1",
+- elixir: "~> 1.0.0",
+ deps: deps,
+ description: description,
+ package: package,
diff --git a/databases/elixir-mongo/Makefile b/databases/elixir-mongo/Makefile
index e75da547f144..8e64ae97e4f1 100644
--- a/databases/elixir-mongo/Makefile
+++ b/databases/elixir-mongo/Makefile
@@ -2,6 +2,7 @@
PORTNAME= elixir-mongo
PORTVERSION= 0.5.1
+PORTREVISION= 1
CATEGORIES= databases
MAINTAINER= vanilla@FreeBSD.org
diff --git a/databases/elixir-mongo/files/patch-mix.exs b/databases/elixir-mongo/files/patch-mix.exs
index 086aebd2dc94..5abaa91822ca 100644
--- a/databases/elixir-mongo/files/patch-mix.exs
+++ b/databases/elixir-mongo/files/patch-mix.exs
@@ -1,6 +1,14 @@
---- mix.exs.orig 2015-07-08 05:55:21 UTC
+--- mix.exs.orig 2015-04-23 23:09:40 UTC
+++ mix.exs
-@@ -24,7 +24,6 @@ defmodule Mongo.Mixfile do
+@@ -5,7 +5,6 @@ defmodule Mongo.Mixfile do
+ [ app: :mongo,
+ name: "mongo",
+ version: "0.5.1",
+- elixir: "~> 1.0.0",
+ source_url: "https://github.com/checkiz/elixir-mongo",
+ description: "MongoDB driver for Elixir",
+ deps: deps(Mix.env),
+@@ -24,7 +23,6 @@ defmodule Mongo.Mixfile do
# Returns the list of dependencies for prod
defp deps(:prod) do
[
diff --git a/devel/elixir-bson/Makefile b/devel/elixir-bson/Makefile
index 39f6070baa15..e55f446e9575 100644
--- a/devel/elixir-bson/Makefile
+++ b/devel/elixir-bson/Makefile
@@ -2,6 +2,7 @@
PORTNAME= elixir-bson
PORTVERSION= 0.4.3
+PORTREVISION= 1
CATEGORIES= devel
MAINTAINER= vanilla@FreeBSD.org
diff --git a/devel/elixir-bson/files/patch-mix.exs b/devel/elixir-bson/files/patch-mix.exs
new file mode 100644
index 000000000000..edc06dd85691
--- /dev/null
+++ b/devel/elixir-bson/files/patch-mix.exs
@@ -0,0 +1,10 @@
+--- mix.exs.orig 2015-09-26 08:10:10 UTC
++++ mix.exs
+@@ -5,7 +5,6 @@ defmodule Bson.Mixfile do
+ [ app: :bson,
+ name: "bson",
+ version: "0.4.3",
+- elixir: "~> 1.0.0",
+ description: "BSON implementation for Elixir",
+ source_url: "https://github.com/checkiz/elixir-bson",
+ deps: deps(Mix.env),
diff --git a/devel/elixir-lager_logger/Makefile b/devel/elixir-lager_logger/Makefile
index bb6f43b868ee..2f13355393ea 100644
--- a/devel/elixir-lager_logger/Makefile
+++ b/devel/elixir-lager_logger/Makefile
@@ -3,6 +3,7 @@
PORTNAME= lager_logger
PORTVERSION= 1.0.0
DISTVERSIONPREFIX= v
+PORTREVISION= 1
CATEGORIES= devel
PKGNAMEPREFIX= elixir-
diff --git a/devel/elixir-lager_logger/files/patch-mix.exs b/devel/elixir-lager_logger/files/patch-mix.exs
index f0638daf52a3..550f746c2c8e 100644
--- a/devel/elixir-lager_logger/files/patch-mix.exs
+++ b/devel/elixir-lager_logger/files/patch-mix.exs
@@ -1,10 +1,14 @@
---- mix.exs.orig 2015-07-02 13:24:56 UTC
+--- mix.exs.orig 2015-09-26 08:36:49 UTC
+++ mix.exs
-@@ -30,7 +30,6 @@ defmodule LagerLogger.Mixfile do
-
- defp deps do
- [
-- {:lager, ">= 2.1.0"},
- ]
+@@ -4,10 +4,8 @@ defmodule LagerLogger.Mixfile do
+ def project do
+ [app: :lager_logger,
+ version: "1.0.0",
+- elixir: "~> 1.0.0",
+ package: package,
+- description: description,
+- deps: deps]
++ description: description]
end
- end
+
+ defp package do
diff --git a/textproc/elixir-funnel/Makefile b/textproc/elixir-funnel/Makefile
index 9b19a2ee57ff..aa2eb81db127 100644
--- a/textproc/elixir-funnel/Makefile
+++ b/textproc/elixir-funnel/Makefile
@@ -2,6 +2,7 @@
PORTNAME= funnel
PORTVERSION= 0.4.1
+PORTREVISION= 1
CATEGORIES= textproc
PKGNAMEPREFIX= elixir-
diff --git a/textproc/elixir-funnel/files/patch-mix.exs b/textproc/elixir-funnel/files/patch-mix.exs
index 5c60c4f2e06b..164a63133551 100644
--- a/textproc/elixir-funnel/files/patch-mix.exs
+++ b/textproc/elixir-funnel/files/patch-mix.exs
@@ -1,15 +1,14 @@
--- mix.exs.orig 2014-09-10 19:01:07 UTC
+++ mix.exs
-@@ -6,10 +6,9 @@ defmodule Funnel.Mixfile do
+@@ -6,10 +6,8 @@ defmodule Funnel.Mixfile do
version: "0.4.1",
compilers: [:elixir, :app],
compile_path: "tmp/#{Mix.env}/funnel/ebin",
- elixir: "~> 0.15 or 1.0.0-rc1 or 1.0.0",
-+ elixir: "~> 0.15 or ~> 1.0.0",
description: description,
- package: package,
- deps: deps ]
-+ package: package]
++ package: package ]
end
# Configuration for the OTP application
diff --git a/textproc/elixir-sweet_xml/Makefile b/textproc/elixir-sweet_xml/Makefile
index 9e95a0236b63..08bd218dee80 100644
--- a/textproc/elixir-sweet_xml/Makefile
+++ b/textproc/elixir-sweet_xml/Makefile
@@ -2,6 +2,7 @@
PORTNAME= sweet_xml
PORTVERSION= 0.3.0
+PORTREVISION= 1
CATEGORIES= textproc
PKGNAMEPREFIX= elixir-
diff --git a/textproc/elixir-sweet_xml/files/patch-mix.exs b/textproc/elixir-sweet_xml/files/patch-mix.exs
index 30a2e1332a8b..9bc7d31345f2 100644
--- a/textproc/elixir-sweet_xml/files/patch-mix.exs
+++ b/textproc/elixir-sweet_xml/files/patch-mix.exs
@@ -1,11 +1,11 @@
---- mix.exs.orig 2015-07-15 14:25:56 UTC
+--- mix.exs.orig 2015-09-26 08:20:55 UTC
+++ mix.exs
-@@ -26,8 +26,6 @@ defmodule SweetXml.Mixfile do
-
- defp deps do
+@@ -5,8 +5,6 @@ defmodule SweetXml.Mixfile do
[
-- {:ex_doc, "~> 0.7", only: :dev},
-- {:markdown, github: "devinus/markdown"}
- ]
- end
- end
+ app: :sweet_xml,
+ version: "0.3.0",
+- elixir: "~> 1.0.0-rc2",
+- deps: deps,
+ package: [
+ contributors: ["Frank Liu", "Arnaud Wetzel", "Tomáš Brukner", "Vinícius Sales"],
+ licenses: ["MIT"],
diff --git a/www/elixir-joken/Makefile b/www/elixir-joken/Makefile
index 3d47c6363c31..c510defd8a91 100644
--- a/www/elixir-joken/Makefile
+++ b/www/elixir-joken/Makefile
@@ -3,6 +3,7 @@
PORTNAME= joken
PORTVERSION= 0.15.0
DISTVERSIONPREFIX= v
+PORTREVISION= 1
CATEGORIES= www
PKGNAMEPREFIX= elixir-
diff --git a/www/elixir-joken/files/patch-mix.exs b/www/elixir-joken/files/patch-mix.exs
index 95cdeb51d3ec..dd527fc9435c 100644
--- a/www/elixir-joken/files/patch-mix.exs
+++ b/www/elixir-joken/files/patch-mix.exs
@@ -1,8 +1,10 @@
---- mix.exs.orig 2015-07-08 12:15:58 UTC
+--- mix.exs.orig 2015-07-13 13:00:06 UTC
+++ mix.exs
-@@ -6,8 +6,7 @@ defmodule Joken.Mixfile do
- version: "0.14.1",
- elixir: "~> 1.0.0",
+@@ -4,10 +4,8 @@ defmodule Joken.Mixfile do
+ def project do
+ [app: :joken,
+ version: "0.15.0",
+- elixir: "~> 1.0.0",
description: description,
- package: package,
- deps: deps]
diff --git a/www/elixir-webassembly/Makefile b/www/elixir-webassembly/Makefile
index 53f96bf0a3b8..039944a7bcdd 100644
--- a/www/elixir-webassembly/Makefile
+++ b/www/elixir-webassembly/Makefile
@@ -3,6 +3,7 @@
PORTNAME= webassembly
PORTVERSION= 0.5.1
DISTVERSIONPREFIX= v
+PORTREVISION= 1
CATEGORIES= www
PKGNAMEPREFIX= elixir-
diff --git a/www/elixir-webassembly/files/patch-mix.exs b/www/elixir-webassembly/files/patch-mix.exs
index aa00830ca6ea..036b7c6beb94 100644
--- a/www/elixir-webassembly/files/patch-mix.exs
+++ b/www/elixir-webassembly/files/patch-mix.exs
@@ -1,12 +1,11 @@
---- mix.exs.orig 2015-07-03 10:57:27 UTC
+--- mix.exs.orig 2015-09-26 08:21:42 UTC
+++ mix.exs
-@@ -18,9 +18,6 @@ defmodule WebAssembly.Mixfile do
- end
-
- defp deps, do: [
-- {:excoveralls, "== 0.3.6", only: :test},
-- {:ex_doc, "~> 0.7.1", only: :dev},
-- {:dialyze, "== 0.1.3", only: :dev},
- ]
-
- defp description do
+@@ -5,8 +5,6 @@ defmodule WebAssembly.Mixfile do
+ [app: :webassembly,
+ docs: [main: WebAssembly],
+ version: "0.5.1",
+- elixir: "~> 1.0.0",
+- deps: deps,
+ description: description,
+ package: package,
+ test_coverage: [tool: ExCoveralls]]