aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--textproc/xerces-c3/Makefile3
-rw-r--r--textproc/xerces-c3/distinfo4
-rw-r--r--textproc/xerces-c3/files/patch-src-xercesc-util-XMLUTF8Transcoder.cpp53
-rw-r--r--textproc/xerces-c3/files/patch-src-xercesc-util-XMLUTF8Transcoder.hpp11
-rw-r--r--textproc/xerces-c3/files/patch-src-xercesc-util-regx-ParserForXMLSchema.cpp11
-rw-r--r--textproc/xerces-c3/files/patch-src-xercesc-util-regx-RegxParser.cpp43
-rw-r--r--textproc/xerces-c3/files/patch-src-xercesc-validators-common-ContentSpecNode.cpp11
7 files changed, 3 insertions, 133 deletions
diff --git a/textproc/xerces-c3/Makefile b/textproc/xerces-c3/Makefile
index 648eaadf0ba0..b72d0251f247 100644
--- a/textproc/xerces-c3/Makefile
+++ b/textproc/xerces-c3/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= xerces-c
-PORTVERSION= 3.1.1
-PORTREVISION= 4
+PORTVERSION= 3.1.2
CATEGORIES= textproc
MASTER_SITES= APACHE/xerces/c/3/sources
PKGNAMESUFFIX= 3
diff --git a/textproc/xerces-c3/distinfo b/textproc/xerces-c3/distinfo
index e86449791422..4b1df3ec23d9 100644
--- a/textproc/xerces-c3/distinfo
+++ b/textproc/xerces-c3/distinfo
@@ -1,2 +1,2 @@
-SHA256 (xerces-c-3.1.1.tar.gz) = a42785f71e0b91d5fd273831c87410ce60a73ccfdd207de1b805d26d44968736
-SIZE (xerces-c-3.1.1.tar.gz) = 5051308
+SHA256 (xerces-c-3.1.2.tar.gz) = 743bd0a029bf8de56a587c270d97031e0099fe2b7142cef03e0da16e282655a0
+SIZE (xerces-c-3.1.2.tar.gz) = 6959894
diff --git a/textproc/xerces-c3/files/patch-src-xercesc-util-XMLUTF8Transcoder.cpp b/textproc/xerces-c3/files/patch-src-xercesc-util-XMLUTF8Transcoder.cpp
deleted file mode 100644
index b26d7eafb481..000000000000
--- a/textproc/xerces-c3/files/patch-src-xercesc-util-XMLUTF8Transcoder.cpp
+++ /dev/null
@@ -1,53 +0,0 @@
---- src/xercesc/util/XMLUTF8Transcoder.cpp.orig
-+++ src/xercesc/util/XMLUTF8Transcoder.cpp
-@@ -178,7 +178,7 @@ XMLUTF8Transcoder::transcodeFrom(const XMLByte* const srcData
- if((gUTFByteIndicatorTest[trailingBytes] & *srcPtr) != gUTFByteIndicator[trailingBytes]) {
- char pos[2] = {(char)0x31, 0};
- char len[2] = {(char)(trailingBytes+0x31), 0};
-- char byte[2] = {*srcPtr,0};
-+ char byte[2] = {static_cast<char>(*srcPtr),0};
- ThrowXMLwithMemMgr3(UTFDataFormatException, XMLExcepts::UTF8_FormatError, pos, byte, len, getMemoryManager());
- }
-
-@@ -246,8 +246,8 @@ XMLUTF8Transcoder::transcodeFrom(const XMLByte* const srcData
- //
- if (( *srcPtr == 0xE0) && ( *(srcPtr+1) < 0xA0))
- {
-- char byte0[2] = {*srcPtr ,0};
-- char byte1[2] = {*(srcPtr+1),0};
-+ char byte0[2] = {static_cast<char>(*srcPtr) ,0};
-+ char byte1[2] = {static_cast<char>(*(srcPtr+1)),0};
-
- ThrowXMLwithMemMgr2(UTFDataFormatException
- , XMLExcepts::UTF8_Invalid_3BytesSeq
-@@ -284,8 +284,8 @@ XMLUTF8Transcoder::transcodeFrom(const XMLByte* const srcData
-
- if ((*srcPtr == 0xED) && (*(srcPtr+1) >= 0xA0))
- {
-- char byte0[2] = {*srcPtr, 0};
-- char byte1[2] = {*(srcPtr+1),0};
-+ char byte0[2] = {static_cast<char>(*srcPtr), 0};
-+ char byte1[2] = {static_cast<char>(*(srcPtr+1)),0};
-
- ThrowXMLwithMemMgr2(UTFDataFormatException
- , XMLExcepts::UTF8_Irregular_3BytesSeq
-@@ -310,8 +310,8 @@ XMLUTF8Transcoder::transcodeFrom(const XMLByte* const srcData
- if (((*srcPtr == 0xF0) && (*(srcPtr+1) < 0x90)) ||
- ((*srcPtr == 0xF4) && (*(srcPtr+1) > 0x8F)) )
- {
-- char byte0[2] = {*srcPtr ,0};
-- char byte1[2] = {*(srcPtr+1),0};
-+ char byte0[2] = {static_cast<char>(*srcPtr) ,0};
-+ char byte1[2] = {static_cast<char>(*(srcPtr+1)),0};
-
- ThrowXMLwithMemMgr2(UTFDataFormatException
- , XMLExcepts::UTF8_Invalid_4BytesSeq
-@@ -344,7 +344,7 @@ XMLUTF8Transcoder::transcodeFrom(const XMLByte* const srcData
- * surrogates, nor U+FFFE and U+FFFF (but it does allow other noncharacters).
- ***/
- char len[2] = {(char)(trailingBytes+0x31), 0};
-- char byte[2] = {*srcPtr,0};
-+ char byte[2] = {static_cast<char>(*srcPtr),0};
-
- ThrowXMLwithMemMgr2(UTFDataFormatException
- , XMLExcepts::UTF8_Exceeds_BytesLimit
diff --git a/textproc/xerces-c3/files/patch-src-xercesc-util-XMLUTF8Transcoder.hpp b/textproc/xerces-c3/files/patch-src-xercesc-util-XMLUTF8Transcoder.hpp
deleted file mode 100644
index a2804b4bc77f..000000000000
--- a/textproc/xerces-c3/files/patch-src-xercesc-util-XMLUTF8Transcoder.hpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/xercesc/util/XMLUTF8Transcoder.hpp.orig
-+++ src/xercesc/util/XMLUTF8Transcoder.hpp
-@@ -107,7 +107,7 @@ void XMLUTF8Transcoder::checkTrailingBytes(const XMLByte toCheck
- {
- char len[2] = {(char)(trailingBytes+0x31), 0};
- char pos[2] = {(char)(position+0x31), 0};
-- char byte[2] = {toCheck,0};
-+ char byte[2] = {static_cast<char>(toCheck),0};
- ThrowXMLwithMemMgr3(UTFDataFormatException, XMLExcepts::UTF8_FormatError, pos, byte, len, getMemoryManager());
- }
-
diff --git a/textproc/xerces-c3/files/patch-src-xercesc-util-regx-ParserForXMLSchema.cpp b/textproc/xerces-c3/files/patch-src-xercesc-util-regx-ParserForXMLSchema.cpp
deleted file mode 100644
index a409a53e1731..000000000000
--- a/textproc/xerces-c3/files/patch-src-xercesc-util-regx-ParserForXMLSchema.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/xercesc/util/regx/ParserForXMLSchema.cpp.orig
-+++ src/xercesc/util/regx/ParserForXMLSchema.cpp
-@@ -156,7 +156,7 @@ XMLInt32 ParserForXMLSchema::decodeEscaped() {
- break;
- default:
- {
-- XMLCh chString[] = {chBackSlash, ch, chNull};
-+ XMLCh chString[] = {chBackSlash, static_cast<XMLCh>(ch), chNull};
- ThrowXMLwithMemMgr1(ParseException,XMLExcepts::Parser_Process2, chString, getMemoryManager());
- }
- }
diff --git a/textproc/xerces-c3/files/patch-src-xercesc-util-regx-RegxParser.cpp b/textproc/xerces-c3/files/patch-src-xercesc-util-regx-RegxParser.cpp
deleted file mode 100644
index c1537d500c23..000000000000
--- a/textproc/xerces-c3/files/patch-src-xercesc-util-regx-RegxParser.cpp
+++ /dev/null
@@ -1,43 +0,0 @@
---- src/xercesc/util/regx/RegxParser.cpp.orig
-+++ src/xercesc/util/regx/RegxParser.cpp
-@@ -691,11 +691,11 @@ RangeToken* RegxParser::parseCharacterClass(const bool useNRange) {
- || (ch == chDash && getCharData() == chCloseSquare && firstLoop))) {
- // if regex = [-] then invalid...
- // '[', ']', '-' not allowed and should be escaped
-- XMLCh chStr[] = { ch, chNull };
-+ XMLCh chStr[] = { static_cast<XMLCh>(ch), chNull };
- ThrowXMLwithMemMgr2(ParseException,XMLExcepts::Parser_CC6, chStr, chStr, getMemoryManager());
- }
- if (ch == chDash && getCharData() == chDash && getState() != REGX_T_BACKSOLIDUS && !wasDecoded) {
-- XMLCh chStr[] = { ch, chNull };
-+ XMLCh chStr[] = { static_cast<XMLCh>(ch), chNull };
- ThrowXMLwithMemMgr2(ParseException,XMLExcepts::Parser_CC6, chStr, chStr, getMemoryManager());
- }
-
-@@ -720,7 +720,7 @@ RangeToken* RegxParser::parseCharacterClass(const bool useNRange) {
- else {
-
- XMLInt32 rangeEnd = getCharData();
-- XMLCh rangeEndStr[] = { rangeEnd, chNull };
-+ XMLCh rangeEndStr[] = { static_cast<XMLCh>(rangeEnd), chNull };
-
- if (type == REGX_T_CHAR) {
-
-@@ -737,7 +737,7 @@ RangeToken* RegxParser::parseCharacterClass(const bool useNRange) {
- processNext();
-
- if (ch > rangeEnd) {
-- XMLCh chStr[] = { ch, chNull };
-+ XMLCh chStr[] = { static_cast<XMLCh>(ch), chNull };
- ThrowXMLwithMemMgr2(ParseException,XMLExcepts::Parser_Ope3, rangeEndStr, chStr, getMemoryManager());
- }
-
-@@ -845,7 +845,7 @@ XMLInt32 RegxParser::decodeEscaped() {
- break;
- default:
- {
-- XMLCh chString[] = {chBackSlash, ch, chNull};
-+ XMLCh chString[] = {chBackSlash, static_cast<XMLCh>(ch), chNull};
- ThrowXMLwithMemMgr1(ParseException,XMLExcepts::Parser_Process2, chString, getMemoryManager());
- }
- }
diff --git a/textproc/xerces-c3/files/patch-src-xercesc-validators-common-ContentSpecNode.cpp b/textproc/xerces-c3/files/patch-src-xercesc-validators-common-ContentSpecNode.cpp
deleted file mode 100644
index c6ede7e6efe5..000000000000
--- a/textproc/xerces-c3/files/patch-src-xercesc-validators-common-ContentSpecNode.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- orig/xercesc/validators/common/ContentSpecNode.cpp.orig
-+++ src/xercesc/validators/common/ContentSpecNode.cpp
-@@ -259,7 +259,7 @@ int ContentSpecNode::getMaxTotalRange() const {
- else {
-
- if ((fType & 0x0f) == ContentSpecNode::Choice) {
-- max = max * (maxFirst > maxSecond) ? maxFirst : maxSecond;
-+ max = max * ((maxFirst > maxSecond) ? maxFirst : maxSecond);
- }
- else {
- max = max * (maxFirst + maxSecond);