aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--cad/librecad/Makefile4
-rw-r--r--devel/qdevelop/Makefile6
-rw-r--r--editors/texmaker/Makefile2
-rw-r--r--emulators/dboxfe/Makefile2
-rw-r--r--emulators/qtemu/Makefile4
-rw-r--r--games/colorcode/Makefile4
-rw-r--r--games/hexglass/Makefile2
-rw-r--r--math/qtiplot/Makefile8
-rw-r--r--math/qwtplot3d-qt4/Makefile5
-rw-r--r--multimedia/minitube/Makefile5
-rw-r--r--print/kpdftool/Makefile2
-rw-r--r--textproc/beediff/Makefile2
-rw-r--r--textproc/qstardict/Makefile6
-rw-r--r--x11-toolkits/qwt5-designerplugin/Makefile2
-rw-r--r--x11-toolkits/qwt5/Makefile2
-rw-r--r--x11-toolkits/qwt6-designerplugin/Makefile2
-rw-r--r--x11-toolkits/qwt6/Makefile2
17 files changed, 28 insertions, 32 deletions
diff --git a/cad/librecad/Makefile b/cad/librecad/Makefile
index 34e69e2f876b..50a826dea526 100644
--- a/cad/librecad/Makefile
+++ b/cad/librecad/Makefile
@@ -10,7 +10,7 @@ COMMENT= 2D CAD system
BUILD_DEPENDS= ${LOCALBASE}/lib/libmuparser.a:${PORTSDIR}/math/muparser
-USE_QT4= help qt3support help-tools_build moc_build qmake_build \
+USE_QT4= help qt3support help-tools_build moc_build \
rcc_build uic_build uic3_build
USES= qmake
MAKE_ENV= XDG_CONFIG_HOME=/dev/null
@@ -42,7 +42,7 @@ post-patch:
post-build:
.if ${PORT_OPTIONS:MNLS}
cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} \
- ${LOCALBASE}/bin/lrelease-qt4 -compress librecad.pro
+ ${LRELEASE} -compress librecad.pro
${MKDIR} ${WRKSRC}/unix/resources/qm
${INSTALL_DATA} ${WRKSRC}/ts/*.qm ${WRKSRC}/unix/resources/qm
.endif
diff --git a/devel/qdevelop/Makefile b/devel/qdevelop/Makefile
index c95c501d1143..1fe7de24738e 100644
--- a/devel/qdevelop/Makefile
+++ b/devel/qdevelop/Makefile
@@ -14,14 +14,12 @@ COMMENT= Development environment entirely dedicated to Qt4
RUN_DEPENDS= exctags:${PORTSDIR}/devel/ctags
USE_QT4= gui sql network xml designer sql-sqlite3_run \
- qmake_build moc_build uic_build rcc_build
+ moc_build uic_build rcc_build
USES= qmake
QMAKE_PRO= QDevelop.pro
STRIP_FILES= bin/${PORTNAME}
-QT_LRELEASE= ${LOCALBASE}/bin/lrelease-qt4
-
DESKTOP_ENTRIES= "QDevelop" \
"Qt4 development environment" \
"${PREFIX}/share/pixmaps/qdevelop.png" \
@@ -66,7 +64,7 @@ post-patch:
post-configure:
.if ${PORT_OPTIONS:MNLS}
- cd ${WRKSRC} && ${QT_LRELEASE} ${QMAKE_PRO}
+ cd ${WRKSRC} && ${LRELEASE} ${QMAKE_PRO}
.endif
post-install:
diff --git a/editors/texmaker/Makefile b/editors/texmaker/Makefile
index ed3f29b8a10f..2472a2afcadb 100644
--- a/editors/texmaker/Makefile
+++ b/editors/texmaker/Makefile
@@ -17,7 +17,7 @@ USES= desktop-file-utils pkgconfig qmake
USE_BZIP2= yes
USE_GHOSTSCRIPT_RUN= yes
USE_QT4= gui network xml webkit \
- moc_build qmake_build rcc_build uic_build
+ moc_build rcc_build uic_build
USE_TEX= latex dvipsk
QMAKE_ARGS= ICONDIR=${PREFIX}/share/pixmaps \
DESKTOPDIR=${DESKTOPDIR}
diff --git a/emulators/dboxfe/Makefile b/emulators/dboxfe/Makefile
index be34abad5c8a..81aad1da4fa2 100644
--- a/emulators/dboxfe/Makefile
+++ b/emulators/dboxfe/Makefile
@@ -29,7 +29,7 @@ DESKTOP_ENTRIES= "DBoxFE" "DOSBox configuration manager" \
post-build:
@(cd ${WRKSRC}/dboxfetray && \
- ${SETENV} ${CONFIGURE_ENV} ${QMAKE} ${QMAKEFLAGS} && \
+ ${SETENV} ${QMAKE_ENV} ${QMAKE} ${QMAKE_ARGS} && \
${SETENV} ${MAKE_ENV} ${MAKE})
do-install:
diff --git a/emulators/qtemu/Makefile b/emulators/qtemu/Makefile
index 6a32a3bd17e4..a41692205cc9 100644
--- a/emulators/qtemu/Makefile
+++ b/emulators/qtemu/Makefile
@@ -10,7 +10,7 @@ MAINTAINER= makc@FreeBSD.org
COMMENT= Qt 4 based frontend for QEMU
USE_BZIP2= yes
-USE_QT4= gui xml uic_build moc_build qmake_build rcc_build
+USE_QT4= gui xml uic_build moc_build rcc_build
USES= qmake
CONFIGURE_ENV+= LOCALBASE=${LOCALBASE}
@@ -30,7 +30,7 @@ PLIST_SUB+= NLS="@comment "
post-configure:
.if ${PORT_OPTIONS:MNLS}
- (cd ${WRKSRC} && ${LOCALBASE}/bin/lrelease-qt4 qtemu.pro)
+ (cd ${WRKSRC} && ${LRELEASE} qtemu.pro)
.endif
do-install:
diff --git a/games/colorcode/Makefile b/games/colorcode/Makefile
index ecfa8e4b0d0e..414fca2183df 100644
--- a/games/colorcode/Makefile
+++ b/games/colorcode/Makefile
@@ -10,13 +10,13 @@ DISTNAME= ColorCode-${PORTVERSION}
MAINTAINER= makc@FreeBSD.org
COMMENT= Advanced MasterMind game and solver
-USE_QT4= gui moc_build qmake_build rcc_build uic_build
+USE_QT4= gui moc_build rcc_build uic_build
USES= qmake
WRKSRC= ${WRKDIR}/ColorCode-${PORTVERSION}
DESKTOP_ENTRIES= "ColorCode" "${COMMENT}" \
"${PREFIX}/share/pixmaps/colorcode.png" "colorcode" \
- "LogicGame;Game;Qt;" false
+ "LogicGame;Game;Qt;" true
PLIST_FILES= bin/colorcode \
share/pixmaps/colorcode.png
diff --git a/games/hexglass/Makefile b/games/hexglass/Makefile
index 91f4c9aff6d3..9eb7947d540f 100644
--- a/games/hexglass/Makefile
+++ b/games/hexglass/Makefile
@@ -9,7 +9,7 @@ MASTER_SITES= GOOGLE_CODE
MAINTAINER= makc@FreeBSD.org
COMMENT= Tetris-like puzzle game based on a hexagonal grid
-USE_QT4= gui qmake_build moc_build rcc_build
+USE_QT4= gui moc_build rcc_build
USES= qmake
PLIST_FILES= bin/${PORTNAME} \
diff --git a/math/qtiplot/Makefile b/math/qtiplot/Makefile
index 27a3928f9cda..f1b6b92a8bf7 100644
--- a/math/qtiplot/Makefile
+++ b/math/qtiplot/Makefile
@@ -17,13 +17,13 @@ LIB_DEPENDS= libgsl.so:${PORTSDIR}/math/gsl \
# qwt.5:${PORTSDIR}/x11-toolkits/qwt5 \
# qwtplot3d-qt4:${PORTSDIR}/math/qwtplot3d-qt4
-USES= gmake qmake
+USES= dos2unix gmake qmake
USE_BZIP2= yes
USE_QT4= gui opengl svg qt3support network assistantclient \
- moc_build qmake_build rcc_build
+ moc_build rcc_build
USE_GL= glu
QMAKE_ARGS+= LOCALBASE=${LOCALBASE} PYTHON_CMD=${PYTHON_CMD}
-USE_DOS2UNIX= *.pro
+DOS2UNIX_GLOB= *.pro
DESKTOP_ENTRIES="QtiPlot" "Data analysis and plotting" \
"${DATADIR}/qtiplot.png" \
@@ -96,7 +96,7 @@ post-patch:
pre-configure:
.if ${PORT_OPTIONS:MNLS}
- cd ${WRKSRC}/qtiplot && ${LOCALBASE}/bin/lrelease-qt4 -compress qtiplot.pro
+ cd ${WRKSRC}/qtiplot && ${LRELEASE} -compress qtiplot.pro
.endif
post-install:
diff --git a/math/qwtplot3d-qt4/Makefile b/math/qwtplot3d-qt4/Makefile
index c38e1b422f48..a26df193176d 100644
--- a/math/qwtplot3d-qt4/Makefile
+++ b/math/qwtplot3d-qt4/Makefile
@@ -11,11 +11,10 @@ EXTRACT_SUFX= .tgz
MAINTAINER= makc@FreeBSD.org
COMMENT= 3D plotting widgets for scientific data and math expressions
-USES= qmake
-USE_QT4= gui moc_build qmake_build opengl
+USES= dos2unix qmake
+USE_QT4= gui moc_build opengl
USE_GL= glu
USE_LDCONFIG= yes
-USE_DOS2UNIX= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
diff --git a/multimedia/minitube/Makefile b/multimedia/minitube/Makefile
index 46e1963305ff..4e9a72f3535c 100644
--- a/multimedia/minitube/Makefile
+++ b/multimedia/minitube/Makefile
@@ -9,15 +9,14 @@ MAINTAINER= makc@FreeBSD.org
COMMENT= TV-like client for YouTube
USE_QT4= gui network xml dbus phonon phonon-gst \
- qmake_build moc_build rcc_build imageformats_run
+ moc_build rcc_build imageformats_run
USE_GSTREAMER= ffmpeg
USES= qmake
INSTALLS_ICONS= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
-QMAKE_ARGS= QMAKE_LRELEASE=${QT_LRELEASE}
+QMAKE_ARGS= QMAKE_LRELEASE=${LRELEASE}
QMAKE_PRO= ${WRKSRC}/${PORTNAME}.pro
-QT_LRELEASE= ${LOCALBASE}/bin/lrelease-qt4
STRIP_FILES= bin/minitube
diff --git a/print/kpdftool/Makefile b/print/kpdftool/Makefile
index e0b71a63450d..cc9bf2b17ca3 100644
--- a/print/kpdftool/Makefile
+++ b/print/kpdftool/Makefile
@@ -14,7 +14,7 @@ COMMENT= Simple utility to manipulate PS and PDF files
RUN_DEPENDS= convert:${PORTSDIR}/graphics/ImageMagick
USE_ZIP= yes
-USE_QT4= qt3support moc_build porting_build qmake_build uic3_build
+USE_QT4= qt3support moc_build porting_build uic3_build
USE_GHOSTSCRIPT_RUN= yes
USES= qmake
diff --git a/textproc/beediff/Makefile b/textproc/beediff/Makefile
index 8cb322ce8b05..69d2d0bcff2d 100644
--- a/textproc/beediff/Makefile
+++ b/textproc/beediff/Makefile
@@ -11,7 +11,7 @@ MAINTAINER= makc@FreeBSD.org
COMMENT= Qt 4 based diff frontend
USES= qmake
-USE_QT4= gui moc_build rcc_build qmake_build
+USE_QT4= gui moc_build rcc_build
WRKSRC= ${WRKDIR}/${PORTNAME}
diff --git a/textproc/qstardict/Makefile b/textproc/qstardict/Makefile
index 5d40d9bad5cf..3af28c29f484 100644
--- a/textproc/qstardict/Makefile
+++ b/textproc/qstardict/Makefile
@@ -9,10 +9,10 @@ MASTER_SITES= http://qstardict.ylsoftware.com/files/
MAINTAINER= makc@FreeBSD.org
COMMENT= Qt 4 based dictionary program (stardict clone)
-USES= pkgconfig qmake
+USES= dos2unix pkgconfig qmake
USE_BZIP2= yes
-USE_QT4= gui network xml qmake_build uic_build moc_build rcc_build
-USE_DOS2UNIX= qstardict.pri
+USE_QT4= gui network xml uic_build moc_build rcc_build
+DOS2UNIX_FILES= qstardict.pri
DICPATH= ${LOCALBASE}/share/stardict/dic
diff --git a/x11-toolkits/qwt5-designerplugin/Makefile b/x11-toolkits/qwt5-designerplugin/Makefile
index 6b5d45520987..eeeedfe13499 100644
--- a/x11-toolkits/qwt5-designerplugin/Makefile
+++ b/x11-toolkits/qwt5-designerplugin/Makefile
@@ -12,7 +12,7 @@ COMMENT= Qt Designer plugin for Qwt
LIB_DEPENDS= libqwt.so:${PORTSDIR}/x11-toolkits/qwt5
USES= gmake qmake
-USE_QT4= designer moc_build qmake_build rcc_build
+USE_QT4= designer moc_build rcc_build
USE_BZIP2= yes
QMAKE_ARGS+= CONFIG+=QwtDesigner \
PLUGINDIR=${PREFIX}/${QT_PLUGINDIR_REL}
diff --git a/x11-toolkits/qwt5/Makefile b/x11-toolkits/qwt5/Makefile
index f06ffbad5ace..e7733afeac3b 100644
--- a/x11-toolkits/qwt5/Makefile
+++ b/x11-toolkits/qwt5/Makefile
@@ -10,7 +10,7 @@ MAINTAINER= makc@FreeBSD.org
COMMENT= Qt Widgets for Technical Applications
USES= gmake qmake
-USE_QT4= gui svg moc_build qmake_build
+USE_QT4= gui svg moc_build
USE_BZIP2= yes
USE_LDCONFIG= yes
PORTSCOUT= limit:^5\.
diff --git a/x11-toolkits/qwt6-designerplugin/Makefile b/x11-toolkits/qwt6-designerplugin/Makefile
index 4eb11f8035f6..3defd0541f45 100644
--- a/x11-toolkits/qwt6-designerplugin/Makefile
+++ b/x11-toolkits/qwt6-designerplugin/Makefile
@@ -12,7 +12,7 @@ COMMENT= Qt Designer plugin for Qwt
LIB_DEPENDS= libqwt6.so:${PORTSDIR}/x11-toolkits/qwt6
USES= gmake qmake
-USE_QT4= designer moc_build qmake_build rcc_build
+USE_QT4= designer moc_build rcc_build
USE_BZIP2= yes
QMAKE_ARGS+= CONFIG+=QwtDesigner \
PLUGINDIR=${PREFIX}/${QT_PLUGINDIR_REL}
diff --git a/x11-toolkits/qwt6/Makefile b/x11-toolkits/qwt6/Makefile
index 8fbd10240f84..b0f781b19ba2 100644
--- a/x11-toolkits/qwt6/Makefile
+++ b/x11-toolkits/qwt6/Makefile
@@ -10,7 +10,7 @@ MAINTAINER= makc@FreeBSD.org
COMMENT= Qt Widgets for Technical Applications
USES= gmake qmake
-USE_QT4= gui opengl svg xml moc_build qmake_build
+USE_QT4= gui opengl svg xml moc_build
USE_BZIP2= yes
USE_LDCONFIG= yes
DOCSDIR= ${PREFIX}/share/doc/qwt6