aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--chinese/libchewing/Makefile4
-rw-r--r--devel/m17n-db/Makefile3
-rw-r--r--devel/m17n-lib/Makefile2
-rw-r--r--editors/gummi/Makefile4
-rw-r--r--games/gnudoku/Makefile3
-rw-r--r--graphics/makehuman/Makefile3
-rw-r--r--graphics/nathive/Makefile2
-rw-r--r--net-mgmt/collectd5/Makefile5
-rw-r--r--print/libotf/Makefile6
9 files changed, 10 insertions, 22 deletions
diff --git a/chinese/libchewing/Makefile b/chinese/libchewing/Makefile
index 41526684602f..3ed444ba8a09 100644
--- a/chinese/libchewing/Makefile
+++ b/chinese/libchewing/Makefile
@@ -11,9 +11,7 @@ COMMENT= The Chewing intelligent phonetic input method library
INFO= libchewing
-USE_GMAKE= yes
-USE_GNOME= gnomehack
-USE_PKGCONFIG= yes
+USES= gmake pkgconfig pathfix
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
USE_BZIP2= yes
diff --git a/devel/m17n-db/Makefile b/devel/m17n-db/Makefile
index 1b57dcffcc72..a5ca42c62491 100644
--- a/devel/m17n-db/Makefile
+++ b/devel/m17n-db/Makefile
@@ -15,8 +15,7 @@ EXTRACT_ONLY= ${M17N_DISTFILE}
MAINTAINER= nikola.lecic@anthesphoria.net
COMMENT= Data files for the m17n library
-USE_PKGCONFIG= yes
-USE_GMAKE= yes
+USES= gmake pkgconfig
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-charmaps=${CHARMAPSDIR}
diff --git a/devel/m17n-lib/Makefile b/devel/m17n-lib/Makefile
index 02efe96b66c1..626a7194b6fe 100644
--- a/devel/m17n-lib/Makefile
+++ b/devel/m17n-lib/Makefile
@@ -21,8 +21,8 @@ RUN_DEPENDS= m17n-db>=1.6.4:${PORTSDIR}/devel/m17n-db
MAKE_JOBS_UNSAFE= yes
+USES= pkgconfig
USE_XORG= ice sm x11 xaw xft xt
-USE_PKGCONFIG= yes
USE_GNOME= libxml2
USE_AUTOTOOLS= autoconf libtool
USE_LDCONFIG= yes
diff --git a/editors/gummi/Makefile b/editors/gummi/Makefile
index d54e6a5e039b..c6a9d13cb2d4 100644
--- a/editors/gummi/Makefile
+++ b/editors/gummi/Makefile
@@ -15,12 +15,10 @@ BUILD_DEPENDS+= msgfmt:${PORTSDIR}/devel/gettext
LIB_DEPENDS+= poppler-glib:${PORTSDIR}/graphics/poppler-glib \
gtkspell:${PORTSDIR}/textproc/gtkspell
-USE_GMAKE= yes
+USES= iconv gmake pkgconfig
GNU_CONFIGURE= yes
-USE_ICONV= yes
USE_XORG= xdamage xft xcursor xcomposite
USE_GNOME= desktopfileutils gtksourceview2 glib20 intlhack
-USE_PKGCONFIG= build
INSTALLS_ICONS= yes
INSTALLS_OMF= yes
diff --git a/games/gnudoku/Makefile b/games/gnudoku/Makefile
index c108ab147c6d..0f45d2b3b2ee 100644
--- a/games/gnudoku/Makefile
+++ b/games/gnudoku/Makefile
@@ -13,9 +13,8 @@ COMMENT= A free program for creating and solving Su Doku puzzles
LIB_DEPENDS= gtkmm-2.4:${PORTSDIR}/x11-toolkits/gtkmm24
-USE_GMAKE= yes
+USES= gmake pkgconfig
MAKE_ENV= CXXLAGS="${CXXFLAGS}"
-USE_PKGCONFIG= build
post-patch:
@${REINPLACE_CMD} -e 's|PREFIX=|PREFIX?=|' ${WRKSRC}/Makefile
diff --git a/graphics/makehuman/Makefile b/graphics/makehuman/Makefile
index 0269fefa002e..1cdc83695e23 100644
--- a/graphics/makehuman/Makefile
+++ b/graphics/makehuman/Makefile
@@ -13,9 +13,8 @@ COMMENT= Application for parametrical modeling of 3D humanoid characters
LIB_DEPENDS= animorph:${PORTSDIR}/graphics/animorph \
mhgui:${PORTSDIR}/graphics/mhgui
+USES= gmake pkgconfig
GNU_CONFIGURE= yes
-USE_GMAKE= yes
-USE_PKGCONFIG= build
USE_GL= glut
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/graphics/nathive/Makefile b/graphics/nathive/Makefile
index ae1b391b1692..717199163702 100644
--- a/graphics/nathive/Makefile
+++ b/graphics/nathive/Makefile
@@ -12,8 +12,8 @@ DISTNAME= ${PORTNAME}_${PORTVERSION}_source
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Lightweight image editor
+USES= pkgconfig
USE_GNOME= glib20 gtk20
-USE_PKGCONFIG= build
ALL_TARGET= default
post-patch:
diff --git a/net-mgmt/collectd5/Makefile b/net-mgmt/collectd5/Makefile
index 5c5d4148cc7b..025dc54bb7db 100644
--- a/net-mgmt/collectd5/Makefile
+++ b/net-mgmt/collectd5/Makefile
@@ -10,11 +10,10 @@ MASTER_SITES= http://collectd.org/files/
MAINTAINER= ports@bsdserwis.com
COMMENT= Systems & network statistics collection daemon
+USES= gmake
USE_BZIP2= yes
-USE_GMAKE= yes
GNU_CONFIGURE= yes
USE_AUTOTOOLS= autoconf autoheader automake libltdl
-WANT_GNOME= yes
LATEST_LINK= collectd5
@@ -310,7 +309,7 @@ PLIST_SUB+= RRDTOOL="@comment "
.endif
.if ${PORT_OPTIONS:MSTATGRAB}
-USE_PKGCONFIG= yes
+USES+= pkgconfig
LIB_DEPENDS+= statgrab:${PORTSDIR}/devel/libstatgrab
CONFIGURE_ENV+= LIBS="`pkg-config --libs libstatgrab`"
CONFIGURE_ARGS+=--with-libstatgrab=${LOCALBASE} \
diff --git a/print/libotf/Makefile b/print/libotf/Makefile
index 20f5a9869bff..5d80caee1b5a 100644
--- a/print/libotf/Makefile
+++ b/print/libotf/Makefile
@@ -12,14 +12,10 @@ COMMENT= Library for handling OpenType fonts
LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2
+USES= pathfix pkgconfig
USE_XORG= x11 xt xaw xmu
-USE_PKGCONFIG= yes
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
CPPFLAGS+= -I${LOCALBASE}/include
-post-patch:
- @${REINPLACE_CMD} -e 's|[(]libdir[)]/pkgconfig|(prefix)/libdata/pkgconfig|g' \
- ${WRKSRC}/Makefile.in
-
.include <bsd.port.mk>