aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--GIDs1
-rw-r--r--UIDs1
-rw-r--r--databases/cego/Makefile13
-rw-r--r--databases/cego/distinfo4
-rw-r--r--databases/cego/files/cego.in111
-rw-r--r--databases/cego/pkg-plist1
6 files changed, 128 insertions, 3 deletions
diff --git a/GIDs b/GIDs
index 6e6ff8cc3ec3..977a7b27d689 100644
--- a/GIDs
+++ b/GIDs
@@ -193,3 +193,4 @@ get_iplayer:*:937:
vdr:*:938:
noip:*:939:
_tcpproxy:*:940:
+cego:*:941:
diff --git a/UIDs b/UIDs
index b1a647802e09..42204607cd8a 100644
--- a/UIDs
+++ b/UIDs
@@ -201,3 +201,4 @@ get_iplayer:*:937:937::0:0:get_iplayer user:/nonexistent:/sbin/nologin
vdr:*:938:938::0:0:vdr user:/nonexistent:/usr/sbin/nologin
noip:*:939:939::0:0:noip user:/nonexistent:/usr/sbin/nologin
_tcpproxy:*:940:940::0:0:tcpproxy user:/nonexistent:/usr/sbin/nologin
+cego:*:941:941::0:0:cego user:/usr/local/cego:/usr/sbin/nologin
diff --git a/databases/cego/Makefile b/databases/cego/Makefile
index b473fe44956a..6caf7c149b34 100644
--- a/databases/cego/Makefile
+++ b/databases/cego/Makefile
@@ -5,7 +5,7 @@
# $FreeBSD$
PORTNAME= cego
-PORTVERSION= 2.6.18
+PORTVERSION= 2.8.3
CATEGORIES= databases
MASTER_SITES= http://www.lemke-it.com/
@@ -21,5 +21,16 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
USE_LDCONFIG= yes
USE_AUTOTOOLS= autoconf:env
+USE_RC_SUBR= cego
+
+USE_NCURSES= yes
+
+USERS= cego
+GROUPS= cego
+
+PLIST_SUB+= USER=${USERS}
+
+post-patch:
+ @${REINPLACE_CMD} -e 's,-O3,,g' ${WRKSRC}/src/Makefile.in
.include <bsd.port.mk>
diff --git a/databases/cego/distinfo b/databases/cego/distinfo
index 34331ce3103f..70748db44aec 100644
--- a/databases/cego/distinfo
+++ b/databases/cego/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cego-2.6.18.tar.gz) = afd48d6c49b072cc76be30600e43a15a34d65a6382a98c46f3fcad528ab82d3b
-SIZE (cego-2.6.18.tar.gz) = 642309
+SHA256 (cego-2.8.3.tar.gz) = df5bf41b732637d3e7a3def0bd5403d91f4bb4230a3f5a47e62765997baecb68
+SIZE (cego-2.8.3.tar.gz) = 642171
diff --git a/databases/cego/files/cego.in b/databases/cego/files/cego.in
new file mode 100644
index 000000000000..737d8650ca51
--- /dev/null
+++ b/databases/cego/files/cego.in
@@ -0,0 +1,111 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+# PROVIDE: cego
+# REQUIRE: LOGIN cleanvar
+# KEYWORD: shutdown
+
+#
+# Add the following lines to /etc/rc.conf to enable cego:
+# cego_enable (bool): Set to "NO" by default.
+# Set it to "YES" to enable cego
+# cego_profiles (str): Set to "" by default.
+# Define your profiles here.
+# cego_tablespc (str): Set it to the tablespace
+# cego_flags (str): Set to "" by default.
+# Extra flags passed to start command.
+
+. /etc/rc.subr
+
+name="cego"
+rcvar=`set_rcvar`
+
+command="%%PREFIX%%/bin/cego"
+
+: ${cego_enable="NO"}
+: ${cego_conf="%%PREFIX%%/cego"}
+: ${cego_root="%%PREFIX%%/cego"}
+: ${cego_tablespc=""}
+: ${cego_user="%%USER%%"}
+
+flags="--mode=daemon"
+
+_pidprefix="/var/run/cego"
+pidfile="${_pidprefix}.pid"
+
+command_arg="--mode=daemon"
+_pidprefix="/var/run/cego"
+
+flags="--mode=daemon"
+
+load_rc_config $name
+
+if [ -n "$2" ]; then
+ profile="$2"
+ if [ "x${cego_profiles}" != "x" ]; then
+ pidfile="${_pidprefix}.${profile}.pid"
+
+ echo profile is $profile
+
+ eval cego_tablespc="\${cego_${profile}_tablespc:-}"
+ if [ "x${cego_tablespc}" = "x" ]; then
+ err 1 "You must define a tableset for db instance cego_${profile}_tablespc"
+ fi
+
+ eval cego_conf="\${cego_${profile}_conf:-${cego_conf}}"
+ eval cego_root="\${cego_${profile}_root:-${cego_root}}"
+
+ required_files="${cego_conf}/${profile}.xml"
+ eval cego_enable="\${cego_${profile}_enable:-${cego_enable}}"
+ command_args="--dbxml=${required_files} --tableset=${cego_tablespc} --lockfile=${cego_root}/${profile}.lck --logfile=${cego_root}/${profile}.log"
+ echo "Setting command_args $command_args"
+ else
+ warn "$0: extra argument ignored"
+ fi
+else
+ if [ "x${cego_profiles}" != "x" -a "x$1" != "x" ]; then
+ for profile in ${cego_profiles}; do
+ eval _enable="\${cego_${profile}_enable}"
+ case "x${_enable:-${cego_enable}}" in
+ x|x[Nn][Oo]|x[Nn][Oo][Nn][Ee])
+ continue
+ ;;
+ x[Yy][Ee][Ss])
+ ;;
+ *)
+ if test -z "$_enable"; then
+ _var=cego_enable
+ else
+ _var=cego_"${profile}"_enable
+ fi
+ warn "Bad value" \
+ "'${_enable:-${cego_enable}}'" \
+ "for ${_var}. " \
+ "Profile ${profile} skipped."
+ continue
+ ;;
+ esac
+ echo "===> cego profile: ${profile}"
+ %%PREFIX%%/etc/rc.d/cego $1 ${profile}
+ retcode="$?"
+ if [ "0${retcode}" -ne 0 ]; then
+ failed="${profile} (${retcode}) ${failed:-}"
+ else
+ success="${profile} ${success:-}"
+ fi
+ done
+ exit 0
+ fi
+fi
+
+
+cego_requirepidfile()
+{
+ if [ ! "0`check_pidfile ${pidfile} ${command}`" -gt 1 ]; then
+ err 1 "${name} not running? (check $pidfile)."
+ fi
+}
+
+run_rc_command "$1"
diff --git a/databases/cego/pkg-plist b/databases/cego/pkg-plist
index 555479587730..7e227ee22a08 100644
--- a/databases/cego/pkg-plist
+++ b/databases/cego/pkg-plist
@@ -3,6 +3,7 @@ bin/cgadm
bin/cgblow
bin/cgclt
bin/cglog
+include/cego/CegoAdmNet.h
include/cego/CegoBlob.h
include/cego/CegoCheckObject.h
include/cego/CegoContentObject.h