aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/libjpeg-turbo/Makefile38
-rw-r--r--graphics/libjpeg-turbo/distinfo3
-rw-r--r--graphics/libjpeg-turbo/pkg-descr20
-rw-r--r--graphics/libjpeg-turbo/pkg-plist12
5 files changed, 74 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 9b2c06d1f859..dc2727932c9c 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -438,6 +438,7 @@
SUBDIR += libgphoto2
SUBDIR += libimg
SUBDIR += libiptcdata
+ SUBDIR += libjpeg-turbo
SUBDIR += libkdcraw
SUBDIR += libkexif
SUBDIR += libkexiv2
diff --git a/graphics/libjpeg-turbo/Makefile b/graphics/libjpeg-turbo/Makefile
new file mode 100644
index 000000000000..e9aeda9a2c5c
--- /dev/null
+++ b/graphics/libjpeg-turbo/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: libjpeg-turbo
+# Date created: 2010-04-09
+# Date modified: 2010-04-12
+# Whom: Denis Podolskiy bytestore@yandex.ru (based on D. R. Commander)
+#
+# $FreeBSD$
+#
+
+PORTNAME= libjpeg-turbo
+PORTVERSION= 0.0.92
+CATEGORIES= graphics
+MASTER_SITES= http://openmoko.spb.ru/repository/ \
+ http://mesh.dl.sourceforge.net/project/libjpeg-turbo/${PORTVERSION}/ \
+ ${MASTER_SITE_XCONTRIB}
+
+MAINTAINER= bytestore@yandex.ru
+COMMENT= Uses MMX, SSE, and SSE2 to accelerate baseline JPEG (de)compression
+
+ONLY_FOR_ARCH= amd64 i386
+USE_AUTOTOOLS= autoconf:262 automake:19 libtool:22
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+
+BUILD_DEPENDS+= ${LOCALBASE}/bin/nasm:${PORTSDIR}/devel/nasm:install
+
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == amd64
+CONFIGURE_ARGS= --host x86_64-unknown-freebsd
+.elif ${ARCH} == i386
+CONFIGURE_ARGS= --host i386-unknown-freebsd
+.endif
+
+pre-configure:
+ @${ECHO_CMD} configure jpeg-turbo library
+ @cd ${WRKDIR}/libjpeg-turbo-${PORTVERSION} && ${AUTORECONF} -fiv && ${LIBTOOLIZE} --force
+
+.include <bsd.port.post.mk>
diff --git a/graphics/libjpeg-turbo/distinfo b/graphics/libjpeg-turbo/distinfo
new file mode 100644
index 000000000000..bd7bcea4b491
--- /dev/null
+++ b/graphics/libjpeg-turbo/distinfo
@@ -0,0 +1,3 @@
+MD5 (libjpeg-turbo-0.0.92.tar.gz) = 4eca10a2fbb0fe141a9b81186df6e15e
+SHA256 (libjpeg-turbo-0.0.92.tar.gz) = de56ae022f78f128ce542c016c528acfac8fa22ec41e650972657e1d30731123
+SIZE (libjpeg-turbo-0.0.92.tar.gz) = 1819003
diff --git a/graphics/libjpeg-turbo/pkg-descr b/graphics/libjpeg-turbo/pkg-descr
new file mode 100644
index 000000000000..ca98b84317e5
--- /dev/null
+++ b/graphics/libjpeg-turbo/pkg-descr
@@ -0,0 +1,20 @@
+libjpeg-turbo is a high-speed version of libjpeg for x86 and x86-64 processors
+which uses SIMD instructions (MMX, SSE2, etc.) to accelerate baseline JPEG
+compression and decompression.
+libjpeg-turbo is generally 2-4x as fast as the unmodified version
+of libjpeg, all else being equal.
+
+libjpeg-turbo was originally based on libjpeg/SIMD by Miyasaka Masaru,
+but the TigerVNC and VirtualGL projects made numerous enhancements to the codec,
+including improved support for Mac OS X, 64-bit support,
+support for 32-bit and big endian pixel formats (RGBA, ABGR, etc.),
+accelerated Huffman encoding/decoding, and various bug fixes.
+The goal was to produce a fully open source codec that could replace
+the partially closed source TurboJPEG/IPP codec used by VirtualGL and TurboVNC.
+libjpeg-turbo generally achieves 80-120% of the performance of TurboJPEG/IPP.
+It is faster in some areas but slower in others.
+
+WWW: http://libjpeg-turbo.virtualgl.org/
+
+- D. R. Commander
+information@virtualgl.org
diff --git a/graphics/libjpeg-turbo/pkg-plist b/graphics/libjpeg-turbo/pkg-plist
new file mode 100644
index 000000000000..4499a05f9b26
--- /dev/null
+++ b/graphics/libjpeg-turbo/pkg-plist
@@ -0,0 +1,12 @@
+lib/libjpeg.a
+lib/libjpeg.la
+lib/libjpeg.so
+lib/libjpeg.so.62
+lib/libturbojpeg.a
+lib/libturbojpeg.la
+lib/libturbojpeg.so
+include/jerror.h
+include/jmorecfg.h
+include/jpeglib.h
+include/turbojpeg.h
+include/jconfig.h