aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/libbonobo-reference/Makefile6
-rw-r--r--devel/libbonobo/Makefile10
-rw-r--r--devel/libbonobo/pkg-plist91
4 files changed, 15 insertions, 93 deletions
diff --git a/devel/Makefile b/devel/Makefile
index a786ef26b52d..6248152ee73e 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -458,6 +458,7 @@
SUBDIR += libbinio
SUBDIR += libbnr
SUBDIR += libbonobo
+ SUBDIR += libbonobo-reference
SUBDIR += libbonobomm
SUBDIR += libcapsinetwork
SUBDIR += libccid
diff --git a/devel/libbonobo-reference/Makefile b/devel/libbonobo-reference/Makefile
new file mode 100644
index 000000000000..8c441e4c0c06
--- /dev/null
+++ b/devel/libbonobo-reference/Makefile
@@ -0,0 +1,6 @@
+# $FreeBSD$
+
+REFERENCE_SRC= ${WRKSRC}/doc
+BOOKS= activation-api api
+
+.include "${.CURDIR}/../../devel/glib20-reference/bsd.gnome-reference.mk"
diff --git a/devel/libbonobo/Makefile b/devel/libbonobo/Makefile
index c45bc6670046..05e39dabd6bf 100644
--- a/devel/libbonobo/Makefile
+++ b/devel/libbonobo/Makefile
@@ -8,7 +8,6 @@
PORTNAME= libbonobo
PORTVERSION= 2.14.0
-PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
@@ -18,13 +17,18 @@ MAINTAINER= gnome@FreeBSD.org
COMMENT= A component and compound document system for GNOME2
USE_BZIP2= yes
+
+.if !defined(REFERENCE_PORT)
+
+PORTREVISION= 2
+
USE_GMAKE= yes
USE_BISON= yes
USE_GETTEXT= yes
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
USE_PERL5= yes
-USE_GNOME= gnomehack intlhack libxml2 orbit2
+USE_GNOME= gnomehack intlhack libxml2 orbit2 referencehack
CONFIGURE_ARGS= --with-html-dir=${PREFIX}/share/doc \
--disable-gtk-doc
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
@@ -34,3 +38,5 @@ MAKE_ENV= gnomelocaledir=${PREFIX}/share/locale
MAN1= bonobo-activation-server.1
.include <bsd.port.mk>
+
+.endif
diff --git a/devel/libbonobo/pkg-plist b/devel/libbonobo/pkg-plist
index 2bf441f2bb1c..9047e06155d4 100644
--- a/devel/libbonobo/pkg-plist
+++ b/devel/libbonobo/pkg-plist
@@ -70,95 +70,6 @@ libdata/pkgconfig/bonobo-activation-2.0.pc
libdata/pkgconfig/libbonobo-2.0.pc
libexec/bonobo-activation-server
sbin/bonobo-activation-sysconf
-share/doc/bonobo-activation/api-reference.html
-share/doc/bonobo-activation/architecture.html
-share/doc/bonobo-activation/async-activation.html
-share/doc/bonobo-activation/attribute-tag.html
-share/doc/bonobo-activation/bonobo-activation-Debugging.html
-share/doc/bonobo-activation/bonobo-activation-Initialization.html
-share/doc/bonobo-activation/bonobo-activation-Query-and-Activation.html
-share/doc/bonobo-activation/bonobo-activation-Registration.html
-share/doc/bonobo-activation/bonobo-activation-Utilities.html
-share/doc/bonobo-activation/bonobo-activation.devhelp
-share/doc/bonobo-activation/bonobo-activation.png
-share/doc/bonobo-activation/checklist.html
-share/doc/bonobo-activation/configuring.html
-share/doc/bonobo-activation/home.png
-share/doc/bonobo-activation/index.html
-share/doc/bonobo-activation/index.sgml
-share/doc/bonobo-activation/left.png
-share/doc/bonobo-activation/lgpl.html
-share/doc/bonobo-activation/migrating.html
-share/doc/bonobo-activation/query-langage.html
-share/doc/bonobo-activation/query-syntax.html
-share/doc/bonobo-activation/right.png
-share/doc/bonobo-activation/server-arch.html
-share/doc/bonobo-activation/server-xml-reference.html
-share/doc/bonobo-activation/style.css
-share/doc/bonobo-activation/terms.html
-share/doc/bonobo-activation/tutorial.html
-share/doc/bonobo-activation/up.png
-%%DOCSDIR%%/debugging.html
-%%DOCSDIR%%/factories.html
-%%DOCSDIR%%/general.html
-%%DOCSDIR%%/home.png
-%%DOCSDIR%%/index.html
-%%DOCSDIR%%/index.sgml
-%%DOCSDIR%%/left.png
-%%DOCSDIR%%/libbonobo-bonobo-app-client.html
-%%DOCSDIR%%/libbonobo-bonobo-application.html
-%%DOCSDIR%%/libbonobo-bonobo-arg.html
-%%DOCSDIR%%/libbonobo-bonobo-config-database.html
-%%DOCSDIR%%/libbonobo-bonobo-context.html
-%%DOCSDIR%%/libbonobo-bonobo-event-source.html
-%%DOCSDIR%%/libbonobo-bonobo-exception.html
-%%DOCSDIR%%/libbonobo-bonobo-generic-factory.html
-%%DOCSDIR%%/libbonobo-bonobo-i18n.html
-%%DOCSDIR%%/libbonobo-bonobo-item-container.html
-%%DOCSDIR%%/libbonobo-bonobo-item-handler.html
-%%DOCSDIR%%/libbonobo-bonobo-listener.html
-%%DOCSDIR%%/libbonobo-bonobo-main.html
-%%DOCSDIR%%/libbonobo-bonobo-moniker-context.html
-%%DOCSDIR%%/libbonobo-bonobo-moniker-extender.html
-%%DOCSDIR%%/libbonobo-bonobo-moniker-simple.html
-%%DOCSDIR%%/libbonobo-bonobo-moniker-util.html
-%%DOCSDIR%%/libbonobo-bonobo-moniker.html
-%%DOCSDIR%%/libbonobo-bonobo-object.html
-%%DOCSDIR%%/libbonobo-bonobo-persist-client.html
-%%DOCSDIR%%/libbonobo-bonobo-persist-file.html
-%%DOCSDIR%%/libbonobo-bonobo-persist-stream.html
-%%DOCSDIR%%/libbonobo-bonobo-persist.html
-%%DOCSDIR%%/libbonobo-bonobo-property-bag-client.html
-%%DOCSDIR%%/libbonobo-bonobo-property-bag.html
-%%DOCSDIR%%/libbonobo-bonobo-running-context.html
-%%DOCSDIR%%/libbonobo-bonobo-shlib-factory.html
-%%DOCSDIR%%/libbonobo-bonobo-shutdown.html
-%%DOCSDIR%%/libbonobo-bonobo-storage-memory.html
-%%DOCSDIR%%/libbonobo-bonobo-storage.html
-%%DOCSDIR%%/libbonobo-bonobo-stream-client.html
-%%DOCSDIR%%/libbonobo-bonobo-stream-memory.html
-%%DOCSDIR%%/libbonobo-bonobo-types.html
-%%DOCSDIR%%/libbonobo-faq.html
-%%DOCSDIR%%/libbonobo.devhelp
-%%DOCSDIR%%/misc.html
-%%DOCSDIR%%/monikers-overview.html
-%%DOCSDIR%%/monikers.html
-%%DOCSDIR%%/persist-file.png
-%%DOCSDIR%%/persist-storage.png
-%%DOCSDIR%%/persist-stream.png
-%%DOCSDIR%%/persist.html
-%%DOCSDIR%%/persist.png
-%%DOCSDIR%%/properties.html
-%%DOCSDIR%%/property-bags.html
-%%DOCSDIR%%/refcounting.html
-%%DOCSDIR%%/right.png
-%%DOCSDIR%%/running-context.png
-%%DOCSDIR%%/storage.png
-%%DOCSDIR%%/stream.png
-%%DOCSDIR%%/streams.html
-%%DOCSDIR%%/style.css
-%%DOCSDIR%%/unknown.png
-%%DOCSDIR%%/up.png
share/idl/bonobo-2.0/Bonobo.idl
share/idl/bonobo-2.0/Bonobo_Application.idl
share/idl/bonobo-2.0/Bonobo_Canvas.idl
@@ -254,8 +165,6 @@ share/locale/zh_CN/LC_MESSAGES/libbonobo-2.0.mo
share/locale/zh_TW/LC_MESSAGES/libbonobo-2.0.mo
@dirrm share/idl/bonobo-activation-2.0
@dirrm share/idl/bonobo-2.0
-@dirrm %%DOCSDIR%%
-@dirrm share/doc/bonobo-activation
@dirrm libdata/bonobo/servers
@dirrm libdata/bonobo
@dirrm lib/bonobo-2.0/samples