aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--archivers/bzip2/Makefile4
-rw-r--r--archivers/unzip/Makefile4
-rw-r--r--devel/autoconf213/Makefile4
-rw-r--r--devel/automake/Makefile4
-rw-r--r--devel/automake110/Makefile4
-rw-r--r--devel/automake14/Makefile4
-rw-r--r--devel/automake15/Makefile4
-rw-r--r--devel/automake16/Makefile4
-rw-r--r--devel/automake17/Makefile4
-rw-r--r--devel/automake18/Makefile4
-rw-r--r--devel/automake19/Makefile4
-rw-r--r--devel/bison-devel/Makefile4
-rw-r--r--devel/bison/Makefile4
-rw-r--r--devel/bison175/Makefile4
-rw-r--r--devel/bison1875/Makefile4
-rw-r--r--devel/bison2/Makefile4
-rw-r--r--devel/bison20/Makefile4
-rw-r--r--devel/gmake/Makefile4
-rw-r--r--devel/gmake381/Makefile4
-rw-r--r--devel/gnu-automake/Makefile4
-rw-r--r--devel/gnu-libtool/Makefile4
-rw-r--r--devel/imake-4/Makefile4
-rw-r--r--devel/imake/Makefile4
-rw-r--r--devel/libtool/Makefile4
-rw-r--r--devel/libtool13/Makefile4
-rw-r--r--devel/libtool14/Makefile4
-rw-r--r--devel/libtool15/Makefile4
-rw-r--r--emulators/linux_base-8/Makefile4
-rw-r--r--emulators/linux_base-rh-9/Makefile4
-rw-r--r--emulators/linux_base-suse-9.1/Makefile4
-rw-r--r--emulators/linux_base-suse-9.2/Makefile4
-rw-r--r--emulators/linux_base-suse-9.3/Makefile4
-rw-r--r--emulators/linux_base/Makefile4
-rw-r--r--graphics/Mesa3/Makefile4
-rw-r--r--graphics/mesagl/Makefile4
-rw-r--r--graphics/xpm/Makefile4
-rw-r--r--lang/gcc295/Makefile4
-rw-r--r--lang/gcc31/Makefile4
-rw-r--r--lang/perl5.6/Makefile4
-rw-r--r--lang/perl5/Makefile4
-rw-r--r--print/freetype/Makefile4
-rw-r--r--security/openssl/Makefile4
-rw-r--r--textproc/sed_inplace/Makefile4
-rw-r--r--x11-toolkits/open-motif/Makefile4
-rw-r--r--x11/XFree86-4-libraries/Makefile4
-rw-r--r--x11/XFree86/Makefile4
-rw-r--r--x11/dgs/Makefile6
47 files changed, 188 insertions, 2 deletions
diff --git a/archivers/bzip2/Makefile b/archivers/bzip2/Makefile
index c1928f39c43f..04d2fe27dbe7 100644
--- a/archivers/bzip2/Makefile
+++ b/archivers/bzip2/Makefile
@@ -27,6 +27,10 @@ MLINKS= bzip2.1 bunzip2.1 bzip2.1 bzcat.1 bzip2.1 bz2cat.1 \
bzgrep.1 bzfgrep.1 \
bzmore.1 bzless.1
+.ifdef USE_BZIP2
+.error You have `USE_BZIP2' variable defined either in environment or in make(1) arguments. Please undefine and try again.
+.endif
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/bzip2 ${PREFIX}/bin
${LN} -sf ${PREFIX}/bin/bzip2 ${PREFIX}/bin/bunzip2
diff --git a/archivers/unzip/Makefile b/archivers/unzip/Makefile
index 767294ce728c..dcbd2ce1a7d7 100644
--- a/archivers/unzip/Makefile
+++ b/archivers/unzip/Makefile
@@ -25,6 +25,10 @@ EXTRACT_ONLY= ${PORTNAME}550.tar.gz
MAKE_ENV= LOCAL_UNZIP="${CFLAGS} -DUSE_UNSHRINK -DUSE_SMITH_CODE"
.endif
+.ifdef USE_UNZIP
+.error You have `USE_UNZIP' variable defined either in environment or in make(1) arguments. Please undefine and try again.
+.endif
+
.include <bsd.port.pre.mk>
.if ${ARCH} == "i386"
diff --git a/devel/autoconf213/Makefile b/devel/autoconf213/Makefile
index 600cafb0e211..051ace52e0e9 100644
--- a/devel/autoconf213/Makefile
+++ b/devel/autoconf213/Makefile
@@ -28,6 +28,10 @@ CONFIGURE_ENV= M4=${LOCALBASE}/bin/gm4
CONFIGURE_ARGS= --program-suffix=213 --datadir=${PREFIX}/share/autoconf213
WRKSRC= ${WRKDIR}/autoconf
+.if defined(USE_AUTOCONF) || defined(USE_AUTOCONF_VER)
+.error You have `USE_AUTOCONF' or `USE_AUTOCONF_VER' variables defined either in environment or in make(1) arguments. Please undefine and try again.
+.endif
+
post-patch:
@-${RM} ${WRKSRC}/*.info*
diff --git a/devel/automake/Makefile b/devel/automake/Makefile
index 6bdf74a777bd..a63c7ea3d63d 100644
--- a/devel/automake/Makefile
+++ b/devel/automake/Makefile
@@ -21,6 +21,10 @@ WRKSRC= ${WRKDIR}/${DISTNAME}
STRIP= # none
+.if defined(USE_AUTOMAKE) || defined(USE_AUTOMAKE_VER)
+.error You have `USE_AUTOMAKE' or `USE_AUTOMAKE_VER' variables defined either in environment or in make(1) arguments. Please undefine and try again.
+.endif
+
pre-configure:
${PERL} -pi -e "s^%%X11BASE%%^${X11BASE}^" ${WRKSRC}/aclocal.in
diff --git a/devel/automake110/Makefile b/devel/automake110/Makefile
index 6bdf74a777bd..a63c7ea3d63d 100644
--- a/devel/automake110/Makefile
+++ b/devel/automake110/Makefile
@@ -21,6 +21,10 @@ WRKSRC= ${WRKDIR}/${DISTNAME}
STRIP= # none
+.if defined(USE_AUTOMAKE) || defined(USE_AUTOMAKE_VER)
+.error You have `USE_AUTOMAKE' or `USE_AUTOMAKE_VER' variables defined either in environment or in make(1) arguments. Please undefine and try again.
+.endif
+
pre-configure:
${PERL} -pi -e "s^%%X11BASE%%^${X11BASE}^" ${WRKSRC}/aclocal.in
diff --git a/devel/automake14/Makefile b/devel/automake14/Makefile
index e447b7379256..3333ebc8f75f 100644
--- a/devel/automake14/Makefile
+++ b/devel/automake14/Makefile
@@ -23,6 +23,10 @@ WRKSRC= ${WRKDIR}/${DISTNAME}
STRIP= # none
+.if defined(USE_AUTOMAKE) || defined(USE_AUTOMAKE_VER)
+.error You have `USE_AUTOMAKE' or `USE_AUTOMAKE_VER' variables defined either in environment or in make(1) arguments. Please undefine and try again.
+.endif
+
post-patch:
@-${RM} ${WRKSRC}/*.info* ${WRKSRC}/*.dvi
${MV} ${WRKSRC}/automake.texi ${WRKSRC}/automake14.texi
diff --git a/devel/automake15/Makefile b/devel/automake15/Makefile
index 6bdf74a777bd..a63c7ea3d63d 100644
--- a/devel/automake15/Makefile
+++ b/devel/automake15/Makefile
@@ -21,6 +21,10 @@ WRKSRC= ${WRKDIR}/${DISTNAME}
STRIP= # none
+.if defined(USE_AUTOMAKE) || defined(USE_AUTOMAKE_VER)
+.error You have `USE_AUTOMAKE' or `USE_AUTOMAKE_VER' variables defined either in environment or in make(1) arguments. Please undefine and try again.
+.endif
+
pre-configure:
${PERL} -pi -e "s^%%X11BASE%%^${X11BASE}^" ${WRKSRC}/aclocal.in
diff --git a/devel/automake16/Makefile b/devel/automake16/Makefile
index 6bdf74a777bd..a63c7ea3d63d 100644
--- a/devel/automake16/Makefile
+++ b/devel/automake16/Makefile
@@ -21,6 +21,10 @@ WRKSRC= ${WRKDIR}/${DISTNAME}
STRIP= # none
+.if defined(USE_AUTOMAKE) || defined(USE_AUTOMAKE_VER)
+.error You have `USE_AUTOMAKE' or `USE_AUTOMAKE_VER' variables defined either in environment or in make(1) arguments. Please undefine and try again.
+.endif
+
pre-configure:
${PERL} -pi -e "s^%%X11BASE%%^${X11BASE}^" ${WRKSRC}/aclocal.in
diff --git a/devel/automake17/Makefile b/devel/automake17/Makefile
index 6bdf74a777bd..a63c7ea3d63d 100644
--- a/devel/automake17/Makefile
+++ b/devel/automake17/Makefile
@@ -21,6 +21,10 @@ WRKSRC= ${WRKDIR}/${DISTNAME}
STRIP= # none
+.if defined(USE_AUTOMAKE) || defined(USE_AUTOMAKE_VER)
+.error You have `USE_AUTOMAKE' or `USE_AUTOMAKE_VER' variables defined either in environment or in make(1) arguments. Please undefine and try again.
+.endif
+
pre-configure:
${PERL} -pi -e "s^%%X11BASE%%^${X11BASE}^" ${WRKSRC}/aclocal.in
diff --git a/devel/automake18/Makefile b/devel/automake18/Makefile
index 6bdf74a777bd..a63c7ea3d63d 100644
--- a/devel/automake18/Makefile
+++ b/devel/automake18/Makefile
@@ -21,6 +21,10 @@ WRKSRC= ${WRKDIR}/${DISTNAME}
STRIP= # none
+.if defined(USE_AUTOMAKE) || defined(USE_AUTOMAKE_VER)
+.error You have `USE_AUTOMAKE' or `USE_AUTOMAKE_VER' variables defined either in environment or in make(1) arguments. Please undefine and try again.
+.endif
+
pre-configure:
${PERL} -pi -e "s^%%X11BASE%%^${X11BASE}^" ${WRKSRC}/aclocal.in
diff --git a/devel/automake19/Makefile b/devel/automake19/Makefile
index 6bdf74a777bd..a63c7ea3d63d 100644
--- a/devel/automake19/Makefile
+++ b/devel/automake19/Makefile
@@ -21,6 +21,10 @@ WRKSRC= ${WRKDIR}/${DISTNAME}
STRIP= # none
+.if defined(USE_AUTOMAKE) || defined(USE_AUTOMAKE_VER)
+.error You have `USE_AUTOMAKE' or `USE_AUTOMAKE_VER' variables defined either in environment or in make(1) arguments. Please undefine and try again.
+.endif
+
pre-configure:
${PERL} -pi -e "s^%%X11BASE%%^${X11BASE}^" ${WRKSRC}/aclocal.in
diff --git a/devel/bison-devel/Makefile b/devel/bison-devel/Makefile
index f9c118fa8644..ed700d39c92e 100644
--- a/devel/bison-devel/Makefile
+++ b/devel/bison-devel/Makefile
@@ -27,6 +27,10 @@ CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
MAN1= bison.1
+.ifdef USE_BISON
+.error You have `USE_BISON' variable defined either in environment or in make(1) arguments. Please undefine and try again.
+.endif
+
post-extract:
@${RM} -f ${WRKSRC}/doc/bison.info*
diff --git a/devel/bison/Makefile b/devel/bison/Makefile
index f9c118fa8644..ed700d39c92e 100644
--- a/devel/bison/Makefile
+++ b/devel/bison/Makefile
@@ -27,6 +27,10 @@ CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
MAN1= bison.1
+.ifdef USE_BISON
+.error You have `USE_BISON' variable defined either in environment or in make(1) arguments. Please undefine and try again.
+.endif
+
post-extract:
@${RM} -f ${WRKSRC}/doc/bison.info*
diff --git a/devel/bison175/Makefile b/devel/bison175/Makefile
index f9c118fa8644..ed700d39c92e 100644
--- a/devel/bison175/Makefile
+++ b/devel/bison175/Makefile
@@ -27,6 +27,10 @@ CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
MAN1= bison.1
+.ifdef USE_BISON
+.error You have `USE_BISON' variable defined either in environment or in make(1) arguments. Please undefine and try again.
+.endif
+
post-extract:
@${RM} -f ${WRKSRC}/doc/bison.info*
diff --git a/devel/bison1875/Makefile b/devel/bison1875/Makefile
index f9c118fa8644..ed700d39c92e 100644
--- a/devel/bison1875/Makefile
+++ b/devel/bison1875/Makefile
@@ -27,6 +27,10 @@ CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
MAN1= bison.1
+.ifdef USE_BISON
+.error You have `USE_BISON' variable defined either in environment or in make(1) arguments. Please undefine and try again.
+.endif
+
post-extract:
@${RM} -f ${WRKSRC}/doc/bison.info*
diff --git a/devel/bison2/Makefile b/devel/bison2/Makefile
index f9c118fa8644..ed700d39c92e 100644
--- a/devel/bison2/Makefile
+++ b/devel/bison2/Makefile
@@ -27,6 +27,10 @@ CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
MAN1= bison.1
+.ifdef USE_BISON
+.error You have `USE_BISON' variable defined either in environment or in make(1) arguments. Please undefine and try again.
+.endif
+
post-extract:
@${RM} -f ${WRKSRC}/doc/bison.info*
diff --git a/devel/bison20/Makefile b/devel/bison20/Makefile
index f9c118fa8644..ed700d39c92e 100644
--- a/devel/bison20/Makefile
+++ b/devel/bison20/Makefile
@@ -27,6 +27,10 @@ CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
MAN1= bison.1
+.ifdef USE_BISON
+.error You have `USE_BISON' variable defined either in environment or in make(1) arguments. Please undefine and try again.
+.endif
+
post-extract:
@${RM} -f ${WRKSRC}/doc/bison.info*
diff --git a/devel/gmake/Makefile b/devel/gmake/Makefile
index 5c90eb5e6ab1..ce8d5b070e51 100644
--- a/devel/gmake/Makefile
+++ b/devel/gmake/Makefile
@@ -23,6 +23,10 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -DHAVE_LOCALE_H -DHAVE_LC_MESSAG
MAN1= gmake.1
+.ifdef USE_GMAKE
+.error You have `USE_GMAKE' variable defined either in environment or in make(1) arguments. Please undefine and try again.
+.endif
+
# joerg@freebsd.org says our getloadavg() no longer requires setgid kmem
post-install:
diff --git a/devel/gmake381/Makefile b/devel/gmake381/Makefile
index 5c90eb5e6ab1..ce8d5b070e51 100644
--- a/devel/gmake381/Makefile
+++ b/devel/gmake381/Makefile
@@ -23,6 +23,10 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -DHAVE_LOCALE_H -DHAVE_LC_MESSAG
MAN1= gmake.1
+.ifdef USE_GMAKE
+.error You have `USE_GMAKE' variable defined either in environment or in make(1) arguments. Please undefine and try again.
+.endif
+
# joerg@freebsd.org says our getloadavg() no longer requires setgid kmem
post-install:
diff --git a/devel/gnu-automake/Makefile b/devel/gnu-automake/Makefile
index 6bdf74a777bd..a63c7ea3d63d 100644
--- a/devel/gnu-automake/Makefile
+++ b/devel/gnu-automake/Makefile
@@ -21,6 +21,10 @@ WRKSRC= ${WRKDIR}/${DISTNAME}
STRIP= # none
+.if defined(USE_AUTOMAKE) || defined(USE_AUTOMAKE_VER)
+.error You have `USE_AUTOMAKE' or `USE_AUTOMAKE_VER' variables defined either in environment or in make(1) arguments. Please undefine and try again.
+.endif
+
pre-configure:
${PERL} -pi -e "s^%%X11BASE%%^${X11BASE}^" ${WRKSRC}/aclocal.in
diff --git a/devel/gnu-libtool/Makefile b/devel/gnu-libtool/Makefile
index 1a27412f5338..a2ee543ab5ee 100644
--- a/devel/gnu-libtool/Makefile
+++ b/devel/gnu-libtool/Makefile
@@ -22,4 +22,8 @@ INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= PREFIX=${PREFIX}
+.ifdef USE_LIBTOOL
+.error You have `USE_LIBTOOL' variable defined either in environment or in make(1) arguments. Please undefine and try again.
+.endif
+
.include <bsd.port.mk>
diff --git a/devel/imake-4/Makefile b/devel/imake-4/Makefile
index ff68bc6c4182..3c650db988cb 100644
--- a/devel/imake-4/Makefile
+++ b/devel/imake-4/Makefile
@@ -22,6 +22,10 @@ MAINTAINER= anholt@freebsd.org
PREFIX?= ${X11BASE}
USE_PERL5= YES
+.ifdef USE_IMAKE
+.error You have `USE_IMAKE' variable defined either in environment or in make(1) arguments. Please undefine and try again.
+.endif
+
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 500000
diff --git a/devel/imake/Makefile b/devel/imake/Makefile
index 71f86452ab44..beb091ee45a9 100644
--- a/devel/imake/Makefile
+++ b/devel/imake/Makefile
@@ -35,6 +35,10 @@ MANCOMPRESSED= yes
INSTALL_TARGET= install install.man
MTREE_FILE= /etc/mtree/BSD.x11.dist
+.ifdef USE_IMAKE
+.error You have `USE_IMAKE' variable defined either in environment or in make(1) arguments. Please undefine and try again.
+.endif
+
do-configure:
@${ECHO_CMD} > ${WRKSRC}/cf/host.def
@(cd ${WRKDIR}/xc; \
diff --git a/devel/libtool/Makefile b/devel/libtool/Makefile
index 1a27412f5338..a2ee543ab5ee 100644
--- a/devel/libtool/Makefile
+++ b/devel/libtool/Makefile
@@ -22,4 +22,8 @@ INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= PREFIX=${PREFIX}
+.ifdef USE_LIBTOOL
+.error You have `USE_LIBTOOL' variable defined either in environment or in make(1) arguments. Please undefine and try again.
+.endif
+
.include <bsd.port.mk>
diff --git a/devel/libtool13/Makefile b/devel/libtool13/Makefile
index 1a27412f5338..a2ee543ab5ee 100644
--- a/devel/libtool13/Makefile
+++ b/devel/libtool13/Makefile
@@ -22,4 +22,8 @@ INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= PREFIX=${PREFIX}
+.ifdef USE_LIBTOOL
+.error You have `USE_LIBTOOL' variable defined either in environment or in make(1) arguments. Please undefine and try again.
+.endif
+
.include <bsd.port.mk>
diff --git a/devel/libtool14/Makefile b/devel/libtool14/Makefile
index 1a27412f5338..a2ee543ab5ee 100644
--- a/devel/libtool14/Makefile
+++ b/devel/libtool14/Makefile
@@ -22,4 +22,8 @@ INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= PREFIX=${PREFIX}
+.ifdef USE_LIBTOOL
+.error You have `USE_LIBTOOL' variable defined either in environment or in make(1) arguments. Please undefine and try again.
+.endif
+
.include <bsd.port.mk>
diff --git a/devel/libtool15/Makefile b/devel/libtool15/Makefile
index 1a27412f5338..a2ee543ab5ee 100644
--- a/devel/libtool15/Makefile
+++ b/devel/libtool15/Makefile
@@ -22,4 +22,8 @@ INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= PREFIX=${PREFIX}
+.ifdef USE_LIBTOOL
+.error You have `USE_LIBTOOL' variable defined either in environment or in make(1) arguments. Please undefine and try again.
+.endif
+
.include <bsd.port.mk>
diff --git a/emulators/linux_base-8/Makefile b/emulators/linux_base-8/Makefile
index 8cb25cc99b19..a3fd42bada52 100644
--- a/emulators/linux_base-8/Makefile
+++ b/emulators/linux_base-8/Makefile
@@ -63,6 +63,10 @@ UPDATES= glibc-common-2.2.4-29.${MACHINE_ARCH}.rpm \
glibc-2.2.4-29.${MACHINE_ARCH}.rpm \
zlib-1.1.3-25.7.${MACHINE_ARCH}.rpm
+.ifdef USE_LINUX
+.error You have `USE_LINUX' variable defined either in environment or in make(1) arguments. Please undefine and try again.
+.endif
+
.include <bsd.port.pre.mk>
.if (${MACHINE_ARCH} == "i386")
diff --git a/emulators/linux_base-rh-9/Makefile b/emulators/linux_base-rh-9/Makefile
index 8cb25cc99b19..a3fd42bada52 100644
--- a/emulators/linux_base-rh-9/Makefile
+++ b/emulators/linux_base-rh-9/Makefile
@@ -63,6 +63,10 @@ UPDATES= glibc-common-2.2.4-29.${MACHINE_ARCH}.rpm \
glibc-2.2.4-29.${MACHINE_ARCH}.rpm \
zlib-1.1.3-25.7.${MACHINE_ARCH}.rpm
+.ifdef USE_LINUX
+.error You have `USE_LINUX' variable defined either in environment or in make(1) arguments. Please undefine and try again.
+.endif
+
.include <bsd.port.pre.mk>
.if (${MACHINE_ARCH} == "i386")
diff --git a/emulators/linux_base-suse-9.1/Makefile b/emulators/linux_base-suse-9.1/Makefile
index 8cb25cc99b19..a3fd42bada52 100644
--- a/emulators/linux_base-suse-9.1/Makefile
+++ b/emulators/linux_base-suse-9.1/Makefile
@@ -63,6 +63,10 @@ UPDATES= glibc-common-2.2.4-29.${MACHINE_ARCH}.rpm \
glibc-2.2.4-29.${MACHINE_ARCH}.rpm \
zlib-1.1.3-25.7.${MACHINE_ARCH}.rpm
+.ifdef USE_LINUX
+.error You have `USE_LINUX' variable defined either in environment or in make(1) arguments. Please undefine and try again.
+.endif
+
.include <bsd.port.pre.mk>
.if (${MACHINE_ARCH} == "i386")
diff --git a/emulators/linux_base-suse-9.2/Makefile b/emulators/linux_base-suse-9.2/Makefile
index 8cb25cc99b19..a3fd42bada52 100644
--- a/emulators/linux_base-suse-9.2/Makefile
+++ b/emulators/linux_base-suse-9.2/Makefile
@@ -63,6 +63,10 @@ UPDATES= glibc-common-2.2.4-29.${MACHINE_ARCH}.rpm \
glibc-2.2.4-29.${MACHINE_ARCH}.rpm \
zlib-1.1.3-25.7.${MACHINE_ARCH}.rpm
+.ifdef USE_LINUX
+.error You have `USE_LINUX' variable defined either in environment or in make(1) arguments. Please undefine and try again.
+.endif
+
.include <bsd.port.pre.mk>
.if (${MACHINE_ARCH} == "i386")
diff --git a/emulators/linux_base-suse-9.3/Makefile b/emulators/linux_base-suse-9.3/Makefile
index 8cb25cc99b19..a3fd42bada52 100644
--- a/emulators/linux_base-suse-9.3/Makefile
+++ b/emulators/linux_base-suse-9.3/Makefile
@@ -63,6 +63,10 @@ UPDATES= glibc-common-2.2.4-29.${MACHINE_ARCH}.rpm \
glibc-2.2.4-29.${MACHINE_ARCH}.rpm \
zlib-1.1.3-25.7.${MACHINE_ARCH}.rpm
+.ifdef USE_LINUX
+.error You have `USE_LINUX' variable defined either in environment or in make(1) arguments. Please undefine and try again.
+.endif
+
.include <bsd.port.pre.mk>
.if (${MACHINE_ARCH} == "i386")
diff --git a/emulators/linux_base/Makefile b/emulators/linux_base/Makefile
index 8cb25cc99b19..a3fd42bada52 100644
--- a/emulators/linux_base/Makefile
+++ b/emulators/linux_base/Makefile
@@ -63,6 +63,10 @@ UPDATES= glibc-common-2.2.4-29.${MACHINE_ARCH}.rpm \
glibc-2.2.4-29.${MACHINE_ARCH}.rpm \
zlib-1.1.3-25.7.${MACHINE_ARCH}.rpm
+.ifdef USE_LINUX
+.error You have `USE_LINUX' variable defined either in environment or in make(1) arguments. Please undefine and try again.
+.endif
+
.include <bsd.port.pre.mk>
.if (${MACHINE_ARCH} == "i386")
diff --git a/graphics/Mesa3/Makefile b/graphics/Mesa3/Makefile
index a8200a941dbe..1e392a66c048 100644
--- a/graphics/Mesa3/Makefile
+++ b/graphics/Mesa3/Makefile
@@ -53,6 +53,10 @@ MAKE_ARGS= -e
MAKE_ENV+= SUB_GL="${SUB_GL}" \
INCLUDE_GL=${INCLUDE_GL}
+.ifdef USE_MESA
+.error You have `USE_MESA' variable defined either in environment or in make(1) arguments. Please undefine and try again.
+.endif
+
pre-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
diff --git a/graphics/mesagl/Makefile b/graphics/mesagl/Makefile
index a8200a941dbe..1e392a66c048 100644
--- a/graphics/mesagl/Makefile
+++ b/graphics/mesagl/Makefile
@@ -53,6 +53,10 @@ MAKE_ARGS= -e
MAKE_ENV+= SUB_GL="${SUB_GL}" \
INCLUDE_GL=${INCLUDE_GL}
+.ifdef USE_MESA
+.error You have `USE_MESA' variable defined either in environment or in make(1) arguments. Please undefine and try again.
+.endif
+
pre-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
diff --git a/graphics/xpm/Makefile b/graphics/xpm/Makefile
index 75e75820c880..664258448671 100644
--- a/graphics/xpm/Makefile
+++ b/graphics/xpm/Makefile
@@ -18,6 +18,10 @@ INSTALLS_SHLIB= yes
MAN1= cxpm.1 sxpm.1
+.ifdef USE_XPM
+.error You have `USE_XPM' variable defined either in environment or in make(1) arguments. Please undefine and try again.
+.endif
+
post-install:
@ranlib ${PREFIX}/lib/libXpm.a
diff --git a/lang/gcc295/Makefile b/lang/gcc295/Makefile
index b6f8482a3a80..afc8c93d76ab 100644
--- a/lang/gcc295/Makefile
+++ b/lang/gcc295/Makefile
@@ -21,6 +21,10 @@ USE_BZIP2= yes
LATEST_LINK= gcc295
+.ifdef USE_GCC
+.error You have `USE_GCC' variable defined either in environment or in make(1) arguments. Please undefine and try again.
+.endif
+
.include <bsd.port.pre.mk>
GCC_REV= ${DISTNAME:S/gcc-//g:S/.test3//g}
diff --git a/lang/gcc31/Makefile b/lang/gcc31/Makefile
index 0b92fb1c433e..630eac1230de 100644
--- a/lang/gcc31/Makefile
+++ b/lang/gcc31/Makefile
@@ -79,6 +79,10 @@ MAN1= cpp31.1 g++31.1 g77-31.1 gcc31.1 gcov31.1 \
jcf-dump31.1 jv-scan31.1 jv-convert.1
MAN7= fsf-funding.7 gfdl.7 gpl.7
+.ifdef USE_GCC
+.error You have `USE_GCC' variable defined either in environment or in make(1) arguments. Please undefine and try again.
+.endif
+
pre-fetch:
@${ECHO} "Making GCC ${DISTNAME:S/^gcc-//} for ${OPSYS} ${OSREL} ${PORTOBJFORMAT} target ${CONFIGURE_TARGET}"
diff --git a/lang/perl5.6/Makefile b/lang/perl5.6/Makefile
index 943341d19ed3..d88341c43852 100644
--- a/lang/perl5.6/Makefile
+++ b/lang/perl5.6/Makefile
@@ -50,6 +50,10 @@ CONFIGURE_ARGS+= -Dusemymalloc=n
INCLUDEDIR= /usr/include
+.ifdef USE_PERL5
+.error You have `USE_PERL5' variable defined either in environment or in make(1) arguments. Please undefine and try again.
+.endif
+
.include <bsd.port.pre.mk>
MAN1= a2p.1 c2ph.1 dprofpp.1 find2perl.1 h2ph.1 h2xs.1 perl.1 \
diff --git a/lang/perl5/Makefile b/lang/perl5/Makefile
index 943341d19ed3..d88341c43852 100644
--- a/lang/perl5/Makefile
+++ b/lang/perl5/Makefile
@@ -50,6 +50,10 @@ CONFIGURE_ARGS+= -Dusemymalloc=n
INCLUDEDIR= /usr/include
+.ifdef USE_PERL5
+.error You have `USE_PERL5' variable defined either in environment or in make(1) arguments. Please undefine and try again.
+.endif
+
.include <bsd.port.pre.mk>
MAN1= a2p.1 c2ph.1 dprofpp.1 find2perl.1 h2ph.1 h2xs.1 perl.1 \
diff --git a/print/freetype/Makefile b/print/freetype/Makefile
index 280a86efcaf7..d5a83380046f 100644
--- a/print/freetype/Makefile
+++ b/print/freetype/Makefile
@@ -24,6 +24,10 @@ USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
CONFIGURE_ARGS= --disable-nls --enable-static --enable-shared
+.ifdef USE_FREETYPE
+.error You have `USE_FREETYPE' variable defined either in environment or in make(1) arguments. Please undefine and try again.
+.endif
+
# Older versions of freetype installed include files in ${PREFIX}/include
# this is a compatibility hack for now
diff --git a/security/openssl/Makefile b/security/openssl/Makefile
index 175444a02ffc..315b1ba4feeb 100644
--- a/security/openssl/Makefile
+++ b/security/openssl/Makefile
@@ -15,6 +15,10 @@ MASTER_SITES= http://www.openssl.org/source/ \
MAINTAINER= dinoex@FreeBSD.org
+.ifdef USE_OPENSSL
+.error You have `USE_OPENSSL' variable defined either in environment or in make(1) arguments. Please undefine and try again.
+.endif
+
.include <bsd.port.pre.mk>
.if ${PORTOBJFORMAT} == "aout"
diff --git a/textproc/sed_inplace/Makefile b/textproc/sed_inplace/Makefile
index 4494303348ce..df905fc56dba 100644
--- a/textproc/sed_inplace/Makefile
+++ b/textproc/sed_inplace/Makefile
@@ -18,6 +18,10 @@ NO_WRKSUBDIR= yes
MAKEFILE= ${PKGDIR}/src/Makefile
MAKE_ENV= PKGDIR="${PKGDIR}"
+.ifdef USE_REINPLACE
+.error You have `USE_REINPLACE' variable defined either in environment or in make(1) arguments. Please undefine and try again.
+.endif
+
.include <bsd.port.pre.mk>
.if ${OSVERSION} > 500033
diff --git a/x11-toolkits/open-motif/Makefile b/x11-toolkits/open-motif/Makefile
index 35f2126ed57e..5f308789a4ad 100644
--- a/x11-toolkits/open-motif/Makefile
+++ b/x11-toolkits/open-motif/Makefile
@@ -28,6 +28,10 @@ INSTALLS_SHLIB= yes
DEMOS_SRC= ${WRKSRC}/demos/programs
+.ifdef USE_MOTIF
+.error You have `USE_MOTIF' variable defined either in environment or in make(1) arguments. Please undefine and try again.
+.endif
+
.include <bsd.port.pre.mk>
.if ${XFREE86_VERSION} >= 4
diff --git a/x11/XFree86-4-libraries/Makefile b/x11/XFree86-4-libraries/Makefile
index 7ba9227c93d6..8fb1cdccdd12 100644
--- a/x11/XFree86-4-libraries/Makefile
+++ b/x11/XFree86-4-libraries/Makefile
@@ -74,6 +74,10 @@ ForceNormalLib?= DEFAULT
DebuggableLibraries?= DEFAULT
# End of XFree86 User Config
+.ifdef USE_XLIB
+.error You have `USE_XLIB' variable defined either in environment or in make(1) arguments. Please undefine and try again.
+.endif
+
.include <bsd.port.pre.mk>
# BuildXF86DRI is false for FreeBSD < 4.1
diff --git a/x11/XFree86/Makefile b/x11/XFree86/Makefile
index cbc499ea8719..60c6cb50d758 100644
--- a/x11/XFree86/Makefile
+++ b/x11/XFree86/Makefile
@@ -44,6 +44,10 @@ PLIST= ${PKGDIR}/pkg-plist.pc98
PLIST= ${PKGDIR}/pkg-plist.alpha
.endif
+.ifdef USE_XLIB
+.error You have `USE_XLIB' variable defined either in environment or in make(1) arguments. Please undefine and try again.
+.endif
+
.if defined(XDM_DES) && (${USA_RESIDENT} != YES && ${USA_RESIDENT} != NO)
pre-fetch:
@${ECHO}
diff --git a/x11/dgs/Makefile b/x11/dgs/Makefile
index 3811835380a7..036afd4507dd 100644
--- a/x11/dgs/Makefile
+++ b/x11/dgs/Makefile
@@ -28,10 +28,12 @@ GNU_CONFIGURE= yes
MAN1= dgs.1 dpsnx.agent.1
MANN= dpsexec.man makepsres.man xepsf.man
+.ifdef USE_DGS
+.error You have `USE_DGS' variable defined either in environment or in make(1) arguments. Please undefine and try again.
+.endif
+
pre-patch:
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|manm|mann|g'
-
-
.include <bsd.port.mk>