aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Mk/bsd.openssl.mk2
-rw-r--r--UPDATING22
-rw-r--r--security/libressl/Makefile14
-rw-r--r--security/libressl/distinfo4
-rw-r--r--security/libressl/files/patch-include_openssl_opensslv.h10
-rw-r--r--security/libressl/pkg-plist17
6 files changed, 50 insertions, 19 deletions
diff --git a/Mk/bsd.openssl.mk b/Mk/bsd.openssl.mk
index e4cec22c2cb1..a435e3a1dce7 100644
--- a/Mk/bsd.openssl.mk
+++ b/Mk/bsd.openssl.mk
@@ -107,7 +107,7 @@ OPENSSL_SHLIBVER?= ${OPENSSL_SHLIBFILE:E}
# try to guess SHLIBVER for libressl
.if defined(OPENSSL_PORT) && ${OPENSSL_PORT} == security/libressl
-OPENSSL_SHLIBVER?= 34
+OPENSSL_SHLIBVER?= 35
.endif
# default
diff --git a/UPDATING b/UPDATING
index c70222e86807..26ac9a9a8571 100644
--- a/UPDATING
+++ b/UPDATING
@@ -5,6 +5,28 @@ they are unavoidable.
You should get into the habit of checking this file for changes each time
you update your ports collection, before attempting any port upgrades.
+20150806:
+ AFFECTS: users of security/libressl
+ AUTHOR: brnrd@FreeBSD.org
+
+ After upgrading to 2.2.2, manually update all packages that depend on
+ any of the libraries provided by LibreSSL (libssl, libcrypto and
+ libtls) since the versions of these libraries have changed. Normally,
+ you can obtain the list of dependent software by running the following
+ command:
+
+ # pkg info -r libressl
+
+ Then you should rebuild all ports depending on libressl to avoid dangling
+ shared library dependencies. Poudriere and pkg handle this correctly,
+ portmaster and portupgrade users can use the following to rebuild all
+ dependent ports.
+
+ Portmaster users:
+ portmaster -r libressl
+ Portupgrade users:
+ portupgrade -fr security/libressl
+
20150805:
AFFECTS: users of sysutils/tracker
AUTHOR: kwm@FreeBSD.org
diff --git a/security/libressl/Makefile b/security/libressl/Makefile
index 69dbdaefa4a3..c801901bd5f4 100644
--- a/security/libressl/Makefile
+++ b/security/libressl/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= libressl
-PORTVERSION= 2.2.1
+PORTVERSION= 2.2.2
CATEGORIES= security devel
MASTER_SITES= OPENBSD/LibreSSL
@@ -10,18 +10,24 @@ MAINTAINER= vsevolod@FreeBSD.org
COMMENT= Free version of the SSL/TLS protocol forked from OpenSSL
LICENSE= BSD4CLAUSE
+LICENSE_FILE= ${WRKSRC}/COPYING
CPE_VENDOR= openbsd
-CONFLICTS?= openssl-*
+CONFLICTS?= openssl-[0-9]*
GNU_CONFIGURE= yes
USES= cpe libtool pathfix pkgconfig
USE_LDCONFIG= yes
+USE_OPENSSL= yes
INSTALL_TARGET= install-strip
-test: build
+regression-test: build
cd ${WRKSRC} && ${MAKE} check
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+PLIST_SUB+= SHLIBVER=${OPENSSL_SHLIBVER}
+
+.include <bsd.port.post.mk>
diff --git a/security/libressl/distinfo b/security/libressl/distinfo
index 72f96dace247..59d63a38a634 100644
--- a/security/libressl/distinfo
+++ b/security/libressl/distinfo
@@ -1,2 +1,2 @@
-SHA256 (libressl-2.2.1.tar.gz) = 4f331750abfc3b605b02eeca1e8994fa0d2629985bc3f62924378197fbfe572d
-SIZE (libressl-2.2.1.tar.gz) = 2855917
+SHA256 (libressl-2.2.2.tar.gz) = e094b09f33d468545edbb2b16dc178f958ec2f66de1a2fc7cc2a20bd2489a114
+SIZE (libressl-2.2.2.tar.gz) = 2967327
diff --git a/security/libressl/files/patch-include_openssl_opensslv.h b/security/libressl/files/patch-include_openssl_opensslv.h
index 08386624c151..43a61234fa76 100644
--- a/security/libressl/files/patch-include_openssl_opensslv.h
+++ b/security/libressl/files/patch-include_openssl_opensslv.h
@@ -1,11 +1,11 @@
---- include/openssl/opensslv.h.orig 2015-05-23 21:50:16 UTC
+--- include/openssl/opensslv.h.orig 2015-07-26 14:58:42 UTC
+++ include/openssl/opensslv.h
-@@ -3,7 +3,7 @@
- #define HEADER_OPENSSLV_H
+@@ -7,7 +7,7 @@
+ #define LIBRESSL_VERSION_TEXT "LibreSSL 2.2.2"
- #define LIBRESSL_VERSION_NUMBER 0x20000000L
+ /* These will never change */
-#define OPENSSL_VERSION_NUMBER 0x20000000L
+#define OPENSSL_VERSION_NUMBER 0x1000107fL
- #define OPENSSL_VERSION_TEXT "LibreSSL 2.2.1"
+ #define OPENSSL_VERSION_TEXT LIBRESSL_VERSION_TEXT
#define OPENSSL_VERSION_PTEXT " part of " OPENSSL_VERSION_TEXT
diff --git a/security/libressl/pkg-plist b/security/libressl/pkg-plist
index 7b28950d718f..fe688c7c7819 100644
--- a/security/libressl/pkg-plist
+++ b/security/libressl/pkg-plist
@@ -1,4 +1,7 @@
bin/openssl
+etc/ssl/cert.pem
+etc/ssl/openssl.cnf
+etc/ssl/x509v3.cnf
include/openssl/aes.h
include/openssl/asn1.h
include/openssl/asn1_mac.h
@@ -74,16 +77,16 @@ include/openssl/x509v3.h
include/tls.h
lib/libcrypto.a
lib/libcrypto.so
-lib/libcrypto.so.34
-lib/libcrypto.so.34.0.0
+lib/libcrypto.so.%%SHLIBVER%%
+lib/libcrypto.so.%%SHLIBVER%%.0.0
lib/libssl.a
lib/libssl.so
-lib/libssl.so.33
-lib/libssl.so.33.0.0
+lib/libssl.so.35
+lib/libssl.so.35.0.0
lib/libtls.a
lib/libtls.so
-lib/libtls.so.4
-lib/libtls.so.4.0.0
+lib/libtls.so.6
+lib/libtls.so.6.0.0
libdata/pkgconfig/libcrypto.pc
libdata/pkgconfig/libssl.pc
libdata/pkgconfig/libtls.pc
@@ -829,7 +832,6 @@ man/man3/EVP_idea_ofb.3.gz
man/man3/EVP_md2.3.gz
man/man3/EVP_md5.3.gz
man/man3/EVP_md_null.3.gz
-man/man3/EVP_mdc2.3.gz
man/man3/EVP_rc2_40_cbc.3.gz
man/man3/EVP_rc2_64_cbc.3.gz
man/man3/EVP_rc2_cbc.3.gz
@@ -1541,4 +1543,5 @@ man/man3/ui.3.gz
man/man3/ui_compat.3.gz
man/man3/verify_callback.3.gz
man/man3/x509.3.gz
+@dir etc/ssl/certs
@dir include/openssl