aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--benchmarks/hpl/Makefile14
-rw-r--r--benchmarks/imb/Makefile8
-rw-r--r--benchmarks/mdtest/Makefile8
-rw-r--r--cad/astk-serveur/Makefile4
-rw-r--r--cad/scotch/Makefile7
-rw-r--r--french/aster/Makefile5
-rw-r--r--math/blacs/Makefile6
-rw-r--r--math/blacs/files/Bmake.inc-mpich.diff2
-rw-r--r--math/blacs/files/pkg-message.in8
-rw-r--r--math/blocksolve95/Makefile8
-rw-r--r--math/mumps/Makefile20
-rw-r--r--math/mumps/files/patch-Make.inc+Makefile.inc.generic4
-rw-r--r--math/parmetis/Makefile6
-rw-r--r--math/parmetis/files/patch-ab4
-rw-r--r--math/petsc/Makefile16
-rw-r--r--math/scalapack/Makefile12
-rw-r--r--math/scalapack/files/SLmake.inc-mpich.diff2
-rw-r--r--math/scalapack/files/pkg-message.in12
-rw-r--r--math/sdpara/Makefile28
-rw-r--r--math/spooles/Makefile4
-rw-r--r--math/spooles/files/patch-Make.inc2
-rw-r--r--science/fvm/Makefile7
-rw-r--r--science/gromacs/Makefile2
-rw-r--r--science/mbdyn/Makefile6
-rw-r--r--science/mpqc/Makefile8
-rw-r--r--science/ncs/Makefile4
-rw-r--r--science/pnetcdf/Makefile7
27 files changed, 107 insertions, 107 deletions
diff --git a/benchmarks/hpl/Makefile b/benchmarks/hpl/Makefile
index 9eba6860e269..9a385e984d77 100644
--- a/benchmarks/hpl/Makefile
+++ b/benchmarks/hpl/Makefile
@@ -7,7 +7,7 @@
PORTNAME= hpl
PORTVERSION= 2.0
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= benchmarks
MASTER_SITES= http://www.netlib.org/benchmark/hpl/
@@ -15,7 +15,7 @@ MAINTAINER= oliver@FreeBSD.org
COMMENT= High Performance Computing Linpack Benchmark
.if !defined(WITH_LAM)
-BUILD_DEPENDS= ${LOCALBASE}/mpich2/bin/mpicc:${PORTSDIR}/net/mpich2
+BUILD_DEPENDS= ${LOCALBASE}/bin/mpicc:${PORTSDIR}/net/mpich2
.else
BUILD_DEPENDS= ${LOCALBASE}/bin/lamd:${PORTSDIR}/net/lam
CC= ${LOCALBASE}/bin/mpicc
@@ -28,14 +28,14 @@ USE_FORTRAN= yes
.include <bsd.port.pre.mk>
.if exists(${LOCALBASE}/lib/libatlas.a) && !defined(WITH_BLAS)
-WITH_ATLAS= yes
+WITH_ATLAS= yes
.else
WITH_BLAS= yes
.endif
.if defined(WITH_ATLAS)
-LIB_DEPENDS+= atlas.2:${PORTSDIR}/math/atlas
+LIB_DEPENDS+= atlas.2:${PORTSDIR}/math/atlas
.else
-LIB_DEPENDS+= blas.2:${PORTSDIR}/math/blas
+LIB_DEPENDS+= blas.2:${PORTSDIR}/math/blas
.endif
USE_LDCONFIG= yes
@@ -75,7 +75,7 @@ MAN3= HPL_abort.3 HPL_all_reduce.3 HPL_barrier.3 HPL_bcast.3 \
post-patch:
@${REINPLACE_CMD} -e 's|^TOPdir[ ]*=.*$$|TOPdir = ${WRKSRC}| ; \
- s|^MPdir[ ]*=.*$$|MPdir = ${LOCALBASE}/mpich2| ; \
+ s|^MPdir[ ]*=.*$$|MPdir = ${LOCALBASE}| ; \
s|^LAdir[ ]*=.*$$|LAdir = ${LOCALBASE}/lib| ; \
s|^CC[ ]*=.*$$|CC = ${CC}| ; \
s|^CCFLAGS[ ]*=.*$$|CCFLAGS = $$\(HPL_DEFS\) ${CFLAGS} -fomit-frame-pointer -funroll-loops| ; \
@@ -90,7 +90,7 @@ post-patch:
s|^MPlib[ ]*=.*$$|MPlib = /usr/lib/libg2c.a|' \
${WRKSRC}/setup/Make.${HPL_ARCH}
.else
- @${REINPLACE_CMD} -e 's|^MPdir[ ]*=.*$$|MPdir = ${LOCALBASE}/mpich2|' \
+ @${REINPLACE_CMD} -e 's|^MPdir[ ]*=.*$$|MPdir = ${LOCALBASE}|' \
${WRKSRC}/setup/Make.${HPL_ARCH}
.endif
diff --git a/benchmarks/imb/Makefile b/benchmarks/imb/Makefile
index 33beecc41ea7..6c926d398583 100644
--- a/benchmarks/imb/Makefile
+++ b/benchmarks/imb/Makefile
@@ -7,7 +7,7 @@
PORTNAME= imb
PORTVERSION= 3.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= benchmarks parallel
MASTER_SITES= ${MASTER_SITE_LOCAL} \
http://cache-www.intel.com/cd/00/00/32/71/
@@ -46,9 +46,9 @@ BUILD_DEPENDS= ${LOCALBASE}/mpi/openmpi/lib/libmpi.so:${PORTSDIR}/net/openmpi
RUN_DEPENDS= ${LOCALBASE}/mpi/openmpi/bin/mpirun:${PORTSDIR}/net/openmpi
MAKE_ENV= MPI_HOME=${LOCALBASE}/mpi/openmpi
.else
-BUILD_DEPENDS= ${LOCALBASE}/mpich2/bin/mpicc:${PORTSDIR}/net/mpich2
-RUN_DEPENDS= ${LOCALBASE}/mpich2/bin/mpirun:${PORTSDIR}/net/mpich2
-MAKE_ENV= MPI_HOME=${LOCALBASE}/mpich2
+BUILD_DEPENDS= ${LOCALBASE}/bin/mpicc:${PORTSDIR}/net/mpich2
+RUN_DEPENDS= ${LOCALBASE}/bin/mpirun:${PORTSDIR}/net/mpich2
+MAKE_ENV= MPI_HOME=${LOCALBASE}
.endif
do-install:
diff --git a/benchmarks/mdtest/Makefile b/benchmarks/mdtest/Makefile
index 507dceb84a20..41db7cea6e4c 100644
--- a/benchmarks/mdtest/Makefile
+++ b/benchmarks/mdtest/Makefile
@@ -7,7 +7,7 @@
PORTNAME= mdtest
PORTVERSION= 1.7.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= benchmarks
MASTER_SITES= http://www.llnl.gov/icc/lc/siop/downloads/
@@ -25,9 +25,9 @@ BUILD_DEPENDS+= ${LOCALBASE}/mpi/openmpi/bin/mpicc:${PORTSDIR}/net/openmpi
RUN_DEPENDS+= ${LOCALBASE}/mpi/openmpi/lib/libmpi.so:${PORTSDIR}/net/openmpi
MPICC= ${LOCALBASE}/mpi/openmpi/bin/mpicc
.else
-BUILD_DEPENDS+= ${LOCALBASE}/mpich2/bin/mpicc:${PORTSDIR}/net/mpich2
-RUN_DEPENDS+= ${LOCALBASE}/mpich2/lib/libmpich.so:${PORTSDIR}/net/mpich2
-MPICC= ${LOCALBASE}/mpich2/bin/mpicc
+BUILD_DEPENDS+= ${LOCALBASE}/bin/mpicc:${PORTSDIR}/net/mpich2
+RUN_DEPENDS+= ${LOCALBASE}/lib/libmpich.so:${PORTSDIR}/net/mpich2
+MPICC= ${LOCALBASE}/bin/mpicc
.endif
USE_GMAKE= yes
diff --git a/cad/astk-serveur/Makefile b/cad/astk-serveur/Makefile
index 169f2bfe05c7..1c4ddb841071 100644
--- a/cad/astk-serveur/Makefile
+++ b/cad/astk-serveur/Makefile
@@ -67,12 +67,12 @@ PATCH2RM= conf/config lib/as_config.py conf/aster_profile.sh
. if exists(${LOCALBASE}/sbin/pbs_server)
WITH_PBS= yes
. endif
-. if exists(${LOCALBASE}/mpich2/bin/mpirun)
+. if exists(${LOCALBASE}/bin/mpirun)
WITH_MPI= yes
. endif
. if defined(WITH_MPI)
RUN_DEPENDS+= ${HOME_MPI}/bin/mpirun:${PORTSDIR}/net/mpich2
-HOME_MPI= ${LOCALBASE}/mpich2
+HOME_MPI= ${LOCALBASE}
PLIST_SUB+= MPI=""
. else
PLIST_SUB+= MPI="@comment "
diff --git a/cad/scotch/Makefile b/cad/scotch/Makefile
index 8f7da3beb45c..31ee7af7e366 100644
--- a/cad/scotch/Makefile
+++ b/cad/scotch/Makefile
@@ -7,7 +7,7 @@
PORTNAME= scotch
PORTVERSION= 5.0.6
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= cad science
MASTER_SITES= http://gforge.inria.fr/frs/download.php/3795/
DISTNAME= ${PORTNAME}_${PORTVERSION}
@@ -39,11 +39,10 @@ EXAMPLES= scotch_example.f
PKGMESSAGE= ${WRKSRC}/LICENSE_en.txt
.if !defined(WITHOUT_MPI)
-BUILD_DEPENDS+= ${LOCALBASE}/mpich2/bin/mpicc:${PORTSDIR}/net/mpich2
-RUN_DEPENDS+= ${LOCALBASE}/mpich2/lib/libmpich.so:${PORTSDIR}/net/mpich2
+BUILD_DEPENDS+= ${LOCALBASE}/bin/mpicc:${PORTSDIR}/net/mpich2
+RUN_DEPENDS+= ${LOCALBASE}/lib/libmpich.so:${PORTSDIR}/net/mpich2
ALL_TARGET+= ptscotch
-MAKE_ENV+= PATH=${PATH}:${LOCALBASE}/mpich2/bin
INCS+= ptscotch.h ptscotchf.h
LIBS+= libptscotch.a libptscotcherr.a
diff --git a/french/aster/Makefile b/french/aster/Makefile
index ac9d00bab824..35c2166f432d 100644
--- a/french/aster/Makefile
+++ b/french/aster/Makefile
@@ -132,14 +132,14 @@ MUMPS_PORT= mumps
BUILD_DEPENDS+= ${LOCALBASE}/lib/libblacs.a:${PORTSDIR}/math/blacs \
${LOCALBASE}/lib/libscalapack.a:${PORTSDIR}/math/scalapack
MUMPS_PORT= mumps-mpich
-MUMPSLIB= -L${LOCALBASE}/lib -ldmumps -lzmumps -lmumps_common -lpord -lscalapack -lblacs -lblacsc -lblacs -L${LOCALBASE}/mpich2/lib -lmpich
+MUMPSLIB= -L${LOCALBASE}/lib -ldmumps -lzmumps -lmumps_common -lpord -lscalapack -lblacs -lblacsc -lblacs -L${LOCALBASE}/lib -lmpich
. endif
BUILD_DEPENDS+= ${LOCALBASE}/lib/libcmumps.a:${PORTSDIR}/math/${MUMPS_PORT}
.endif
.if defined(WITH_MPI)
BUILD_DEPENDS+= ${HOME_MPI}/include/mpif.h:${PORTSDIR}/net/mpich2
-HOME_MPI= ${LOCALBASE}/mpich2
+HOME_MPI= ${LOCALBASE}
.endif
USE_FORTRAN= yes
@@ -220,7 +220,6 @@ ${WRKSRC}/instdir/${vaster}/elements: build
pre-everything::
.if defined(WITH_MPI)
@${ECHO_MSG} "To build Code_Aster with MPI enabled, you nedd to run `mpd &'"
- @${ECHO_MSG} "and may be you have to run `ldconfig -R ${LOCALBASE}/mpich2/lib'"
.endif
pre-configure:
diff --git a/math/blacs/Makefile b/math/blacs/Makefile
index 98832be54db6..e5bc8879dc28 100644
--- a/math/blacs/Makefile
+++ b/math/blacs/Makefile
@@ -7,7 +7,7 @@
PORTNAME= blacs
PORTVERSION= 1.7
-PORTREVISION= 11
+PORTREVISION= 12
CATEGORIES= math
MASTER_SITES= ftp://ftp.netlib.org/blacs/
DISTNAME= BLACS
@@ -28,7 +28,7 @@ SUB_FILES= pkg-message
.include <bsd.port.pre.mk>
.if exists(${LOCALBASE}/mpi/openmpi/bin/mpirun)
-WITH_OPENMPI= yes
+WITH_OPENMPI= yes
.endif
.if defined(WITH_OPENMPI)
@@ -37,7 +37,7 @@ RUN_DEPENDS= ${LOCALBASE}/mpi/openmpi/bin/mpirun:${PORTSDIR}/net/openmpi
EXTRA_PATCHES+= ${FILESDIR}/Bmake.inc-openmpi.diff
.else
LIB_DEPENDS= mpich:${PORTSDIR}/net/mpich2
-RUN_DEPENDS= ${LOCALBASE}/mpich2/bin/mpirun:${PORTSDIR}/net/mpich2
+RUN_DEPENDS= ${LOCALBASE}/bin/mpirun:${PORTSDIR}/net/mpich2
EXTRA_PATCHES+= ${FILESDIR}/Bmake.inc-mpich.diff
.endif
diff --git a/math/blacs/files/Bmake.inc-mpich.diff b/math/blacs/files/Bmake.inc-mpich.diff
index c4d362b8d6b0..b3efd0032202 100644
--- a/math/blacs/files/Bmake.inc-mpich.diff
+++ b/math/blacs/files/Bmake.inc-mpich.diff
@@ -31,7 +31,7 @@
# Name and location of the MPI library.
# -------------------------------------
- MPIdir = /usr/local/mpich
-+ MPIdir = @LOCALBASE@/mpich2
++ MPIdir = @LOCALBASE@
MPILIBdir = $(MPIdir)/lib/
MPIINCdir = $(MPIdir)/include
- MPILIB = $(MPILIBdir)/libmpich.a
diff --git a/math/blacs/files/pkg-message.in b/math/blacs/files/pkg-message.in
index 1c08c8429a88..bd2426b21079 100644
--- a/math/blacs/files/pkg-message.in
+++ b/math/blacs/files/pkg-message.in
@@ -4,10 +4,10 @@
Example:
% cd %%PREFIX%%/share/BLACS/TESTING
- % %%LOCALBASE%%/mpich2/bin/mpd &
- % %%LOCALBASE%%/mpich2/bin/mpirun -np 4 ./xCbtest_MPI-FreeBSD
- % %%LOCALBASE%%/mpich2/bin/mpirun -np 4 ./xFbtest_MPI-FreeBSD
- % %%LOCALBASE%%/mpich2/bin/mpdallexit
+ % %%LOCALBASE%%/bin/mpd &
+ % %%LOCALBASE%%/bin/mpirun -np 4 ./xCbtest_MPI-FreeBSD
+ % %%LOCALBASE%%/bin/mpirun -np 4 ./xFbtest_MPI-FreeBSD
+ % %%LOCALBASE%%/bin/mpdallexit
Or, if you're using OpenMPI:
% cd %%PREFIX%%/share/BLACS/TESTING
diff --git a/math/blocksolve95/Makefile b/math/blocksolve95/Makefile
index bc2716f68b94..eea1bd0fbca5 100644
--- a/math/blocksolve95/Makefile
+++ b/math/blocksolve95/Makefile
@@ -7,7 +7,7 @@
PORTNAME= blocksolve95
PORTVERSION= 3.0
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= math parallel
MASTER_SITES= ftp://info.mcs.anl.gov/pub/BlockSolve95/ \
ftp://ftp.irisa.fr/pub/mirrors/BlockSolve95/
@@ -27,7 +27,7 @@ MAKEFILE= makefile
MAKE_ARGS= GMAKE=${GMAKE} PETSC_ARCH=${PETSC_ARCH} BOPT=${BOPT} \
BLAS_LIB=${BLAS_LIB} LAPACK_LIB=${LAPACK_LIB}
-MPIDIR= ${LOCALBASE}/mpich2
+MPIDIR= ${LOCALBASE}
PETSC_ARCH= freebsd
BOPT?= O
@@ -73,10 +73,10 @@ regression-test: build
${CHMOD} go-r ${HOME}/.mpd.conf
@${ECHO_MSG} "${HOME}/.mpd.conf has been generated - please change the secret word!"
. endif
- ${LOCALBASE}/mpich2/bin/mpd &
+ ${LOCALBASE}/bin/mpd &
@(cd ${BUILD_WRKSRC}/examples; \
${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} bsrunexamples clean)
- ${LOCALBASE}/mpich2/bin/mpdallexit
+ ${LOCALBASE}/bin/mpdallexit
.endif
.include "${FILESDIR}/BSman3.inc"
diff --git a/math/mumps/Makefile b/math/mumps/Makefile
index 3647575bb100..5b4736b4a79b 100644
--- a/math/mumps/Makefile
+++ b/math/mumps/Makefile
@@ -7,7 +7,7 @@
PORTNAME= mumps
PORTVERSION= 4.8.3
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= math
MASTER_SITES= http://mumps.enseeiht.fr/ \
http://graal.ens-lyon.fr/MUMPS/ \
@@ -66,12 +66,12 @@ LAPACK_LIBS= -llapack
.ifdef WITH_MPI
PKGNAMESUFFIX+= -mpich
-BUILD_DEPENDS+= ${LOCALBASE}/mpich2/include/mpif.h:${PORTSDIR}/net/mpich2 \
+BUILD_DEPENDS+= ${LOCALBASE}/include/mpif.h:${PORTSDIR}/net/mpich2 \
${LOCALBASE}/lib/libblacs.a:${PORTSDIR}/math/blacs \
${LOCALBASE}/lib/libscalapack.a:${PORTSDIR}/math/scalapack
LIB_DEPENDS+= lapack:${PORTSDIR}/math/lapack
# Note: -l?mumps still requires to be linked with -lblacs + -lscalapack
-RUN_DEPENDS+= ${LOCALBASE}/mpich2/bin/mpirun:${PORTSDIR}/net/mpich2 \
+RUN_DEPENDS+= ${LOCALBASE}/bin/mpirun:${PORTSDIR}/net/mpich2 \
${LOCALBASE}/lib/libblacs.a:${PORTSDIR}/math/blacs \
${LOCALBASE}/lib/libscalapack.a:${PORTSDIR}/math/scalapack
CONFLICTS= mumps-4*
@@ -142,16 +142,16 @@ regression-test:
${CHMOD} go-r ${HOME}/.mpd.conf
@${ECHO_MSG} "${HOME}/.mpd.conf has been generated - please change the secret word!"
. endif
- ${LOCALBASE}/mpich2/bin/mpd &
+ ${LOCALBASE}/bin/mpd &
(cd ${WRKSRC}/examples && \
- ${LOCALBASE}/mpich2/bin/mpirun -np 2 ./ssimpletest < input_simpletest_real ; \
- ${LOCALBASE}/mpich2/bin/mpirun -np 2 ./dsimpletest < input_simpletest_real ; \
- ${LOCALBASE}/mpich2/bin/mpirun -np 2 ./csimpletest < input_simpletest_cmplx ; \
- ${LOCALBASE}/mpich2/bin/mpirun -np 2 ./zsimpletest < input_simpletest_cmplx ; \
+ ${LOCALBASE}/bin/mpirun -np 2 ./ssimpletest < input_simpletest_real ; \
+ ${LOCALBASE}/bin/mpirun -np 2 ./dsimpletest < input_simpletest_real ; \
+ ${LOCALBASE}/bin/mpirun -np 2 ./csimpletest < input_simpletest_cmplx ; \
+ ${LOCALBASE}/bin/mpirun -np 2 ./zsimpletest < input_simpletest_cmplx ; \
${ECHO_MSG} "The solution should be (1,2,3,4,5)" ; \
- ${LOCALBASE}/mpich2/bin/mpirun -np 3 ./c_example ; \
+ ${LOCALBASE}/bin/mpirun -np 3 ./c_example ; \
${ECHO_MSG} "The solution should be (1,2)")
- ${LOCALBASE}/mpich2/bin/mpdallexit
+ ${LOCALBASE}/bin/mpdallexit
.else
(cd ${WRKSRC}/examples && \
./ssimpletest < input_simpletest_real ; \
diff --git a/math/mumps/files/patch-Make.inc+Makefile.inc.generic b/math/mumps/files/patch-Make.inc+Makefile.inc.generic
index 0381879259af..7421456b4d47 100644
--- a/math/mumps/files/patch-Make.inc+Makefile.inc.generic
+++ b/math/mumps/files/patch-Make.inc+Makefile.inc.generic
@@ -48,11 +48,11 @@
# INCLUDE DIRECTORY FOR MPI
-INCPAR = -I/usr/include
-+INCPAR = -I@LOCALBASE@/mpich2/include
++INCPAR = -I@LOCALBASE@/include
# LIBRARIES USED BY THE PARALLEL VERSION OF MUMPS: $(SCALAP) and MPI
-LIBPAR = $(SCALAP) -L/usr/lib -lmpi
-+LIBPAR = -L@LOCALBASE@/mpich2/lib -lfmpich -lmpich $(SCALAP)
++LIBPAR = -L@LOCALBASE@/lib -lfmpich -lmpich $(SCALAP)
# The parallel version is not concerned by the next two lines.
# They are related to the sequential library provided by MUMPS,
diff --git a/math/parmetis/Makefile b/math/parmetis/Makefile
index 9fbf1d0d0398..601c8d5e024c 100644
--- a/math/parmetis/Makefile
+++ b/math/parmetis/Makefile
@@ -7,15 +7,15 @@
PORTNAME= ParMetis
PORTVERSION= 3.1
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= math parallel
MASTER_SITES= http://glaros.dtc.umn.edu/gkhome/fetch/sw/parmetis/
MAINTAINER= ports@FreeBSD.org
COMMENT= A package for parallel (mpi) unstructured graph partitioning
-RUN_DEPENDS= ${LOCALBASE}/mpich2/bin/mpirun:${PORTSDIR}/net/mpich2
-BUILD_DEPENDS= ${LOCALBASE}/mpich2/bin/mpicc:${PORTSDIR}/net/mpich2
+RUN_DEPENDS= ${LOCALBASE}/bin/mpirun:${PORTSDIR}/net/mpich2
+BUILD_DEPENDS= ${LOCALBASE}/bin/mpicc:${PORTSDIR}/net/mpich2
ALL_TARGET=
diff --git a/math/parmetis/files/patch-ab b/math/parmetis/files/patch-ab
index 568b3698917b..09756660bccf 100644
--- a/math/parmetis/files/patch-ab
+++ b/math/parmetis/files/patch-ab
@@ -4,7 +4,7 @@
# Which compiler to use
-CC = mpicc
-+CC = ${LOCALBASE}/mpich2/bin/mpicc
++CC = ${LOCALBASE}/bin/mpicc
# What optimization level to use
@@ -13,7 +13,7 @@
# Which loader to use
-LD = mpicc
-+LD = ${LOCALBASE}/mpich2/bin/mpicc
++LD = ${LOCALBASE}/bin/mpicc
# In which directories to look for any additional libraries
LIBDIR =
diff --git a/math/petsc/Makefile b/math/petsc/Makefile
index 2fec4ee29837..80ba614cb627 100644
--- a/math/petsc/Makefile
+++ b/math/petsc/Makefile
@@ -7,7 +7,7 @@
PORTNAME= petsc
DISTVERSION= 2.3.3-p0
-PORTREVISION= 3
+PORTREVISION= 4
PORTEPOCH= 1
CATEGORIES= math parallel
MASTER_SITES= ftp://ftp.mcs.anl.gov/pub/petsc/release-snapshots/
@@ -65,7 +65,7 @@ PORTDOCS= *
LIBSCALAPACK= ${LOCALBASE}/lib/libscalapack.a
LIBBLACS= ${LOCALBASE}/lib/libblacs.a
-MPIDIR= ${LOCALBASE}/mpich2
+MPIDIR= ${LOCALBASE}
.include <bsd.port.pre.mk>
@@ -82,7 +82,7 @@ WITHOUT_SUPERLU= yes
WITH_MPI= yes
.endif
.if defined(WITH_MPI)
-. if exists(${LOCALBASE}/include/mpi.h)
+. if exists(${LOCALBASE}/bin/lamboot)
BROKEN= Cannot build with MPI when lam-7 is installed - set WITHOUT_MPI or deinstall net/lam
. endif
.if defined(WITH_OPENMPI)
@@ -97,8 +97,8 @@ WITHOUT_SPOOLES= yes
WITHOUT_PARMETIS= yes
CONFIGURE_ARGS+= --with-cc=${MPIDIR}/bin/mpicc --with-fc=${MPIDIR}/bin/mpif77
.else
-BUILD_DEPENDS+= ${LOCALBASE}/mpich2/bin/mpicc:${PORTSDIR}/net/mpich2
-RUN_DEPENDS+= ${LOCALBASE}/mpich2/bin/mpirun:${PORTSDIR}/net/mpich2
+BUILD_DEPENDS+= ${LOCALBASE}/bin/mpicc:${PORTSDIR}/net/mpich2
+RUN_DEPENDS+= ${LOCALBASE}/bin/mpirun:${PORTSDIR}/net/mpich2
PKGNAMESUFFIX+= -mpich
WITHOUT_SPOOLES= yes
.endif
@@ -139,7 +139,7 @@ CONFIGURE_ARGS+= --with-superlu-include=${LOCALBASE}/include/superlu \
CONFIGURE_ARGS+= --with-blocksolve95=0
.else
BUILD_DEPENDS+= ${LOCALBASE}/lib/libBS95.a:${PORTSDIR}/math/blocksolve95
-CONFIGURE_ARGS+= --with-blocksolve95-include=${LOCALBASE}/mpich2/include \
+CONFIGURE_ARGS+= --with-blocksolve95-include=${LOCALBASE}/include \
--with-blocksolve95-lib=${LOCALBASE}/lib/libBS95.a
.endif
@@ -288,12 +288,12 @@ regression-test:
${CHMOD} go-r ${HOME}/.mpd.conf
@${ECHO_MSG} "${HOME}/.mpd.conf has been generated - please change the secret word!"
. endif
- ${LOCALBASE}/mpich2/bin/mpd &
+ ${LOCALBASE}/bin/mpd &
. endif
(cd ${BUILD_WRKSRC}; \
${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} test)
. if defined (WITH_MPI) && !defined(WITH_OPENMPI)
- ${LOCALBASE}/mpich2/bin/mpdallexit
+ ${LOCALBASE}/bin/mpdallexit
. endif
.endif
diff --git a/math/scalapack/Makefile b/math/scalapack/Makefile
index 8e16690b938e..ea5070e3ef80 100644
--- a/math/scalapack/Makefile
+++ b/math/scalapack/Makefile
@@ -7,7 +7,7 @@
PORTNAME= scalapack
PORTVERSION= 1.8.0
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= math
MASTER_SITES= ftp://ftp.netlib.org/scalapack/
DISTFILES= scalapack-${PORTVERSION}.tgz manpages.tgz
@@ -57,7 +57,7 @@ LAPACK= -llapack
.endif
.if exists(${LOCALBASE}/mpi/openmpi/bin/mpirun)
-WITH_OPENMPI= yes
+WITH_OPENMPI= yes
.endif
.if defined(WITH_OPENMPI)
@@ -66,8 +66,8 @@ RUN_DEPENDS+= ${LOCALBASE}/mpi/openmpi/bin/mpirun:${PORTSDIR}/net/openmpi
EXTRA_PATCHES+= ${FILESDIR}/SLmake.inc-openmpi.diff
.else
#LIB_DEPENDS+= mpich:${PORTSDIR}/net/mpich2
-BUILD_DEPENDS+= ${LOCALBASE}/mpich2/bin/mpicc:${PORTSDIR}/net/mpich2
-RUN_DEPENDS+= ${LOCALBASE}/mpich2/bin/mpirun:${PORTSDIR}/net/mpich2
+BUILD_DEPENDS+= ${LOCALBASE}/bin/mpicc:${PORTSDIR}/net/mpich2
+RUN_DEPENDS+= ${LOCALBASE}/bin/mpirun:${PORTSDIR}/net/mpich2
EXTRA_PATCHES+= ${FILESDIR}/SLmake.inc-mpich.diff
.endif
@@ -100,8 +100,8 @@ NOOPT= -O0
MPIF77= ${LOCALBASE}/mpi/openmpi/bin/mpif77
MPICC= ${LOCALBASE}/mpi/openmpi/bin/mpicc
.else
-MPIF77= ${LOCALBASE}/mpich2/bin/mpif77
-MPICC= ${LOCALBASE}/mpich2/bin/mpicc
+MPIF77= ${LOCALBASE}/bin/mpif77
+MPICC= ${LOCALBASE}/bin/mpicc
.endif
post-patch:
diff --git a/math/scalapack/files/SLmake.inc-mpich.diff b/math/scalapack/files/SLmake.inc-mpich.diff
index e24f66bd150a..3a35693d450c 100644
--- a/math/scalapack/files/SLmake.inc-mpich.diff
+++ b/math/scalapack/files/SLmake.inc-mpich.diff
@@ -27,7 +27,7 @@
-BLACSFINIT = $(BLACSdir)/libmpiblacsF77init-p4.a
-BLACSCINIT = $(BLACSdir)/libmpiblacsCinit-p4.a
-BLACSLIB = $(BLACSdir)/libmpiblacs-p4.a
-+SMPLIB = -L@LOCALBASE@/mpich2 -lmpich
++SMPLIB = -L@LOCALBASE@ -lmpich
+BLACSFINIT = $(BLACSdir)/libblacsf77.a #-L$(BLACSdir) -lblacsf77
+BLACSCINIT = $(BLACSdir)/libblacsc.a #-L$(BLACSdir) -lblacsc
+BLACSLIB = $(BLACSdir)/libblacs.a #-L$(BLACSdir) -lblacs
diff --git a/math/scalapack/files/pkg-message.in b/math/scalapack/files/pkg-message.in
index 28d99c43a274..74b24ecc5d10 100644
--- a/math/scalapack/files/pkg-message.in
+++ b/math/scalapack/files/pkg-message.in
@@ -6,19 +6,19 @@
Example:
% cd %%DATADIR%%/TESTING
- % %%LOCALBASE%%/mpich2/bin/mpd &
- % %%LOCALBASE%%/mpich2/bin/mpirun -np 4 ./xcbrd
- % %%LOCALBASE%%/mpich2/bin/mpirun -np 4 ./xcdblu
+ % %%LOCALBASE%%/bin/mpd &
+ % %%LOCALBASE%%/bin/mpirun -np 4 ./xcbrd
+ % %%LOCALBASE%%/bin/mpirun -np 4 ./xcdblu
etc., etc. ...
to perform all the tests,
% cd %%DATADIR%%/TESTING
- % %%LOCALBASE%%/mpich2/bin/mpd &
+ % %%LOCALBASE%%/bin/mpd &
% csh
% foreach i (x*)
- ? %%LOCALBASE%%/mpich2/bin/mpirun -np 4 ./$i >& ~/$i.log
+ ? %%LOCALBASE%%/bin/mpirun -np 4 ./$i >& ~/$i.log
? end
- % %%LOCALBASE%%/mpich2/bin/mpdallexit
+ % %%LOCALBASE%%/bin/mpdallexit
If you're using OpenMPI, use this instead:
% cd %%DATADIR%%/TESTING
diff --git a/math/sdpara/Makefile b/math/sdpara/Makefile
index fa704eca7ae3..6858dc0713dd 100644
--- a/math/sdpara/Makefile
+++ b/math/sdpara/Makefile
@@ -7,9 +7,9 @@
PORTNAME= sdpara
PORTVERSION= 7.2.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= math parallel
-MASTER_SITES= http://sdpa.indsys.chuo-u.ac.jp/sdpa/files/
+MASTER_SITES= http://sdpa.indsys.chuo-u.ac.jp/sdpa/files/
DISTFILES= ${SRCFILE}#${MANUALFILE}
DIST_SUBDIR= sdpa
EXTRACT_ONLY= ${SRCFILE}
@@ -34,9 +34,9 @@ WRKSRC= ${WRKDIR}/${PORTNAME}.${PORTVERSION}
USE_BLAS?= reference
.if exists(${LOCALBASE}/lib/libgoto.so)
-USE_BLAS= gotoblas
+USE_BLAS= gotoblas
.elif exists(${LOCALBASE}/lib/libatlas_r.so)
-USE_BLAS= atlas
+USE_BLAS= atlas
.endif
. if ${USE_BLAS} == reference
@@ -50,21 +50,21 @@ LIB_DEPENDS+= lapack.4:${PORTSDIR}/math/lapack
BLAS= -lgotop
LAPACK= -lgotop -llapack
.elif ${USE_BLAS} == atlas
-LIB_DEPENDS+= atlas:${PORTSDIR}/math/atlas
+LIB_DEPENDS+= atlas:${PORTSDIR}/math/atlas
BLAS= -lptf77blas -lptcblas -latlas_r
LAPACK= -lalapack_r
.endif
#PLIST_SUB+= MANUALFILE=${MANUALFILE}
-SCALAPACK = -L/usr/local/lib -lscalapack -lblacs -lblacsc
-FORTRAN_LIBS= -lgfortran
-GCCLIBDIR = -L`${CAT} ${WRKSRC}/LIBDIR` -L`${CAT} ${WRKSRC}/LIBDIR`/../../..
+SCALAPACK= -L/usr/local/lib -lscalapack -lblacs -lblacsc
+FORTRAN_LIBS= -lgfortran
+GCCLIBDIR= -L`${CAT} ${WRKSRC}/LIBDIR` -L`${CAT} ${WRKSRC}/LIBDIR`/../../..
post-patch:
- @${REINPLACE_CMD} -e 's|%%MPICC%%|${LOCALBASE}/mpich2/bin/mpicc|g ; \
- s|%%MPICXX%%|${LOCALBASE}/mpich2/bin/mpicxx|g ; \
- s|%%MPIF77%%|${LOCALBASE}/mpich2/bin/mpif77|g ; \
+ @${REINPLACE_CMD} -e 's|%%MPICC%%|${LOCALBASE}/bin/mpicc|g ; \
+ s|%%MPICXX%%|${LOCALBASE}/bin/mpicxx|g ; \
+ s|%%MPIF77%%|${LOCALBASE}/bin/mpif77|g ; \
s|%%CFLAGS%%|${CFLAGS}|g ; \
s|%%CXXFLAGS%%|${CXXFLAGS}|g ; \
s|%%FFLAGS%%|${FFLAGS}|g ; \
@@ -73,9 +73,9 @@ post-patch:
s|%%SCALAPACK%%|${SCALAPACK}|g ; \
s|%%PTHREAD_LIBS%%|${PTHREAD_LIBS}|g ; \
s|%%FORTRAN_LIBS%%|${GCCLIBDIR} ${FORTRAN_LIBS}|g ' ${WRKSRC}/Makefile
- @${REINPLACE_CMD} -e 's|%%MPICC%%|${LOCALBASE}/mpich2/bin/mpicc|g ; \
- s|%%MPICXX%%|${LOCALBASE}/mpich2/bin/mpicxx|g ; \
- s|%%MPIF77%%|${LOCALBASE}/mpich2/bin/mpif77|g ; \
+ @${REINPLACE_CMD} -e 's|%%MPICC%%|${LOCALBASE}/bin/mpicc|g ; \
+ s|%%MPICXX%%|${LOCALBASE}/bin/mpicxx|g ; \
+ s|%%MPIF77%%|${LOCALBASE}/bin/mpif77|g ; \
s|%%CFLAGS%%|${CFLAGS}|g ; \
s|%%CXXFLAGS%%|${CXXFLAGS}|g ; \
s|%%FFLAGS%%|${FFLAGS}|g ; \
diff --git a/math/spooles/Makefile b/math/spooles/Makefile
index 80e0b1e8cce8..2242f34da39c 100644
--- a/math/spooles/Makefile
+++ b/math/spooles/Makefile
@@ -7,7 +7,7 @@
PORTNAME= spooles
PORTVERSION= 2.2
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= math
MASTER_SITES= http://www.netlib.org/linalg/spooles/
.ifdef WITH_MPI
@@ -27,7 +27,7 @@ MAINTAINER= maho@FreeBSD.org
COMMENT= SParse Object Oriented Linear Equations Solver
.if defined(WITH_MPI)
-BUILD_DEPENDS= ${LOCALBASE}/mpich2/lib/libmpich.a:${PORTSDIR}/net/mpich2
+BUILD_DEPENDS= ${LOCALBASE}/lib/libmpich.a:${PORTSDIR}/net/mpich2
.endif
USE_GMAKE= yes #BSD make gives problems here
diff --git a/math/spooles/files/patch-Make.inc b/math/spooles/files/patch-Make.inc
index cd0ad9f78e57..142e44598f05 100644
--- a/math/spooles/files/patch-Make.inc
+++ b/math/spooles/files/patch-Make.inc
@@ -72,7 +72,7 @@
#
# MPI_INSTALL_DIR =
- MPI_INSTALL_DIR = /usr/local/mpich-1.0.13
-+MPI_INSTALL_DIR = %%LOCALBASE%%/mpich2
++MPI_INSTALL_DIR = %%LOCALBASE%%
#
#---------------------------------------------------------------------
#
diff --git a/science/fvm/Makefile b/science/fvm/Makefile
index 246a9b7d0164..9c539f5a1115 100644
--- a/science/fvm/Makefile
+++ b/science/fvm/Makefile
@@ -7,6 +7,7 @@
PORTNAME= fvm
PORTVERSION= 0.12.0
+PORTREVISION= 1
CATEGORIES= science parallel
MASTER_SITES= http://rd.edf.com/fichiers/fckeditor/File/EDF%20RD/Code_Saturne/Fichiers/
DISTNAME= ${PORTNAME}-${PORTVERSION:S/.//g}
@@ -39,9 +40,9 @@ BUILD_DEPENDS+= ${LOCALBASE}/mpi/openmpi/bin/mpicc:${PORTSDIR}/net/openmpi
RUN_DEPENDS+= ${LOCALBASE}/mpi/openmpi/bin/mpirun:${PORTSDIR}/net/openmpi
CONFIGURE_ARGS+= --with-mpi=${LOCALBASE}/mpi/openmpi
.else
-BUILD_DEPENDS+= ${LOCALBASE}/mpich2/bin/mpicc:${PORTSDIR}/net/mpich2
-RUN_DEPENDS+= ${LOCALBASE}/mpich2/bin/mpirun:${PORTSDIR}/net/mpich2
-CONFIGURE_ARGS+= --with-mpi=${LOCALBASE}/mpich2
+BUILD_DEPENDS+= ${LOCALBASE}/bin/mpicc:${PORTSDIR}/net/mpich2
+RUN_DEPENDS+= ${LOCALBASE}/bin/mpirun:${PORTSDIR}/net/mpich2
+CONFIGURE_ARGS+= --with-mpi=${LOCALBASE}
.endif
.if defined(WITH_DEBUG)
diff --git a/science/gromacs/Makefile b/science/gromacs/Makefile
index 8c11148bb714..b316e576b069 100644
--- a/science/gromacs/Makefile
+++ b/science/gromacs/Makefile
@@ -86,7 +86,7 @@ PLIST_SUB+= SUFFIX_D=_d SUFFIX_DOUBLE=_double
.if defined(WITH_MPICH) || defined(WITH_OMPI)
CONFIGURE_ARGS+= --enable-mpi
.if defined(WITH_MPICH)
-CONFIGURE_ENV+= MPICC=${PREFIX}/mpich2/bin/mpicc
+CONFIGURE_ENV+= MPICC=${PREFIX}/bin/mpicc
BUILD_DEPENDS+= ${LOCALBASE}/bin/mpicc:${PORTSDIR}/net/mpich2
RUN_DEPENDS+= ${LOCALBASE}/bin/mpicc:${PORTSDIR}/net/mpich2
.elif defined(WITH_OMPI)
diff --git a/science/mbdyn/Makefile b/science/mbdyn/Makefile
index 250b3e4d039b..feee992e3e36 100644
--- a/science/mbdyn/Makefile
+++ b/science/mbdyn/Makefile
@@ -45,15 +45,15 @@ LIB_DEPENDS+= goto:${PORTSDIR}/math/gotoblas
CONFIGURE_ARGS+= --with-blas=goto
.elif ${USE_BLAS} == atlas
LIB_DEPENDS+= atlas:${PORTSDIR}/math/atlas
-CONFIGURE_ARGS+= --with-blas=atlas
+CONFIGURE_ARGS+= --with-blas=atlas
.endif
LIB_DEPENDS+= lapack.4:${PORTSDIR}/math/lapack
.if defined(WITH_MPI)
LIB_DEPENDS+= mpich:${PORTSDIR}/net/mpich2
CONFIGURE_ARGS+= --with-mpi=pmpi
-CPPFLAGS+= -I${LOCALBASE}/mpich/include -I${LOCALBASE}/mpich/include/mpi2c++
-LDFLAGS+= -L${LOCALBASE}/mpich/lib
+CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/mpi2c++
+LDFLAGS+= -L${LOCALBASE}/lib
.else
CONFIGURE_ARGS+= --with-mpi=no
.endif
diff --git a/science/mpqc/Makefile b/science/mpqc/Makefile
index 5eb74c7c2966..0fbc4b8f32e4 100644
--- a/science/mpqc/Makefile
+++ b/science/mpqc/Makefile
@@ -7,7 +7,7 @@
PORTNAME= mpqc
PORTVERSION= 2.3.1
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= science parallel
MASTER_SITES= SF
@@ -22,7 +22,7 @@ USE_LDCONFIG= yes
.include <bsd.port.pre.mk>
.if defined(WITH_ICC)
-BUILD_DEPENDS+= ${LOCALBASE}/intel_cc_80/bin/icc:${PORTSDIR}/lang/icc
+BUILD_DEPENDS+= ${LOCALBASE}/intel_cc_80/bin/icc:${PORTSDIR}/lang/icc
.endif
.if exists(${LOCALBASE}/lib/libatlas_r.so) && !defined(WITH_BLAS)
WITH_ATLAS= yes
@@ -72,11 +72,11 @@ CONFIGURE_ARGS+=--with-cc=${CC} \
CONFIGURE_ARGS+=--with-libs="-lsvml"
.endif
.if defined(WITH_MPICH)
-CONFIGURE_ARGS+=--with-libdirs="-L${LOCALBASE}/lib -L${LOCALBASE}/mpich2/lib"\
+CONFIGURE_ARGS+=--with-libdirs="-L${LOCALBASE}/lib -L${LOCALBASE}/lib"\
--enable-always-use-mpi
.endif
.if defined(WITH_MPICH)
-CONFIGURE_ARGS+=--with-include="-I${LOCALBASE}/mpich2/include -I${WRKDIR} -I${LOCALBASE}/include"
+CONFIGURE_ARGS+=--with-include="-I${LOCALBASE}/include -I${WRKDIR} -I${LOCALBASE}/include"
.else
CONFIGURE_ARGS+=--with-include="-I${WRKDIR} -I${LOCALBASE}/include"
.endif
diff --git a/science/ncs/Makefile b/science/ncs/Makefile
index ea529a358a33..8844edfe14ac 100644
--- a/science/ncs/Makefile
+++ b/science/ncs/Makefile
@@ -7,7 +7,7 @@
PORTNAME= ncs
PORTVERSION= 1.3.3
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= science parallel
MASTER_SITES= http://rd.edf.com/fichiers/fckeditor/File/EDF%20RD/Code_Saturne/Fichiers/
DISTNAME= ${PORTNAME}-${PORTVERSION:S/.//g}
@@ -64,7 +64,7 @@ BUILD_DEPENDS+= ${MPI_HOME}/bin/mpicc:${PORTSDIR}/net/openmpi
RUN_DEPENDS+= ${MPI_HOME}/bin/mpirun:${PORTSDIR}/net/openmpi
MPI_LIBS= -lmpi -lorte -lopal
.else
-MPI_HOME= ${LOCALBASE}/mpich2
+MPI_HOME= ${LOCALBASE}
BUILD_DEPENDS+= ${MPI_HOME}/bin/mpicc:${PORTSDIR}/net/mpich2
RUN_DEPENDS+= ${MPI_HOME}/bin/mpirun:${PORTSDIR}/net/mpich2
MPI_LIBS= -lmpich
diff --git a/science/pnetcdf/Makefile b/science/pnetcdf/Makefile
index 188ec2533c3e..1d035c6c6487 100644
--- a/science/pnetcdf/Makefile
+++ b/science/pnetcdf/Makefile
@@ -7,6 +7,7 @@
PORTNAME= pnetcdf
PORTVERSION= 1.1.0
+PORTREVISION= 1
CATEGORIES= science parallel
MASTER_SITES= http://ftp.mcs.anl.gov/pub/parallel-netcdf/
DISTNAME= parallel-netcdf-${PORTVERSION}
@@ -40,9 +41,9 @@ BUILD_DEPENDS+= ${LOCALBASE}/mpi/openmpi/bin/mpicc:${PORTSDIR}/net/openmpi
RUN_DEPENDS+= ${LOCALBASE}/mpi/openmpi/lib/libmpi.so:${PORTSDIR}/net/openmpi
CONFIGURE_ARGS+=--with-mpi=${LOCALBASE}/mpi/openmpi
.else
-BUILD_DEPENDS+= ${LOCALBASE}/mpich2/bin/mpicc:${PORTSDIR}/net/mpich2
-RUN_DEPENDS+= ${LOCALBASE}/mpich2/lib/libmpich.so:${PORTSDIR}/net/mpich2
-CONFIGURE_ARGS+=--with-mpi=${LOCALBASE}/mpich2
+BUILD_DEPENDS+= ${LOCALBASE}/bin/mpicc:${PORTSDIR}/net/mpich2
+RUN_DEPENDS+= ${LOCALBASE}/lib/libmpich.so:${PORTSDIR}/net/mpich2
+CONFIGURE_ARGS+=--with-mpi=${LOCALBASE}
.endif
post-patch: