aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--astro/osmium/Makefile2
-rw-r--r--converters/osm2pgsql/Makefile2
-rw-r--r--databases/postgis20/Makefile2
-rw-r--r--databases/postgis21/Makefile2
-rw-r--r--databases/spatialite/Makefile2
-rw-r--r--devel/libgpkg/Makefile1
-rw-r--r--devel/py-shapely/Makefile1
-rw-r--r--graphics/geos/Makefile51
-rw-r--r--graphics/geos/pkg-plist9
-rw-r--r--graphics/librasterlite/Makefile2
-rw-r--r--graphics/libreatlas/Makefile2
-rw-r--r--graphics/mapserver/Makefile2
-rw-r--r--graphics/qgis/Makefile2
13 files changed, 35 insertions, 45 deletions
diff --git a/astro/osmium/Makefile b/astro/osmium/Makefile
index ccc265fef526..0b5329caf32b 100644
--- a/astro/osmium/Makefile
+++ b/astro/osmium/Makefile
@@ -3,7 +3,7 @@
PORTNAME= osmium
PORTVERSION= git20130522
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= astro geography devel
MAINTAINER= amdmi3@FreeBSD.org
diff --git a/converters/osm2pgsql/Makefile b/converters/osm2pgsql/Makefile
index 4536a8baf24d..73603274f29e 100644
--- a/converters/osm2pgsql/Makefile
+++ b/converters/osm2pgsql/Makefile
@@ -3,7 +3,7 @@
PORTNAME= osm2pgsql
PORTVERSION= 0.84.0
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= converters geography
MAINTAINER= amdmi3@FreeBSD.org
diff --git a/databases/postgis20/Makefile b/databases/postgis20/Makefile
index 217cd902cf1f..a5b868ddb73f 100644
--- a/databases/postgis20/Makefile
+++ b/databases/postgis20/Makefile
@@ -2,7 +2,7 @@
PORTNAME= postgis
PORTVERSION= 2.0.4
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= databases geography
MASTER_SITES= http://download.osgeo.org/postgis/source/
PKGNAMESUFFIX= 20
diff --git a/databases/postgis21/Makefile b/databases/postgis21/Makefile
index 4ff3d067aba5..cfc484448cd0 100644
--- a/databases/postgis21/Makefile
+++ b/databases/postgis21/Makefile
@@ -2,7 +2,7 @@
PORTNAME= postgis
PORTVERSION= 2.1.0
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= databases geography
MASTER_SITES= http://download.osgeo.org/postgis/source/
diff --git a/databases/spatialite/Makefile b/databases/spatialite/Makefile
index 68def4ee96dd..227769b6f5ea 100644
--- a/databases/spatialite/Makefile
+++ b/databases/spatialite/Makefile
@@ -3,7 +3,7 @@
PORTNAME= spatialite
PORTVERSION= 4.1.1
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= databases geography
MASTER_SITES= http://www.gaia-gis.it/gaia-sins/
DISTNAME= lib${PORTNAME}-${PORTVERSION}
diff --git a/devel/libgpkg/Makefile b/devel/libgpkg/Makefile
index 85e064f7170a..b5df1ea22ee6 100644
--- a/devel/libgpkg/Makefile
+++ b/devel/libgpkg/Makefile
@@ -3,6 +3,7 @@
PORTNAME= libgpkg
PORTVERSION= 0.9.18
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= https://bitbucket.org/luciad/libgpkg/get/ \
LOCAL/sunpoet/${PORTNAME}
diff --git a/devel/py-shapely/Makefile b/devel/py-shapely/Makefile
index e4f3af7fcbd3..7cb9a5b8d40e 100644
--- a/devel/py-shapely/Makefile
+++ b/devel/py-shapely/Makefile
@@ -3,6 +3,7 @@
PORTNAME= Shapely
PORTVERSION= 1.3.1
+PORTREVISION= 1
CATEGORIES= devel python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
diff --git a/graphics/geos/Makefile b/graphics/geos/Makefile
index f135ef26c008..d20912d45b05 100644
--- a/graphics/geos/Makefile
+++ b/graphics/geos/Makefile
@@ -3,47 +3,38 @@
PORTNAME= geos
PORTVERSION= 3.4.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics geography
-MASTER_SITES= http://download.osgeo.org/geos/
+MASTER_SITES= http://download.osgeo.org/geos/ \
+ LOCAL/sunpoet
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= GEOS implements all the OpenGIS "Simple Features for SQL"
LICENSE= LGPL21
-USE_AUTOTOOLS= libtool
-USES= gmake tar:bzip2
-GNU_CONFIGURE= yes
-
OPTIONS_DEFINE= PHP PYTHON RUBY
OPTIONS_SUB= yes
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MPHP} || ${PORT_OPTIONS:MPYTHON} || ${PORT_OPTIONS:MRUBY}
-BUILD_DEPENDS+= swig1.3:${PORTSDIR}/devel/swig13
-.endif
-
-.if ${PORT_OPTIONS:MPYTHON}
-USE_PYTHON= yes
-CONFIGURE_ARGS+= --enable-python
-.endif
-
-.if ${PORT_OPTIONS:MPHP}
-USE_PHP= yes
-USE_PHP_BUILD= yes
-CONFIGURE_ARGS+= --enable-php
-.endif
-
-.if ${PORT_OPTIONS:MRUBY}
-USE_RUBY= yes
-CONFIGURE_ARGS+= --enable-ruby
-CONFIGURE_ENV+= RUBY="${RUBY}"
-.endif
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+USES= gmake libtool tar:bzip2
+
+PLIST_SUB= PORTVERSION=${PORTVERSION}
+
+PHP_BUILD_DEPENDS= ${LOCALBASE}/bin/swig1.3:${PORTSDIR}/devel/swig13
+PHP_CONFIGURE_ENABLE= php
+PHP_USE= PHP=yes PHP_BUILD=yes
+PYTHON_BUILD_DEPENDS= ${LOCALBASE}/bin/swig1.3:${PORTSDIR}/devel/swig13
+PYTHON_CONFIGURE_ENABLE=python
+PYTHON_USE= PYTHON=2
+RUBY_BUILD_DEPENDS= ${LOCALBASE}/bin/swig1.3:${PORTSDIR}/devel/swig13
+RUBY_CONFIGURE_ENABLE= ruby
+RUBY_CONFIGURE_ENV= RUBY="${RUBY}"
+RUBY_USE= RUBY=yes
post-install:
- @${LN} -s ${PREFIX}/lib/libgeos-${PORTVERSION}.so \
- ${STAGEDIR}${PREFIX}/lib/libgeos.so.0
+ ${LN} -s ${PREFIX}/lib/libgeos-${PORTVERSION}.so ${STAGEDIR}${PREFIX}/lib/libgeos.so.0
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libgeos-${PORTVERSION}.so ${STAGEDIR}${PREFIX}/lib/libgeos_c.so.1.8.2
.include <bsd.port.mk>
diff --git a/graphics/geos/pkg-plist b/graphics/geos/pkg-plist
index 926890c1fe17..2b56b93b3a0f 100644
--- a/graphics/geos/pkg-plist
+++ b/graphics/geos/pkg-plist
@@ -372,15 +372,14 @@ include/geos/util/UnsupportedOperationException.h
include/geos/util/math.h
include/geos/version.h
include/geos_c.h
-lib/libgeos-3.4.2.so
+lib/libgeos-%%PORTVERSION%%.so
lib/libgeos.a
-lib/libgeos.la
lib/libgeos.so
lib/libgeos.so.0
lib/libgeos_c.a
-lib/libgeos_c.la
lib/libgeos_c.so
-lib/libgeos_c.so.9
+lib/libgeos_c.so.1
+lib/libgeos_c.so.1.8.2
@dirrmtry lib/geos
@dirrm include/geos/util
@dirrm include/geos/triangulate/quadedge
@@ -423,7 +422,6 @@ lib/libgeos_c.so.9
@dirrm include/geos
%%PYTHON%%%%PYTHON_SITELIBDIR%%/geos.pth
%%PYTHON%%%%PYTHON_SITELIBDIR%%/geos/_geos.a
-%%PYTHON%%%%PYTHON_SITELIBDIR%%/geos/_geos.la
%%PYTHON%%%%PYTHON_SITELIBDIR%%/geos/_geos.so
%%PYTHON%%%%PYTHON_SITELIBDIR%%/geos/geos.py
%%PYTHON%%%%PYTHON_SITELIBDIR%%/geos/geos.pyc
@@ -431,7 +429,6 @@ lib/libgeos_c.so.9
%%PYTHON%%@dirrm %%PYTHON_SITELIBDIR%%/geos
%%PYTHON%%@dirrmtry %%PYTHON_SITELIBDIR%%
%%RUBY%%%%RUBY_SITEARCHLIBDIR%%/geos.a
-%%RUBY%%%%RUBY_SITEARCHLIBDIR%%/geos.la
%%RUBY%%%%RUBY_SITEARCHLIBDIR%%/geos.so
%%RUBY%%@dirrmtry %%RUBY_SITEARCHLIBDIR%%/
%%PHP%%lib/php/20100525/geos.so
diff --git a/graphics/librasterlite/Makefile b/graphics/librasterlite/Makefile
index 61bb88b16d5f..e2583d475048 100644
--- a/graphics/librasterlite/Makefile
+++ b/graphics/librasterlite/Makefile
@@ -3,7 +3,7 @@
PORTNAME= librasterlite
PORTVERSION= 1.1g
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= graphics geography
MASTER_SITES= http://www.gaia-gis.it/gaia-sins/librasterlite-sources/
diff --git a/graphics/libreatlas/Makefile b/graphics/libreatlas/Makefile
index 3ac0ac27f4b8..f1ed5870547b 100644
--- a/graphics/libreatlas/Makefile
+++ b/graphics/libreatlas/Makefile
@@ -3,7 +3,7 @@
PORTNAME= libreatlas
PORTVERSION= 1.0.0a
-PORTREVISION= 11
+PORTREVISION= 12
CATEGORIES= graphics geography
MASTER_SITES= http://www.gaia-gis.it/gaia-sins/
diff --git a/graphics/mapserver/Makefile b/graphics/mapserver/Makefile
index 2a066dfa1e11..95ef6f81f692 100644
--- a/graphics/mapserver/Makefile
+++ b/graphics/mapserver/Makefile
@@ -3,7 +3,7 @@
PORTNAME= mapserver
PORTVERSION= 6.4.0
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= graphics www geography
MASTER_SITES= http://download.osgeo.org/mapserver/
diff --git a/graphics/qgis/Makefile b/graphics/qgis/Makefile
index 350e329d5353..8355aac8fc1f 100644
--- a/graphics/qgis/Makefile
+++ b/graphics/qgis/Makefile
@@ -3,7 +3,7 @@
PORTNAME= qgis
PORTVERSION= 2.2.0
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= graphics geography
MAINTAINER= rhurlin@gwdg.de