aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--mail/Makefile1
-rw-r--r--mail/pear-Net_Cyrus/Makefile24
-rw-r--r--mail/pear-Net_Cyrus/distinfo2
-rw-r--r--mail/pear-Net_Cyrus/pkg-descr7
4 files changed, 34 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index 625feb1031d4..cb282fe10d1f 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -260,6 +260,7 @@
SUBDIR += pathalias
SUBDIR += pear-Mail
SUBDIR += pear-Mail_Mime
+ SUBDIR += pear-Net_Cyrus
SUBDIR += pear-Net_IMAP
SUBDIR += pear-mailparse
SUBDIR += perdition
diff --git a/mail/pear-Net_Cyrus/Makefile b/mail/pear-Net_Cyrus/Makefile
new file mode 100644
index 000000000000..643018db2a6a
--- /dev/null
+++ b/mail/pear-Net_Cyrus/Makefile
@@ -0,0 +1,24 @@
+# Ports collection makefile for: pear-Net_Cyrus
+# Date created: 12 March 2004
+# Whom: Attila Nagy <bra@fsn.hu>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net_Cyrus
+PORTVERSION= 0.1.0
+CATEGORIES= mail net pear
+
+MAINTAINER= bra@fsn.hu
+COMMENT= PEAR class to administer Cyrus IMAP servers
+
+BUILD_DEPENDS= ${PEARDIR}/Net/Socket.php:${PORTSDIR}/net/pear-Net_Socket \
+ ${PEARDIR}/Net/IMAP.php:${PORTSDIR}/mail/pear-Net_IMAP
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+CATEGORY= Net
+FILES= Cyrus.php
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
+.include <bsd.port.post.mk>
diff --git a/mail/pear-Net_Cyrus/distinfo b/mail/pear-Net_Cyrus/distinfo
new file mode 100644
index 000000000000..47b4f0c141e3
--- /dev/null
+++ b/mail/pear-Net_Cyrus/distinfo
@@ -0,0 +1,2 @@
+MD5 (PEAR/Net_Cyrus-0.1.0.tgz) = e960034e37e08596ad8796c2baf9b713
+SIZE (PEAR/Net_Cyrus-0.1.0.tgz) = 4954
diff --git a/mail/pear-Net_Cyrus/pkg-descr b/mail/pear-Net_Cyrus/pkg-descr
new file mode 100644
index 000000000000..1c56d5cc6c84
--- /dev/null
+++ b/mail/pear-Net_Cyrus/pkg-descr
@@ -0,0 +1,7 @@
+Net_Cyrus is a PEAR class which provides an API for the administration of
+Cyrus IMAP servers.
+
+It can be used to create,delete and modify users and it's properties (Quota
+and ACL)
+
+WWW: http://pear.php.net/package/Net_Cyrus