aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--UPDATING9
-rw-r--r--sysutils/Makefile2
-rw-r--r--sysutils/android-file-transfer-qt4/Makefile16
-rw-r--r--sysutils/android-file-transfer-qt5/Makefile16
-rw-r--r--sysutils/android-file-transfer/Makefile19
5 files changed, 58 insertions, 4 deletions
diff --git a/UPDATING b/UPDATING
index bc8d00cdaad6..9c5cd4d2e83e 100644
--- a/UPDATING
+++ b/UPDATING
@@ -5,6 +5,15 @@ they are unavoidable.
You should get into the habit of checking this file for changes each time
you update your ports collection, before attempting any port upgrades.
+20160927:
+ AFFECTS: sysutils/android-file-transfer
+ AUTHOR: jbeich@FreeBSD.org
+
+ Qt* GUI was split into separate ports:
+
+ sysutils/android-file-transfer-qt4
+ sysutils/android-file-transfer-qt5
+
20160922:
AFFECTS: users of databases/pglogical, databases/pglogical-output
AUTHOR: matthew@FreeBSD.org
diff --git a/sysutils/Makefile b/sysutils/Makefile
index ac07864b453a..a31affbb9070 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -32,6 +32,8 @@
SUBDIR += anacron
SUBDIR += and
SUBDIR += android-file-transfer
+ SUBDIR += android-file-transfer-qt4
+ SUBDIR += android-file-transfer-qt5
SUBDIR += ansible
SUBDIR += ansible1
SUBDIR += apachetop
diff --git a/sysutils/android-file-transfer-qt4/Makefile b/sysutils/android-file-transfer-qt4/Makefile
new file mode 100644
index 000000000000..a1873a15eeee
--- /dev/null
+++ b/sysutils/android-file-transfer-qt4/Makefile
@@ -0,0 +1,16 @@
+# $FreeBSD$
+
+PORTREVISION= 0
+PKGNAMESUFFIX= -qt4
+
+MASTERDIR= ${.CURDIR}/../android-file-transfer
+
+CONFLICTS_INSTALL= ${PORTNAME}-qt5
+
+OPTIONS_SLAVE= QT4
+OPTIONS_EXCLUDE=${OPTIONS_MULTI_COMP} ${OPTIONS_RADIO_GUI}
+
+# XXX Why OPTIONS_EXCLUDE doesn't trigger _OFF helpers?
+post-patch-QT4-on: post-patch-CLI-off
+
+.include "${MASTERDIR}/Makefile"
diff --git a/sysutils/android-file-transfer-qt5/Makefile b/sysutils/android-file-transfer-qt5/Makefile
new file mode 100644
index 000000000000..77cb22c54602
--- /dev/null
+++ b/sysutils/android-file-transfer-qt5/Makefile
@@ -0,0 +1,16 @@
+# $FreeBSD$
+
+PORTREVISION= 0
+PKGNAMESUFFIX= -qt5
+
+MASTERDIR= ${.CURDIR}/../android-file-transfer
+
+CONFLICTS_INSTALL= ${PORTNAME}-qt4
+
+OPTIONS_SLAVE= QT5
+OPTIONS_EXCLUDE=${OPTIONS_MULTI_COMP} ${OPTIONS_RADIO_GUI}
+
+# XXX Why OPTIONS_EXCLUDE doesn't trigger _OFF helpers?
+post-patch-QT5-on: post-patch-CLI-off
+
+.include "${MASTERDIR}/Makefile"
diff --git a/sysutils/android-file-transfer/Makefile b/sysutils/android-file-transfer/Makefile
index 987e52fda202..18bad2aeb914 100644
--- a/sysutils/android-file-transfer/Makefile
+++ b/sysutils/android-file-transfer/Makefile
@@ -4,6 +4,7 @@ PORTNAME= android-file-transfer
DISTVERSIONPREFIX= v
DISTVERSION= 3.0-10
DISTVERSIONSUFFIX= -g40640fb
+PORTREVISION?= 1
CATEGORIES= sysutils
MAINTAINER= jbeich@FreeBSD.org
@@ -15,17 +16,24 @@ USE_GITHUB= yes
GH_ACCOUNT= whoozle
GH_PROJECT= ${PORTNAME}-linux
-USES= cmake compiler:c++11-lib localbase pkgconfig readline
+USES= cmake compiler:c++11-lib localbase pkgconfig
CMAKE_ARGS= -DUSB_BACKEND_LIBUSB=on -DBUILD_QT_UI=off
-PLIST_FILES= bin/aft-mtp-cli
-OPTIONS_DEFINE= FUSE
-OPTIONS_DEFAULT=FUSE QT5
+OPTIONS_DEFAULT=CLI FUSE
+OPTIONS_MULTI= COMP
+OPTIONS_MULTI_COMP= CLI FUSE
OPTIONS_RADIO= GUI
OPTIONS_RADIO_GUI= QT4 QT5
+OPTIONS_EXCLUDE?=${OPTIONS_RADIO_GUI}
# XXX http://lists.dragonflybsd.org/pipermail/users/2016-September/313064.html
OPTIONS_EXCLUDE_DragonFly= FUSE
+COMP_DESC= Components
+
+CLI_DESC= CLI (Command-Line Interface) support
+CLI_USES= readline
+CLI_PLIST_FILES=bin/aft-mtp-cli
+
FUSE_USES= fuse
FUSE_CMAKE_BOOL=BUILD_FUSE
FUSE_PLIST_FILES=bin/aft-mtp-mount
@@ -44,4 +52,7 @@ QT5_PLIST_FILES=bin/android-file-transfer \
CONFIGURE_ENV+= PKG_CONFIG_PATH="${FILESDIR}"
.endif
+post-patch-CLI-off:
+ @${REINPLACE_CMD} '/subdirectory(cli)/d' ${WRKSRC}/CMakeLists.txt
+
.include <bsd.port.mk>