aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/ossp-cfg/Makefile30
-rw-r--r--devel/ossp-cfg/distinfo1
-rw-r--r--devel/ossp-cfg/files/manpages.mk1
-rw-r--r--devel/ossp-cfg/files/patch-cfg_data.c11
-rw-r--r--devel/ossp-cfg/files/patch-cfg_node.c21
-rw-r--r--devel/ossp-cfg/pkg-comment1
-rw-r--r--devel/ossp-cfg/pkg-descr9
-rw-r--r--devel/ossp-cfg/pkg-plist6
9 files changed, 81 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index eb7b2e7ab53a..7dab2219bc8d 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -411,6 +411,7 @@
SUBDIR += openzz
SUBDIR += orbitcpp
SUBDIR += ossp-al
+ SUBDIR += ossp-cfg
SUBDIR += ossp-ex
SUBDIR += ossp-l2
SUBDIR += ossp-val
diff --git a/devel/ossp-cfg/Makefile b/devel/ossp-cfg/Makefile
new file mode 100644
index 000000000000..bc2f1577f287
--- /dev/null
+++ b/devel/ossp-cfg/Makefile
@@ -0,0 +1,30 @@
+# ex:ts=8 -*-mode: makefile-*-
+#
+# New ports collection makefile for: ossp-cfg
+# Date created: 2003-01-31
+# Whom: Alan Eldridge <alane@geeksrus.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= cfg
+PORTVERSION= 0.9.0
+PORTREVISION= 0
+PORTEPOCH= 0
+CATEGORIES= devel
+MASTER_SITES= ftp://ftp.ossp.org/pkg/lib/cfg/
+PKGNAMEPREFIX= ossp-
+
+MAINTAINER= alane@FreeBSD.org
+
+USE_GMAKE= yes
+USE_LIBTOOL= yes
+GNU_CONFIGURE= yes
+USE_LIBTOOL= yes
+INSTALLS_SHLIB= yes
+
+.include <bsd.port.pre.mk>
+.include "${FILESDIR}/manpages.mk"
+.include <bsd.port.post.mk>
+
+#EOF
diff --git a/devel/ossp-cfg/distinfo b/devel/ossp-cfg/distinfo
new file mode 100644
index 000000000000..ac642a987d33
--- /dev/null
+++ b/devel/ossp-cfg/distinfo
@@ -0,0 +1 @@
+MD5 (cfg-0.9.0.tar.gz) = 9f90dac8870078cf58483a4dc6b1c3d1
diff --git a/devel/ossp-cfg/files/manpages.mk b/devel/ossp-cfg/files/manpages.mk
new file mode 100644
index 000000000000..50046e436f0a
--- /dev/null
+++ b/devel/ossp-cfg/files/manpages.mk
@@ -0,0 +1 @@
+MAN3+= cfg.3
diff --git a/devel/ossp-cfg/files/patch-cfg_data.c b/devel/ossp-cfg/files/patch-cfg_data.c
new file mode 100644
index 000000000000..815d78e79d8d
--- /dev/null
+++ b/devel/ossp-cfg/files/patch-cfg_data.c
@@ -0,0 +1,11 @@
+--- cfg_data.c.orig Sun Jul 28 07:06:02 2002
++++ cfg_data.c Mon Feb 3 15:15:12 2003
+@@ -186,7 +186,7 @@
+ break;
+ }
+ case CFG_DATA_ATTR_CTRL: {
+- cfg_data_cb_t ctrl = (cfg_data_cb_t)va_arg(ap, void (*)(void));
++ cfg_data_cb_t ctrl = (cfg_data_cb_t)va_arg(ap, void *);
+ data->ctrl = ctrl;
+ break;
+ }
diff --git a/devel/ossp-cfg/files/patch-cfg_node.c b/devel/ossp-cfg/files/patch-cfg_node.c
new file mode 100644
index 000000000000..360cfe03e60f
--- /dev/null
+++ b/devel/ossp-cfg/files/patch-cfg_node.c
@@ -0,0 +1,21 @@
+--- cfg_node.c.orig Sun Jul 28 07:06:03 2002
++++ cfg_node.c Mon Feb 3 15:15:27 2003
+@@ -33,6 +33,7 @@
+ #include <stdarg.h>
+ #include <unistd.h>
+ #include <limits.h>
++#include <sys/types.h>
+
+ #include "cfg_main.h"
+ #include "cfg_node.h"
+@@ -443,8 +444,9 @@
+ fprintf(stderr, "step2: child node 0x%lx\n", (unsigned long)node);
+ do {
+ if (node->token != NULL) {
++ size_t l;
+ token = node->token;
+- size_t l = strlen(token);
++ l = strlen(token);
+ fprintf(stderr, "step2: child node: \"%s\"\n", token);
+ if ( (l == 1 && l == nSel && token[0] == '*')
+ || (l == nSel && strncmp(token, cpSel, nSel) == 0)) {
diff --git a/devel/ossp-cfg/pkg-comment b/devel/ossp-cfg/pkg-comment
new file mode 100644
index 000000000000..676bb9ab341e
--- /dev/null
+++ b/devel/ossp-cfg/pkg-comment
@@ -0,0 +1 @@
+A library for parsing arbitrary C/C++-style configuration files
diff --git a/devel/ossp-cfg/pkg-descr b/devel/ossp-cfg/pkg-descr
new file mode 100644
index 000000000000..12a6e28c987d
--- /dev/null
+++ b/devel/ossp-cfg/pkg-descr
@@ -0,0 +1,9 @@
+OSSP cfg is a ISO-C library for parsing arbitrary C/C++-style configuration
+files. A configuration is sequence of directives. Each directive consists of
+zero or more tokens. Each token can be either a string or again a complete
+sequence. This means the configuration syntax has a recursive structure and
+this way allows to create configurations with arbitrarily nested sections.
+
+WWW: http://www.ossp.org/pkg/lib/cfg/
+
+-- AlanE@FreeBSD.org
diff --git a/devel/ossp-cfg/pkg-plist b/devel/ossp-cfg/pkg-plist
new file mode 100644
index 000000000000..b78b50d75f5f
--- /dev/null
+++ b/devel/ossp-cfg/pkg-plist
@@ -0,0 +1,6 @@
+bin/cfg-config
+include/cfg.h
+lib/libcfg.a
+lib/libcfg.la
+lib/libcfg.so
+lib/libcfg.so.9