aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--UPDATING24
-rw-r--r--www/Makefile1
-rw-r--r--www/files/patch-src_php__http__url.c13
-rw-r--r--www/pecl-http2/Makefile32
-rw-r--r--www/pecl-http2/distinfo2
-rw-r--r--www/pecl-http2/files/patch-src_php__http__url.c13
-rw-r--r--www/pecl-http2/pkg-descr10
7 files changed, 95 insertions, 0 deletions
diff --git a/UPDATING b/UPDATING
index 6f0f487117e2..9be0fb32827f 100644
--- a/UPDATING
+++ b/UPDATING
@@ -5,6 +5,30 @@ they are unavoidable.
You should get into the habit of checking this file for changes each time
you update your ports collection, before attempting any port upgrades.
+20160406:
+ AFFECTS: All users of www/pecl-http
+ AUTHOR: bofh
+
+ www/pecl-http has been updated to the latest 3.x stable release, which
+ supports php70+ and a new port www/pecl-http2 has been created for the
+ 2.x branch.
+
+ Should users want to continue to use version 2.x, replace www/pecl-http with
+ www/pecl-http2 as follows:
+
+ Using packages:
+
+ # pkg delete pecl-http
+ # pkg install pecl-http2
+
+ Using ports:
+
+ # portupgrade -o www/pecl-http2 www/pecl-http
+
+ OR
+
+ # portmaster -o www/pecl-http2 www/pecl-http
+
20160404:
AFFECTS: users of lang/ruby21
AUTHOR: swills@FreeBSD.org
diff --git a/www/Makefile b/www/Makefile
index 521b67c6e146..c1ae754bab9f 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1431,6 +1431,7 @@
SUBDIR += pecl-amfext
SUBDIR += pecl-http
SUBDIR += pecl-http1
+ SUBDIR += pecl-http2
SUBDIR += pecl-solr
SUBDIR += pecl-sphinx
SUBDIR += pecl-swish
diff --git a/www/files/patch-src_php__http__url.c b/www/files/patch-src_php__http__url.c
new file mode 100644
index 000000000000..428f3ac4893d
--- /dev/null
+++ b/www/files/patch-src_php__http__url.c
@@ -0,0 +1,13 @@
+--- src/php_http_url.c.orig 2016-04-05 17:53:32 UTC
++++ src/php_http_url.c
+@@ -27,6 +27,10 @@
+ # include <arpa/inet.h>
+ #endif
+
++#if defined(__FreeBSD__) || defined(__DragonFly__)
++#include <stddef.h>
++#endif
++
+ #include "php_http_utf8.h"
+
+ static inline char *localhostname(void)
diff --git a/www/pecl-http2/Makefile b/www/pecl-http2/Makefile
new file mode 100644
index 000000000000..ea0a4362a15d
--- /dev/null
+++ b/www/pecl-http2/Makefile
@@ -0,0 +1,32 @@
+# Created by: Wen Heping <wenheping@gmail.com>
+# $FreeBSD$
+
+PORTNAME= http
+PORTVERSION= 2.5.6
+CATEGORIES= www
+MASTER_SITES= http://pecl.php.net/get/
+PKGNAMEPREFIX= pecl-
+PKGNAMESUFFIX= 2
+DISTNAME= pecl_${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= bofh@FreeBSD.org
+COMMENT= Extended HTTP Support
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/php/${PHP_EXT_DIR}/raphf.so:devel/pecl-raphf \
+ ${LOCALBASE}/lib/php/${PHP_EXT_DIR}/propro.so:devel/pecl-propro \
+ re2c:devel/re2c
+RUN_DEPENDS= ${LOCALBASE}/lib/php/${PHP_EXT_DIR}/raphf.so:devel/pecl-raphf \
+ ${LOCALBASE}/lib/php/${PHP_EXT_DIR}/propro.so:devel/pecl-propro
+LIB_DEPENDS= libcurl.so:ftp/curl \
+ libevent.so:devel/libevent2
+
+IGNORE_WITH_PHP=70
+USES= tar:tgz
+USE_PHP= yes
+USE_PHPEXT= yes
+CONFLICTS= pecl-http1* pecl-http-*
+
+.include <bsd.port.mk>
diff --git a/www/pecl-http2/distinfo b/www/pecl-http2/distinfo
new file mode 100644
index 000000000000..07551bcbc9c8
--- /dev/null
+++ b/www/pecl-http2/distinfo
@@ -0,0 +1,2 @@
+SHA256 (pecl_http-2.5.6.tgz) = 8435eb9082b8fdc56b630e3d3d8e63617a3bc43d360f6f49fbd7b1856b266be4
+SIZE (pecl_http-2.5.6.tgz) = 200469
diff --git a/www/pecl-http2/files/patch-src_php__http__url.c b/www/pecl-http2/files/patch-src_php__http__url.c
new file mode 100644
index 000000000000..428f3ac4893d
--- /dev/null
+++ b/www/pecl-http2/files/patch-src_php__http__url.c
@@ -0,0 +1,13 @@
+--- src/php_http_url.c.orig 2016-04-05 17:53:32 UTC
++++ src/php_http_url.c
+@@ -27,6 +27,10 @@
+ # include <arpa/inet.h>
+ #endif
+
++#if defined(__FreeBSD__) || defined(__DragonFly__)
++#include <stddef.h>
++#endif
++
+ #include "php_http_utf8.h"
+
+ static inline char *localhostname(void)
diff --git a/www/pecl-http2/pkg-descr b/www/pecl-http2/pkg-descr
new file mode 100644
index 000000000000..172f458595f3
--- /dev/null
+++ b/www/pecl-http2/pkg-descr
@@ -0,0 +1,10 @@
+pecl-http extension aims to provide a convenient and
+powerful set of functionality for one of PHPs major
+applications. It eases handling of HTTP URLs, dates,
+redirects, headers and messages, provides means for
+negotiation of clients preferred language and charset,
+as well as a convenient way to send any arbitrary data
+with caching and resuming capabilities. It provides
+powerful request functionality too.
+
+WWW: http://pecl.php.net/package/pecl_http/