aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--security/snort/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/security/snort/Makefile b/security/snort/Makefile
index e59f13bea5e4..c35883120ecf 100644
--- a/security/snort/Makefile
+++ b/security/snort/Makefile
@@ -7,7 +7,7 @@
PORTNAME= snort
PORTVERSION= 2.8.2.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security
MASTER_SITES= http://www.snort.org/dl/current/
@@ -152,6 +152,14 @@ pre-configure:
@sleep 5
.endif
+pre-install:
+.if defined(WITH_POSTGRESQL)
+ @${REINPLACE_CMD} -e '/REQUIRE:/ s|$$| postgresql|' ${WRKDIR}/snort.sh
+.endif
+.if defined(WITH_MYSQL)
+ @${REINPLACE_CMD} -e '/REQUIRE:/ s|$$| mysql|' ${WRKDIR}/snort.sh
+.endif
+
post-install:
.if !defined(WITHOUT_DYNAMIC)
@${LIBTOOL} --finish ${LOCALBASE}/snort/dynamicpreprocessor