aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/libnotify/Makefile26
-rw-r--r--devel/libnotify/distinfo2
-rw-r--r--devel/libnotify/pkg-descr10
-rw-r--r--devel/libnotify/pkg-plist7
5 files changed, 46 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 927ca3d5c8a8..395933fc4556 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -475,6 +475,7 @@
SUBDIR += libmtrie
SUBDIR += libmusclecard
SUBDIR += libnaji
+ SUBDIR += libnotify
SUBDIR += liboil
SUBDIR += libol
SUBDIR += libole2
diff --git a/devel/libnotify/Makefile b/devel/libnotify/Makefile
new file mode 100644
index 000000000000..5a261ae9fc0c
--- /dev/null
+++ b/devel/libnotify/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: libnotify
+# Date created: 2005-08-06
+# Whom: Andreas Kohn <andreas@syndrom23.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libnotify
+PORTVERSION= 0.2.1
+CATEGORIES= devel gnome
+MASTER_SITES= http://www.galago.info/files/releases/source/
+
+MAINTAINER= andreas@syndrom23.de
+COMMENT= A library for desktop notifications
+
+LIB_DEPENDS= dbus-1.1:${PORTSDIR}/devel/dbus \
+ popt.0:${PORTSDIR}/devel/popt
+
+USE_GNOME= gnomehack gnomeprefix gnometarget intlhack glib20
+USE_GMAKE= yes
+USE_LIBTOOL_VER=15
+INSTALLS_SHLIB= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+.include <bsd.port.mk>
diff --git a/devel/libnotify/distinfo b/devel/libnotify/distinfo
new file mode 100644
index 000000000000..7159993c1ab8
--- /dev/null
+++ b/devel/libnotify/distinfo
@@ -0,0 +1,2 @@
+MD5 (libnotify-0.2.1.tar.gz) = 8c66c7ece5a6387d2391f9c2f5beb1ce
+SIZE (libnotify-0.2.1.tar.gz) = 316429
diff --git a/devel/libnotify/pkg-descr b/devel/libnotify/pkg-descr
new file mode 100644
index 000000000000..b87106285cfb
--- /dev/null
+++ b/devel/libnotify/pkg-descr
@@ -0,0 +1,10 @@
+The Desktop Notifications framework provides a standard way of doing passive
+pop-up notifications on the desktop. These are designed to notify the
+user of something without interrupting their work with a dialog box that they
+must close. Passive popups can automatically disappear after a short period
+of time.
+
+This port contains the only library and a small command line client.
+See deskutils/notification-daemon for the daemon.
+
+WWW: http://www.galago.info/specs/notification/index.php
diff --git a/devel/libnotify/pkg-plist b/devel/libnotify/pkg-plist
new file mode 100644
index 000000000000..5726126cdcd4
--- /dev/null
+++ b/devel/libnotify/pkg-plist
@@ -0,0 +1,7 @@
+bin/notify-send
+include/libnotify/notify.h
+lib/libnotify.a
+lib/libnotify.so
+lib/libnotify.so.0
+libdata/pkgconfig/libnotify.pc
+@dirrm include/libnotify