aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--UPDATING28
-rw-r--r--security/libressl/Makefile10
-rw-r--r--security/libressl/distinfo6
-rw-r--r--security/libressl/files/patch-include_openssl_opensslv.h11
-rw-r--r--security/libressl/pkg-plist12
-rw-r--r--security/libressl/version.mk2
6 files changed, 43 insertions, 26 deletions
diff --git a/UPDATING b/UPDATING
index 15a9625fb9ab..47a515f0657a 100644
--- a/UPDATING
+++ b/UPDATING
@@ -6,6 +6,34 @@ You should get into the habit of checking this file for changes each time
you update your ports collection, before attempting any port upgrades.
20160811:
+ AFFECTS: users of security/libressl
+ AUTHOR: brnrd@FreeBSD.org
+
+ The port has been updated to the latest stable version 2.4 of LibreSSL.
+ The shared library versions of the libraries have been bumped.
+ With this update, the patch for the OPENSSL_VERSION_NUMBER has been
+ removed. This causes issues with a number of ports. Patches for all
+ ports for which this issues is known can be found on
+ https://wiki.freebsd.org/LibreSSL/Ports#OPENSSL_VERSION_NUMBER
+
+ After upgrading, manually update all packages that depend on any of the
+ libraries provided by LibreSSL (libssl, libcrypto and libtls) since the
+ versions of these libraries have changed. Normally, you can obtain the
+ list of dependent software by running the following command:
+
+ # pkg info -r libressl
+
+ Then you should rebuild all ports depending on libressl to avoid dangling
+ shared library dependencies. Poudriere and pkg handle this correctly,
+ portmaster and portupgrade users can use the following to rebuild all
+ dependent ports.
+
+ Portmaster users:
+ portmaster -r libressl
+ Portupgrade users:
+ portupgrade -fr security/libressl
+
+20160811:
AFFECTS: users of databases/postgresqlNN-server with ICU patch
AUTHOR: girgen@FreeBSD.org
diff --git a/security/libressl/Makefile b/security/libressl/Makefile
index 3e8db7c335b2..b7866a4fe921 100644
--- a/security/libressl/Makefile
+++ b/security/libressl/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= libressl
-PORTVERSION= 2.3.7
+PORTVERSION= 2.4.2
CATEGORIES= security devel
MASTER_SITES= OPENBSD/LibreSSL
@@ -32,15 +32,15 @@ CFLAGS+= -fpic -DPIC
INSTALL_TARGET= install-strip
TEST_TARGET= check
-post-install-NC-on:
+post-stage-NC-on:
${INSTALL_PROGRAM} ${WRKSRC}/apps/nc/.libs/nc ${STAGEDIR}/${PREFIX}/bin/nc
${INSTALL_MAN} ${WRKSRC}/apps/nc/nc.1 ${STAGEDIR}/${PREFIX}/man/man1/nc.1
+post-stage:
+ ${RM} -rf ${STAGEDIR}/${PREFIX}/etc/ssl/cert.pem
+
post-install-MAN3-off:
${RM} -rf ${STAGEDIR}/${PREFIX}/man/man3
${REINPLACE_CMD} -e '/^man\/man3/d' ${TMPPLIST}
-post-install:
- ${RM} -rf ${STAGEDIR}/${PREFIX}/etc/ssl/cert.pem
-
.include <bsd.port.mk>
diff --git a/security/libressl/distinfo b/security/libressl/distinfo
index e0774fb742a5..ce36b22cc659 100644
--- a/security/libressl/distinfo
+++ b/security/libressl/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1470249537
-SHA256 (libressl-2.3.7.tar.gz) = f59f5d859ce4867cc4761a13d02024f699491e277d54a9fe76e053e5b5f70860
-SIZE (libressl-2.3.7.tar.gz) = 3013807
+TIMESTAMP = 1470249624
+SHA256 (libressl-2.4.2.tar.gz) = 5f87d778e5d62822d60e38fa9621c1c5648fc559d198ba314bd9d89cbf67d9e3
+SIZE (libressl-2.4.2.tar.gz) = 3021644
diff --git a/security/libressl/files/patch-include_openssl_opensslv.h b/security/libressl/files/patch-include_openssl_opensslv.h
deleted file mode 100644
index 43a61234fa76..000000000000
--- a/security/libressl/files/patch-include_openssl_opensslv.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- include/openssl/opensslv.h.orig 2015-07-26 14:58:42 UTC
-+++ include/openssl/opensslv.h
-@@ -7,7 +7,7 @@
- #define LIBRESSL_VERSION_TEXT "LibreSSL 2.2.2"
-
- /* These will never change */
--#define OPENSSL_VERSION_NUMBER 0x20000000L
-+#define OPENSSL_VERSION_NUMBER 0x1000107fL
- #define OPENSSL_VERSION_TEXT LIBRESSL_VERSION_TEXT
- #define OPENSSL_VERSION_PTEXT " part of " OPENSSL_VERSION_TEXT
-
diff --git a/security/libressl/pkg-plist b/security/libressl/pkg-plist
index 72fc52638a78..fa6697415566 100644
--- a/security/libressl/pkg-plist
+++ b/security/libressl/pkg-plist
@@ -75,16 +75,16 @@ include/openssl/x509v3.h
include/tls.h
lib/libcrypto.a
lib/libcrypto.so
-lib/libcrypto.so.37
-lib/libcrypto.so.37.0.0
+lib/libcrypto.so.38
+lib/libcrypto.so.38.0.0
lib/libssl.a
lib/libssl.so
-lib/libssl.so.38
-lib/libssl.so.38.0.0
+lib/libssl.so.39
+lib/libssl.so.39.0.0
lib/libtls.a
lib/libtls.so
-lib/libtls.so.10
-lib/libtls.so.10.0.0
+lib/libtls.so.11
+lib/libtls.so.11.0.0
libdata/pkgconfig/libcrypto.pc
libdata/pkgconfig/libssl.pc
libdata/pkgconfig/libtls.pc
diff --git a/security/libressl/version.mk b/security/libressl/version.mk
index d71bc8fc0462..2457aac23c3a 100644
--- a/security/libressl/version.mk
+++ b/security/libressl/version.mk
@@ -1 +1 @@
-OPENSSL_SHLIBVER?= 37
+OPENSSL_SHLIBVER?= 38