aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--mail/mutt-devel/Makefile3
-rw-r--r--mail/mutt/Makefile3
-rw-r--r--mail/mutt14/Makefile3
3 files changed, 6 insertions, 3 deletions
diff --git a/mail/mutt-devel/Makefile b/mail/mutt-devel/Makefile
index 4f9ca483d7a7..e74a18b54f67 100644
--- a/mail/mutt-devel/Makefile
+++ b/mail/mutt-devel/Makefile
@@ -94,7 +94,8 @@ MAINTAINER?= udo.schweigert@siemens.com
COMMENT?= The Mongrel of Mail User Agents (part Elm, Pine, Mush, mh, etc.)
DIST_SUBDIR= mutt
-CONFIGURE_ENV= CC="${CC} -I${LOCALBASE}/include" LDFLAGS=-L${LOCALBASE}/lib
+LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ENV= CC="${CC} -I${LOCALBASE}/include" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --enable-flock --disable-fcntl --with-ssl=${OPENSSLBASE} \
--with-sharedir=${PREFIX}/share/mutt \
--with-docdir=${PREFIX}/share/doc/mutt \
diff --git a/mail/mutt/Makefile b/mail/mutt/Makefile
index 23815be5e0d9..b4aebd8aa3bb 100644
--- a/mail/mutt/Makefile
+++ b/mail/mutt/Makefile
@@ -63,7 +63,8 @@ GNU_CONFIGURE= yes
USE_AUTOMAKE= yes # configure.in is patched by <PATCHFILES>
USE_REINPLACE= yes
CONFIGURE_TARGET=${ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ENV= CC="${CC} -I${LOCALBASE}/include" LDFLAGS=-L${LOCALBASE}/lib
+LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ENV= CC="${CC} -I${LOCALBASE}/include" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --enable-pop --enable-imap --enable-flock --disable-fcntl \
--with-ssl=${OPENSSLBASE} --sysconfdir=${PREFIX}/etc \
--with-sharedir=${PREFIX}/share/mutt \
diff --git a/mail/mutt14/Makefile b/mail/mutt14/Makefile
index 23815be5e0d9..b4aebd8aa3bb 100644
--- a/mail/mutt14/Makefile
+++ b/mail/mutt14/Makefile
@@ -63,7 +63,8 @@ GNU_CONFIGURE= yes
USE_AUTOMAKE= yes # configure.in is patched by <PATCHFILES>
USE_REINPLACE= yes
CONFIGURE_TARGET=${ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ENV= CC="${CC} -I${LOCALBASE}/include" LDFLAGS=-L${LOCALBASE}/lib
+LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ENV= CC="${CC} -I${LOCALBASE}/include" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --enable-pop --enable-imap --enable-flock --disable-fcntl \
--with-ssl=${OPENSSLBASE} --sysconfdir=${PREFIX}/etc \
--with-sharedir=${PREFIX}/share/mutt \