aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-fm/emelfm2/Makefile6
-rw-r--r--x11-fm/pcmanfm/Makefile4
-rw-r--r--x11-toolkits/gal2/Makefile6
-rw-r--r--x11-toolkits/gtkmathview/Makefile8
-rw-r--r--x11-toolkits/libgdiplus/Makefile4
-rw-r--r--x11-toolkits/ruby-wx/Makefile4
-rw-r--r--x11-toolkits/vdk/Makefile8
-rw-r--r--x11-toolkits/xscoop/Makefile8
-rw-r--r--x11-wm/ctwm/Makefile7
-rw-r--r--x11-wm/epplets/Makefile4
10 files changed, 3 insertions, 56 deletions
diff --git a/x11-fm/emelfm2/Makefile b/x11-fm/emelfm2/Makefile
index 8449bf5611ff..b0efad453d25 100644
--- a/x11-fm/emelfm2/Makefile
+++ b/x11-fm/emelfm2/Makefile
@@ -86,12 +86,6 @@ MAKE_ENV+= WITH_HAL=1
LIB_DEPENDS+= hal.1:${PORTSDIR}/sysutils/hal
.endif
-.if ${OSVERSION} < 600000
-post-patch:
- @${REINPLACE_CMD} -e 's|blksize_t buf_size =|__int32_t buf_size =|g' \
- ${WRKSRC}/src/filesystem/e2_fs.c
-.endif
-
.if !defined(NOPORTDOCS)
post-install:
@${MKDIR} ${DOCSDIR}
diff --git a/x11-fm/pcmanfm/Makefile b/x11-fm/pcmanfm/Makefile
index 76521bc3cab1..a6bc976a34ae 100644
--- a/x11-fm/pcmanfm/Makefile
+++ b/x11-fm/pcmanfm/Makefile
@@ -33,10 +33,6 @@ OPTIONS= NLS "Native Language Support (devel/gettext)" on
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 600000
-IGNORE= FreeBSD < 6 does not have blkcnt_t in stat.h
-.endif
-
#.if !defined(WITHOUT_HAL)
#LIB_DEPENDS+= hal.1:${PORTSDIR}/sysutils/hal \
# dbus-1.3:${PORTSDIR}/devel/dbus
diff --git a/x11-toolkits/gal2/Makefile b/x11-toolkits/gal2/Makefile
index a8886331c62a..7adc4706dd12 100644
--- a/x11-toolkits/gal2/Makefile
+++ b/x11-toolkits/gal2/Makefile
@@ -44,12 +44,6 @@ post-extract:
post-patch:
@${REINPLACE_CMD} -e '/^SUBDIRS/ s|docs||' ${WRKSRC}/Makefile.in
-.if ( ${OSVERSION} > 600000 && ${OSVERSION} < 600006 ) || \
- ( ${OSVERSION} < 503101 )
-.for po in da.po it.po zh_CN.po
- @${REINPLACE_CMD} -e 's|%-|%|g' ${WRKSRC}/po/${po}
-.endfor
-.endif
.include <bsd.port.post.mk>
diff --git a/x11-toolkits/gtkmathview/Makefile b/x11-toolkits/gtkmathview/Makefile
index 10a03417e879..9141876a76f9 100644
--- a/x11-toolkits/gtkmathview/Makefile
+++ b/x11-toolkits/gtkmathview/Makefile
@@ -32,10 +32,4 @@ USE_LDCONFIG= yes
MAN1= mathmlviewer.1
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 600000
-IGNORE= is unsupported on versions prior to FreeBSD 6.0
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/x11-toolkits/libgdiplus/Makefile b/x11-toolkits/libgdiplus/Makefile
index 7a7b71c72f6a..e17062559ffe 100644
--- a/x11-toolkits/libgdiplus/Makefile
+++ b/x11-toolkits/libgdiplus/Makefile
@@ -41,9 +41,5 @@ CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
CFLAGS+= -fPIC
.endif
-.if ${OSVERSION} < 503000
-IGNORE= does not build and is useless without working Mono
-.endif
-
.include "${.CURDIR}/../../lang/mono/bsd.mono.mk"
.include <bsd.port.post.mk>
diff --git a/x11-toolkits/ruby-wx/Makefile b/x11-toolkits/ruby-wx/Makefile
index aac50ec186c8..080a9a652315 100644
--- a/x11-toolkits/ruby-wx/Makefile
+++ b/x11-toolkits/ruby-wx/Makefile
@@ -26,10 +26,6 @@ WX_COMPS= contrib
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500035
-BROKEN= "Cannot link: undefined versioned symbol name"
-.endif
-
WRKSRC= ${WRKDIR}/${DISTNAME}/src
DOCS= README README.linux ChangeLog
diff --git a/x11-toolkits/vdk/Makefile b/x11-toolkits/vdk/Makefile
index bb827a14f545..1acd234a23ab 100644
--- a/x11-toolkits/vdk/Makefile
+++ b/x11-toolkits/vdk/Makefile
@@ -29,12 +29,6 @@ LDFLAGS= -L${LOCALBASE}/lib -lgnuregex ${PTHREAD_LIBS}
.include <bsd.port.pre.mk>
-.if ${OSVERSION} > 502010
-GNU_REGEX_H= gnu/regex.h
-.else
-GNU_REGEX_H= gnuregex.h
-.endif
-
post-patch:
@${REINPLACE_CMD} -e \
's|CXXFLAGS="-s"|CXXFLAGS="$$CXXFLAGS"|g' ${WRKSRC}/configure
@@ -42,7 +36,7 @@ post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${LDFLAGS}|g' ${WRKSRC}/${file}
.endfor
.for file in vdk/FileDialog.h vdk/gtksourcebuffer.h vdk/gtksourcetag.h
- @${REINPLACE_CMD} -e 's|<regex\.h>|<${GNU_REGEX_H}>|g' ${WRKSRC}/${file}
+ @${REINPLACE_CMD} -e 's|<regex\.h>|<gnu/regex.h>|g' ${WRKSRC}/${file}
.endfor
@${REINPLACE_CMD} -e \
's|VDKComboEntry::||g' ${WRKSRC}/vdk/vdkcomboentry.h
diff --git a/x11-toolkits/xscoop/Makefile b/x11-toolkits/xscoop/Makefile
index 4e44cbd8daf0..e88f7569e4d5 100644
--- a/x11-toolkits/xscoop/Makefile
+++ b/x11-toolkits/xscoop/Makefile
@@ -24,14 +24,8 @@ ONLY_FOR_ARCHS= i386
.include <bsd.port.pre.mk>
-.if ${OSVERSION}>=600000
-EXEFILE= xscoop6
-.else
-EXEFILE= xscoop5
-.endif
-
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${EXEFILE} ${PREFIX}/bin/xscoop
+ ${INSTALL_PROGRAM} ${WRKSRC}/xscoop6 ${PREFIX}/bin/xscoop
${INSTALL_MAN} ${WRKSRC}/xscoop.7 ${MAN7PREFIX}/man/man7/xscoop.7
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/xscoop.pdf ${DOCSDIR}/xscoop.pdf
diff --git a/x11-wm/ctwm/Makefile b/x11-wm/ctwm/Makefile
index 54948df5a21c..ddd0ee763dcc 100644
--- a/x11-wm/ctwm/Makefile
+++ b/x11-wm/ctwm/Makefile
@@ -23,13 +23,6 @@ MAN1= ctwm.1
.include <bsd.port.pre.mk>
-# Very old versions need GNU m4
-.if ( ${OSVERSION} < 500034 )
-EXTRA_PATCHES+= ${FILESDIR}/gm4-patch
-BUILD_DEPENDS+= gm4:${PORTSDIR}/devel/m4
-RUN_DEPENDS+= gm4:${PORTSDIR}/devel/m4
-.endif
-
pre-configure:
${CP} ${WRKSRC}/Imakefile.local-template ${WRKSRC}/Imakefile.local
${CAT} ${FILESDIR}/Imakefile.local-additional >> ${WRKSRC}/Imakefile.local
diff --git a/x11-wm/epplets/Makefile b/x11-wm/epplets/Makefile
index 5d0e03db5c12..86c7b324c025 100644
--- a/x11-wm/epplets/Makefile
+++ b/x11-wm/epplets/Makefile
@@ -32,10 +32,6 @@ CONFIGURE_ARGS= --disable-auto-respawn
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 600000
-BROKEN= Does not compile on 5.x
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|2.61|2.62|g' ${WRKSRC}/aclocal.m4
@${REINPLACE_CMD} -e 's|<machine/soundcard\.h>|<sys/soundcard.h>|g' \