aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--astro/gpsd/Makefile2
-rw-r--r--astro/gpsd/files/patch-gpspipe.c10
2 files changed, 12 insertions, 0 deletions
diff --git a/astro/gpsd/Makefile b/astro/gpsd/Makefile
index e1713a73b99c..c7ffa3080e57 100644
--- a/astro/gpsd/Makefile
+++ b/astro/gpsd/Makefile
@@ -14,6 +14,8 @@ MAINTAINER= toxa@toxahost.ru
COMMENT= Daemon that monitors one or more GPSes attached to a host computer
GNU_CONFIGURE= yes
+CONFIGURE_ENV= CFLAGS="${CFLAGS} ${PTHREAD_CFLAGS}" \
+ LDFLAGS="${LDFLAGS} ${PTHREAD_LIBS}"
MAN1= gpsfake.1 gpsflash.1 gpspipe.1 gpsprof.1 rtcmdecode.1 sirfmon.1 xgps.1
MAN3= libgps.3 libgpsd.3 libgpsmm.3
MAN5= rtcm-104.5 srec.5
diff --git a/astro/gpsd/files/patch-gpspipe.c b/astro/gpsd/files/patch-gpspipe.c
new file mode 100644
index 000000000000..8cce28b6b75b
--- /dev/null
+++ b/astro/gpsd/files/patch-gpspipe.c
@@ -0,0 +1,10 @@
+--- gpspipe.c.orig Mon Jan 30 16:04:07 2006
++++ gpspipe.c Mon Jan 30 16:04:56 2006
+@@ -26,6 +26,7 @@
+
+ #include <errno.h>
+ #include <stdio.h>
++#include <sys/types.h>
+ #include <sys/socket.h>
+ #include <unistd.h>
+ #include <string.h>