aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--emulators/snes9x/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/emulators/snes9x/Makefile b/emulators/snes9x/Makefile
index 48daf1806b1a..64f05b80f197 100644
--- a/emulators/snes9x/Makefile
+++ b/emulators/snes9x/Makefile
@@ -74,6 +74,9 @@ CONFIGURE_ARGS+= --without-mmx
.if defined(WITH_OPENGL)
USE_GL= yes
CONFIGURE_ARGS+= --with-opengl
+SNES9X_BIN= osnes9x
+.else
+SNES9X_BIN= snes9x
.endif
.if !defined(WITHOUT_SCREENSHOT)
@@ -107,7 +110,7 @@ do-install:
.endfor
${INSTALL_DATA} ${WRKSRC}/unix/docs/readme_unix.txt ${DOCSDIR}/README
.endif
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/${SNES9X_BIN} ${PREFIX}/bin/${PORTNAME}
post-install:
@${CAT} ${PKGMESSAGE}