aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--archivers/rpm4/Makefile4
-rw-r--r--audio/pianod2/Makefile3
-rw-r--r--databases/cassandra3/Makefile11
-rw-r--r--databases/couchdb2/Makefile6
-rw-r--r--databases/tarantool/Makefile4
-rw-r--r--devel/etl/Makefile5
-rw-r--r--devel/libappindicator/Makefile6
-rw-r--r--devel/libappindicator/files/extra-patch-bindings_vala_examples_Makefile.am11
-rw-r--r--devel/synfig/Makefile4
-rw-r--r--devel/zziplib/Makefile4
-rw-r--r--dns/knot2/Makefile6
-rw-r--r--graphics/ftgl/files/patch-configure11
-rw-r--r--graphics/synfigstudio/Makefile6
-rw-r--r--java/openjdk11/Makefile7
-rw-r--r--java/openjdk12/Makefile7
-rw-r--r--java/openjdk13/Makefile7
-rw-r--r--math/p5-NetCDF/files/patch-port_master.mk.in16
-rw-r--r--multimedia/vlc/Makefile6
-rw-r--r--net-mgmt/docsis/files/patch-doc_generate-settings.sh20
-rw-r--r--print/pdflib/Makefile5
-rw-r--r--print/pdflib/files/patch-configure4
-rw-r--r--security/amavisd-new/Makefile5
-rw-r--r--sysutils/cinnamon-control-center/Makefile6
-rw-r--r--sysutils/cinnamon-settings-daemon/Makefile6
-rw-r--r--sysutils/conky/Makefile8
-rw-r--r--sysutils/minipro/Makefile4
-rw-r--r--textproc/sphinxsearch/Makefile5
-rw-r--r--x11/evilvte/Makefile5
28 files changed, 140 insertions, 52 deletions
diff --git a/archivers/rpm4/Makefile b/archivers/rpm4/Makefile
index 356359505bab..7e79f3dcc08a 100644
--- a/archivers/rpm4/Makefile
+++ b/archivers/rpm4/Makefile
@@ -3,7 +3,7 @@
PORTNAME= rpm
PORTVERSION= 4.15.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= archivers
MASTER_SITES= http://ftp.rpm.org/releases/rpm-4.15.x/
PKGNAMESUFFIX= 4
@@ -14,6 +14,7 @@ COMMENT= Red Hat Package Manager
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
+BUILD_DEPENDS= gsed:textproc/gsed
LIB_DEPENDS= libpopt.so:devel/popt \
libnss3.so:security/nss \
libzstd.so:archivers/zstd
@@ -25,6 +26,7 @@ USES= alias bdb compiler:openmp gmake iconv libarchive libtool \
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
+BINARY_ALIAS= sed=${LOCALBASE}/bin/gsed
SHEBANG_FILES= scripts/brp-python-bytecompile scripts/check-prereqs \
scripts/check-rpaths-worker scripts/pythondeps.sh \
scripts/pkgconfigdeps.sh scripts/fontconfig.prov \
diff --git a/audio/pianod2/Makefile b/audio/pianod2/Makefile
index 8ca3a6fd7d23..8dae8e766320 100644
--- a/audio/pianod2/Makefile
+++ b/audio/pianod2/Makefile
@@ -3,6 +3,7 @@
PORTNAME= pianod2
PORTVERSION= 329
+PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= http://deviousfish.com/Downloads/pianod2/Devel/
@@ -14,6 +15,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
BROKEN_i386= fails to build
+BUILD_DEPENDS= gsed:textproc/gsed
LIB_DEPENDS= libao.so:audio/libao \
libavcodec.so:multimedia/ffmpeg \
libgcrypt.so:security/libgcrypt \
@@ -38,6 +40,7 @@ GNU_CONFIGURE= yes
SHEBANG_FILES= contrib/piano contrib/runmix
ksh_CMD= ${LOCALBASE}/bin/mksh
+BINARY_ALIAS= sed=${LOCALBASE}/bin/gsed
CONFIGURE_ARGS= --with-compression \
--with-accesscontrol \
--with-engine=gstreamer \
diff --git a/databases/cassandra3/Makefile b/databases/cassandra3/Makefile
index 245f66f367a0..35ea15e5993f 100644
--- a/databases/cassandra3/Makefile
+++ b/databases/cassandra3/Makefile
@@ -2,6 +2,7 @@
PORTNAME= cassandra
DISTVERSION= 3.11.6
+PORTREVISION= 1
CATEGORIES= databases java
MASTER_SITES= APACHE/cassandra/${PORTVERSION}:apache \
LOCAL/yuri:repo
@@ -88,11 +89,11 @@ post-build:
.for f in ${SCRIPT_FILES}
@${REINPLACE_CMD} -e 's|/usr/share/cassandra|${DATADIR}/bin|' ${DIST_DIR}/bin/${f}
.endfor
- @${REINPLACE_CMD} -e 's|\`dirname "\$$\0"\`/..|${DATADIR}|' ${DIST_DIR}/bin/cassandra.in.sh
- @${REINPLACE_CMD} -e 's|\$$\CASSANDRA_HOME/lib/sigar-bin|${JAVAJARDIR}|' ${DIST_DIR}/bin/cassandra.in.sh
- @${REINPLACE_CMD} -e 's|\$$\CASSANDRA_HOME/lib/sigar-bin|${JAVAJARDIR}|' ${DIST_DIR}/conf/cassandra-env.sh
- @${REINPLACE_CMD} -e 's|\$$\CASSANDRA_HOME/conf|${ETCDIR}|' ${DIST_DIR}/bin/cassandra.in.sh
- @${REINPLACE_CMD} -e 's|\$$\CASSANDRA_HOME/conf|${ETCDIR}|' ${DIST_DIR}/conf/cassandra-env.sh
+ @${REINPLACE_CMD} -e 's|`dirname "$$0"`/..|${DATADIR}|' ${DIST_DIR}/bin/cassandra.in.sh
+ @${REINPLACE_CMD} -e 's|$$CASSANDRA_HOME/lib/sigar-bin|${JAVAJARDIR}|' ${DIST_DIR}/bin/cassandra.in.sh
+ @${REINPLACE_CMD} -e 's|$$CASSANDRA_HOME/lib/sigar-bin|${JAVAJARDIR}|' ${DIST_DIR}/conf/cassandra-env.sh
+ @${REINPLACE_CMD} -e 's|$$CASSANDRA_HOME/conf|${ETCDIR}|' ${DIST_DIR}/bin/cassandra.in.sh
+ @${REINPLACE_CMD} -e 's|$$CASSANDRA_HOME/conf|${ETCDIR}|' ${DIST_DIR}/conf/cassandra-env.sh
.for f in ${CONFIG_FILES}
@${MV} ${DIST_DIR}/conf/${f} ${DIST_DIR}/conf/${f}.sample
.endfor
diff --git a/databases/couchdb2/Makefile b/databases/couchdb2/Makefile
index 46a9be5cdb6b..e62e2c28c711 100644
--- a/databases/couchdb2/Makefile
+++ b/databases/couchdb2/Makefile
@@ -3,7 +3,7 @@
PORTNAME= couchdb2
DISTVERSION= 2.3.1
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= databases
MASTER_SITES= APACHE/couchdb/source/${DISTVERSION}
DISTNAME= apache-couchdb-${DISTVERSION}
@@ -60,8 +60,8 @@ post-patch:
-e 's,%%LOCALBASE%%,${LOCALBASE},g' \
-e 's,%%PORTNAME%%,${PORTNAME},g' \
-e 's,%%WWWDIR%%,${WWWDIR},g' \
- -e 's,\$COUCHDB_USER,${USERS},g' \
- -e 's,\$LOG_FILE,${LOGFILE},g' \
+ -e 's,$$COUCHDB_USER,${USERS},g' \
+ -e 's,$$LOG_FILE,${LOGFILE},g' \
${WRKSRC}/configure
pre-install:
diff --git a/databases/tarantool/Makefile b/databases/tarantool/Makefile
index 5870c0f3a081..062234e4d073 100644
--- a/databases/tarantool/Makefile
+++ b/databases/tarantool/Makefile
@@ -3,7 +3,7 @@
PORTNAME= tarantool
PORTVERSION= 2.3.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= databases
MAINTAINER= sunpoet@FreeBSD.org
@@ -15,6 +15,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
NOT_FOR_ARCHS= armv6 powerpc64 sparc64
NOT_FOR_ARCHS_REASON= fails to build: Unsupported architecture
+BUILD_DEPENDS= gsed:textproc/gsed
LIB_DEPENDS= libcurl.so:ftp/curl \
libicui18n.so:devel/icu \
libmsgpuck.so:devel/msgpuck \
@@ -24,6 +25,7 @@ LIB_DEPENDS= libcurl.so:ftp/curl \
USES= cmake:noninja compiler:c++11-lang gettext-runtime gmake iconv perl5 readline ssl
USE_PERL5= build
+BINARY_ALIAS= sed=${LOCALBASE}/bin/gsed
CMAKE_ARGS= -DCMAKE_INSTALL_FULL_SYSCONFDIR=${ETCDIR} \
-DCMAKE_INSTALL_LOCALSTATEDIR=/var \
-DCMAKE_INSTALL_MANDIR=${PREFIX}/man
diff --git a/devel/etl/Makefile b/devel/etl/Makefile
index 3984c886bccc..6a1d25d97aa3 100644
--- a/devel/etl/Makefile
+++ b/devel/etl/Makefile
@@ -4,6 +4,7 @@
PORTNAME= etl
PORTVERSION= 1.2.2
DISTVERSIONPREFIX=v
+PORTREVISION= 1
CATEGORIES= devel lang
MAINTAINER= woodsb02@FreeBSD.org
@@ -11,6 +12,8 @@ COMMENT= Voria Extended Class and Template Library
LICENSE= GPLv2+
+BUILD_DEPENDS= gsed:textproc/gsed
+
NO_ARCH= yes
PORTSCOUT= limitw:1,even
@@ -23,6 +26,8 @@ WRKSRC_SUBDIR= ETL
OPTIONS_DEFINE= DOCS
+BINARY_ALIAS= sed=${LOCALBASE}/bin/gsed
+
post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
.for doc in AUTHORS NEWS README
diff --git a/devel/libappindicator/Makefile b/devel/libappindicator/Makefile
index 0e1ddd73bcef..cdcc725c4950 100644
--- a/devel/libappindicator/Makefile
+++ b/devel/libappindicator/Makefile
@@ -2,6 +2,7 @@
PORTNAME= libappindicator
PORTVERSION= ${MAJOR_VER}.${SNAPSHOT_VER:S/.//g}.${PATCH_VER:S/ubuntu//}
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= http://archive.ubuntu.com/ubuntu/pool/main/liba/${PORTNAME}/
DISTNAME= ${PORTNAME}_${MAJOR_VER}+${SNAPSHOT_VER}.orig
@@ -17,7 +18,8 @@ LICENSE= LGPL21+
LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= gnome-autogen.sh:devel/gnome-common \
- gtkdocize:textproc/gtk-doc
+ gtkdocize:textproc/gtk-doc \
+ gsed:textproc/gsed
LIB_DEPENDS= libdbus-glib-1.so:devel/dbus-glib \
libdbusmenu-gtk3.so:devel/libdbusmenu
@@ -32,7 +34,6 @@ OPTIONS_SUB= yes
VAPI_BUILD_DEPENDS= vala>=0:lang/vala
VAPI_CONFIGURE_ENV_OFF= ac_cv_path_VALA_API_GEN= \
ac_cv_path_VALAC=
-VAPI_VARS= EXTRA_PATCHES+=${PATCHDIR}/extra-patch-bindings_vala_examples_Makefile.am
NO_WRKSUBDIR= yes
@@ -40,6 +41,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-gtk-doc \
--with-gtk=3
INSTALL_TARGET= install-strip
+CONFIGURE_ENV+= ac_cv_path_SED=${LOCALBASE}/bin/gsed
MAJOR_VER= 12.10.1
SNAPSHOT_VER= 18.04.20180322.1
diff --git a/devel/libappindicator/files/extra-patch-bindings_vala_examples_Makefile.am b/devel/libappindicator/files/extra-patch-bindings_vala_examples_Makefile.am
index cfa213214b73..e69de29bb2d1 100644
--- a/devel/libappindicator/files/extra-patch-bindings_vala_examples_Makefile.am
+++ b/devel/libappindicator/files/extra-patch-bindings_vala_examples_Makefile.am
@@ -1,11 +0,0 @@
---- bindings/vala/examples/Makefile.am.orig 2018-03-22 01:15:43 UTC
-+++ bindings/vala/examples/Makefile.am
-@@ -18,7 +18,7 @@ BUILT_SOURCES = indicator-example.c
-
- indicator-example.c: $(VALAFILES) Makefile.am
- $(VALAC) $(VALAFLAGS) -C $< -o $@
-- $(SED) -i "s|#include\s*<\s*libappindicator/app-indicator.h\s*>||g" $@
-+ $(SED) -i '' "s|#include\s*<\s*libappindicator/app-indicator.h\s*>||g" $@
-
- nodist_indicator_example_SOURCES = indicator-example.c
- indicator_example_CFLAGS = \
diff --git a/devel/synfig/Makefile b/devel/synfig/Makefile
index 8a71d6045fc2..e6b8addeb939 100644
--- a/devel/synfig/Makefile
+++ b/devel/synfig/Makefile
@@ -4,7 +4,7 @@
PORTNAME= synfig
PORTVERSION= 1.2.2
DISTVERSIONPREFIX=v
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= devel graphics multimedia
MAINTAINER= woodsb02@FreeBSD.org
@@ -39,6 +39,8 @@ USE_GNOME= cairo glibmm intltool libxml++26 pango
GNU_CONFIGURE= yes
CONFIGURE_ARGS= ${ICONV_CONFIGURE_ARG}
CONFIGURE_ENV+= ac_cv_path_SED=${LOCALBASE}/bin/gsed
+# Other spurious uses of direct sed have popped up
+BINARY_ALIAS= sed=${LOCALBASE}/bin/gsed
INSTALL_TARGET= install-strip
USE_LDCONFIG= yes
WRKSRC_SUBDIR= synfig-core
diff --git a/devel/zziplib/Makefile b/devel/zziplib/Makefile
index dc9fc04f3b11..8df5dea67c2b 100644
--- a/devel/zziplib/Makefile
+++ b/devel/zziplib/Makefile
@@ -4,6 +4,7 @@
PORTNAME= zziplib
DISTVERSIONPREFIX= v
PORTVERSION= 0.13.71
+PORTREVISION= 1
CATEGORIES= devel
MAINTAINER= sunpoet@FreeBSD.org
@@ -14,7 +15,8 @@ LICENSE_COMB= dual
LICENSE_FILE_LGPL21= ${WRKSRC}/COPYING.LIB
LICENSE_FILE_MPL11= ${WRKSRC}/docs/COPYING.MPL
-BUILD_DEPENDS= zip:archivers/zip
+BUILD_DEPENDS= gsed:textproc/gsed \
+ zip:archivers/zip
USES= libtool pathfix pkgconfig
diff --git a/dns/knot2/Makefile b/dns/knot2/Makefile
index dcaafc548911..57ffe284df0a 100644
--- a/dns/knot2/Makefile
+++ b/dns/knot2/Makefile
@@ -3,7 +3,7 @@
PORTNAME= knot
DISTVERSION= 2.9.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= dns
MASTER_SITES= https://secure.nic.cz/files/knot-dns/ \
https://dns.company/downloads/knot-dns/
@@ -17,7 +17,8 @@ LICENSE_FILE= ${WRKSRC}/COPYING
CONFLICTS= knot-1.* knot1-[0-6].*
-BUILD_DEPENDS= autoconf>=2.65:devel/autoconf
+BUILD_DEPENDS= autoconf>=2.65:devel/autoconf \
+ gsed:textproc/gsed
LIB_DEPENDS= libgnutls.so:security/gnutls \
liblmdb.so:databases/lmdb
@@ -25,6 +26,7 @@ LIB_DEPENDS= libgnutls.so:security/gnutls \
USES= alias libtool localbase pkgconfig tar:xz
HAS_CONFIGURE= yes
+BINARY_ALIAS= sed=${LOCALBASE}/bin/gsed
CONFIGURE_ARGS= --enable-recvmmsg=no \
--with-pkgconfigdir=${PREFIX}/libdata/pkgconfig \
--mandir=${MANPREFIX}/man
diff --git a/graphics/ftgl/files/patch-configure b/graphics/ftgl/files/patch-configure
new file mode 100644
index 000000000000..450a02f34335
--- /dev/null
+++ b/graphics/ftgl/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig 2019-09-25 00:59:19 UTC
++++ configure
+@@ -23739,7 +23739,7 @@ GLUT_X_LIBS=
+ { echo "$as_me:$LINENO: checking for a TrueType font on the system" >&5
+ echo $ECHO_N "checking for a TrueType font on the system... $ECHO_C" >&6; }
+
+-FONT_FILE="`fc-match -sv serif 2>/dev/null| sed -ne 's/.*\file:[^"]*"\([^"]*\)".*/\1/p' | sed q`"
++FONT_FILE="`fc-match -sv serif 2>/dev/null| sed -ne 's/.*file:[^"]*"\([^"]*\)".*/\1/p' | sed q`"
+
+ if test "$FONT_FILE" = ""; then
+ for font in \
diff --git a/graphics/synfigstudio/Makefile b/graphics/synfigstudio/Makefile
index 84853295db52..5392fc57fc11 100644
--- a/graphics/synfigstudio/Makefile
+++ b/graphics/synfigstudio/Makefile
@@ -4,7 +4,7 @@
PORTNAME= synfigstudio
PORTVERSION= 1.2.2
DISTVERSIONPREFIX=v
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= graphics multimedia
MAINTAINER= woodsb02@FreeBSD.org
@@ -12,7 +12,8 @@ COMMENT= Vector-based 2D animation software package
LICENSE= GPLv2+
-BUILD_DEPENDS= etl>=1.2.2:devel/etl
+BUILD_DEPENDS= etl>=1.2.2:devel/etl \
+ gsed:textproc/gsed
LIB_DEPENDS= libHalf.so:graphics/ilmbase \
libIlmImf.so:graphics/openexr \
libMagick++-6.so:graphics/ImageMagick6 \
@@ -35,6 +36,7 @@ WRKSRC_SUBDIR= synfig-studio
USE_CXXSTD= c++11
USE_GNOME= gtkmm30 intltool
GNU_CONFIGURE= yes
+BINARY_ALIAS= sed=${LOCALBASE}/bin/gsed
CONFIGURE_ARGS= --disable-update-mimedb
INSTALL_TARGET= install-strip
USE_LDCONFIG= yes
diff --git a/java/openjdk11/Makefile b/java/openjdk11/Makefile
index 353e178870b0..e5dc63d27b39 100644
--- a/java/openjdk11/Makefile
+++ b/java/openjdk11/Makefile
@@ -3,6 +3,7 @@
PORTNAME= openjdk
DISTVERSIONPREFIX= jdk-
DISTVERSION= ${JDK_MAJOR_VERSION}.${JDK_MINOR_VERSION}.${JDK_PATCH_VERSION}+${JDK_BUILD_NUMBER}-${BSD_JDK_VERSION}
+PORTREVISION= 1
CATEGORIES= java devel
PKGNAMESUFFIX?= ${JDK_MAJOR_VERSION}
@@ -16,7 +17,8 @@ ONLY_FOR_ARCHS= amd64 i386 powerpc64
BUILD_DEPENDS= zip:archivers/zip \
autoconf>0:devel/autoconf \
${LOCALBASE}/include/cups/cups.h:print/cups \
- bash:shells/bash
+ bash:shells/bash \
+ gsed:textproc/gsed
LIB_DEPENDS= libasound.so:audio/alsa-lib \
libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2 \
@@ -61,7 +63,8 @@ BSD_JDK_VERSION= 2
GNU_CONFIGURE= yes
CONFIGURE_ENV= CC=${CC} \
CXX=${CXX} \
- CPP=${CPP}
+ CPP=${CPP} \
+ ac_cv_path_SED=${LOCALBASE}/bin/gsed
CONFIGURE_ARGS= --with-boot-jdk=${BOOTSTRAPJDKDIR} \
--disable-ccache \
--disable-javac-server \
diff --git a/java/openjdk12/Makefile b/java/openjdk12/Makefile
index cc4b3b1d78ee..79b030d68ada 100644
--- a/java/openjdk12/Makefile
+++ b/java/openjdk12/Makefile
@@ -3,6 +3,7 @@
PORTNAME= openjdk
DISTVERSIONPREFIX= jdk-
DISTVERSION= ${JDK_MAJOR_VERSION}.${JDK_MINOR_VERSION}.${JDK_PATCH_VERSION}+${JDK_BUILD_NUMBER}-${BSD_JDK_VERSION}
+PORTREVISION= 1
CATEGORIES= java devel
PKGNAMESUFFIX?= ${JDK_MAJOR_VERSION}
@@ -16,7 +17,8 @@ ONLY_FOR_ARCHS= amd64 i386 powerpc64
BUILD_DEPENDS= zip:archivers/zip \
autoconf>0:devel/autoconf \
${LOCALBASE}/include/cups/cups.h:print/cups \
- bash:shells/bash
+ bash:shells/bash \
+ gsed:textproc/gsed
LIB_DEPENDS= libasound.so:audio/alsa-lib \
libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2 \
@@ -61,7 +63,8 @@ BSD_JDK_VERSION= 4
GNU_CONFIGURE= yes
CONFIGURE_ENV= CC=${CC} \
CXX=${CXX} \
- CPP=${CPP}
+ CPP=${CPP} \
+ ac_cv_path_SED=${LOCALBASE}/bin/gsed
CONFIGURE_ARGS= --with-boot-jdk=${BOOTSTRAPJDKDIR} \
--disable-ccache \
--disable-javac-server \
diff --git a/java/openjdk13/Makefile b/java/openjdk13/Makefile
index d253a9fde6ae..b8068621d29f 100644
--- a/java/openjdk13/Makefile
+++ b/java/openjdk13/Makefile
@@ -3,6 +3,7 @@
PORTNAME= openjdk
DISTVERSIONPREFIX= jdk-
DISTVERSION= ${JDK_MAJOR_VERSION}.${JDK_MINOR_VERSION}.${JDK_PATCH_VERSION}+${JDK_BUILD_NUMBER}-${BSD_JDK_VERSION}
+PORTREVISION= 1
CATEGORIES= java devel
PKGNAMESUFFIX?= ${JDK_MAJOR_VERSION}
@@ -16,7 +17,8 @@ ONLY_FOR_ARCHS= amd64 i386 powerpc64
BUILD_DEPENDS= zip:archivers/zip \
autoconf>0:devel/autoconf \
${LOCALBASE}/include/cups/cups.h:print/cups \
- bash:shells/bash
+ bash:shells/bash \
+ gsed:textproc/gsed
LIB_DEPENDS= libasound.so:audio/alsa-lib \
libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2 \
@@ -61,7 +63,8 @@ BSD_JDK_VERSION= 1
GNU_CONFIGURE= yes
CONFIGURE_ENV= CC=${CC} \
CXX=${CXX} \
- CPP=${CPP}
+ CPP=${CPP} \
+ ac_cv_path_SED=${LOCALBASE}/bin/gsed
CONFIGURE_ARGS= --with-boot-jdk=${BOOTSTRAPJDKDIR} \
--disable-ccache \
--disable-javac-server \
diff --git a/math/p5-NetCDF/files/patch-port_master.mk.in b/math/p5-NetCDF/files/patch-port_master.mk.in
new file mode 100644
index 000000000000..d2c81382b56d
--- /dev/null
+++ b/math/p5-NetCDF/files/patch-port_master.mk.in
@@ -0,0 +1,16 @@
+--- port/master.mk.in.orig 2019-09-25 01:28:25 UTC
++++ port/master.mk.in
+@@ -426,11 +426,11 @@ $(MANDIR)/dummy.man $(MANDIR)/$(MANUAL): $(MANDIR) $(M
+ case `uname -s` in \
+ OSF1*|IRIX*|HP-UX) \
+ sed \
+- -e '/^\.TH/s/$$D\ate: \([0-9]*\)\/\([0-9]*\)\/\([0-9]*\).*\$$/\1-\2-\3/'\
++ -e '/^\.TH/s/$$Date: \([0-9]*\)\/\([0-9]*\)\/\([0-9]*\).*$$/\1-\2-\3/'\
+ $(MANUAL) > $@;; \
+ *) \
+ sed \
+- -e '/^\.TH/s/$$D\ate: \([0-9]*\)\/\([0-9]*\)\/\([0-9]*\).*\$$/\1-\2-\3/'\
++ -e '/^\.TH/s/$$Date: \([0-9]*\)\/\([0-9]*\)\/\([0-9]*\).*$$/\1-\2-\3/'\
+ $(MANUAL) | $(TBL) | $(NEQN) > $@;; \
+ esac
+ extension=`echo $(MANUAL) | sed 's/[^.]*\.//'`; \
diff --git a/multimedia/vlc/Makefile b/multimedia/vlc/Makefile
index cf5b59f24599..6d710e1cb8b6 100644
--- a/multimedia/vlc/Makefile
+++ b/multimedia/vlc/Makefile
@@ -3,7 +3,7 @@
PORTNAME= vlc
DISTVERSION= 3.0.10
-PORTREVISION= 5
+PORTREVISION= 6
PORTEPOCH= 4
CATEGORIES= multimedia audio net www
MASTER_SITES= http://download.videolan.org/pub/videolan/${PORTNAME}/${DISTVERSION:S/a$//}/ \
@@ -21,7 +21,8 @@ LIB_DEPENDS= libgcrypt.so:security/libgcrypt \
libfreetype.so:print/freetype2 \
libidn.so:dns/libidn \
libmatroska.so:multimedia/libmatroska
-BUILD_DEPENDS= ffmpeg>=3.4.1,1:multimedia/ffmpeg \
+BUILD_DEPENDS= gsed:textproc/gsed \
+ ffmpeg>=3.4.1,1:multimedia/ffmpeg \
yasm:devel/yasm
RUN_DEPENDS= ffmpeg>=3.4.1,1:multimedia/ffmpeg
@@ -39,6 +40,7 @@ USE_LDCONFIG= yes
INSTALL_TARGET= install-strip
GNU_CONFIGURE= yes
+BINARY_ALIAS= sed=${LOCALBASE}/bin/gsed
CONFIGURE_ARGS= --enable-avcodec --enable-avformat --enable-dvbpsi \
--enable-fontconfig --enable-freetype --enable-libgcrypt \
--enable-libxml2 --enable-oss --enable-postproc \
diff --git a/net-mgmt/docsis/files/patch-doc_generate-settings.sh b/net-mgmt/docsis/files/patch-doc_generate-settings.sh
new file mode 100644
index 000000000000..73e5cd5eaaca
--- /dev/null
+++ b/net-mgmt/docsis/files/patch-doc_generate-settings.sh
@@ -0,0 +1,20 @@
+--- doc/generate-settings.sh.orig 2019-09-25 00:51:22 UTC
++++ doc/generate-settings.sh
+@@ -33,13 +33,13 @@ grep -e "^{" ../src/docsis_symtable.h \
+ | grep -v "*" \
+ | grep -v "decode_md5" \
+ | awk '{print $5 "_" $3 " " $7 " " $8 " " $9}' \
+- | sed 's/\"//g' \
++ | sed 's/"//g' \
+ | sed 's/^0,_//g' \
+ | sed 's/^[0-9]*,_/\&nbsp\;\&nbsp\;\&nbsp\;\&nbsp\;/g' \
+- | sed 's/\decode_//g' \
+- | sed 's/\ //g' | tr -s "\(\)" "%%" \
++ | sed 's/decode_//g' \
++ | sed 's/ //g' | tr -s "\(\)" "%%" \
+ | sed 's/^/<tr><td><b>/g' \
+- | sed 's/,\%/<\/b><\/td><td>/g' \
++ | sed 's/,%/<\/b><\/td><td>/g' \
+ | sed 's/%,/<\/td><td>/g' \
+ | sed 's/,/-/g' \
+ | sed 's/$/<\/td><\/tr>/g'\
diff --git a/print/pdflib/Makefile b/print/pdflib/Makefile
index d566e22e0283..684b27b1ea0b 100644
--- a/print/pdflib/Makefile
+++ b/print/pdflib/Makefile
@@ -3,7 +3,7 @@
PORTNAME= pdflib
PORTVERSION= 7.0.5
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= print perl5 java
MASTER_SITES= LOCAL/ale
DISTNAME= PDFlib-Lite-${PORTVERSION}p3
@@ -11,6 +11,8 @@ DISTNAME= PDFlib-Lite-${PORTVERSION}p3
MAINTAINER= ale@FreeBSD.org
COMMENT= C library for dynamically generating PDF
+BUILD_DEPENDS= gsed:textproc/gsed
+
RESTRICTED= Many odd restrictions on usage and distribution
OPTIONS_DEFINE= PERL JAVA DOCS
@@ -20,6 +22,7 @@ JAVA_DESC= Build Java bindings
USES= gmake libtool
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
+BINARY_ALIAS= sed=${LOCALBASE}/bin/gsed
CONFIGURE_ARGS= --with-py=no --with-ruby=no --with-tcl=no
PORTDOCS= *
diff --git a/print/pdflib/files/patch-configure b/print/pdflib/files/patch-configure
index 33c29667c63e..0ba3413ff302 100644
--- a/print/pdflib/files/patch-configure
+++ b/print/pdflib/files/patch-configure
@@ -13,8 +13,8 @@
aix*|AIX*) PERLLINK="-L$PERLINCLUDE -lperl $PERLLINK";;
osf1*|OSF1*) PERLLINK="-L$PERLINCLUDE -lperl $PERLLINK";;
darwin|Darwin*) PERLLINK="-L$PERLINCLUDE -lperl $PERLLINK";;
-+ dragonfly|DragonFly*) PERLLINK=`perl -V:lddlflags|sed -e "s|.*=\'\(.*\)\';|\1|"`;;
-+ freebsd|FreeBSD*) PERLLINK=`perl -V:lddlflags|sed -e "s|.*=\'\(.*\)\';|\1|"`;;
++ dragonfly|DragonFly*) PERLLINK=`perl -V:lddlflags|sed -e "s|.*='\(.*\)';|\1|"`;;
++ freebsd|FreeBSD*) PERLLINK=`perl -V:lddlflags|sed -e "s|.*='\(.*\)';|\1|"`;;
*) ;;
esac
diff --git a/security/amavisd-new/Makefile b/security/amavisd-new/Makefile
index e0bbb07f936d..4697dd5d57d4 100644
--- a/security/amavisd-new/Makefile
+++ b/security/amavisd-new/Makefile
@@ -2,6 +2,7 @@
PORTNAME= amavisd-new
PORTVERSION= 2.12.0
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= security
MASTER_SITES= https://gitlab.com/amavis/amavis/-/archive/v${PORTVERSION}/
@@ -211,8 +212,8 @@ RUN_DEPENDS+= ${LOCALBASE}/bin/tnef:converters/tnef
.include <bsd.port.pre.mk>
post-patch:
- @${REINPLACE_CMD} -e "s|$daemon_user = \'vscan\';|$daemon_user = \'${AMAVISUSER}\';|" \
- -e "s|$daemon_group = \'vscan\';|$daemon_group = \'${AMAVISGROUP}\';|" \
+ @${REINPLACE_CMD} -e "s|$$daemon_user = 'vscan';|$$daemon_user = '${AMAVISUSER}';|" \
+ -e "s|$$daemon_group = 'vscan';|$$daemon_group = '${AMAVISGROUP}';|" \
-e "s|/var/amavis|${AMAVISDIR}|" \
-e "s|/var/lib/amavis|${AMAVISDIR}|" \
-e "s|/var/virusmails|${AMAVISQUARANTINE}|" \
diff --git a/sysutils/cinnamon-control-center/Makefile b/sysutils/cinnamon-control-center/Makefile
index 3ddd338c7958..47d373629a7d 100644
--- a/sysutils/cinnamon-control-center/Makefile
+++ b/sysutils/cinnamon-control-center/Makefile
@@ -3,7 +3,7 @@
PORTNAME= cinnamon-control-center
PORTVERSION= 2.4.2
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= sysutils gnome
MASTER_SITES= https://raw.githubusercontent.com/${GH_ACCOUNT}/${GH_PROJECT}/9363a4a1e121344ae98f22b55fb28623cf0f6038/panels/datetime/data/:tzpng
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
@@ -15,7 +15,8 @@ COMMENT= Control center for Cinnamon
BUILD_DEPENDS= ca_root_nss>=0:security/ca_root_nss \
cinnamon-settings-daemon>=0:sysutils/cinnamon-settings-daemon \
- gnome-autogen.sh:devel/gnome-common
+ gnome-autogen.sh:devel/gnome-common \
+ gsed:textproc/gsed
LIB_DEPENDS= libstartup-notification-1.so:x11/startup-notification \
libupower-glib.so:sysutils/upower \
libcheese.so:multimedia/cheese \
@@ -49,6 +50,7 @@ INSTALLS_ICONS= yes
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--enable-compile-warnings=no
+CONFIGURE_ENV+=ac_cv_path_SED=${LOCALBASE}/bin/gsed
CFLAGS+= -I${LOCALBASE}/include
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/sysutils/cinnamon-settings-daemon/Makefile b/sysutils/cinnamon-settings-daemon/Makefile
index aa4bf29bddf3..eb80302e1046 100644
--- a/sysutils/cinnamon-settings-daemon/Makefile
+++ b/sysutils/cinnamon-settings-daemon/Makefile
@@ -3,7 +3,7 @@
PORTNAME= cinnamon-settings-daemon
PORTVERSION= 2.4.3
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= sysutils gnome
DIST_SUBDIR= gnome3
@@ -13,7 +13,8 @@ COMMENT= GNOME 3 settings daemon
BUILD_DEPENDS= cinnamon-session:x11/cinnamon-session \
gnome-autogen.sh:devel/gnome-common \
gsettings-desktop-schemas>=0:devel/gsettings-desktop-schemas \
- docbook-xsl>=0:textproc/docbook-xsl
+ docbook-xsl>=0:textproc/docbook-xsl \
+ gsed:textproc/gsed
LIB_DEPENDS= libcanberra-gtk3.so:audio/libcanberra-gtk3 \
libpolkit-gobject-1.so:sysutils/polkit \
libibus-1.0.so:textproc/ibus \
@@ -33,6 +34,7 @@ USE_GNOME= gnomeprefix intlhack libgnomekbd \
USE_GITHUB= yes
GH_ACCOUNT= linuxmint
GNU_CONFIGURE= yes
+CONFIGURE_ENV+= ac_cv_path_SED=${LOCALBASE}/bin/gsed
INSTALLS_ICONS= yes
USE_LDCONFIG= yes
CONFIGURE_ARGS= --disable-gudev \
diff --git a/sysutils/conky/Makefile b/sysutils/conky/Makefile
index 133b6184863a..694eff71f438 100644
--- a/sysutils/conky/Makefile
+++ b/sysutils/conky/Makefile
@@ -4,7 +4,7 @@
PORTNAME= conky
PORTVERSION= 1.11.5
DISTVERSIONPREFIX= v
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= sysutils
MAINTAINER= madpilot@FreeBSD.org
@@ -13,7 +13,8 @@ COMMENT?= Advanced, highly configurable system monitor for X11
LIB_DEPENDS= libinotify.so:devel/libinotify
BUILD_DEPENDS= db2x_xsltproc:textproc/docbook2X \
docbook-xsl>=0:textproc/docbook-xsl \
- xsltproc:textproc/libxslt
+ xsltproc:textproc/libxslt \
+ gsed:textproc/gsed
USES= cpe cmake:noninja compiler:c++11-lib gettext-runtime iconv \
localbase lua:52 pkgconfig tar:bzip2
@@ -23,7 +24,8 @@ CMAKE_ARGS= -DBUILD_PORT_MONITORS:BOOL=false \
-DBUILD_HDDTEMP:BOOL=false \
-DBUILD_IOSTATS:BOOL=false \
-DBUILD_AUDACIOUS:BOOL=false \
- -DBUILD_DOCS:BOOL=true
+ -DBUILD_DOCS:BOOL=true \
+ -DAPP_SED=${LOCALBASE}/bin/gsed
CONFLICTS?= conky-awesome-[0-9]*
SLAVEDIRS= sysutils/conky-awesome
diff --git a/sysutils/minipro/Makefile b/sysutils/minipro/Makefile
index 4cf993190005..929ab92dfd61 100644
--- a/sysutils/minipro/Makefile
+++ b/sysutils/minipro/Makefile
@@ -3,7 +3,7 @@
PORTNAME= minipro
PORTVERSION= 0.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= sysutils
MAINTAINER= lhondareyte@laposte.net
@@ -11,6 +11,7 @@ COMMENT= CLI for MiniPRO TL866xx chip programmers
LICENSE= GPLv3
+BUILD_DEPENDS= gsed:textproc/gsed
RUN_DEPENDS= bash:shells/bash
USES= compiler:c11 gmake pkgconfig shebangfix
@@ -19,6 +20,7 @@ USE_GITLAB= yes
GL_ACCOUNT= DavidGriffith
GL_COMMIT= e6fb06822e6685886a045ae98c3c82d832bd8e9c
GL_PROJECT= ${PORTNAME}
+BINARY_ALIAS= sed=${LOCALBASE}/bin/gsed
SHEBANG_FILES= miniprohex
PLIST_FILES= bin/minipro \
bin/miniprohex \
diff --git a/textproc/sphinxsearch/Makefile b/textproc/sphinxsearch/Makefile
index 2973973212f8..25c6728dd63d 100644
--- a/textproc/sphinxsearch/Makefile
+++ b/textproc/sphinxsearch/Makefile
@@ -7,7 +7,7 @@
PORTNAME= sphinxsearch
PORTVERSION= 2.2.11
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= textproc databases
MASTER_SITES= http://sphinxsearch.com/files/ \
http://snowball.tartarus.org/dist/:libstemmer
@@ -21,11 +21,14 @@ LICENSE= GPLv2
USES= compiler:c++11-lang
+BUILD_DEPENDS= gsed:textproc/gsed
# If expat is present on the system and configure finds it, it will
# unconditionally link the output binary against it. There's no way
# of turning this off. So for consistency, make sure it's always on.
LIB_DEPENDS= libexpat.so:textproc/expat2
+BINARY_ALIAS= sed=${LOCALBASE}/bin/gsed
+
OPTIONS_DEFINE= ICONV ID64 LIBSTEMMER MYSQL OPTIMIZED_CFLAGS PGSQL \
RE2 SYSLOG UNIXODBC DOCS EXAMPLES
OPTIONS_DEFAULT=ICONV ID64 MYSQL SYSLOG
diff --git a/x11/evilvte/Makefile b/x11/evilvte/Makefile
index 86e594c36475..dc2f3a66d42b 100644
--- a/x11/evilvte/Makefile
+++ b/x11/evilvte/Makefile
@@ -3,14 +3,17 @@
PORTNAME= evilvte
DISTVERSION= 0.5.2~pre1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= x11 gnome
MASTER_SITES= http://www.calno.com/${PORTNAME}/
MAINTAINER= aragon@phat.za.net
COMMENT= VTE based, super lightweight terminal emulator
+BUILD_DEPENDS= gsed:textproc/gsed
+
USES= gmake gnome pkgconfig tar:xz
+BINARY_ALIAS= sed=${LOCALBASE}/bin/gsed
HAS_CONFIGURE= yes
ALL_TARGET= evilvte
INSTALLS_ICONS= yes