aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--graphics/ImageMagick6/Makefile3
-rw-r--r--graphics/ImageMagick7/Makefile3
-rw-r--r--graphics/fpc-rsvg/Makefile3
-rw-r--r--graphics/gimageview/Makefile2
-rw-r--r--graphics/osg-devel/Makefile4
-rw-r--r--graphics/osg/Makefile4
-rw-r--r--x11-fm/librfm/Makefile3
-rw-r--r--x11/xxkb/Makefile5
8 files changed, 13 insertions, 14 deletions
diff --git a/graphics/ImageMagick6/Makefile b/graphics/ImageMagick6/Makefile
index 0c38c5998b12..0aeb5aa40c10 100644
--- a/graphics/ImageMagick6/Makefile
+++ b/graphics/ImageMagick6/Makefile
@@ -162,8 +162,7 @@ RAW_IMPLIES= LCMS2
SVG_DESC= SVG vector image format support (via librsvg, implies the x11 option)
SVG_CONFIGURE_WITH= rsvg
-SVG_LIB_DEPENDS= librsvg-2.so:graphics/librsvg2
-SVG_USE= gnome=cairo,gdkpixbuf2
+SVG_USE= gnome=cairo,gdkpixbuf2,librsvg2
SVG_IMPLIES= X11
TIFF_CONFIGURE_WITH= tiff
diff --git a/graphics/ImageMagick7/Makefile b/graphics/ImageMagick7/Makefile
index 5a401f3c5d1e..1afc8893e890 100644
--- a/graphics/ImageMagick7/Makefile
+++ b/graphics/ImageMagick7/Makefile
@@ -161,8 +161,7 @@ RAW_IMPLIES= LCMS2
SVG_DESC= SVG vector image format support (via librsvg, implies the x11 option)
SVG_CONFIGURE_WITH= rsvg
-SVG_LIB_DEPENDS= librsvg-2.so:graphics/librsvg2
-SVG_USE= gnome=cairo,gdkpixbuf2
+SVG_USE= gnome=cairo,gdkpixbuf2,librsvg2
SVG_IMPLIES= X11
TIFF_CONFIGURE_WITH= tiff
diff --git a/graphics/fpc-rsvg/Makefile b/graphics/fpc-rsvg/Makefile
index b8e18e41fb7b..806b38fa7e5e 100644
--- a/graphics/fpc-rsvg/Makefile
+++ b/graphics/fpc-rsvg/Makefile
@@ -17,6 +17,7 @@ OPTIONS_DEFINE= LIBRSVG2
LIBRSVG2_DESC= Install librsvg2 library
OPTIONS_DEFAULT= LIBRSVG2
-LIBRSVG2_LIB_DEPENDS= librsvg-2.so:graphics/librsvg2
+LIBRSVG2_USES= gnome
+LIBRSVG2_USE= GNOME=librsvg2
.include "${MASTERDIR}/Makefile"
diff --git a/graphics/gimageview/Makefile b/graphics/gimageview/Makefile
index 44898d3ab46f..2d58a2755166 100644
--- a/graphics/gimageview/Makefile
+++ b/graphics/gimageview/Makefile
@@ -40,7 +40,7 @@ LIBWMF_CONFIGURE_WITH= libwmf
LIBWMF_LIB_DEPENDS= libwmf.so:graphics/libwmf
LIBRSVG2_CONFIGURE_WITH=librsvg
-LIBRSVG2_LIB_DEPENDS= librsvg-2.so:graphics/librsvg2
+LIBRSVG2_USE= GNOME=librsvg2
LIBEXIF_CONFIGURE_ENABLE=exif # bundled exif is used
LIBEXIF_BROKEN_OFF= does not build without libexif support
diff --git a/graphics/osg-devel/Makefile b/graphics/osg-devel/Makefile
index 1591a7defd3e..8d85af3b4204 100644
--- a/graphics/osg-devel/Makefile
+++ b/graphics/osg-devel/Makefile
@@ -103,8 +103,8 @@ QT5_VARS_OFF= FORCE_IGNORE+="Qt5Widgets Qt5WebKitWidgets"
SDL_USE= sdl=sdl
SDL_VARS= FORCE_REQUIRE+=SDL
SDL_VARS_OFF= FORCE_IGNORE+=SDL
-SVG_LIB_DEPENDS= librsvg-2.so:graphics/librsvg2
-SVG_USE= gnome=cairo
+SVG_USES= gnome
+SVG_USE= gnome=cairo,librsvg2
SVG_VARS= FORCE_REQUIRE+=RSVG
SVG_VARS_OFF= FORCE_IGNORE+=RSVG
VNC_LIB_DEPENDS= libvncserver.so:net/libvncserver
diff --git a/graphics/osg/Makefile b/graphics/osg/Makefile
index e20ac79deb8f..496098a0bc8c 100644
--- a/graphics/osg/Makefile
+++ b/graphics/osg/Makefile
@@ -106,8 +106,8 @@ QT5_VARS_OFF= FORCE_IGNORE+="Qt5Widgets Qt5WebKitWidgets"
SDL_USE= sdl=sdl
SDL_VARS= FORCE_REQUIRE+=SDL
SDL_VARS_OFF= FORCE_IGNORE+=SDL
-SVG_LIB_DEPENDS= librsvg-2.so:graphics/librsvg2
-SVG_USE= gnome=cairo
+SVG_USES= gnome
+SVG_USE= gnome=cairo,librsvg2
SVG_VARS= FORCE_REQUIRE+=RSVG
SVG_VARS_OFF= FORCE_IGNORE+=RSVG
VNC_LIB_DEPENDS= libvncserver.so:net/libvncserver
diff --git a/x11-fm/librfm/Makefile b/x11-fm/librfm/Makefile
index d49f4ebad8df..c3182b2ff94c 100644
--- a/x11-fm/librfm/Makefile
+++ b/x11-fm/librfm/Makefile
@@ -16,7 +16,6 @@ BUILD_DEPENDS= gawk:lang/gawk
LIB_DEPENDS= libtubo.so:x11-fm/libtubo \
libdbh.so:databases/dbh \
libzip.so:archivers/libzip \
- librsvg-2.so:graphics/librsvg2 \
libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2
@@ -26,7 +25,7 @@ CONFIGURE_ARGS+=--with-pkglibdata
INSTALLS_ICONS= yes
USES= autoreconf gettext gnome gmake libtool:keepla pkgconfig tar:bzip2
GNU_CONFIGURE= yes
-USE_GNOME= gtk20 intltool cairo libxml2
+USE_GNOME= gtk20 intltool cairo libxml2 librsvg2
USE_XORG+= x11
USE_LDCONFIG= yes
INSTALL_TARGET= install-strip
diff --git a/x11/xxkb/Makefile b/x11/xxkb/Makefile
index bbeffc7e6eb6..70a5a23470e9 100644
--- a/x11/xxkb/Makefile
+++ b/x11/xxkb/Makefile
@@ -20,8 +20,9 @@ PORTDOCS= README CHANGES.ru README.ru
OPTIONS_DEFINE= LIBRSVG2 DOCS
-LIBRSVG2_LIB_DEPENDS= librsvg-2.so:graphics/librsvg2
-LIBRSVG2_VARS= XMKMF_ARGS=-DWITH_SVG_SUPPORT
+LIBRSVG2_USES= gnome
+LIBRSVG2_USE= GNOME=librsvg2
+LIBRSVG2_VARS= XMKMF_ARGS=-DWITH_SVG_SUPPORT
post-build:
# Convert Russian language docs from archaic KOI8-R to modern UTF-8