aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/p5-Data-UUID/Makefile9
-rw-r--r--devel/p5-Log-Handler/Makefile9
-rw-r--r--net/p5-AnyEvent-Twitter-Stream/Makefile9
-rw-r--r--net/p5-AnyEvent-Twitter/Makefile9
-rw-r--r--security/p5-Filter-Crypto/Makefile9
-rw-r--r--textproc/p5-XML-RSS-JavaScript/Makefile9
-rw-r--r--www/p5-WWW-OpenSearch/Makefile9
7 files changed, 21 insertions, 42 deletions
diff --git a/devel/p5-Data-UUID/Makefile b/devel/p5-Data-UUID/Makefile
index a57ea0d235e9..73072c2424a4 100644
--- a/devel/p5-Data-UUID/Makefile
+++ b/devel/p5-Data-UUID/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: Data::UUID
-# Date created: 28 Jan 2002
-# Whom: Sergey Skvortsov <skv@FreeBSD.org>
-#
+# Created by: Sergey Skvortsov <skv@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Data-UUID
PORTVERSION= 1.219
@@ -14,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Generate Globally/Universally Unique Identifiers (GUIDs/UUIDs)
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
CONFIGURE_ARGS= </dev/null
MAN3= Data::UUID.3
diff --git a/devel/p5-Log-Handler/Makefile b/devel/p5-Log-Handler/Makefile
index 31f382b227ce..42b4383a3f4b 100644
--- a/devel/p5-Log-Handler/Makefile
+++ b/devel/p5-Log-Handler/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: Log::Handler
-# Date created: 7 Nov 2009
-# Whom: Sahil Tandon <sahil@tandon.net>
-#
+# Created by: Sahil Tandon <sahil@tandon.net>
# $FreeBSD$
-#
PORTNAME= Log-Handler
PORTVERSION= 0.78
@@ -17,7 +13,8 @@ COMMENT= An object-oriented handler for logging, tracing, and debugging in Perl
BUILD_DEPENDS= p5-Params-Validate>=0:${PORTSDIR}/devel/p5-Params-Validate
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Log::Handler.3 \
Log::Handler::Config.3 \
diff --git a/net/p5-AnyEvent-Twitter-Stream/Makefile b/net/p5-AnyEvent-Twitter-Stream/Makefile
index 9a7c8028c29e..2f69802adb52 100644
--- a/net/p5-AnyEvent-Twitter-Stream/Makefile
+++ b/net/p5-AnyEvent-Twitter-Stream/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: AnyEvent::Twitter::Stream
-# Date created: 2010-04-18
-# Whom: Sahil Tandon <sahil@FreeBSD.org>
-#
+# Created by: Sahil Tandon <sahil@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= AnyEvent-Twitter-Stream
PORTVERSION= 0.26
@@ -19,7 +15,8 @@ RUN_DEPENDS= p5-AnyEvent>=0:${PORTSDIR}/devel/p5-AnyEvent \
p5-JSON>=2.0:${PORTSDIR}/converters/p5-JSON \
p5-URI>=0:${PORTSDIR}/net/p5-URI
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= AnyEvent::Twitter::Stream.3
diff --git a/net/p5-AnyEvent-Twitter/Makefile b/net/p5-AnyEvent-Twitter/Makefile
index a1522bc18ecc..4d92ccd7369c 100644
--- a/net/p5-AnyEvent-Twitter/Makefile
+++ b/net/p5-AnyEvent-Twitter/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: AnyEvent::Twitter
-# Date created: 07 Nov 2009
-# Whom: Sahil Tandon <sahil@tandon.net>
-#
+# Created by: Sahil Tandon <sahil@tandon.net>
# $FreeBSD$
-#
PORTNAME= AnyEvent-Twitter
PORTVERSION= 0.64
@@ -22,7 +18,8 @@ BUILD_DEPENDS= p5-AnyEvent>=5.34:${PORTSDIR}/devel/p5-AnyEvent \
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= AnyEvent::Twitter.3
diff --git a/security/p5-Filter-Crypto/Makefile b/security/p5-Filter-Crypto/Makefile
index be1044e33fe2..dae1088ccb63 100644
--- a/security/p5-Filter-Crypto/Makefile
+++ b/security/p5-Filter-Crypto/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: Filter-Crypto
-# Date created: 04 November 2004
-# Whom: Sergey Skvortsov <skv@protey.ru>
-#
+# Created by: Sergey Skvortsov <skv@protey.ru>
# $FreeBSD$
-#
PORTNAME= Filter-Crypto
PORTVERSION= 2.03
@@ -17,7 +13,8 @@ COMMENT= Create runnable Perl files encrypted with OpenSSL libcrypto
BUILD_DEPENDS= p5-PAR-Packer>=0:${PORTSDIR}/devel/p5-PAR-Packer
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
USE_OPENSSL= yes
CONFIGURE_ARGS= --prefix-dir=${OPENSSLBASE} --defaults
diff --git a/textproc/p5-XML-RSS-JavaScript/Makefile b/textproc/p5-XML-RSS-JavaScript/Makefile
index 0baef10cc808..209e0c9f45c3 100644
--- a/textproc/p5-XML-RSS-JavaScript/Makefile
+++ b/textproc/p5-XML-RSS-JavaScript/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-XML-RSS-JavaScript
-# Date created: 31 Oct 2003
-# Whom: Foxfair Hu <foxfair@FreeBSD.org>
-#
+# Created by: Foxfair Hu <foxfair@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= XML-RSS-JavaScript
PORTVERSION= 0.64
@@ -17,7 +13,8 @@ COMMENT= Perl extension to serialize your RSS as JavaScript
RUN_DEPENDS= p5-XML-RSS>=1.31:${PORTSDIR}/textproc/p5-XML-RSS
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= XML::RSS::JavaScript.3
diff --git a/www/p5-WWW-OpenSearch/Makefile b/www/p5-WWW-OpenSearch/Makefile
index d5831d6be027..36022df1bb4a 100644
--- a/www/p5-WWW-OpenSearch/Makefile
+++ b/www/p5-WWW-OpenSearch/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-WWW-OpenSearch
-# Date created: 2006-07-10
-# Whom: Gea-Suan Lin <gslin@gslin.org>
-#
+# Created by: Gea-Suan Lin <gslin@gslin.org>
# $FreeBSD$
-#
PORTNAME= WWW-OpenSearch
PORTVERSION= 0.17
@@ -22,7 +18,8 @@ RUN_DEPENDS= p5-URI-Template>=0:${PORTSDIR}/net/p5-URI-Template \
p5-XML-LibXML>=1.58:${PORTSDIR}/textproc/p5-XML-LibXML
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= WWW::OpenSearch.3 \
WWW::OpenSearch::Agent.3 \