aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--GIDs2
-rw-r--r--MOVED1
-rw-r--r--UIDs2
-rw-r--r--net-p2p/Makefile2
-rw-r--r--net-p2p/btsync/Makefile51
-rw-r--r--net-p2p/btsync/distinfo5
-rw-r--r--net-p2p/btsync/pkg-plist3
-rw-r--r--net-p2p/rslsync/Makefile49
-rw-r--r--net-p2p/rslsync/distinfo5
-rw-r--r--net-p2p/rslsync/files/pkg-message.in (renamed from net-p2p/btsync/files/pkg-message.in)8
-rw-r--r--net-p2p/rslsync/files/rslsync.in (renamed from net-p2p/btsync/files/btsync.in)30
-rw-r--r--net-p2p/rslsync/pkg-descr (renamed from net-p2p/btsync/pkg-descr)4
-rw-r--r--net-p2p/rslsync/pkg-plist3
13 files changed, 82 insertions, 83 deletions
diff --git a/GIDs b/GIDs
index 9adf0b403155..d92002204237 100644
--- a/GIDs
+++ b/GIDs
@@ -757,7 +757,7 @@ foreman_proxy:*:812:
puppet:*:814:
uchiwa:*:815:
# free: 816
-btsync:*:817:
+rslsync:*:817:
jenkins:*:818:
rundeck:*:819:
openacs:*:820:
diff --git a/MOVED b/MOVED
index 132af8eb50c1..11bf76fb0928 100644
--- a/MOVED
+++ b/MOVED
@@ -10183,3 +10183,4 @@ devel/llvm39||2018-05-08|Obsolete, no remaining dependencies
textproc/p5-Spork||2018-05-09|Removed, depends on expired www/p5-Kwiki
www/p5-Kwiki||2018-05-09|Has expired: All www files wrongly belongs to www user
x11-servers/x11rdp|x11-drivers/xorgxrdp|2018-05-13|Obsoleted by update of net/xrdp
+net-p2p/btsync|net-p2p/rslsync|2018-05-13|Renamed by the vendor
diff --git a/UIDs b/UIDs
index cd17059a865e..a3848d270ef8 100644
--- a/UIDs
+++ b/UIDs
@@ -763,7 +763,7 @@ foreman_proxy:*:812:812::0:0:Foreman Smart Proxy:/usr/local/share/foreman-proxy:
puppet:*:814:814::0:0:Puppet Daemon:/nonexistent:/usr/sbin/nologin
uchiwa:*:815:815::0:0:Uchiwa Dashboard:/nonexistent:/usr/sbin/nologin
# free: 816
-btsync:*:817:817::0:0:BitTorrent Sync Daemon:/nonexistent:/usr/sbin/nologin
+rslsync:*:817:817::0:0:Resilio Sync Daemon:/nonexistent:/usr/sbin/nologin
jenkins:*:818:818::0:0:Jenkins CI:/usr/local/jenkins:/bin/sh
rundeck:*:819:819::0:0:Rundeck:/usr/local/rundeck:/bin/sh
openacs:*:820:820::0:0:OpenACS Daemon User:/nonexistent:/usr/sbin/nologin
diff --git a/net-p2p/Makefile b/net-p2p/Makefile
index 49f821d7a2c2..21b32f5767cf 100644
--- a/net-p2p/Makefile
+++ b/net-p2p/Makefile
@@ -12,7 +12,6 @@
SUBDIR += bitmessage
SUBDIR += bnbt
SUBDIR += btpd
- SUBDIR += btsync
SUBDIR += couchpotato
SUBDIR += cpuminer
SUBDIR += createtorrent
@@ -82,6 +81,7 @@
SUBDIR += qtum
SUBDIR += radarr
SUBDIR += retroshare
+ SUBDIR += rslsync
SUBDIR += rtorrent
SUBDIR += shx
SUBDIR += sonarr
diff --git a/net-p2p/btsync/Makefile b/net-p2p/btsync/Makefile
deleted file mode 100644
index 26ffb9e28871..000000000000
--- a/net-p2p/btsync/Makefile
+++ /dev/null
@@ -1,51 +0,0 @@
-# $FreeBSD$
-
-PORTNAME= btsync
-PORTVERSION= 2.3.8
-CATEGORIES= net-p2p
-MASTER_SITES= https://download-cdn.getsync.com/${PORTVERSION}/FreeBSD-${CONFIG_ARCH}/ \
- http://download-cdn.getsync.com/${PORTVERSION}/FreeBSD-${CONFIG_ARCH}/
-DISTNAME= BitTorrent-Sync_freebsd_${CONFIG_ARCH}
-
-MAINTAINER= joshruehlig@gmail.com
-COMMENT= Distributed peer-to-peer file syncing application
-
-LICENSE= EULA
-LICENSE_NAME= BitTorrent Sync
-LICENSE_FILE= ${WRKSRC}/LICENSE.TXT
-LICENSE_PERMS= auto-accept
-
-NO_WRKSUBDIR= yes
-NO_BUILD= yes
-ONLY_FOR_ARCHS= amd64 i386
-ONLY_FOR_ARCHS_REASON= It is a binary-only program. Source code not available.
-
-PLIST_SUB= PORTNAME=${PORTNAME} USER=${USERS} GROUP=${GROUPS}
-SUB_LIST= PORTNAME=${PORTNAME} USER=${USERS} GROUP=${GROUPS}
-SUB_FILES= pkg-message
-USE_RC_SUBR= ${PORTNAME}
-
-USERS= ${PORTNAME}
-GROUPS= ${USERS}
-
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == "amd64"
-CONFIG_ARCH= x64
-.else
-CONFIG_ARCH= ${ARCH}
-.endif
-
-post-extract:
- ${MKDIR} ${WRKSRC}/temp
- ${MV} ${WRKSRC}/${PORTNAME} ${WRKSRC}/temp
-
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/temp/btsync ${STAGEDIR}${PREFIX}/bin
- ${WRKSRC}/temp/btsync --dump-sample-config > ${STAGEDIR}${PREFIX}/etc/${PORTNAME}.conf.sample
- ${REINPLACE_CMD} -e 's;^//\([[:space:]]*"storage_path"[[:space:]]*:[[:space:]]*\)"/.*",$$;\1"/var/db/${PORTNAME}",;' ${STAGEDIR}${PREFIX}/etc/${PORTNAME}.conf.sample
- ${REINPLACE_CMD} -e 's;^//\([[:space:]]*"pid_file"[[:space:]]*:[[:space:]]*"/var/run/${PORTNAME}/${PORTNAME}.pid",\)$$;\1;' ${STAGEDIR}${PREFIX}/etc/${PORTNAME}.conf.sample
-
- ${MKDIR} ${STAGEDIR}/var/db/${PORTNAME}
-
-.include <bsd.port.post.mk>
diff --git a/net-p2p/btsync/distinfo b/net-p2p/btsync/distinfo
deleted file mode 100644
index c06d2a451455..000000000000
--- a/net-p2p/btsync/distinfo
+++ /dev/null
@@ -1,5 +0,0 @@
-TIMESTAMP = 1466844210
-SHA256 (BitTorrent-Sync_freebsd_i386.tar.gz) = 103ba012acd4af2365243f10f2fa8a2bdc551b47ac326b00a71624a0289c73fc
-SIZE (BitTorrent-Sync_freebsd_i386.tar.gz) = 5714805
-SHA256 (BitTorrent-Sync_freebsd_x64.tar.gz) = fa0312f6616eb29ac9daa4b436ffda3dda3790d03f57008271963c63006060f6
-SIZE (BitTorrent-Sync_freebsd_x64.tar.gz) = 5879165
diff --git a/net-p2p/btsync/pkg-plist b/net-p2p/btsync/pkg-plist
deleted file mode 100644
index 2b726896f597..000000000000
--- a/net-p2p/btsync/pkg-plist
+++ /dev/null
@@ -1,3 +0,0 @@
-bin/btsync
-@sample etc/%%PORTNAME%%.conf.sample
-@dir(%%USER%%,%%GROUP%%,) /var/db/%%PORTNAME%%
diff --git a/net-p2p/rslsync/Makefile b/net-p2p/rslsync/Makefile
new file mode 100644
index 000000000000..048a76d98bcb
--- /dev/null
+++ b/net-p2p/rslsync/Makefile
@@ -0,0 +1,49 @@
+# $FreeBSD$
+
+PORTNAME= rslsync
+PORTVERSION= 2.5.12
+CATEGORIES= net-p2p
+MASTER_SITES= https://download-cdn.resilio.com/${PORTVERSION}/FreeBSD-${CONFIG_ARCH}/ \
+ http://download-cdn.resilio.com/${PORTVERSION}/FreeBSD-${CONFIG_ARCH}/
+DISTNAME= resilio-sync_freebsd_${CONFIG_ARCH}
+DIST_SUBDIR= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= joshruehlig@gmail.com
+COMMENT= Distributed peer-to-peer file syncing application
+
+LICENSE= EULA
+LICENSE_NAME= Resilio Sync
+LICENSE_FILE= ${WRKSRC}/LICENSE.TXT
+LICENSE_PERMS= auto-accept
+
+NO_WRKSUBDIR= yes
+ONLY_FOR_ARCHS= amd64 i386
+ONLY_FOR_ARCHS_REASON= It is a binary-only program. Source code not available.
+
+PLIST_SUB= USER=${USERS} GROUP=${GROUPS}
+SUB_LIST= USER=${USERS} GROUP=${GROUPS}
+SUB_FILES= pkg-message
+USE_RC_SUBR= rslsync
+
+USERS= rslsync
+GROUPS= ${USERS}
+
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "amd64"
+CONFIG_ARCH= x64
+.else
+CONFIG_ARCH= ${ARCH}
+.endif
+
+do-build:
+ ${WRKSRC}/rslsync --dump-sample-config > ${WRKSRC}/rslsync.conf.sample
+ ${REINPLACE_CMD} -e 's;^//\([[:space:]]*"storage_path"[[:space:]]*:[[:space:]]*\)"/.*",$$;\1"/var/db/rslsync",;' ${WRKSRC}/rslsync.conf.sample
+ ${REINPLACE_CMD} -e 's;^//\([[:space:]]*"pid_file"[[:space:]]*:[[:space:]]*\)"/.*",$$;\1"/var/run/rslsync/rslsync.pid",;' ${WRKSRC}/rslsync.conf.sample
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/rslsync ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/rslsync.conf.sample ${STAGEDIR}${PREFIX}/etc
+ ${MKDIR} ${STAGEDIR}/var/db/rslsync
+
+.include <bsd.port.post.mk>
diff --git a/net-p2p/rslsync/distinfo b/net-p2p/rslsync/distinfo
new file mode 100644
index 000000000000..538b3491e2d9
--- /dev/null
+++ b/net-p2p/rslsync/distinfo
@@ -0,0 +1,5 @@
+TIMESTAMP = 1526266298
+SHA256 (rslsync-2.5.12/resilio-sync_freebsd_i386.tar.gz) = 90aec753fb41c55c3344047ba6c94a7012642ff9eff9e19a7460f9cdbe303454
+SIZE (rslsync-2.5.12/resilio-sync_freebsd_i386.tar.gz) = 10960760
+SHA256 (rslsync-2.5.12/resilio-sync_freebsd_x64.tar.gz) = 32462b30f706791da1997021f7a51d0b42497cb076760ae9937f37836762b4ba
+SIZE (rslsync-2.5.12/resilio-sync_freebsd_x64.tar.gz) = 11138832
diff --git a/net-p2p/btsync/files/pkg-message.in b/net-p2p/rslsync/files/pkg-message.in
index 6228b28fb678..ea5383906b8c 100644
--- a/net-p2p/btsync/files/pkg-message.in
+++ b/net-p2p/rslsync/files/pkg-message.in
@@ -1,13 +1,13 @@
* * * * * * * * * * * * * * * * * * * * * * * * * * * * * * *
-net-p2p/%%PORTNAME%% includes an RC script:
-%%PREFIX%%/etc/rc.d/%%PORTNAME%%
+net-p2p/rslsync includes an RC script:
+%%PREFIX%%/etc/rc.d/rslsync
TO START ON BOOT:
-# echo '%%PORTNAME%%_enable="YES"' >> /etc/rc.conf
+# sysrc rslsync_enable=YES
START MANUALLY:
-# service %%PORTNAME%% start
+# service rslsync start
Once started, visit the following to configure:
http://localhost:8888/
diff --git a/net-p2p/btsync/files/btsync.in b/net-p2p/rslsync/files/rslsync.in
index 7c871fc44786..1111f36794e2 100644
--- a/net-p2p/btsync/files/btsync.in
+++ b/net-p2p/rslsync/files/rslsync.in
@@ -2,41 +2,41 @@
#
# $FreeBSD$
#
-# PROVIDE: %%PORTNAME%%
+# PROVIDE: rslsync
# REQUIRE: LOGIN
# KEYWORD: shutdown
#
# Add the following lines to /etc/rc.conf.local or /etc/rc.conf
# to enable this service:
#
-# %%PORTNAME%%_enable (bool): Set to NO by default.
+# rslsync_enable (bool): Set to NO by default.
# Set it to YES to enable it.
-# %%PORTNAME%%_user: The user account %%PORTNAME%% daemon runs as
+# rslsync_user: The user account rslsync daemon runs as
# what you want it to be. It uses '%%USER%%'
# user by default. Do not sets it as empty or it
# will run as root.
-# %%PORTNAME%%_group: The group account %%PORTNAME%% daemon runs as
+# rslsync_group: The group account rslsync daemon runs as
# what you want it to be. It uses '%%GROUP%%'
# group by default. Do not sets it as empty or it
# will run as wheel.
. /etc/rc.subr
-name="%%PORTNAME%%"
+name="rslsync"
rcvar="${name}_enable"
-load_rc_config $name
+load_rc_config ${name}
-: ${%%PORTNAME%%_enable:="NO"}
-: ${%%PORTNAME%%_user:="%%USER%%"}
-: ${%%PORTNAME%%_group:="%%GROUP%%"}
+: ${rslsync_enable:="NO"}
+: ${rslsync_user:="%%USER%%"}
+: ${rslsync_group:="%%GROUP%%"}
-pidfile="/var/run/%%PORTNAME%%/%%PORTNAME%%.pid"
-command="%%PREFIX%%/bin/btsync"
-command_args="--config %%PREFIX%%/etc/%%PORTNAME%%.conf"
+pidfile="/var/run/rslsync/rslsync.pid"
+command="%%PREFIX%%/bin/rslsync"
+command_args="--config %%PREFIX%%/etc/rslsync.conf"
-start_precmd=%%PORTNAME%%_prestart
-%%PORTNAME%%_prestart() {
+start_precmd=rslsync_prestart
+rslsync_prestart() {
if [ ! -d ${pidfile%/*} ]; then
- install -d -o $%%PORTNAME%%_user -g $%%PORTNAME%%_group ${pidfile%/*}
+ install -d -o ${rslsync_user} -g ${rslsync_group} ${pidfile%/*}
fi
}
diff --git a/net-p2p/btsync/pkg-descr b/net-p2p/rslsync/pkg-descr
index 5f024971581f..e2d2132246c3 100644
--- a/net-p2p/btsync/pkg-descr
+++ b/net-p2p/rslsync/pkg-descr
@@ -1,6 +1,6 @@
-Bittorrent Sync is a way to automatically sync files via a secure,
+Resilio Sync is a way to automatically sync files via a secure,
distributed technology. This allows users to share, sync and copy
data between computers and, optionally, share subsets of their data
with other people.
-WWW: http://www.bittorrent.com/sync
+WWW: https://www.resilio.com/
diff --git a/net-p2p/rslsync/pkg-plist b/net-p2p/rslsync/pkg-plist
new file mode 100644
index 000000000000..f13c80edbf78
--- /dev/null
+++ b/net-p2p/rslsync/pkg-plist
@@ -0,0 +1,3 @@
+bin/rslsync
+@sample etc/rslsync.conf.sample
+@dir(%%USER%%,%%GROUP%%,) /var/db/rslsync