aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--GIDs1
-rw-r--r--UIDs1
-rw-r--r--dns/dnsdist/Makefile7
-rw-r--r--dns/dnsdist/distinfo4
-rw-r--r--dns/dnsdist/files/dnsdist.in15
-rw-r--r--dns/dnsdist/pkg-plist2
6 files changed, 18 insertions, 12 deletions
diff --git a/GIDs b/GIDs
index af219598b9c9..55a636938597 100644
--- a/GIDs
+++ b/GIDs
@@ -126,6 +126,7 @@ yate:*:204:
gnugk:*:205:
gini:*:206:
_mixminion:*:207:
+_dnsdist:*:208:
gogs:*:209:
shoutcast:*:210:
git:*:211:
diff --git a/UIDs b/UIDs
index a88057daeb48..f7368f4e420d 100644
--- a/UIDs
+++ b/UIDs
@@ -131,6 +131,7 @@ yate:*:204:204::0:0:Yate:/nonexistent:/usr/sbin/nologin
gnugk:*:205:205::0:0:GNU GateKeeper pseudo-user:/nonexistent:/usr/sbin/nologin
gini:*:206:206::0:0:& streaming server:/var/log/gini:/usr/sbin/nologin
_mixminion:*:207:207::0:0:Mixminion server:/nonexistent:/usr/sbin/nologin
+_dnsdist:*:208:208::0:0:dnsdist user:/nonexistent:/usr/sbin/nologin
gogs:*:209:209::0:0:gogs user:/var/db/gogs/home:/bin/sh
shoutcast:*:210:210::0:0:Shoutcast sandbox:/nonexistent:/bin/sh
git:*:211:211::0:0:gitosis user:/usr/local/git:/bin/sh
diff --git a/dns/dnsdist/Makefile b/dns/dnsdist/Makefile
index 8b001678e827..db749cdb2a9f 100644
--- a/dns/dnsdist/Makefile
+++ b/dns/dnsdist/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= dnsdist
-DISTVERSION= 1.0.0-alpha2
+DISTVERSION= 1.0.0
CATEGORIES= dns net
MASTER_SITES= https://downloads.powerdns.com/releases/ \
LOCAL/cpm
@@ -25,9 +25,12 @@ LDFLAGS+= -L${LOCALBASE}/lib -latomic
GNU_CONFIGURE= yes
USE_GCC= yes
USES= bison cpe gmake libedit libtool lua:52 pkgconfig tar:bz2
-CONFIGURE_ARGS= --enable-dnscrypt --enable-libsodium
+CONFIGURE_ARGS= --bindir=${PREFIX}/sbin --enable-dnscrypt --enable-libsodium --without-protobuf
INSTALL_TARGET= install-strip
+USERS= _dnsdist
+GROUPS= _dnsdist
+
USE_RC_SUBR= dnsdist
post-install:
diff --git a/dns/dnsdist/distinfo b/dns/dnsdist/distinfo
index aacd343a740a..b9353bf1f999 100644
--- a/dns/dnsdist/distinfo
+++ b/dns/dnsdist/distinfo
@@ -1,2 +1,2 @@
-SHA256 (dnsdist-1.0.0-alpha2.tar.bz2) = dcbfa4f375a856694276f11921a6007bc954edd517a1cf1311a31839ca083c50
-SIZE (dnsdist-1.0.0-alpha2.tar.bz2) = 789252
+SHA256 (dnsdist-1.0.0.tar.bz2) = 1f72a5ca420fdea248dda60733a9b0ce3d68e13ee77dd5031887769a8451c713
+SIZE (dnsdist-1.0.0.tar.bz2) = 834177
diff --git a/dns/dnsdist/files/dnsdist.in b/dns/dnsdist/files/dnsdist.in
index 6cc93eb77595..63bf4a755a79 100644
--- a/dns/dnsdist/files/dnsdist.in
+++ b/dns/dnsdist/files/dnsdist.in
@@ -6,22 +6,23 @@
# REQUIRE: NETWORKING DAEMON
# KEYWORD: shutdown
#
-# Add the following to /etc/rc.conf to enable dnsdist:
+# Add the following line to /etc/rc.conf to enable dnsdist:
#
# dnsdist_enable="YES"
-#
. /etc/rc.subr
-name="dnsdist"
-rcvar="dnsdist_enable"
+desc="dnsdist is a powerful, scriptable DNS loadbalancer"
+name=dnsdist
+rcvar=dnsdist_enable
load_rc_config ${name}
-: ${dnsdist_enable:="NO"}
-: ${dnsdist_pidfile:=/var/run/${name}/pid}
+: ${dnsdist_priv_user:=_dnsdist}
+: ${dnsdist_priv_group:=_dnsdist}
+: ${dnsdist_enable:=NO}
command=/usr/local/sbin/${name}
-command_args="-l 127.0.0.1:53"
+command_args="-u ${dnsdist_priv_user} -g ${dnsdist_priv_group} -d"
run_rc_command "$1"
diff --git a/dns/dnsdist/pkg-plist b/dns/dnsdist/pkg-plist
index 1eeaf31ff11d..84caac4a6aaf 100644
--- a/dns/dnsdist/pkg-plist
+++ b/dns/dnsdist/pkg-plist
@@ -1,3 +1,3 @@
-bin/dnsdist
+sbin/dnsdist
man/man1/dnsdist.1.gz
@sample etc/dnsdist.conf.sample