aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--finance/Makefile1
-rw-r--r--finance/p5-Business-OCV/Makefile20
-rw-r--r--finance/p5-Business-OCV/distinfo1
-rw-r--r--finance/p5-Business-OCV/pkg-descr4
-rw-r--r--finance/p5-Business-OCV/pkg-plist4
5 files changed, 30 insertions, 0 deletions
diff --git a/finance/Makefile b/finance/Makefile
index 6acf5d166d43..bae1ea0d8014 100644
--- a/finance/Makefile
+++ b/finance/Makefile
@@ -10,6 +10,7 @@
SUBDIR += myphpmoney
SUBDIR += openhbci
SUBDIR += p5-Business-CreditCard
+ SUBDIR += p5-Business-OCV
SUBDIR += p5-Business-OnlinePayment
SUBDIR += p5-Business-OnlinePayment-2CheckOut
SUBDIR += p5-Business-OnlinePayment-AuthorizeNet
diff --git a/finance/p5-Business-OCV/Makefile b/finance/p5-Business-OCV/Makefile
new file mode 100644
index 000000000000..831bfbd0b4d8
--- /dev/null
+++ b/finance/p5-Business-OCV/Makefile
@@ -0,0 +1,20 @@
+# New ports collection makefile for: Business::OCV
+# Date created: 17 December 2003
+# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Business-OCV
+PORTVERSION= 0.1
+CATEGORIES= finance perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../by-authors/id/B/BE/BENL
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= An interface to the Ingenico OCV Server
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.mk>
diff --git a/finance/p5-Business-OCV/distinfo b/finance/p5-Business-OCV/distinfo
new file mode 100644
index 000000000000..ad1d3e55ac5e
--- /dev/null
+++ b/finance/p5-Business-OCV/distinfo
@@ -0,0 +1 @@
+MD5 (Business-OCV-0.1.tar.gz) = 42bf03be40b3a4c497e7bb733cc0254a
diff --git a/finance/p5-Business-OCV/pkg-descr b/finance/p5-Business-OCV/pkg-descr
new file mode 100644
index 000000000000..10c0fbe35257
--- /dev/null
+++ b/finance/p5-Business-OCV/pkg-descr
@@ -0,0 +1,4 @@
+This module provides an interface to the Ingenico Online Credit Verification
+Server (OCV) (see http://www.ingenico.com.au). The OCV server provides an
+interface into the bank network and allows credit card transactions to be
+processed in real-time.
diff --git a/finance/p5-Business-OCV/pkg-plist b/finance/p5-Business-OCV/pkg-plist
new file mode 100644
index 000000000000..37863477896c
--- /dev/null
+++ b/finance/p5-Business-OCV/pkg-plist
@@ -0,0 +1,4 @@
+%%SITE_PERL%%/Business/OCV.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Business/OCV/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Business/OCV
+@unexec rmdir %D/%%SITE_PERL%%/Business 2>/dev/null || true