aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--math/Makefile1
-rw-r--r--math/py-pynndescent/Makefile26
-rw-r--r--math/py-pynndescent/distinfo3
-rw-r--r--math/py-pynndescent/pkg-descr6
4 files changed, 36 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index a2082b3ad565..f418db30e224 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -772,6 +772,7 @@
SUBDIR += py-pymc3
SUBDIR += py-pyneqsys
SUBDIR += py-pynleq2
+ SUBDIR += py-pynndescent
SUBDIR += py-pyodeint
SUBDIR += py-pyodesys
SUBDIR += py-pysparse
diff --git a/math/py-pynndescent/Makefile b/math/py-pynndescent/Makefile
new file mode 100644
index 000000000000..e42e0a6e999a
--- /dev/null
+++ b/math/py-pynndescent/Makefile
@@ -0,0 +1,26 @@
+# $FreeBSD$
+
+PORTNAME= pynndescent
+DISTVERSION= 0.4.4
+CATEGORIES= math python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Python nearest neighbor descent for approximate nearest neighbors
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}joblib>0:devel/py-joblib@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}llvmlite>=0.30:devel/py-llvmlite@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}numba>=0.46:devel/py-numba@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}scikit-learn>=0.18:science/py-scikit-learn@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}scipy>0:science/py-scipy@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= distutils autoplist
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/math/py-pynndescent/distinfo b/math/py-pynndescent/distinfo
new file mode 100644
index 000000000000..bd7e14dc2b3f
--- /dev/null
+++ b/math/py-pynndescent/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1579920493
+SHA256 (pynndescent-0.4.4.tar.gz) = 43d390ae80793f4c1f8a8096b4ebab4186c3a9c378f7214975480105257ffb4b
+SIZE (pynndescent-0.4.4.tar.gz) = 1132646
diff --git a/math/py-pynndescent/pkg-descr b/math/py-pynndescent/pkg-descr
new file mode 100644
index 000000000000..2fb3556ca93d
--- /dev/null
+++ b/math/py-pynndescent/pkg-descr
@@ -0,0 +1,6 @@
+A Python nearest neighbor descent for approximate nearest neighbors.
+This is a relatively straightforward python implementation of Nearest
+Neighbor Descent for k-neighbor-graph construction and approximate
+nearest neighbor search.
+
+WWW: https://github.com/lmcinnes/pynndescent