aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--lang/gcc8/Makefile8
-rw-r--r--lang/gcc8/pkg-descr6
2 files changed, 6 insertions, 8 deletions
diff --git a/lang/gcc8/Makefile b/lang/gcc8/Makefile
index a995b947d8ae..c063974f2445 100644
--- a/lang/gcc8/Makefile
+++ b/lang/gcc8/Makefile
@@ -59,9 +59,7 @@ CONFIGURE_TARGET= x86_64-portbld-${OPSYS:tl}${OSREL}
.elif ${ARCH} == powerpc64
CONFIGURE_ENV+= UNAME_m="powerpc64"
-USE_GCC= 5 # This port requires at least GCC 4.9, and we need
- # to ensure not to cause a dependency on itself (so
- # USE_GCC=yes or USE_GCC=X+ are not an option).
+MAKE_ARGS+= CFLAGS_FOR_TARGET="-O1" CXXFLAGS_FOR_TARGET="-O1" BOOT_CFLAGS="-O1" # PR235975
.elif ${ARCH} == powerpcspe
CONFIGURE_ARGS+= --with-cpu=8548 --enable-e500_double --without-fp
@@ -140,8 +138,8 @@ post-stage:
${RM} ${WRKDIR}/PLIST.lib
.if ${ARCH} == powerpc64 && ${PORT_OPTIONS:MMULTILIB}
- ${MKDIR} ${STAGEDIR}${TARGLIB32}/gcc${SUFFIX}
- ${MV} ${STAGEDIR}${PREFIX}/lib/lib32/* ${STAGEDIR}${TARGLIB32}/gcc${SUFFIX}
+ ${MKDIR} ${STAGEDIR}${TARGLIB32}
+ ${MV} ${STAGEDIR}${PREFIX}/lib/lib32 ${STAGEDIR}${TARGLIB32}/gcc${SUFFIX}
.endif
.for d in ${TARGLIB:S/^${PREFIX}\///} ${TARGLIB32:S/^${PREFIX}\///} ${LIBEXEC:S/^${PREFIX}\///}
diff --git a/lang/gcc8/pkg-descr b/lang/gcc8/pkg-descr
index 4685f20de855..6269fd42b1fd 100644
--- a/lang/gcc8/pkg-descr
+++ b/lang/gcc8/pkg-descr
@@ -1,6 +1,6 @@
-GCC, the GNU Compiler Collection, supports a number of languages. This
-port installs the C, C++, and Fortran front ends as gcc8, g++8, gfortran8,
-respectively.
+GCC, the GNU Compiler Collection, supports a number of languages.
+This port installs the C, C++, and Fortran front ends as gcc8, g++8,
+and gfortran8, respectively.
WWW: https://gcc.gnu.org