aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--UPDATING11
-rw-r--r--devel/Makefile1
-rw-r--r--devel/libplist/Makefile66
-rw-r--r--devel/libplist/distinfo4
-rw-r--r--devel/libplist/files/patch-libcnary__node.c11
-rw-r--r--devel/libplist/files/patch-src__base64.c14
-rw-r--r--devel/libplist/pkg-descr21
-rw-r--r--devel/libplist/pkg-plist19
-rw-r--r--devel/py-libplist/Makefile30
-rw-r--r--devel/py-libplist/files/CMakeLists.txt14
-rw-r--r--devel/py-libplist/pkg-plist9
11 files changed, 108 insertions, 92 deletions
diff --git a/UPDATING b/UPDATING
index 41a1648a9236..e174d047d3b3 100644
--- a/UPDATING
+++ b/UPDATING
@@ -5,6 +5,13 @@ they are unavoidable.
You should get into the habit of checking this file for changes each time
you update your ports collection, before attempting any port upgrades.
+20130507:
+ AFFECTS: users of devel/libplist
+ AUTHOR: avilla@FreeBSD.org
+
+ libplist Python bindings were split from the main port. To get them you
+ need to install devel/py-libplist.
+
20130506:
AFFECTS: users of TeX
AUTHOR: hrs@FreeBSD.org
@@ -49,7 +56,7 @@ you update your ports collection, before attempting any port upgrades.
* DVI ware
- print/tex-xdvik: XDvi
-
+
20130503:
AFFECTS: users of security/libgcrypt and any port that depends on it
AUTHOR: ehaupt@FreeBSD.org
@@ -61,7 +68,7 @@ you update your ports collection, before attempting any port upgrades.
# portmaster -r libgcrypt
or
-
+
# portupgrade -rf libgcrypt
Alternatively, you may install sysutils/bsdadminscripts, run pkg_libchk and
diff --git a/devel/Makefile b/devel/Makefile
index 464f27618c10..33941ae3b95a 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -3538,6 +3538,7 @@
SUBDIR += py-kss-core
SUBDIR += py-levenshtein
SUBDIR += py-liblarch
+ SUBDIR += py-libplist
SUBDIR += py-ll-core
SUBDIR += py-lock_file
SUBDIR += py-lockfile
diff --git a/devel/libplist/Makefile b/devel/libplist/Makefile
index cfa06420b9c1..9d439cdd1cf6 100644
--- a/devel/libplist/Makefile
+++ b/devel/libplist/Makefile
@@ -1,63 +1,47 @@
# $FreeBSD$
PORTNAME= libplist
-PORTVERSION= 1.8
-CATEGORIES= devel
+PORTVERSION= 1.10
+PORTREVISION?= 0
+CATEGORIES?= devel
MASTER_SITES= http://www.libimobiledevice.org/downloads/
-MAINTAINER= avilla@FreeBSD.org
-COMMENT= Library to handle Apple Property List format
+MAINTAINER?= avilla@FreeBSD.org
+COMMENT?= Library to handle Apple Property List format
-LICENSE= LGPL21
+LICENSE?= LGPL21
+
+SLAVE_PORT?= no
-USE_GNOME= libxml2
-# Unlisted dependency.
USE_BZIP2= yes
-USES= cmake iconv
-# Required for iconv headers.
-CFLAGS+= -I${LOCALBASE}/include
+USES= cmake pkgconfig
+
+.if ${SLAVE_PORT} == "no"
+
+USE_GNOME= libxml2
+CMAKE_ARGS= -DENABLE_CYTHON:BOOL=False \
+ -DENABLE_SWIG:BOOL=False
MAKE_JOBS_UNSAFE= yes
USE_LDCONFIG= ${LOCALBASE}/lib
PORTDOCS= AUTHORS NEWS README
-OPTIONS_DEFINE= CYTHON SWIG
-
-CYTHON_DESC= Cython Python bindings
-SWIG_DESC= Swig Python bindings
-
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MCYTHON}
-BUILD_DEPENDS+= cython:${PORTSDIR}/lang/cython
-USE_PYTHON= yes
-CMAKE_ARGS+= -DENABLE_CYTHON:BOOL=On
-PLIST_SUB+= CYTHON=""
-.else
-CMAKE_ARGS+= -DENABLE_CYTHON:BOOL=Off
-PLIST_SUB+= CYTHON="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MSWIG}
-BUILD_DEPENDS+= swig:${PORTSDIR}/devel/swig13
-USE_PYTHON= yes
-CMAKE_ARGS+= -DENABLE_SWIG:BOOL=On
-PLIST_SUB+= SWIG=""
-.else
-CMAKE_ARGS+= -DENABLE_SWIG:BOOL=Off
-PLIST_SUB+= SWIG="@comment "
-.endif
-
-pre-configure:
- ${REINPLACE_CMD} -e 's:$${CMAKE_INSTALL_LIBDIR}/pkgconfig:libdata/pkgconfig:' \
+post-patch:
+# Required for iconv headers (included by libxml2). Do not add to
+# CFLAGS as it may break updates from old versions.
+ @${REINPLACE_CMD} -e 's,$${LIBXML2_INCLUDE_DIR},$${LIBXML2_INCLUDE_DIR} ${LOCALBASE}/include,' \
+ ${WRKSRC}/src/CMakeLists.txt
+ @${REINPLACE_CMD} -e 's,$${CMAKE_INSTALL_LIBDIR}/pkgconfig,libdata/pkgconfig,' \
${WRKSRC}/CMakeLists.txt
post-install:
.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
-.for f in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
-.endfor
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}
.endif
+.endif # ${SLAVE_PORT} == "no"
+
.include <bsd.port.mk>
diff --git a/devel/libplist/distinfo b/devel/libplist/distinfo
index d7281a9040a0..0a4b90d43530 100644
--- a/devel/libplist/distinfo
+++ b/devel/libplist/distinfo
@@ -1,2 +1,2 @@
-SHA256 (libplist-1.8.tar.bz2) = a418da3880308199b74766deef2a760a9b169b81a868a6a9032f7614e20500ec
-SIZE (libplist-1.8.tar.bz2) = 81278
+SHA256 (libplist-1.10.tar.bz2) = f44c52a0f8065d41d44772a7484f93bc5e7da21a8f4a9ad3f38a36b827eeff0b
+SIZE (libplist-1.10.tar.bz2) = 82519
diff --git a/devel/libplist/files/patch-libcnary__node.c b/devel/libplist/files/patch-libcnary__node.c
deleted file mode 100644
index 36f0bcc25b8e..000000000000
--- a/devel/libplist/files/patch-libcnary__node.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./libcnary/node.c.orig 2012-01-29 11:49:28.786656365 +0100
-+++ ./libcnary/node.c 2012-01-29 11:53:54.146697468 +0100
-@@ -104,7 +104,7 @@
-
- int node_insert(node_t* parent, unsigned int index, node_t* child)
- {
-- if (!parent || !child) return;
-+ if (!parent || !child) return -1;
- child->isLeaf = TRUE;
- child->isRoot = FALSE;
- child->parent = parent;
diff --git a/devel/libplist/files/patch-src__base64.c b/devel/libplist/files/patch-src__base64.c
deleted file mode 100644
index ae38994763a8..000000000000
--- a/devel/libplist/files/patch-src__base64.c
+++ /dev/null
@@ -1,14 +0,0 @@
---- ./src/base64.c.orig 2012-01-29 13:01:09.956709152 +0100
-+++ ./src/base64.c 2012-01-29 13:17:28.106706024 +0100
-@@ -104,9 +104,9 @@
-
- unsigned char *base64decode(const char *buf, size_t *size)
- {
-- if (!buf) return;
-+ if (!buf) return NULL;
- size_t len = strlen(buf);
-- if (len <= 0) return;
-+ if (len <= 0) return NULL;
- unsigned char *outbuf = (unsigned char*)malloc((len/4)*3+3);
-
- unsigned char *line;
diff --git a/devel/libplist/pkg-descr b/devel/libplist/pkg-descr
index 0a4cd845ab1d..cfa677ae91a6 100644
--- a/devel/libplist/pkg-descr
+++ b/devel/libplist/pkg-descr
@@ -1,11 +1,14 @@
-libimobiledevice is a software library that talks the protocols to
-support iPhone, iPod Touch and iPad devices on Linux. Unlike other
-projects, it does not depend on using any existing proprietary
-libraries and does not require jailbreaking. It allows other software
-to easily access the device's filesystem, retrieve information about
-the device and its internals, backup/restore the device, manage
-SpringBoard icons, manage installed applications, retrieve
-addressbook/calendars/notes and bookmarks and synchronize music and
-video to the device.
+libimobiledevice is a cross-platform software library that talks the
+protocols to support iPhone, iPod Touch, iPad and Apple TV devices.
+Unlike other projects, it does not depend on using any existing
+proprietary libraries and does not require jailbreaking. It allows
+other software to easily access the device's filesystem, retrieve
+information about the device and its internals, backup/restore the
+device, manage SpringBoard icons, manage installed applications,
+retrieve addressbook/calendars/notes and bookmarks and synchronize
+music and video to the device.
+
+This port installs the library required to handle Apple Binary and XML
+Property Lists.
WWW: http://www.libimobiledevice.org
diff --git a/devel/libplist/pkg-plist b/devel/libplist/pkg-plist
index 22c55f694dab..37f69eab8a2c 100644
--- a/devel/libplist/pkg-plist
+++ b/devel/libplist/pkg-plist
@@ -1,32 +1,25 @@
-bin/plutil
-bin/plutil-1.8
+bin/plistutil
+bin/plistutil-1.10
include/plist/Array.h
include/plist/Boolean.h
include/plist/Data.h
include/plist/Date.h
include/plist/Dictionary.h
include/plist/Integer.h
+include/plist/Key.h
include/plist/Node.h
include/plist/Real.h
include/plist/String.h
include/plist/Structure.h
-%%CYTHON%%include/plist/cython/plist.pxd
+include/plist/Uid.h
include/plist/plist++.h
include/plist/plist.h
-%%SWIG%%include/plist/swig/plist.i
lib/libplist++.so
lib/libplist++.so.1
-lib/libplist++.so.1.1.8
+lib/libplist++.so.1.1.10
lib/libplist.so
lib/libplist.so.1
-lib/libplist.so.1.1.8
-%%SWIG%%%%PYTHON_SITELIBDIR%%/plist/__init__.py
-%%SWIG%%%%PYTHON_SITELIBDIR%%/plist/_plist.so
-%%SWIG%%%%PYTHON_SITELIBDIR%%/plist/plist.py
-%%CYTHON%%%%PYTHON_SITELIBDIR%%/plist.so
+lib/libplist.so.1.1.10
libdata/pkgconfig/libplist++.pc
libdata/pkgconfig/libplist.pc
-%%SWIG%%@dirrm %%PYTHON_SITELIBDIR%%/plist
-%%SWIG%%@dirrm include/plist/swig
-%%CYTHON%%@dirrm include/plist/cython
@dirrm include/plist
diff --git a/devel/py-libplist/Makefile b/devel/py-libplist/Makefile
new file mode 100644
index 000000000000..f01ec69ec283
--- /dev/null
+++ b/devel/py-libplist/Makefile
@@ -0,0 +1,30 @@
+# $FreeBSD$
+
+PORTREVISION= 0
+CATEGORIES= devel python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= avilla@FreeBSD.org
+COMMENT= Python bindings for libplist
+
+LIB_DEPENDS= plist:${PORTSDIR}/${MASTER_PORT}
+BUILD_DEPENDS= cython:${PORTSDIR}/lang/cython \
+ swig2.0:${PORTSDIR}/devel/swig20
+
+USE_PYTHON= yes
+SLAVE_PORT= yes
+MASTERDIR= ${.CURDIR:H:H}/devel/libplist
+# Required to reference installed libplist.
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+MAKE_JOBS_SAFE= yes
+
+PLIST= ${.CURDIR}/pkg-plist
+FILESDIR= ${.CURDIR}/files
+
+post-patch:
+ @${CP} ${FILESDIR}/CMakeLists.txt ${WRKSRC}
+ @${REINPLACE_CMD} -e 's,/usr/local,${LOCALBASE},' \
+ ${WRKSRC}/CMakeLists.txt
+
+.include "${MASTERDIR}/Makefile"
diff --git a/devel/py-libplist/files/CMakeLists.txt b/devel/py-libplist/files/CMakeLists.txt
new file mode 100644
index 000000000000..ef4acd1df70e
--- /dev/null
+++ b/devel/py-libplist/files/CMakeLists.txt
@@ -0,0 +1,14 @@
+set(CMAKE_MODULE_PATH
+ ${CMAKE_SOURCE_DIR}/cmake
+ ${CMAKE_SOURCE_DIR}/cmake/modules)
+
+# Required by SWIG.
+include_directories(/usr/local/include)
+
+find_package(Cython REQUIRED)
+find_package(SWIG REQUIRED)
+find_package(PythonInterp REQUIRED)
+find_package(PythonLibs REQUIRED)
+
+add_subdirectory(cython)
+add_subdirectory(swig)
diff --git a/devel/py-libplist/pkg-plist b/devel/py-libplist/pkg-plist
new file mode 100644
index 000000000000..3164bf1ac016
--- /dev/null
+++ b/devel/py-libplist/pkg-plist
@@ -0,0 +1,9 @@
+include/plist/cython/plist.pxd
+include/plist/swig/plist.i
+%%PYTHON_SITELIBDIR%%/plist.so
+%%PYTHON_SITELIBDIR%%/plist/__init__.py
+%%PYTHON_SITELIBDIR%%/plist/_plist.so
+%%PYTHON_SITELIBDIR%%/plist/plist.py
+@dirrm %%PYTHON_SITELIBDIR%%/plist
+@dirrm include/plist/swig
+@dirrm include/plist/cython