aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--GIDs2
-rw-r--r--UIDs2
-rw-r--r--net/tcpdump/Makefile9
3 files changed, 7 insertions, 6 deletions
diff --git a/GIDs b/GIDs
index 48d161789582..4652d8f6d64b 100644
--- a/GIDs
+++ b/GIDs
@@ -825,7 +825,7 @@ _geodns:*:853:
# free: 882
# free: 883
# free: 884
-# free: 885
+tcpdump:*:885:
miniflux:*:886:
pdagent:*:887:
vuls:*:888:
diff --git a/UIDs b/UIDs
index 912af677064c..28656ecd19be 100644
--- a/UIDs
+++ b/UIDs
@@ -831,7 +831,7 @@ archiva:*:871:871::0:0:Apache Archiva Daemon:/nonexistent:/usr/sbin/nologin
# free: 882
# free: 883
# free: 884
-# free: 885
+tcpdump:*:885:885::0:0:tcpdump user:/nonexistent:/usr/sbin/nologin
miniflux:*:886:886::0:0:Miniflux:/nonexistent:/usr/sbin/nologin
pdagent:*:887:887::0:0:PagerDuty Agent:/nonexistent:/usr/sbin/nologin
vuls:*:888:888::0:0:VULnerability Scanner:/var/db/vuls:/usr/sbin/nologin
diff --git a/net/tcpdump/Makefile b/net/tcpdump/Makefile
index b8c9c3829a18..b9161af83852 100644
--- a/net/tcpdump/Makefile
+++ b/net/tcpdump/Makefile
@@ -3,6 +3,7 @@
PORTNAME= tcpdump
PORTVERSION= 4.9.2
+PORTREVISION= 1
CATEGORIES= net ipv6
MASTER_SITES= http://www.tcpdump.org/release/
@@ -16,10 +17,10 @@ LIB_DEPENDS= libpcap.so.1:net/libpcap
GNU_CONFIGURE= yes
USES= gmake
-UNPRIV_USER?= nobody
+UNPRIV_USER?= tcpdump
CHROOTDIR?= /var/run/tcpdump
-OPTIONS_DEFINE= CRYPTO IPV6 SMB SMI USER CHROOT
+OPTIONS_DEFINE= CRYPTO SMB SMI USER CHROOT
OPTIONS_DEFAULT= CRYPTO SMB SMI
CRYPTO_DESC= Support IPSEC and TCPMD5
@@ -28,16 +29,16 @@ CRYPTO_DESC= Support IPSEC and TCPMD5
# is not true. It will just not print it if this option is off.
SMB_DESC= Support printing SMB information
SMI_DESC= Allow MIBs to be loaded on the fly
-USER_DESC= Drop privileges to nobody
+USER_DESC= Drop privileges to dedicated user
CHROOT_DESC= Chroot to /var/run/tcpdump (set CHROOTDIR to change)
CRYPTO_USES= ssl
CRYPTO_CONFIGURE_WITH= crypto
-IPV6_CONFIGURE_ENABLE= ipv6
SMB_CONFIGURE_ENABLE= smb
SMI_CONFIGURE_WITH= smi
SMI_LIB_DEPENDS= libsmi.so:net-mgmt/libsmi
USER_CONFIGURE_ON= --with-user=${UNPRIV_USER}
+USER_VARS= USERS=${UNPRIV_USER} GROUPS=${UNPRIV_USER}
CHROOT_CONFIGURE_ON= --with-chroot=${CHROOTDIR}
PLIST_FILES= sbin/tcpdump \