aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11/nvidia-driver/Makefile3
-rw-r--r--x11/nvidia-driver/Makefile.common1
-rw-r--r--x11/nvidia-driver/files/extra-patch-src_nvidia-modeset_nvidia-modeset-freebsd.c7
3 files changed, 7 insertions, 4 deletions
diff --git a/x11/nvidia-driver/Makefile b/x11/nvidia-driver/Makefile
index b6adbd15b266..0d4ae8cf124e 100644
--- a/x11/nvidia-driver/Makefile
+++ b/x11/nvidia-driver/Makefile
@@ -68,9 +68,6 @@ NVSRC= nvidia
.endif
.if ${NVVERSION} >= 358.009
-# Initialize memory allocations to avoid spurious "lock re-initialization"
-# errors. A little more detail can be found in bug 201340 starting around
-# comment #50.
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-src_nvidia-modeset_nvidia-modeset-freebsd.c
.endif
diff --git a/x11/nvidia-driver/Makefile.common b/x11/nvidia-driver/Makefile.common
index 1217a625d339..856c5d5ba0c3 100644
--- a/x11/nvidia-driver/Makefile.common
+++ b/x11/nvidia-driver/Makefile.common
@@ -1,5 +1,6 @@
# $FreeBSD$
+# LICENSE_FILE is set in the consumer ports because its location varies
LICENSE= NVIDIA
LICENSE_NAME= License For Customer Use of NVIDIA Software
LICENSE_PERMS= dist-mirror no-dist-sell pkg-mirror no-pkg-sell auto-accept
diff --git a/x11/nvidia-driver/files/extra-patch-src_nvidia-modeset_nvidia-modeset-freebsd.c b/x11/nvidia-driver/files/extra-patch-src_nvidia-modeset_nvidia-modeset-freebsd.c
index d129820b5988..a8e6a5a221a6 100644
--- a/x11/nvidia-driver/files/extra-patch-src_nvidia-modeset_nvidia-modeset-freebsd.c
+++ b/x11/nvidia-driver/files/extra-patch-src_nvidia-modeset_nvidia-modeset-freebsd.c
@@ -16,11 +16,16 @@
#endif
-@@ -250,7 +252,7 @@ struct nvkms_ref_ptr {
+@@ -252,7 +254,12 @@ struct nvkms_ref_ptr {
struct nvkms_ref_ptr* NVKMS_API_CALL nvkms_alloc_ref_ptr(void *ptr)
{
- struct nvkms_ref_ptr *ref_ptr = nvkms_alloc(sizeof(*ref_ptr), NV_FALSE);
++ /*
++ * Initialize memory to avoid spurious "lock re-initialization" errors.
++ * A little more detail can be found in the PR 201340 starting around
++ * comment #50.
++ */
+ struct nvkms_ref_ptr *ref_ptr = nvkms_alloc(sizeof(*ref_ptr), NV_TRUE);
if (ref_ptr) {
mtx_init(&ref_ptr->lock, "nvkms-ref-ptr-lock", NULL, MTX_SPIN);