aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--misc/Makefile1
-rw-r--r--misc/p5-File-Sort/Makefile22
-rw-r--r--misc/p5-File-Sort/distinfo1
-rw-r--r--misc/p5-File-Sort/pkg-comment1
-rw-r--r--misc/p5-File-Sort/pkg-descr9
-rw-r--r--misc/p5-File-Sort/pkg-plist5
6 files changed, 39 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index 5609b40d7cc6..3cebb4bb74ad 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -153,6 +153,7 @@
SUBDIR += p5-Data-Buffer
SUBDIR += p5-DataCash
SUBDIR += p5-File-CounterFile
+ SUBDIR += p5-File-Sort
SUBDIR += p5-Finance-Quote
SUBDIR += p5-Geo-Weather
SUBDIR += p5-I18N-Charset
diff --git a/misc/p5-File-Sort/Makefile b/misc/p5-File-Sort/Makefile
new file mode 100644
index 000000000000..1c30773e32a0
--- /dev/null
+++ b/misc/p5-File-Sort/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: File::Sort
+# Date created: 30 Dec 2001
+# Whom: Seamus Venasse <svenasse@polaris.ca>
+#
+# $FreeBSD$
+#
+
+PORTNAME= File-Sort
+PORTVERSION= 1.00
+CATEGORIES= misc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= File
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= svenasse@polaris.ca
+
+PERL_CONFIGURE= yes
+
+MAN3= File::Sort.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.mk>
diff --git a/misc/p5-File-Sort/distinfo b/misc/p5-File-Sort/distinfo
new file mode 100644
index 000000000000..f93140b2f53c
--- /dev/null
+++ b/misc/p5-File-Sort/distinfo
@@ -0,0 +1 @@
+MD5 (File-Sort-1.00.tar.gz) = 4e0b336dcc9188ae0cb3c719776fdfdf
diff --git a/misc/p5-File-Sort/pkg-comment b/misc/p5-File-Sort/pkg-comment
new file mode 100644
index 000000000000..defc2d6ef5ad
--- /dev/null
+++ b/misc/p5-File-Sort/pkg-comment
@@ -0,0 +1 @@
+Sort a file or merge sort multiple files
diff --git a/misc/p5-File-Sort/pkg-descr b/misc/p5-File-Sort/pkg-descr
new file mode 100644
index 000000000000..f8d925bf9113
--- /dev/null
+++ b/misc/p5-File-Sort/pkg-descr
@@ -0,0 +1,9 @@
+This is File::Sort 1.00, for sorting files similarly to sort(1). Written
+primarily for MacPerl users who do not have sort(1) and because of memory
+limitations cannot sort files in memory, but works on all perls, and can
+be useful for portable sorting of large files, or for any system that
+doesn't have a sort(1) and is virtual-memory-deprived (including Windows).
+
+WWW: http://search.cpan.org/search?dist=File-Sort
+
+Seamus Venasse <svenasse@polaris.ca>
diff --git a/misc/p5-File-Sort/pkg-plist b/misc/p5-File-Sort/pkg-plist
new file mode 100644
index 000000000000..a27894b16bab
--- /dev/null
+++ b/misc/p5-File-Sort/pkg-plist
@@ -0,0 +1,5 @@
+lib/perl5/site_perl/%%PERL_VER%%/File/Sort.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/File/Sort/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/File/Sort
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/File 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/File 2>/dev/null || true